source: projects/specs/trunk/p/pspp/pspp-vl.spec @ 11207

Revision 11207, 2.6 KB checked in by ara_t, 7 years ago (diff)

pspp: initial commit

Line 
1%define pkg_name    pspp
2%define pkg_version 1.0.1
3%define pkg_release 1%{?_dist_release}
4
5Summary:     A program for statistical analysis of sampled data
6Summary(ja): データ統計解析用プログラム
7Name:        %{pkg_name}
8Version:     %{pkg_version}
9Release:     %{pkg_release}
10
11License: GPLv3 or later
12Group:   Applications/Edutainment
13URL:     http://www.gnu.org/software/pspp/
14Source0: http://public.p-knowledge.co.jp/gnu-mirror/pspp/pspp-%{version}.tar.gz
15
16Buildroot: %{_tmppath}/%{name}-%{version}-root
17
18BuildRequires: texinfo
19BuildRequires: readline-devel
20BuildRequires: gtk3-devel gtksourceview3-devel
21BuildRequires: gsl-devel
22BuildRequires: plotutils-devel
23
24Requires: gtk3 gtksourceview3
25Requires: gsl
26Requires: plotutils
27
28
29Vendor: Project Vine
30Distribution: Vine Linux
31
32
33%description
34PSPP is a program for statistical analysis of sampled data.
35It is a free replacement for the proprietary program SPSS.
36
37PSPP supports t-tests, ANOVA, GLM, factor analysis, non-parametric tests,
38and other statistical features. PSPP produces statistical reports
39in plain text, PDF, PostScript, CSV, HTML, SVG, and OpenDocument formats.
40
41PSPP has both text-based and graphical user interfaces.
42The PSPP user interface has been translated into a number of languages.
43
44%description -l ja
45%{description}
46
47
48%prep
49%{__rm} -rf ${RPM_BUILD_ROOT}
50%setup -q
51
52%build
53%{configure} \
54 --disable-static \
55 --docdir=%{_docdir}/%{name}-%{version}
56
57%{__make} %{?_smp_mflags}
58
59%check
60%{__make} check
61
62%install
63%{make_install}
64%{__rm} ${RPM_BUILD_ROOT}%{_libdir}/pspp/*.la
65%{__rm} ${RPM_BUILD_ROOT}%{_infodir}/dir
66
67%{__cp} AUTHORS COPYING ChangeLog NEWS ONEWS README THANKS TODO \
68        ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
69
70# modify desktop file
71%{__perl} -pi -e s/"Education;Science;Math;"/"Education;Science;"/g \
72 ${RPM_BUILD_ROOT}%{_datadir}/applications/pspp.desktop
73
74%clean
75%{__rm} -rf ${RPM_BUILD_ROOT}
76
77%post
78for doc in pspp pspp-dev; do
79    file=%{_infodir}/${doc}.info.gz
80    if [ -e ${file} ]; then
81        /sbin/install-info ${file} %{_infodir}/dir 2>/dev/null
82    fi
83done
84%{_syssbindir}/ldconfig
85
86%preun
87if [ $1 = 0 ]; then
88    for doc in pspp pspp-dev; do
89        file=%{_infodir}/${doc}.info.gz
90        if [ -e ${file} ]; then
91            /sbin/install-info --delete ${file} %{_infodir}/dir 2>/dev/null
92        fi
93    done
94fi
95
96%postun -p %{_syssbindir}/ldconfig
97
98
99%files
100%defattr(-,root,root)
101%{_bindir}/
102%{_libdir}/pspp/
103%{_datadir}/appdata/
104%{_datadir}/applications/
105%{_datadir}/icons/
106%{_datadir}/locale/
107%{_datadir}/pspp
108%{_infodir}/
109%{_mandir}/man1/
110%{_docdir}/
111
112
113%changelog
114* Sun Oct 15 2017 Toshiaki Ara <ara_t@384.jp> 1.0.1-1
115- new package
116
Note: See TracBrowser for help on using the repository browser.