source: projects/specs/trunk/p/psmisc/psmisc-vl.spec @ 521

Revision 521, 4.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define with_pidof 0
2
3Summary:     Utilities for managing processes on your system.
4Summary(ja): システムのプロセスを管理するユーティリティ
5Name: psmisc
6Version: 22.6
7Release: 2%{?_dist_release}
8License: BSD/GPLv2+
9Group: Applications/System
10Source: ftp://ftp.sf.net/pub/sourceforge/psmisc/psmisc-%{version}.tar.gz
11Patch0: psmisc-22.6-types.patch
12Patch1: psmisc-22.6-pstree-overflow.patch
13Buildroot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: gettext ncurses-devel
15BuildRequires: autoconf automake
16
17
18%description
19The psmisc package contains utilities for managing processes on your
20system: pstree, killall and fuser.  The pstree command displays a tree
21structure of all of the running processes on your system.  The killall
22command sends a specified signal (SIGTERM if nothing is specified) to
23processes identified by name.  The fuser command identifies the PIDs
24of processes that are using specified files or filesystems.
25
26%description -l ja
27psmisc パッケージには pstree, killall, fuser といった,システムの
28プロセスを管理するユーティリティが収められています.pstree コマンドは
29システム上で動作している全プロセスをツリー状に表示します.
30killall コマンドは,指定されたシグナル (何も指定しなければ SIGTERM) を
31名前で指定したプロセスに送ります.
32fuser コマンドは,指定したファイルやファイルシステムを使用している
33プロセスの PID を特定します.
34
35
36%prep
37%setup -q
38%patch0 -p1 -b .types
39%patch1 -p1 -b .pstree-overflow
40
41%build
42export CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE"
43autoreconf
44%configure --prefix=%{_prefix}
45make %{?_smp_mflags}
46
47%install
48rm -rf $RPM_BUILD_ROOT
49# The rpm makeinstall macro breaks the build, so we do it the old way
50make install DESTDIR="$RPM_BUILD_ROOT"
51mkdir -p $RPM_BUILD_ROOT%{_syssbindir}
52mv $RPM_BUILD_ROOT%{_bindir}/fuser $RPM_BUILD_ROOT%{_syssbindir}
53
54%if ! %{with_pidof}
55rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/pidof.1*
56%endif
57rm -f $RPM_BUILD_ROOT/%{_bindir}/oldfuser
58
59%ifnarch %ix86 x86_64 ppc ppc64
60rm -f $RPM_BUILD_ROOT/%{_mandir}/man1/peekfd.1*
61%endif
62
63%find_lang %name
64
65%clean
66rm -rf $RPM_BUILD_ROOT
67
68
69%files -f %{name}.lang
70%defattr(-,root,root)
71%{_syssbindir}/fuser
72%{_bindir}/killall
73%{_bindir}/pstree
74%{_bindir}/pstree.x11
75%{_mandir}/man1/fuser.1*
76%{_mandir}/man1/killall.1*
77%{_mandir}/man1/pstree.1*
78%ifarch %ix86 x86_64 ppc ppc64
79%{_bindir}/peekfd
80%{_mandir}/man1/peekfd.1*
81%endif
82
83
84%changelog
85* Mon Aug 18 2008 Shu KONNO <owa@bg.wakwak.com> 22.6-2
86- added psmisc-22.6-types.patch by fedora
87- added psmisc-22.6-pstree-overflow.patch by fedora
88
89* Sat Aug 16 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 22.6-1
90- new upstream release
91- add peekfd to %%files on %%ix86, x86_64, ppc and ppc64
92
93* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 22.5-2vl5
94- applied new versioning policy, spec in utf-8
95
96* Sat Oct 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 22.5-2vl1
97- based on 22.5-2 from Fedora
98- rebuilt with new toolchains
99
100* Sun Jun 15 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 21.2-4vl1
101- based on 21.2-4 from Redhat9
102- dropped psmisc-17-buildroot.patch and psmisc-19-noroot.patch
103- rebuild with new toolchains
104
105* Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
106- 19-4vl1
107- based on 19-4 from Rawhide
108- use better macros (%%{_syssbindir}, %%{_bindir})
109- added Japanese summary and description
110
111* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
112- automatic rebuild
113
114* Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
115- FHS man paths
116- patch makefile to enable non-root builds
117
118* Sat Feb  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
119- Deal with compressed man pages
120
121* Sun Nov 21 1999 Bernhard Rosenkraenzer <bero@redhat.com>
122- update to v19
123- handle RPM_OPT_FLAGS
124
125* Mon Sep 27 1999 Bill Nottingham <notting@redhat.com>
126- move fuser to /sbin
127
128* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
129- auto rebuild in the new build environment (release 2)
130
131* Sat Mar 13 1999 Michael Maher <mike@redhat.com>
132- updated package
133
134* Fri May 01 1998 Prospector System <bugs@redhat.com>
135- translations modified for de, fr, tr
136
137* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
138- renamed the patch file .patch instead of .spec
139
140* Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
141- updated to psmisc version 17
142- buildrooted
143
144* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
145- updated from version 11 to version 16
146- spec file cleanups
147
148* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
149- built against glibc
Note: See TracBrowser for help on using the repository browser.