source: projects/specs/trunk/p/psgml/psgml-vl.spec @ 521

Revision 521, 8.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define       _noVersionedDependencies        1
2%define       prereq_ge()   %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define       emacsen_pkgdir /usr/lib/emacsen-common/packages
4%define       origname      psgml
5%define       origver       1.2.5
6%define       release       6%{?_dist_release}
7
8Summary:      A GNU emacs major mode for editing SGML documents.
9name:         %{origname}
10Version:      %{origver}
11Release:      %{release}
12Distribution: Vine Linux
13Vendor:       Project Vine
14Conflicts:    %{origname}-el
15
16PreReq:       emacsen
17PreReq:       sgml-common
18Requires:     emacsen
19%prereq_ge emacsen-common
20
21License: GPL
22Source: ftp://ftp.lysator.liu.se/pub/sgml/%{origname}-%{version}.tar.gz
23Source1: psgml-install.sh
24Source2: psgml-remove.sh
25Group: Applications/Editors/Emacs
26BuildRoot: %{_tmppath}/%{name}-%{version}-root
27BuildArch: noarch
28Prefix: /usr
29
30#%define psgmldir %{prefix}/share/emacs/site-lisp/psgml/
31
32%description
33Emacs is an advanced and extensible editor. An Emacs major mode
34customizes Emacs for editing particular types of text documents. PSGML
35is a major mode for SGML (a markup language) documents.  PSGML
36provides several functionalities for editing SGML documents:
37indentation according to element nesting depth and identification of
38structural errors (but it is not a validating SGML parser); menus and
39commands for inserting tags with only the contextually valid tags;
40attribute values can be edited in a separate window with information
41about types and defaults; structure based editing includes movement
42and killing; and also several commands for folding editing.
43
44%description -l ja
45Emacs は拡張性に優れたエディターです.Emacs メジャーモードは特定の
46テキスト文書を入力する時に Emacs をカスタマイズします.PSGML は
47SGML (マークアップ言語)文書用のメジャーモードです.PSGML は SGML 文書を
48入力ための機能を持っています。例えば,階層構造にネストしている
49エレメントに従ってインデントさせたり,構造エラーを(SGML パーサで
50検証しなくても)確認できます.また,文脈から正しいタグだけを挿入する
51メニューやコマンド,属性値は型(type) や deaults に関する情報を別
52ウィンドウで編集できます.また、movement や killing を含む編集を
53ベースにした構造、編集を保持するコマンドもあります.
54
55%prep
56rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
57
58%setup -q -n %{origname}-%{origver}
59
60%build
61%configure
62# make sure we "find" etags in the installed place...
63#cat > psgml-init.el << __ELISP__
64#;(setq load-path (append load-path '("%{psgmldir}")))
65#
66#(autoload 'sgml-mode "psgml" "Major mode for editing SGML." t)
67#(autoload 'xml-mode "psgml" "Major mode for editing XML." t)
68#(if (not (getenv "SGML_CATALOG_FILES"))
69#   (defvar sgml-catalog-files '("CATALOG" "catalog" "%{_sysconfdir}/sgml/catalog" "%{_libdir}/sgml/CATALOG" "%{_libdir}/sgml-tools/dtd/catalog"))
70#  "*List of catalog entry files.
71#The files are in the format defined in the SGML Open Draft Technical
72#Resolution on Entity Management.")
73#(put 'sgml-catalog-files 'sgml-type 'list)
74#
75#__ELISP__
76
77
78%install
79[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
80[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
81
82mkdir -p $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp/%{origname}
83#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/install
84#mkdir -p $RPM_BUILD_ROOT%{_libdir}/emacsen-common/packages/remove
85mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/install
86mkdir -p $RPM_BUILD_ROOT%{emacsen_pkgdir}/remove
87mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/sgml/cdtd
88mkdir -p $RPM_BUILD_ROOT%{_infodir}
89#touch $RPM_BUILD_ROOT%{_infodir}/dir
90
91#
92# install el files
93#
94cp -a Makefile install-sh mkinstalldirs iso88591.map install-sh \
95      psgml*.el ${RPM_BUILD_ROOT}%{_datadir}/emacs/site-lisp/%{origname}
96
97#
98#  build & install info
99#
100make EMACS=emacs infodir=${RPM_BUILD_ROOT}%{_infodir} install-info
101
102
103#
104# install  script( bytecompile el and install elc , remove )   
105#
106%_installemacsenscript %{origname} %{SOURCE1}
107
108%_removeemacsenscript  %{origname} %{SOURCE2}
109
110
111#
112#mkdir -p ${RPM_BUILD_ROOT}%{psgmldir}
113#mkdir -p ${RPM_BUILD_ROOT}%{_infodir}
114
115#touch ${RPM_BUILD_ROOT}/usr/info/dir
116
117#make install infodir=${RPM_BUILD_ROOT}%{_infodir} \
118#  prefix=${RPM_BUILD_ROOT}%{prefix} \
119#  psgmldir=${RPM_BUILD_ROOT}%{psgmldir} \
120#  lispdir=${RPM_BUILD_ROOT}%{psgmldir}
121
122#make install-info infodir=${RPM_BUILD_ROOT}%{_infodir}
123
124#gzip ${RPM_BUILD_ROOT}/usr/info/*.info
125
126#rm ${RPM_BUILD_ROOT}%{_infodir}/dir
127
128#cp psgml-init.el ${RPM_BUILD_ROOT}%{prefix}/share/emacs/site-lisp/
129
130%post
131#
132# bytecompile and install
133#
134
135if [ "$1" = 2 ]; then
136
137%_emacsenPackageRemove %{origname}
138
139fi
140
141%_addemacsenlist %{origname}
142
143%_emacsenPackageInstall %{origname}
144
145/sbin/install-info %{_infodir}/psgml.info.gz %{_infodir}/dir \
146        --section="Emacs"
147/sbin/install-info %{_infodir}/psgml-api.info.gz %{_infodir}/dir \
148        --section="Emacs"
149
150#SS=%{prefix}/share/emacs/site-lisp/site-start.el
151## must version the load since the old postun runs *after* the new post...
152#V=%{version}-%{release}
153#if grep -q psgml-auto-setup-$V $SS 2>/dev/null
154#then
155#  :
156#else
157#  echo '(load "psgml-init") ;; psgml-auto-setup-'"$V" >> $SS
158#fi
159
160%preun
161if [ "$1" = 0 ]; then
162
163%_emacsenPackageRemove %{origname}
164
165%_removeemacsenlist %{origname}
166
167/sbin/install-info --delete %{_infodir}/psgml.info.gz %{_infodir}/dir \
168        --section="Emacs"
169/sbin/install-info --delete %{_infodir}/psgml-api.info.gz %{_infodir}/dir \
170        --section="Emacs"
171
172fi
173
174%postun
175
176
177#SS=%{prefix}/share/emacs/site-lisp/site-start.el
178#V=%{version}-%{release}
179#if [ "$1" = 0 ] ; then
180#  install-info --info-dir=%{_infodir} --delete %{_infodir}/psgml.info
181#  install-info --info-dir=%{_infodir} --delete %{_infodir}/psgml-api.info
182#  if grep -q psgml-auto-setup-1 $SS 2>/dev/null
183#  then
184#    grep -v psgml-auto-setup-1 $SS > $SS.new 2>/dev/null
185#    mv $SS.new $SS
186#  fi
187#fi
188#if grep -q psgml-auto-setup-$V $SS
189#then
190#  grep -v psgml-auto-setup-$V $SS > $SS.new 2>/dev/null
191#  mv $SS.new $SS
192#fi
193
194%clean
195[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
196
197rm -rf ${RPM_BUILD_DIR}/%{origname}-%{origver}
198
199
200
201%files
202%defattr(-,root,root)
203%doc psgml.ps README.psgml
204%dir %{_prefix}/lib/sgml/cdtd
205#%{prefix}/share/emacs/site-lisp/psgml/*
206#%{prefix}/share/emacs/site-lisp/psgml-init.el
207%{_infodir}/psgml*
208/usr/share/emacs/site-lisp/%{origname}/
209#/usr/lib/emacsen-common/packages/install/%{origname}
210#/usr/lib/emacsen-common/packages/remove/%{origname}
211%{emacsen_pkgdir}/install/%{origname}
212%{emacsen_pkgdir}/remove/%{origname}
213
214%changelog
215* Fri Oct 10 2008 Shu KONNO <owa@bg.wakwak.com> 1.2.5-6vl5
216- applied new versioning policy, spec in utf-8
217- added macro %%emacsen_pkgdir
218
219* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.5-5vl3
220- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
221- s/Copyright/License/
222
223* Mon Mar 17 2003 IWAI Masaharu <iwai@alib.jp> 1.2.5-5vl2
224- rebuild
225
226* Sun Jul 21 2002 IWAI Masaharu <iwai@alib.jp> 1.2.5-5vl1
227- upstream release
228
229* Thu Jan  3 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.2.4-5vl1
230- upstream release
231- eliminated Patch1 for Emacs21 (obsoleted)
232- updated psgml-install.sh
233
234* Tue Jan  1 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.2.2-5vl2
235- emacsenize
236- package name changed psgml-el -> psgml again
237- added patch for Emacs21
238     ( /emacs-21.0.104.xtar.gz:emacs-21.0.104/etc/PROBLEMS )
239- stopped creating psgml-init.el
240
241* Fri Aug 31 2001 IWAI, Masaharu <iwaim@cc.mbn.or.jp>
242- 1.2.2-5vl1
243- upstream release
244- build on Vine Seed
245- use rpm macros
246- package name changed psgml -> psgml-el
247
248* Mon Feb 28 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
249- 1.2.1-5vl1
250- build on Vine Linux 2.0β2
251- added description -l ja
252 
253* Wed Feb 16 2000 Bill Nottingham <notting@redhat.com>
254- look in old sgml-tools dirs for catalogs, to catch linuxdoc
255
256* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
257- handle compressed man pages
258
259* Wed Jan  5 2000 Bill Nottingham <notting@redhat.com>
260- clean up spec file some
261
262* Wed Nov 24 1999 Tim Powers <timp@redhat.com>
263- came in on my day off to buld this package, feel special?
264- updated to 1.2.1
265
266* Mon Aug 30 1999 Tim Powers <timp@redhat.com>
267- changed group
268- changed buildroot toe be in /var/tmp
269- added %defattr
270
271* Tue Jul 21 1999 Tim Powers <timp@redhat.com>
272- rebuilt for 6.1
273
274* Fri Apr 23 1999 Michael K. Johnson <johnsonm@redhat.com>
275- PATH hack to protect "make install" from install-info
276- %doc path fixed
277- protect postun from uninstall
278- Moved $V outside of '' so that it gets interpolated
279
280* Thu Apr 22 1999 Owen Taylor <otaylor@redhat.com>
281- Upgrade to psgml-1.0.3
282- Made noarch
283
Note: See TracBrowser for help on using the repository browser.