source: projects/specs/trunk/p/proftpd/proftpd-vl.spec @ 6953

Revision 6953, 15.6 KB checked in by iwamoto, 12 years ago (diff)

update: zlib, libpng, xz, proftpd

Line 
1%define _prefix         /usr
2%define _localstatedir  /var/run
3%define _sysconfdir     /etc
4%define _rundir         /var/run/proftpd
5%define tarballversion  1.3.4b
6%define origversion     1.3.4b
7
8Summary: ProFTPd -- Professional FTP Server.
9Summary(ja): ProFTPd -- プロフェッショナル FTP サーバ
10Name: proftpd
11Epoch: 1
12Version: %{origversion}
13Release: 2%{?_dist_release}
14License: GPL
15Group: System Environment/Daemons
16URL: http://www.proftpd.org/
17
18Source0: ftp://ftp.proftpd.org/distrib/%{name}-%{origversion}.tar.gz
19Source1: proftpd.vine.conf
20Source2: ftpusers.vine
21Source3: proftpd.init
22Source5: welcome.msg
23
24# upstream bug fixes & security fixes
25Patch14: proftpd-1.3.4a-bug3720.patch
26Patch23: proftpd-1.3.4a-bug3744.patch
27Patch24: proftpd-1.3.4a-bug3745.patch
28Patch25: proftpd-1.3.4a-bug3746.patch
29
30# auth
31Patch201: proftpd-1.3.1-use-system-auth-instead-of-pam_pwdb.patch
32
33# iconv patch (CharsetLocal/CharsetRemote)
34# Patch300: http://www.hakusan.tsg.ne.jp/tjkawa/software/misc/proftpd-iconv/pack/proftpd-1.3.0-iconv.patch.gz
35Patch300: proftpd-1.3.4b-iconv.patch
36
37# fix build on recent kernel headers
38# Patch400: proftpd-1.3.1-umode.patch
39
40# security fix
41# nothing..
42
43BuildRoot: %{_tmppath}/%{name}-%{version}-root
44BuildRequires: pam-devel, openldap-devel, openssl-devel
45BuildRequires: ncurses-devel, libcap-devel, libacl-devel
46BuildRequires: e2fsprogs-devel
47Requires: pam > 0.59
48Obsoletes: wu-ftpd, anonftp
49Provides: ftpserver
50
51Vendor: Project Vine
52Distribution: Vine Linux
53
54%description
55ProFTPd is an enhanced FTP server with a focus toward simplicity,
56security, and ease of configuration.  It features a very Apache-like
57configuration syntax, and a highly customizable server infrastructure,
58including support for multiple 'virtual' FTP servers, anonymous FTP,
59and permission-based directory visibility.
60
61%description -l ja
62ProFTPd は シンプルさ, セキュリティ, 設定の容易さに焦点をあてた 優れた
63FTP サーバです。Apache に似た構文による設定や、複数の仮想 FTP サーバ、
64anonymous FTP, パーミッションベースのディレクトリ可視性のサポートを含む、
65高度にカスタマイズ可能なサーバ・インターフェイスを特徴としています。
66
67
68%package utils
69Summary: ProFTPD - Additional utilities
70Group:           System Environment/Daemons
71Requires:        %{name} = %{epoch}:%{version}-%{release}
72
73%description utils
74This package contains additional utilities for monitoring and configuring the
75ProFTPD server:
76
77* ftpasswd: generate passwd(5) files for use with AuthUserFile
78* ftpcount: show the current number of connections per server/virtualhost
79* ftpmail: monitor transfer log and send email when files uploaded
80* ftpquota: manipulate quota tables
81* ftptop: show the current status of FTP sessions
82* ftpwho: show the current process information for each FTP session
83
84%prep
85%setup -q -n %{name}-%{tarballversion}
86find . -type d -name CVS | xargs -r rm -frv
87
88# upstream fixes
89
90# Various module logfile permissions are 0600 instead of 0640
91# http://bugs.proftpd.org/show_bug.cgi?id=3720
92%patch14 -p0
93
94# Support ls(1) -1 option for LIST command
95# http://bugs.proftpd.org/show_bug.cgi?id=3744
96%patch23 -p0
97
98# Reject PASV command if no IPv4 address available
99# http://bugs.proftpd.org/show_bug.cgi?id=3745
100%patch24 -p0
101
102# Support applying ListOptions only to NLST or to LIST commands
103# http://bugs.proftpd.org/show_bug.cgi?id=3746
104%patch25 -p0
105
106## patches from mdk
107# use system-auth instaed of pam_pwdb
108%patch201 -p1
109
110# iconv patch (CharsetLocal/CharsetRemote)
111%patch300 -p1
112
113# fix build on recent kernel headers
114# %patch400 -p0
115
116# security fixes
117
118%build
119# Disable stripping in order to get useful debuginfo packages
120%{__perl} -pi -e 's|"-s"|""|g' configure
121
122%configure \
123    --libexecdir="%{_libexecdir}/proftpd" \
124    --localstatedir="%{_var}/run/proftpd" \
125    --enable-ctrls \
126    --enable-facl \
127    --enable-dso \
128    --enable-nls \
129    --enable-ipv6 \
130    --with-modules=mod_readme:mod_auth_pam:mod_tls:mod_codeconv:mod_df:\
131mod_ban:mod_dynmasq:mod_load:mod_ratio:mod_rewrite \
132    --with-shared=mod_ldap:mod_quotatab:mod_quotatab_file:mod_quotatab_ldap
133
134# It seems that with _smp_mflags -lsupp tries to get linked before being built
135# (as of 1.3.0a-4 F7/devel with koji, happened on F8 x86_64 and F7 ppc64)
136%{__make}
137
138
139%install
140%{__rm} -rf %{buildroot}
141%{__make} install DESTDIR=%{buildroot} \
142    rundir="%{_var}/run/proftpd" \
143    INSTALL_USER=`id -un` \
144    INSTALL_GROUP=`id -gn`
145
146# auth
147mkdir -p %{buildroot}%{_sysconfdir}/pam.d
148%{__install} -m 644 contrib/dist/rpm/ftp.pamd %{buildroot}%{_sysconfdir}/pam.d/ftp
149
150# logrotate
151mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
152%{__install} -m 644 contrib/dist/rpm/proftpd.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/proftpd
153
154# init.d
155%{__install} -D -p -m 0755 %{SOURCE3} \
156    %{buildroot}%{_sysconfdir}/rc.d/init.d/proftpd
157
158%{__install} -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/proftpd.conf
159%{__install} -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/ftpusers
160%{__install} -D -p -m 0644 %{SOURCE5} %{buildroot}/%{_var}/ftp/welcome.msg
161
162touch %{buildroot}%{_sysconfdir}/ftpusers
163
164rm contrib/README.* || :
165# eliminate executable bit in %doc
166find doc/ sample-configurations/ -type f -perm +111 | xargs -r chmod -x
167
168# remove .{la,a}
169rm -f %{buildroot}%{_libexecdir}/proftpd/*.{la,a}
170
171# remove development files (headers and pkgconfig file)
172# who need these files?
173rm -rf %{buildroot}%{_includedir}/proftpd
174rm -rf %{buildroot}%{_libdir}/pkgconfig
175
176%preun
177if [ -d %{_rundir} ] ; then
178        rm -rf %{_rundir}/*
179fi
180
181if [ $1 = 0 ] ; then
182        /sbin/chkconfig --del proftpd
183fi
184
185%postun
186if [ $1 -ge 1 ]; then
187    /sbin/service proftpd condrestart
188fi
189
190%post
191/sbin/chkconfig --add proftpd
192
193
194%clean
195rm -rf %{buildroot}
196
197%files
198%defattr(-,root,root)
199%doc COPYING CREDITS ChangeLog INSTALL NEWS
200%doc README.{LDAP,PAM,modules} doc/*
201%doc contrib/README contrib/xferstats.holger-preiss
202%doc sample-configurations/
203%{_sbindir}/*
204%{_bindir}/ftpdctl
205%{_bindir}/prxs
206%{_mandir}/man5/xferlog.5*
207%{_mandir}/man8/ftpdctl.8*
208%{_mandir}/man8/ftpscrub.8*
209%{_mandir}/man8/ftpshut.8*
210%{_mandir}/man8/proftpd.8*
211%{_var}/ftp/welcome.msg
212%dir %{_libexecdir}/proftpd/
213%{_libexecdir}/proftpd/mod_*
214%{_localedir}/*
215%dir %{_rundir}
216%dir %{_var}/ftp
217%config %{_sysconfdir}/rc.d/init.d/proftpd
218%config(noreplace) %{_sysconfdir}/pam.d/ftp
219%config(noreplace) %{_sysconfdir}/proftpd.conf
220%config(noreplace) %{_sysconfdir}/ftpusers
221%config(noreplace) %{_sysconfdir}/logrotate.d/proftpd
222
223%files utils
224%doc contrib/xferstats.holger-preiss
225%{_bindir}/ftpasswd
226%{_bindir}/ftpcount
227%{_bindir}/ftpmail
228%{_bindir}/ftpquota
229%{_bindir}/ftptop
230%{_bindir}/ftpwho
231%{_mandir}/man1/ftpasswd.1*
232%{_mandir}/man1/ftpcount.1*
233%{_mandir}/man1/ftpmail.1*
234%{_mandir}/man1/ftpquota.1*
235%{_mandir}/man1/ftptop.1*
236%{_mandir}/man1/ftpwho.1*
237
238
239%changelog
240* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4b-2
241- fix util package dependency
242
243* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4b-1
244- new upstream release
245- util tools in util subpackage
246- update patch300 to fit new version
247- add patch14, 23, 24, 25 from fc18 (thanks to fc team)
248- add enable-nls in configure
249
250* Sun Apr 24 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.3e-1
251- new upstream release
252- update patch300 to fit new version
253- drop patch1000 (is included in new release)
254- add BR: e2fsprogs-devel
255
256* Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2e-2
257- rebuild with openssl-1.0.0c
258
259* Fri Nov  5 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2e-1
260- new upstream release
261- add patch1000 for CVE-2010-4221 (TELNET_IAC)
262- add BRs: ncurses-devel, libcap-devel, libacl-devel
263
264* Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2c-1
265- new upstream release with security fix (CVE-2009-3555)
266
267* Wed Oct 21 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2b-1
268- new upstream release with security fix (NULL char in X.509 certificate)
269- add chkconfig --add in post script
270
271* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2a-3
272- remove .{la,a}
273- remove headers and pkgconfig file
274
275* Mon Jul  6 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-2
276- update Source1 (sample config file for vine)
277  set default char set to UTF-8
278
279* Fri Jul  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-1
280- new upstream release
281
282* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
283- rebuild with openldap-2.4.11
284
285* Tue Mar 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-2
286- built with openssl-0.9.8k
287
288* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-1
289- new upstream release
290- add configure option to activate new modules
291- drop patch400
292
293* Wed Jan 14 2009 Shu KONNO <owa@bg.wakwak.com> 1.3.1-6
294- built with openssl-0.9.8j
295
296* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5
297- built with openssl-0.9.8i
298
299* Sun Aug 10 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.1-4
300- add Patch400 to fix build failure at least on i386
301- spec in UTF-8
302
303* Tue Jul 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-3
304- built with openssl-0.9.8h
305
306* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-2
307- update proftpd.vine.conf (use DisplayChdir instead of DisplayFirstChdir)
308
309* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-1
310- new upstream release
311- drop old patches which are included in new release
312- update patch201, 300
313- build under new versioning policy
314
315* Mon Sep 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.0a-0vl1
316- new upstream release
317- built with openssl098
318- drop old (for 1.2.10) patches
319- Patch100-150 from FC8 package
320- Patch160-170 from upstream CVS (maybe will be fixed in 1.3.1)
321- update patch300 for 1.3.0
322- change configure option refer to FC8
323- add process reboot with message output when package is upgraded
324- docfiles list update
325- fix changelog ver number typo
326
327* Sun Sep 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-0vl6
328- add patch202 for fix timestamp (backport from 1.3.0rc1 #2798)
329  (<WISHES:15>)
330- add Vendor/Distribution tag
331- add patch104 for fix pr_ctrls_recv_request issue
332- add patch103 for fix CVE-2006-6170
333- add patch102 for fix CVE-2006-5815
334- add patch101 for fix CVE-2006-6171
335
336* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl5
337- rebuilt with openldap-2.3.27-0vl
338
339* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 1.2.10-0vl4
340- rebuilt with openldap-2.3.24-0vl1
341
342* Sun May 14 2006 Shoji Matsumoto <shom@vinelinux.org> 1.2.10-0vl3
343- add patch300 for iconv patch
344
345* Thu Mar 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl2
346- enable mod_ldap
347- add BuildRequires: openldap-devel, openssl-devel
348- add Patch200 from MDK to support ldap
349- add Patch201 from MDK to use system-auth instead of pam_pwdb
350  (pam_pwdb is now obsolete, and will be removed in the future pam version)
351
352* Fri Sep 09 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
353- 1.2.10-0vl1.1
354- add patch100 for fix CAN-2005-2390
355
356* Sun Sep 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl1
357- new upstream release
358
359* Tue Aug 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl0.3
360- new upstream release (1.2.10rc3)
361- build for Vine Linux 3.0
362
363* Fri May 21 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.10-0vl0.1
364- new upstream release
365- fix security issue: http://secunia.com/advisories/11527/
366
367* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
368- new upstream release
369
370* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8p-0vl1
371- new upstream release
372- fix security issue: http://xforce.iss.net/xforce/alerts/id/154
373
374* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
375- new upstream release
376
377* Fri Dec  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
378- new upstream release 1.2.7
379- add logrotate config file.
380- move ftp home directory from /home/ftp to /var/ftp
381
382* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl1
383- new upstream release 1.2.6
384
385* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl4
386- new upstream release 1.2.5 (stable release version)
387
388* Mon Jun 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
389- new upstream release 1.2.5-rc3
390
391* Mon Jan 28 2002 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl2
392- eliminate executable bit in %doc (requierment for /usr/bin/perl)
393- put files in sample-configurations/ to the according directory
394- remove unnecessary README.* files
395
396* Thu Dec 20 2001 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl1
397- updated to 1.2.5rc1 for problems in file globbing
398
399* Sun Oct 21 2001 Toru Sagami <sagami@vinelinux.org>
400- 1.2.4-0vl1
401
402* Fri Oct 19 2001 Toru Sagami <sagami@vinelinux.org>
403- 1.2.3-0vl1
404
405* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
406- 1.2.2-0vl1: update to 1.2.2 release
407- added more documents
408
409* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl0.rc3
410- update to 1.2.2rc3
411- use macros
412
413* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
414- 1.2.1-0vl3
415- rebuilt for VineSeed
416
417* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.1-0vl2]
418- update to 1.2.1
419
420* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl2]
421- build for VineSeed
422
423* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl1]
424- update to 1.2.0
425- set Epoch 1 to update from pre* and rc* version
426 
427* Tue Feb 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
428- 1.2.0rc3-0vl3
429- removed PreReq and postun about /etc/ftpusers stuff
430
431* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl3]
432- remove setup of /etc/ftpusers in %%pre script
433- add ftpusers.vine insted of the %%pre script
434- remove contrib/README.* frpm %%files
435- add BuildRequires: pam-devel
436
437* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl2]
438- rebuild for VineSeed
439
440* Wed Feb 07 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl1]
441- update to 1.2.0rc3
442- add 'TimesGMT FALSE' in default configuration file
443- build on Vine 2.1
444
445* Mon Feb 05 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
446- modified pre script to make it run by bash2 and added PreReq
447- remove /etc/ftpusers after uninstall
448
449* Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
450- 1.2.0rc2-0vl8
451- rebuilt on VineSeed
452
453* Thu Feb 01 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl7]
454- remove patch from CVS to avoid 'after 5min data brake'
455- add passive patch insted of abobe CVS patch
456- revival contribute's proftpd.init.d
457
458* Tue Jan 23 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl6]
459- fixed %pre script and remove /etc/ftpusers from files
460- modify Japanese summary and descriptions
461
462* Sun Dec 03 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
463- actually fixed to make the package relocatable.
464- non-root build failure by broken %prein, which should be %pre.
465- dont include CVS directory in doc
466- add %config /etc/rc.d/init.d/proftpd
467
468* Tue Nov 14 2000 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl4]
469- correct config directive of the init.d script
470
471* Wed Oct 18 2000 Yoshihiro Kajiki <kajiki@ylug.org> [1.2.0rc2-0vl3]
472- adopt current patch from CVS to avoid the 'put on passive mode' probrem
473
474* Sun Jul 30 2000 Jun Nishii <jun@vinelinux.org>
475- 1.2.0rc2-0vl1
476- obsoletes anonftp
477- do not chkconfig --add in %post
478- requires: pam
479- added proftpd.vine.conf
480
481* Fri Jul 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
482- libtoolize for alpha
483
484* Sat Jul 15 2000 Kazuhisa TAKEI<takei@vinelinux.org>
485- [1.2.0rc2]
486
487* Wed Jun 28 2000 Kazuhisa TAKEI<takei@vinelinux.org>
488- repackaging for VineLinux
489
490* Thu Oct 3 1999 O.Elliyasa <osman@Cable.EU.org>
491- Multi package creation.
492  Created core, standalone, inetd (&doc) package creations.
493  Added startup script for init.d
494  Need to make the "standalone & inetd" packages being created as "noarch"
495- Added URL.
496- Added prefix to make the package relocatable.
497
498* Wed Sep 8 1999 O.Elliyasa <osman@Cable.EU.org>
499- Corrected inetd.conf line addition/change logic.
500
501* Sat Jul 24 1999 MacGyver <macgyver@tos.net>
502- Initial import of spec.
503
Note: See TracBrowser for help on using the repository browser.