source: projects/specs/trunk/p/proftpd/proftpd-vl.spec @ 12284

Revision 12284, 15.5 KB checked in by tomop, 5 years ago (diff)

updated 7 packages

lmdb-0.9.24-1

libmodsecurity-3.0.3-3

libssh2-1.9.0-1

nginx-1.16.1-2

proftpd-1.3.6b-1

ssdeep-2.14.1-8

yajl-2.1.0-1

Line 
1%define _prefix         /usr
2%define _localstatedir  /var/run
3%define _sysconfdir     /etc
4%define _rundir         /var/run/proftpd
5%define tarballversion  1.3.6b
6%define origversion     1.3.6b
7
8Summary: ProFTPd -- Professional FTP Server.
9Summary(ja): ProFTPd -- プロフェッショナル FTP サーバ
10Name: proftpd
11Epoch: 1
12Version: %{origversion}
13Release: 1%{?_dist_release}
14License: GPL
15Group: System Environment/Daemons
16URL: http://www.proftpd.org/
17
18Source0: https://github.com/proftpd/proftpd/archive/v1.3.6b.tar.gz#/%{name}-%{origversion}.tar.gz
19Source1: proftpd.vine.conf
20Source2: ftpusers.vine
21Source3: proftpd.init
22Source5: welcome.msg
23
24# upstream bug fixes & security fixes
25
26# auth
27Patch201: proftpd-1.3.1-use-system-auth-instead-of-pam_pwdb.patch
28
29# iconv patch (CharsetLocal/CharsetRemote)
30# Patch300: http://www.hakusan.tsg.ne.jp/tjkawa/software/misc/proftpd-iconv/pack/proftpd-1.3.0-iconv.patch.gz
31Patch300: proftpd-1.3.6b-iconv.patch
32
33# fix build on recent kernel headers
34# Patch400: proftpd-1.3.1-umode.patch
35
36# security fix
37# nothing..
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-root
40BuildRequires: pam-devel, openldap-devel, openssl-devel
41BuildRequires: ncurses-devel, libcap-devel, libacl-devel
42BuildRequires: e2fsprogs-devel
43Requires: pam > 0.59
44Obsoletes: wu-ftpd, anonftp
45Provides: ftpserver
46
47Vendor: Project Vine
48Distribution: Vine Linux
49
50%description
51ProFTPd is an enhanced FTP server with a focus toward simplicity,
52security, and ease of configuration.  It features a very Apache-like
53configuration syntax, and a highly customizable server infrastructure,
54including support for multiple 'virtual' FTP servers, anonymous FTP,
55and permission-based directory visibility.
56
57%description -l ja
58ProFTPd は シンプルさ, セキュリティ, 設定の容易さに焦点をあてた 優れた
59FTP サーバです。Apache に似た構文による設定や、複数の仮想 FTP サーバ、
60anonymous FTP, パーミッションベースのディレクトリ可視性のサポートを含む、
61高度にカスタマイズ可能なサーバ・インターフェイスを特徴としています。
62
63
64%package utils
65Summary: ProFTPD - Additional utilities
66Group:           System Environment/Daemons
67Requires:        %{name} = %{epoch}:%{version}-%{release}
68
69%description utils
70This package contains additional utilities for monitoring and configuring the
71ProFTPD server:
72
73* ftpasswd: generate passwd(5) files for use with AuthUserFile
74* ftpcount: show the current number of connections per server/virtualhost
75* ftpmail: monitor transfer log and send email when files uploaded
76* ftpquota: manipulate quota tables
77* ftptop: show the current status of FTP sessions
78* ftpwho: show the current process information for each FTP session
79
80%prep
81%setup -q -n %{name}-%{tarballversion}
82find . -type d -name CVS | xargs -r rm -frv
83
84# upstream fixes
85
86## patches from mdk
87# use system-auth instead of pam_pwdb
88%patch201 -p1
89
90# iconv patch (CharsetLocal/CharsetRemote)
91%patch300 -p1
92
93# fix build on recent kernel headers
94# %patch400 -p0
95
96# security fixes
97
98%build
99# Disable stripping in order to get useful debuginfo packages
100%{__perl} -pi -e 's|"-s"|""|g' configure
101
102%configure \
103    --libexecdir="%{_libexecdir}/proftpd" \
104    --localstatedir="%{_var}/run/proftpd" \
105    --enable-ctrls \
106    --enable-facl \
107    --enable-dso \
108    --enable-nls \
109    --enable-ipv6 \
110    --with-modules=mod_readme:mod_auth_pam:mod_tls:mod_codeconv:mod_df:\
111mod_ban:mod_dynmasq:mod_load:mod_ratio:mod_rewrite \
112    --with-shared=mod_ldap:mod_quotatab:mod_quotatab_file:mod_quotatab_ldap
113
114# It seems that with _smp_mflags -lsupp tries to get linked before being built
115# (as of 1.3.0a-4 F7/devel with koji, happened on F8 x86_64 and F7 ppc64)
116%{__make}
117
118
119%install
120%{__rm} -rf %{buildroot}
121%{__make} install DESTDIR=%{buildroot} \
122    rundir="%{_var}/run/proftpd" \
123    INSTALL_USER=`id -un` \
124    INSTALL_GROUP=`id -gn`
125
126# auth
127mkdir -p %{buildroot}%{_sysconfdir}/pam.d
128%{__install} -m 644 contrib/dist/rpm/ftp.pamd %{buildroot}%{_sysconfdir}/pam.d/ftp
129
130# logrotate
131mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
132%{__install} -m 644 contrib/dist/rpm/proftpd.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/proftpd
133
134# init.d
135%{__install} -D -p -m 0755 %{SOURCE3} \
136    %{buildroot}%{_sysconfdir}/rc.d/init.d/proftpd
137
138%{__install} -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/proftpd.conf
139%{__install} -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/ftpusers
140%{__install} -D -p -m 0644 %{SOURCE5} %{buildroot}/%{_var}/ftp/welcome.msg
141
142touch %{buildroot}%{_sysconfdir}/ftpusers
143
144rm contrib/README.* || :
145# eliminate executable bit in %doc
146find doc/ sample-configurations/ -type f -perm +111 | xargs -r chmod -x
147
148# remove .{la,a}
149rm -f %{buildroot}%{_libexecdir}/proftpd/*.{la,a}
150
151# remove development files (headers and pkgconfig file)
152# who need these files?
153rm -rf %{buildroot}%{_includedir}/proftpd
154rm -rf %{buildroot}%{_libdir}/pkgconfig
155
156%preun
157if [ -d %{_rundir} ] ; then
158        rm -rf %{_rundir}/*
159fi
160
161if [ $1 = 0 ] ; then
162        /sbin/chkconfig --del proftpd
163fi
164
165%postun
166if [ $1 -ge 1 ]; then
167    /sbin/service proftpd condrestart
168fi
169
170%post
171/sbin/chkconfig --add proftpd
172
173
174%clean
175rm -rf %{buildroot}
176
177%files
178%defattr(-,root,root)
179%license COPYING
180%doc CREDITS INSTALL NEWS
181%doc README.{md,LDAP,PAM,modules}
182%doc doc/*
183%doc contrib/README contrib/xferstats.holger-preiss
184%doc sample-configurations/
185%{_sbindir}/*
186%{_bindir}/ftpdctl
187%{_bindir}/prxs
188%{_mandir}/man5/proftpd.conf.5*
189%{_mandir}/man5/xferlog.5*
190%{_mandir}/man8/ftpdctl.8*
191%{_mandir}/man8/ftpscrub.8*
192%{_mandir}/man8/ftpshut.8*
193%{_mandir}/man8/proftpd.8*
194%{_var}/ftp/welcome.msg
195%dir %{_libexecdir}/proftpd/
196%{_libexecdir}/proftpd/mod_*
197%{_localedir}/*
198%dir %{_rundir}
199%dir %{_var}/ftp
200%config %{_sysconfdir}/rc.d/init.d/proftpd
201%config(noreplace) %{_sysconfdir}/pam.d/ftp
202%config(noreplace) %{_sysconfdir}/proftpd.conf
203%config(noreplace) %{_sysconfdir}/ftpusers
204%config(noreplace) %{_sysconfdir}/logrotate.d/proftpd
205
206%files utils
207%doc contrib/xferstats.holger-preiss
208%{_bindir}/ftpasswd
209%{_bindir}/ftpcount
210%{_bindir}/ftpmail
211%{_bindir}/ftpquota
212%{_bindir}/ftptop
213%{_bindir}/ftpwho
214%{_mandir}/man1/ftpasswd.1*
215%{_mandir}/man1/ftpcount.1*
216%{_mandir}/man1/ftpmail.1*
217%{_mandir}/man1/ftpquota.1*
218%{_mandir}/man1/ftptop.1*
219%{_mandir}/man1/ftpwho.1*
220
221
222%changelog
223* Thu Oct 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.6b-1
224- new upstream release.
225
226* Fri Mar 16 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.5e-1
227- new upstream release.
228- remake patch24 for 1.3.5e
229
230* Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.5b-1
231- new upstream release.
232- removed Patch14, Patch23 and Patch25 (no longer needed).
233- updated Patch300.
234
235* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4b-2
236- fix util package dependency
237
238* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4b-1
239- new upstream release
240- util tools in util subpackage
241- update patch300 to fit new version
242- add patch14, 23, 24, 25 from fc18 (thanks to fc team)
243- add enable-nls in configure
244
245* Sun Apr 24 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.3e-1
246- new upstream release
247- update patch300 to fit new version
248- drop patch1000 (is included in new release)
249- add BR: e2fsprogs-devel
250
251* Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2e-2
252- rebuild with openssl-1.0.0c
253
254* Fri Nov  5 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2e-1
255- new upstream release
256- add patch1000 for CVE-2010-4221 (TELNET_IAC)
257- add BRs: ncurses-devel, libcap-devel, libacl-devel
258
259* Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2c-1
260- new upstream release with security fix (CVE-2009-3555)
261
262* Wed Oct 21 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2b-1
263- new upstream release with security fix (NULL char in X.509 certificate)
264- add chkconfig --add in post script
265
266* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2a-3
267- remove .{la,a}
268- remove headers and pkgconfig file
269
270* Mon Jul  6 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-2
271- update Source1 (sample config file for vine)
272  set default char set to UTF-8
273
274* Fri Jul  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-1
275- new upstream release
276
277* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
278- rebuild with openldap-2.4.11
279
280* Tue Mar 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-2
281- built with openssl-0.9.8k
282
283* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-1
284- new upstream release
285- add configure option to activate new modules
286- drop patch400
287
288* Wed Jan 14 2009 Shu KONNO <owa@bg.wakwak.com> 1.3.1-6
289- built with openssl-0.9.8j
290
291* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5
292- built with openssl-0.9.8i
293
294* Sun Aug 10 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.1-4
295- add Patch400 to fix build failure at least on i386
296- spec in UTF-8
297
298* Tue Jul 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-3
299- built with openssl-0.9.8h
300
301* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-2
302- update proftpd.vine.conf (use DisplayChdir instead of DisplayFirstChdir)
303
304* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-1
305- new upstream release
306- drop old patches which are included in new release
307- update patch201, 300
308- build under new versioning policy
309
310* Mon Sep 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.0a-0vl1
311- new upstream release
312- built with openssl098
313- drop old (for 1.2.10) patches
314- Patch100-150 from FC8 package
315- Patch160-170 from upstream CVS (maybe will be fixed in 1.3.1)
316- update patch300 for 1.3.0
317- change configure option refer to FC8
318- add process reboot with message output when package is upgraded
319- docfiles list update
320- fix changelog ver number typo
321
322* Sun Sep 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-0vl6
323- add patch202 for fix timestamp (backport from 1.3.0rc1 #2798)
324  (<WISHES:15>)
325- add Vendor/Distribution tag
326- add patch104 for fix pr_ctrls_recv_request issue
327- add patch103 for fix CVE-2006-6170
328- add patch102 for fix CVE-2006-5815
329- add patch101 for fix CVE-2006-6171
330
331* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl5
332- rebuilt with openldap-2.3.27-0vl
333
334* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 1.2.10-0vl4
335- rebuilt with openldap-2.3.24-0vl1
336
337* Sun May 14 2006 Shoji Matsumoto <shom@vinelinux.org> 1.2.10-0vl3
338- add patch300 for iconv patch
339
340* Thu Mar 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl2
341- enable mod_ldap
342- add BuildRequires: openldap-devel, openssl-devel
343- add Patch200 from MDK to support ldap
344- add Patch201 from MDK to use system-auth instead of pam_pwdb
345  (pam_pwdb is now obsolete, and will be removed in the future pam version)
346
347* Fri Sep 09 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
348- 1.2.10-0vl1.1
349- add patch100 for fix CAN-2005-2390
350
351* Sun Sep 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl1
352- new upstream release
353
354* Tue Aug 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl0.3
355- new upstream release (1.2.10rc3)
356- build for Vine Linux 3.0
357
358* Fri May 21 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.10-0vl0.1
359- new upstream release
360- fix security issue: http://secunia.com/advisories/11527/
361
362* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
363- new upstream release
364
365* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8p-0vl1
366- new upstream release
367- fix security issue: http://xforce.iss.net/xforce/alerts/id/154
368
369* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
370- new upstream release
371
372* Fri Dec  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
373- new upstream release 1.2.7
374- add logrotate config file.
375- move ftp home directory from /home/ftp to /var/ftp
376
377* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl1
378- new upstream release 1.2.6
379
380* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl4
381- new upstream release 1.2.5 (stable release version)
382
383* Mon Jun 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
384- new upstream release 1.2.5-rc3
385
386* Mon Jan 28 2002 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl2
387- eliminate executable bit in %doc (requierment for /usr/bin/perl)
388- put files in sample-configurations/ to the according directory
389- remove unnecessary README.* files
390
391* Thu Dec 20 2001 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl1
392- updated to 1.2.5rc1 for problems in file globbing
393
394* Sun Oct 21 2001 Toru Sagami <sagami@vinelinux.org>
395- 1.2.4-0vl1
396
397* Fri Oct 19 2001 Toru Sagami <sagami@vinelinux.org>
398- 1.2.3-0vl1
399
400* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
401- 1.2.2-0vl1: update to 1.2.2 release
402- added more documents
403
404* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl0.rc3
405- update to 1.2.2rc3
406- use macros
407
408* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
409- 1.2.1-0vl3
410- rebuilt for VineSeed
411
412* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.1-0vl2]
413- update to 1.2.1
414
415* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl2]
416- build for VineSeed
417
418* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl1]
419- update to 1.2.0
420- set Epoch 1 to update from pre* and rc* version
421 
422* Tue Feb 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
423- 1.2.0rc3-0vl3
424- removed PreReq and postun about /etc/ftpusers stuff
425
426* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl3]
427- remove setup of /etc/ftpusers in %%pre script
428- add ftpusers.vine insted of the %%pre script
429- remove contrib/README.* frpm %%files
430- add BuildRequires: pam-devel
431
432* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl2]
433- rebuild for VineSeed
434
435* Wed Feb 07 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl1]
436- update to 1.2.0rc3
437- add 'TimesGMT FALSE' in default configuration file
438- build on Vine 2.1
439
440* Mon Feb 05 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
441- modified pre script to make it run by bash2 and added PreReq
442- remove /etc/ftpusers after uninstall
443
444* Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
445- 1.2.0rc2-0vl8
446- rebuilt on VineSeed
447
448* Thu Feb 01 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl7]
449- remove patch from CVS to avoid 'after 5min data brake'
450- add passive patch insted of abobe CVS patch
451- revival contribute's proftpd.init.d
452
453* Tue Jan 23 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl6]
454- fixed %pre script and remove /etc/ftpusers from files
455- modify Japanese summary and descriptions
456
457* Sun Dec 03 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
458- actually fixed to make the package relocatable.
459- non-root build failure by broken %prein, which should be %pre.
460- dont include CVS directory in doc
461- add %config /etc/rc.d/init.d/proftpd
462
463* Tue Nov 14 2000 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl4]
464- correct config directive of the init.d script
465
466* Wed Oct 18 2000 Yoshihiro Kajiki <kajiki@ylug.org> [1.2.0rc2-0vl3]
467- adopt current patch from CVS to avoid the 'put on passive mode' probrem
468
469* Sun Jul 30 2000 Jun Nishii <jun@vinelinux.org>
470- 1.2.0rc2-0vl1
471- obsoletes anonftp
472- do not chkconfig --add in %post
473- requires: pam
474- added proftpd.vine.conf
475
476* Fri Jul 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
477- libtoolize for alpha
478
479* Sat Jul 15 2000 Kazuhisa TAKEI<takei@vinelinux.org>
480- [1.2.0rc2]
481
482* Wed Jun 28 2000 Kazuhisa TAKEI<takei@vinelinux.org>
483- repackaging for VineLinux
484
485* Sun Oct 3 1999 O.Elliyasa <osman@Cable.EU.org>
486- Multi package creation.
487  Created core, standalone, inetd (&doc) package creations.
488  Added startup script for init.d
489  Need to make the "standalone & inetd" packages being created as "noarch"
490- Added URL.
491- Added prefix to make the package relocatable.
492
493* Wed Sep 8 1999 O.Elliyasa <osman@Cable.EU.org>
494- Corrected inetd.conf line addition/change logic.
495
496* Sat Jul 24 1999 MacGyver <macgyver@tos.net>
497- Initial import of spec.
498
Note: See TracBrowser for help on using the repository browser.