source: projects/specs/trunk/p/proftpd/proftpd-vl.spec @ 10181

Revision 10181, 15.4 KB checked in by tomop, 8 years ago (diff)

proftpd-1.3.5b-1

Line 
1%define _prefix         /usr
2%define _localstatedir  /var/run
3%define _sysconfdir     /etc
4%define _rundir         /var/run/proftpd
5%define tarballversion  1.3.5b
6%define origversion     1.3.5b
7
8Summary: ProFTPd -- Professional FTP Server.
9Summary(ja): ProFTPd -- プロフェッショナル FTP サーバ
10Name: proftpd
11Epoch: 1
12Version: %{origversion}
13Release: 1%{?_dist_release}
14License: GPL
15Group: System Environment/Daemons
16URL: http://www.proftpd.org/
17
18Source0: ftp://ftp.proftpd.org/distrib/source/%{name}-%{origversion}.tar.gz
19Source1: proftpd.vine.conf
20Source2: ftpusers.vine
21Source3: proftpd.init
22Source5: welcome.msg
23
24# upstream bug fixes & security fixes
25Patch24: proftpd-1.3.4a-bug3745.patch
26
27# auth
28Patch201: proftpd-1.3.1-use-system-auth-instead-of-pam_pwdb.patch
29
30# iconv patch (CharsetLocal/CharsetRemote)
31# Patch300: http://www.hakusan.tsg.ne.jp/tjkawa/software/misc/proftpd-iconv/pack/proftpd-1.3.0-iconv.patch.gz
32Patch300: proftpd-1.3.5b-iconv.patch
33
34# fix build on recent kernel headers
35# Patch400: proftpd-1.3.1-umode.patch
36
37# security fix
38# nothing..
39
40BuildRoot: %{_tmppath}/%{name}-%{version}-root
41BuildRequires: pam-devel, openldap-devel, openssl-devel
42BuildRequires: ncurses-devel, libcap-devel, libacl-devel
43BuildRequires: e2fsprogs-devel
44Requires: pam > 0.59
45Obsoletes: wu-ftpd, anonftp
46Provides: ftpserver
47
48Vendor: Project Vine
49Distribution: Vine Linux
50
51%description
52ProFTPd is an enhanced FTP server with a focus toward simplicity,
53security, and ease of configuration.  It features a very Apache-like
54configuration syntax, and a highly customizable server infrastructure,
55including support for multiple 'virtual' FTP servers, anonymous FTP,
56and permission-based directory visibility.
57
58%description -l ja
59ProFTPd は シンプルさ, セキュリティ, 設定の容易さに焦点をあてた 優れた
60FTP サーバです。Apache に似た構文による設定や、複数の仮想 FTP サーバ、
61anonymous FTP, パーミッションベースのディレクトリ可視性のサポートを含む、
62高度にカスタマイズ可能なサーバ・インターフェイスを特徴としています。
63
64
65%package utils
66Summary: ProFTPD - Additional utilities
67Group:           System Environment/Daemons
68Requires:        %{name} = %{epoch}:%{version}-%{release}
69
70%description utils
71This package contains additional utilities for monitoring and configuring the
72ProFTPD server:
73
74* ftpasswd: generate passwd(5) files for use with AuthUserFile
75* ftpcount: show the current number of connections per server/virtualhost
76* ftpmail: monitor transfer log and send email when files uploaded
77* ftpquota: manipulate quota tables
78* ftptop: show the current status of FTP sessions
79* ftpwho: show the current process information for each FTP session
80
81%prep
82%setup -q -n %{name}-%{tarballversion}
83find . -type d -name CVS | xargs -r rm -frv
84
85# upstream fixes
86
87# Reject PASV command if no IPv4 address available
88# http://bugs.proftpd.org/show_bug.cgi?id=3745
89%patch24 -p0
90
91## patches from mdk
92# use system-auth instead of pam_pwdb
93%patch201 -p1
94
95# iconv patch (CharsetLocal/CharsetRemote)
96%patch300 -p1
97
98# fix build on recent kernel headers
99# %patch400 -p0
100
101# security fixes
102
103%build
104# Disable stripping in order to get useful debuginfo packages
105%{__perl} -pi -e 's|"-s"|""|g' configure
106
107%configure \
108    --libexecdir="%{_libexecdir}/proftpd" \
109    --localstatedir="%{_var}/run/proftpd" \
110    --enable-ctrls \
111    --enable-facl \
112    --enable-dso \
113    --enable-nls \
114    --enable-ipv6 \
115    --with-modules=mod_readme:mod_auth_pam:mod_tls:mod_codeconv:mod_df:\
116mod_ban:mod_dynmasq:mod_load:mod_ratio:mod_rewrite \
117    --with-shared=mod_ldap:mod_quotatab:mod_quotatab_file:mod_quotatab_ldap
118
119# It seems that with _smp_mflags -lsupp tries to get linked before being built
120# (as of 1.3.0a-4 F7/devel with koji, happened on F8 x86_64 and F7 ppc64)
121%{__make}
122
123
124%install
125%{__rm} -rf %{buildroot}
126%{__make} install DESTDIR=%{buildroot} \
127    rundir="%{_var}/run/proftpd" \
128    INSTALL_USER=`id -un` \
129    INSTALL_GROUP=`id -gn`
130
131# auth
132mkdir -p %{buildroot}%{_sysconfdir}/pam.d
133%{__install} -m 644 contrib/dist/rpm/ftp.pamd %{buildroot}%{_sysconfdir}/pam.d/ftp
134
135# logrotate
136mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
137%{__install} -m 644 contrib/dist/rpm/proftpd.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/proftpd
138
139# init.d
140%{__install} -D -p -m 0755 %{SOURCE3} \
141    %{buildroot}%{_sysconfdir}/rc.d/init.d/proftpd
142
143%{__install} -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/proftpd.conf
144%{__install} -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/ftpusers
145%{__install} -D -p -m 0644 %{SOURCE5} %{buildroot}/%{_var}/ftp/welcome.msg
146
147touch %{buildroot}%{_sysconfdir}/ftpusers
148
149rm contrib/README.* || :
150# eliminate executable bit in %doc
151find doc/ sample-configurations/ -type f -perm +111 | xargs -r chmod -x
152
153# remove .{la,a}
154rm -f %{buildroot}%{_libexecdir}/proftpd/*.{la,a}
155
156# remove development files (headers and pkgconfig file)
157# who need these files?
158rm -rf %{buildroot}%{_includedir}/proftpd
159rm -rf %{buildroot}%{_libdir}/pkgconfig
160
161%preun
162if [ -d %{_rundir} ] ; then
163        rm -rf %{_rundir}/*
164fi
165
166if [ $1 = 0 ] ; then
167        /sbin/chkconfig --del proftpd
168fi
169
170%postun
171if [ $1 -ge 1 ]; then
172    /sbin/service proftpd condrestart
173fi
174
175%post
176/sbin/chkconfig --add proftpd
177
178
179%clean
180rm -rf %{buildroot}
181
182%files
183%defattr(-,root,root)
184%doc COPYING CREDITS ChangeLog INSTALL NEWS
185%doc README.{LDAP,PAM,modules} doc/*
186%doc contrib/README contrib/xferstats.holger-preiss
187%doc sample-configurations/
188%{_sbindir}/*
189%{_bindir}/ftpdctl
190%{_bindir}/prxs
191%{_mandir}/man5/proftpd.conf.5*
192%{_mandir}/man5/xferlog.5*
193%{_mandir}/man8/ftpdctl.8*
194%{_mandir}/man8/ftpscrub.8*
195%{_mandir}/man8/ftpshut.8*
196%{_mandir}/man8/proftpd.8*
197%{_var}/ftp/welcome.msg
198%dir %{_libexecdir}/proftpd/
199%{_libexecdir}/proftpd/mod_*
200%{_localedir}/*
201%dir %{_rundir}
202%dir %{_var}/ftp
203%config %{_sysconfdir}/rc.d/init.d/proftpd
204%config(noreplace) %{_sysconfdir}/pam.d/ftp
205%config(noreplace) %{_sysconfdir}/proftpd.conf
206%config(noreplace) %{_sysconfdir}/ftpusers
207%config(noreplace) %{_sysconfdir}/logrotate.d/proftpd
208
209%files utils
210%doc contrib/xferstats.holger-preiss
211%{_bindir}/ftpasswd
212%{_bindir}/ftpcount
213%{_bindir}/ftpmail
214%{_bindir}/ftpquota
215%{_bindir}/ftptop
216%{_bindir}/ftpwho
217%{_mandir}/man1/ftpasswd.1*
218%{_mandir}/man1/ftpcount.1*
219%{_mandir}/man1/ftpmail.1*
220%{_mandir}/man1/ftpquota.1*
221%{_mandir}/man1/ftptop.1*
222%{_mandir}/man1/ftpwho.1*
223
224
225%changelog
226* Tue Apr 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.5b-1
227- new upstream release.
228- removed Patch14, Patch23 and Patch25 (no longer needed).
229- updated Patch300.
230
231* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4b-2
232- fix util package dependency
233
234* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.4b-1
235- new upstream release
236- util tools in util subpackage
237- update patch300 to fit new version
238- add patch14, 23, 24, 25 from fc18 (thanks to fc team)
239- add enable-nls in configure
240
241* Sun Apr 24 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.3e-1
242- new upstream release
243- update patch300 to fit new version
244- drop patch1000 (is included in new release)
245- add BR: e2fsprogs-devel
246
247* Wed Jan 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.2e-2
248- rebuild with openssl-1.0.0c
249
250* Fri Nov  5 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2e-1
251- new upstream release
252- add patch1000 for CVE-2010-4221 (TELNET_IAC)
253- add BRs: ncurses-devel, libcap-devel, libacl-devel
254
255* Mon Dec 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2c-1
256- new upstream release with security fix (CVE-2009-3555)
257
258* Wed Oct 21 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2b-1
259- new upstream release with security fix (NULL char in X.509 certificate)
260- add chkconfig --add in post script
261
262* Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2a-3
263- remove .{la,a}
264- remove headers and pkgconfig file
265
266* Mon Jul  6 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-2
267- update Source1 (sample config file for vine)
268  set default char set to UTF-8
269
270* Fri Jul  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2a-1
271- new upstream release
272
273* Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.2-3
274- rebuild with openldap-2.4.11
275
276* Tue Mar 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-2
277- built with openssl-0.9.8k
278
279* Sat Feb 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.2-1
280- new upstream release
281- add configure option to activate new modules
282- drop patch400
283
284* Wed Jan 14 2009 Shu KONNO <owa@bg.wakwak.com> 1.3.1-6
285- built with openssl-0.9.8j
286
287* Mon Sep 22 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-5
288- built with openssl-0.9.8i
289
290* Sun Aug 10 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.1-4
291- add Patch400 to fix build failure at least on i386
292- spec in UTF-8
293
294* Tue Jul 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.3.1-3
295- built with openssl-0.9.8h
296
297* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-2
298- update proftpd.vine.conf (use DisplayChdir instead of DisplayFirstChdir)
299
300* Sun Mar 23 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.1-1
301- new upstream release
302- drop old patches which are included in new release
303- update patch201, 300
304- build under new versioning policy
305
306* Mon Sep 10 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.3.0a-0vl1
307- new upstream release
308- built with openssl098
309- drop old (for 1.2.10) patches
310- Patch100-150 from FC8 package
311- Patch160-170 from upstream CVS (maybe will be fixed in 1.3.1)
312- update patch300 for 1.3.0
313- change configure option refer to FC8
314- add process reboot with message output when package is upgraded
315- docfiles list update
316- fix changelog ver number typo
317
318* Sun Sep 09 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.2.10-0vl6
319- add patch202 for fix timestamp (backport from 1.3.0rc1 #2798)
320  (<WISHES:15>)
321- add Vendor/Distribution tag
322- add patch104 for fix pr_ctrls_recv_request issue
323- add patch103 for fix CVE-2006-6170
324- add patch102 for fix CVE-2006-5815
325- add patch101 for fix CVE-2006-6171
326
327* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.10-0vl5
328- rebuilt with openldap-2.3.27-0vl
329
330* Sun Jul 02 2006 Satoshi MACHINO <machino@vinelinux.org> 1.2.10-0vl4
331- rebuilt with openldap-2.3.24-0vl1
332
333* Sun May 14 2006 Shoji Matsumoto <shom@vinelinux.org> 1.2.10-0vl3
334- add patch300 for iconv patch
335
336* Thu Mar 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl2
337- enable mod_ldap
338- add BuildRequires: openldap-devel, openssl-devel
339- add Patch200 from MDK to support ldap
340- add Patch201 from MDK to use system-auth instead of pam_pwdb
341  (pam_pwdb is now obsolete, and will be removed in the future pam version)
342
343* Fri Sep 09 2005 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp>
344- 1.2.10-0vl1.1
345- add patch100 for fix CAN-2005-2390
346
347* Sun Sep 05 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl1
348- new upstream release
349
350* Tue Aug 03 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.10-0vl0.3
351- new upstream release (1.2.10rc3)
352- build for Vine Linux 3.0
353
354* Fri May 21 2004 IKEDA Katsumi <ikeda@webmasters.gr.jp> 1.2.10-0vl0.1
355- new upstream release
356- fix security issue: http://secunia.com/advisories/11527/
357
358* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.9-0vl1
359- new upstream release
360
361* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8p-0vl1
362- new upstream release
363- fix security issue: http://xforce.iss.net/xforce/alerts/id/154
364
365* Sun Mar  9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.8-0vl1
366- new upstream release
367
368* Fri Dec  6 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-0vl1
369- new upstream release 1.2.7
370- add logrotate config file.
371- move ftp home directory from /home/ftp to /var/ftp
372
373* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6-0vl1
374- new upstream release 1.2.6
375
376* Mon Jun 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl4
377- new upstream release 1.2.5 (stable release version)
378
379* Mon Jun 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-0vl3
380- new upstream release 1.2.5-rc3
381
382* Mon Jan 28 2002 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl2
383- eliminate executable bit in %doc (requierment for /usr/bin/perl)
384- put files in sample-configurations/ to the according directory
385- remove unnecessary README.* files
386
387* Thu Dec 20 2001 Toru Sagami <sagami@vinelinux.org> 1.2.5-0vl1
388- updated to 1.2.5rc1 for problems in file globbing
389
390* Sun Oct 21 2001 Toru Sagami <sagami@vinelinux.org>
391- 1.2.4-0vl1
392
393* Fri Oct 19 2001 Toru Sagami <sagami@vinelinux.org>
394- 1.2.3-0vl1
395
396* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
397- 1.2.2-0vl1: update to 1.2.2 release
398- added more documents
399
400* Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl0.rc3
401- update to 1.2.2rc3
402- use macros
403
404* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
405- 1.2.1-0vl3
406- rebuilt for VineSeed
407
408* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.1-0vl2]
409- update to 1.2.1
410
411* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl2]
412- build for VineSeed
413
414* Tue Feb 27 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0-0vl1]
415- update to 1.2.0
416- set Epoch 1 to update from pre* and rc* version
417 
418* Tue Feb 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
419- 1.2.0rc3-0vl3
420- removed PreReq and postun about /etc/ftpusers stuff
421
422* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl3]
423- remove setup of /etc/ftpusers in %%pre script
424- add ftpusers.vine insted of the %%pre script
425- remove contrib/README.* frpm %%files
426- add BuildRequires: pam-devel
427
428* Mon Feb 19 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl2]
429- rebuild for VineSeed
430
431* Wed Feb 07 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc3-0vl1]
432- update to 1.2.0rc3
433- add 'TimesGMT FALSE' in default configuration file
434- build on Vine 2.1
435
436* Mon Feb 05 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
437- modified pre script to make it run by bash2 and added PreReq
438- remove /etc/ftpusers after uninstall
439
440* Thu Feb 01 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
441- 1.2.0rc2-0vl8
442- rebuilt on VineSeed
443
444* Thu Feb 01 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl7]
445- remove patch from CVS to avoid 'after 5min data brake'
446- add passive patch insted of abobe CVS patch
447- revival contribute's proftpd.init.d
448
449* Tue Jan 23 2001 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl6]
450- fixed %pre script and remove /etc/ftpusers from files
451- modify Japanese summary and descriptions
452
453* Sun Dec 03 2000 Toru Sagami <czs14350@mb.infoweb.ne.jp>
454- actually fixed to make the package relocatable.
455- non-root build failure by broken %prein, which should be %pre.
456- dont include CVS directory in doc
457- add %config /etc/rc.d/init.d/proftpd
458
459* Tue Nov 14 2000 KAJIKI Yoshihiro <kajiki@ylug.org> [1.2.0rc2-0vl4]
460- correct config directive of the init.d script
461
462* Wed Oct 18 2000 Yoshihiro Kajiki <kajiki@ylug.org> [1.2.0rc2-0vl3]
463- adopt current patch from CVS to avoid the 'put on passive mode' probrem
464
465* Sun Jul 30 2000 Jun Nishii <jun@vinelinux.org>
466- 1.2.0rc2-0vl1
467- obsoletes anonftp
468- do not chkconfig --add in %post
469- requires: pam
470- added proftpd.vine.conf
471
472* Fri Jul 28 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
473- libtoolize for alpha
474
475* Sat Jul 15 2000 Kazuhisa TAKEI<takei@vinelinux.org>
476- [1.2.0rc2]
477
478* Wed Jun 28 2000 Kazuhisa TAKEI<takei@vinelinux.org>
479- repackaging for VineLinux
480
481* Sun Oct 3 1999 O.Elliyasa <osman@Cable.EU.org>
482- Multi package creation.
483  Created core, standalone, inetd (&doc) package creations.
484  Added startup script for init.d
485  Need to make the "standalone & inetd" packages being created as "noarch"
486- Added URL.
487- Added prefix to make the package relocatable.
488
489* Wed Sep 8 1999 O.Elliyasa <osman@Cable.EU.org>
490- Corrected inetd.conf line addition/change logic.
491
492* Sat Jul 24 1999 MacGyver <macgyver@tos.net>
493- Initial import of spec.
494
Note: See TracBrowser for help on using the repository browser.