source: projects/specs/trunk/p/preload/preload-vl.spec @ 6450

Revision 6450, 5.7 KB checked in by kudoh, 12 years ago (diff)

preload-vl.spec

Line 
1Name:           preload
2Version:        0.6.4
3Release:        5%{?_dist_release}
4Summary:        an adaptive readahead daemon
5Summary(ja):    適応的先読みデーモン
6Group:          Applications/System
7License:        GPLv2+
8URL:            http://preload.sf.net/
9Source0:        http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
10
11#Patch0:                preload-0.6-start-late.patch
12
13Patch0: preload.init.in.patch
14#This patch prefered to http://sourceforge.net/tracker/index.php?func=detail&aid=2183212&group_id=143398&atid=755420
15Patch1: preload-conf.patch
16#This patch from http://preload.svn.sourceforge.net/viewvc/preload/trunk/src/cmdline.c?revision=122
17Patch2: logrotate_619384
18#http://patch-tracker.debian.org/patch/series/view/preload/0.6.4-2/logrotate_619384
19#This patch from Mandriva
20#Patch3: preload-0.6.3-glib214.patch
21
22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23BuildRequires:  basesystem, glib2-devel, help2man
24Requires:       basesystem, logrotate
25Requires(post): /sbin/chkconfig
26Requires(post): /sbin/service
27Requires(preun): /sbin/chkconfig
28Requires(preun): /sbin/service
29Requires(postun): /sbin/service
30
31%description
32preload monitors applications that users run, and by analyzing this data,
33predicts what applications users might run, and fetches those binaries and
34their dependencies into memory for faster startup times.
35
36%description -l ja
37preload は起動中のアプリケーションを監視し、監視したデータを分析することで、
38度のアプリケーションユーザが起動されるかを予想し、バイナリと依存する
39ライブラリをメモリに取り込み、起動時間を高速にします。
40
41%prep
42%setup -q
43%patch0 -p1
44%patch1 -p1
45%patch2 -p1
46#%patch3 -p1
47
48%build
49%configure
50%{__make}
51
52
53%install
54%{__rm} -rf $RPM_BUILD_ROOT
55%{__make} install DESTDIR=$RPM_BUILD_ROOT
56
57
58%clean
59%{__rm} -rf $RPM_BUILD_ROOT
60
61%post
62/sbin/service preload restart >/dev/null 2>&1
63/sbin/chkconfig --add preload
64/sbin/chkconfig preload on
65
66%preun
67if [ $1 = 0 ]; then
68    /sbin/service preload stop >/dev/null 2>&1
69    /sbin/chkconfig --del preload
70fi
71
72%postun
73if [ "$1" -ge "1" ]; then
74    /sbin/service preload condrestart >/dev/null 2>&1 || :
75fi
76
77
78%files
79%defattr(-,root,root, -)
80%doc README AUTHORS COPYING ChangeLog TODO THANKS NEWS
81%{_sbindir}/preload
82%{_datadir}/man/man8/preload.8.gz
83%{_sysconfdir}/rc.d/init.d/preload
84%config(noreplace) %{_sysconfdir}/preload.conf
85%config(noreplace) %{_sysconfdir}/sysconfig/preload
86%config(noreplace) %{_sysconfdir}/logrotate.d/preload
87%attr(0644,root,root) %ghost %config(missingok,noreplace) %{_localstatedir}/log/preload.log
88%attr(0644,root,root) %ghost %config(missingok,noreplace) %{_localstatedir}/lib/preload/preload.state
89%attr(0755,root,root) %dir %{_localstatedir}/lib/preload
90
91
92%changelog
93* Thu Jun 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.4-5
94- added Patch2 from Debian sid to fix path of pidof
95- added BuildRequires: help2man
96
97* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.4-4
98- rebuilt with gcc-4.4.3-3 on ppc
99
100* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.4-3
101- rebuilt with rpm-4.8.0-3 (on ppc)
102
103* Wed Feb  3 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.6.4-2
104- rebuilt with new toolchain
105
106* Tue May 19 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.4-1
107- new upstream release
108- dropped Patch2,3 (merged)
109
110* Thu Mar 12 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-4
111- added patch3 (import from Mandriva 2009.1)
112
113* Mon Dec 22 2008 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-3
114- changed patch0 (Prefered to Mandriva 2009.0 package in preload-0.6.3-prcsys.patch)
115
116* Mon Dec 8 2008 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.6.3-2
117- Removed preload-0.6-start-late.patch
118- Added patch0, patch1, patch2
119  Patch0: start preload daemon later, changed default-start
120  Patch1: changed mapprefix&exeprefix section
121  added /opt, for some applicaton (ex. Adobe Reader, OpenOffice.org)
122  Patch2: fix segfault src/cmdline.c
123
124* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.6.3-1
125- new upstream release
126- drop all patches, they are all obsolete by upstream.
127- add Patch0 to start preload daemon lator. (use readahead daemon for bootup)
128
129* Wed Aug 27 2008 Shu KONNO <owa@bg.wakwak.com> 0.4-1vl5
130- applied new versioning policy, spec in utf-8
131
132* Sat Mar 15 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4-0vl1
133- initial build for VineSeed based on Fedora package
134
135# * Sun Mar 9 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4-0vlmp0
136# - rebuild for Vine Linux 4.2
137#
138# * Wed Mar 5 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4-0vlmp1
139# - initial build for VineSeed based on Fedora package
140
141* Wed Jan 16 2008 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-5
142- Removed auto start from init
143- Added all the CVS patches prior to next release
144
145* Sun Jan 6 2008 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-4
146- Removed debian patch and added patches from upstream instead
147- Patches fix 64 bit, ionice, sysconfig and loading.
148
149* Fri Nov 9 2007 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-3
150- Used Debian Patch it consists of:
151- Close the file descriptor when writing state to a file in src/state.c,
152- Parse the dev field in /proc/%%d/maps as hexadecimal, not as unsigned
153  integer.  Thanks to Johan Kiviniemi for the patch.
154- Sort the readahead file list by device, block and inode and not file
155  path to reduce seeking.  Adapted by Johan from a patch for readahead
156  by Scott James Remnant.
157- Added my patch to verbosity to 1 due to 30 second log writing
158 
159* Thu Nov 8 2007 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-2
160- Fixed config lines
161- Fixed source lines
162- Added Requires: Logrotate
163- Default preload sequence is stopped
164- %{?_smp_mflags} does not work
165
166* Sat Oct 16 2007 Marc Wiriadisastra <marc@mwiriadi.id.au> - 0.4-1
167- Creation from start
168
169### end of file
Note: See TracBrowser for help on using the repository browser.