source: projects/specs/trunk/p/pragha/pragha-vl.spec @ 6407

Revision 6407, 7.0 KB checked in by munepi, 12 years ago (diff)

added pragha-vl.spec

Line 
1# Review request: https://bugzilla.redhat.com/show_bug.cgi?id=721043
2
3Name:           pragha
4Version:        1.1.0.1
5Release:        1%{?_dist_release}
6Summary:        Lightweight GTK+ music manager
7
8Group:          Applications/Multimedia
9License:        GPLv3+
10URL:            http://pragha.wikispaces.com/
11#VCS: git:https://github.com/matiasdelellis/pragha.git
12Source0:        https://github.com/downloads/matiasdelellis/%{name}/%{name}-%{version}.tar.bz2
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
14
15Obsoletes:      pragha < 1.0, self-build-pragha < 1.0
16
17BuildRequires:  dbus-devel >= 1.1
18BuildRequires:  dbus-glib-devel >= 0.84
19BuildRequires:  gtk2-devel >= 2.20.0
20BuildRequires:  flac-devel >= 1.2.1
21BuildRequires:  keybinder-devel >= 0.2.0
22BuildRequires:  gstreamer-devel >= 0.10
23BuildRequires:  gstreamer-plugins-base-devel >= 0.10
24BuildRequires:  libcddb-devel >= 1.3.0
25BuildRequires:  libcdio-devel >= 0.80
26BuildRequires:  curl-devel >= 7.18
27# libglyr is not yet in Fedora
28#BuildRequires:  libglyr-devel >= 0.9.4
29#BuildRequires:  libclastfm-devel >= 0.5
30BuildRequires:  libnotify-devel >= 0.4.4
31#BuildRequires:  libxfce4ui-devel >= 4.8.0
32BuildRequires:  sqlite3-devel >= 3.4
33#BuildRequires:  taglib-devel >= 1.7.0
34BuildRequires:  taglib-devel
35BuildRequires:  totem-pl-parser-devel
36BuildRequires:  desktop-file-utils
37BuildRequires:  gettext
38Requires:       gstreamer-plugins-base
39
40%description
41Pragha is is a lightweight GTK+ music manager that aims to be fast, bloat-free,
42and light on memory consumption. It is written completely in C and GTK+.
43
44Pragha is a fork of Consonance Music Manager, discontinued by the original
45author.
46
47
48%prep
49%setup -q
50
51%build
52%configure
53make %{?_smp_mflags} V=1
54
55
56%install
57rm -rf %{buildroot}
58make install DESTDIR=%{buildroot} INSTALL='install -p'
59desktop-file-install                                       \
60  --delete-original                                        \
61  --add-category=Audio                                     \
62  --dir=%{buildroot}%{_datadir}/applications          \
63  %{buildroot}%{_datadir}/applications/%{name}.desktop
64%find_lang %{name}
65# remove duplicate docs
66rm -rf %{buildroot}%{_datadir}/doc/%{name}
67
68%clean
69rm -rf %{buildroot}
70
71
72%post
73touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
74update-desktop-database &> /dev/null || :
75
76
77%postun
78if [ $1 -eq 0 ] ; then
79    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
80    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
81fi
82update-desktop-database &> /dev/null || :
83
84
85%posttrans
86gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
87
88
89%files -f %{name}.lang
90%defattr(-,root,root,-)
91# FIXME add AUTHORS if not empty
92%doc ChangeLog COPYING FAQ NEWS README
93%{_bindir}/pragha
94%{_datadir}/applications/%{name}.desktop
95%{_datadir}/icons/hicolor/*x*/apps/%{name}.png
96%{_datadir}/pixmaps/%{name}/
97%{_mandir}/man1/pragha.1.*
98
99
100%changelog
101* Sat Jun 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 1.1.0.1-1
102- ported from Fedora rawhide
103- added Obsoletes: pragha < 1.0, self-build-pragha < 1.0
104
105* Thu Jun 21 2012 Christoph Wickert <cwickert@fedoraproject.org> - 1.1.0.1-1
106- Update to 1.1.0.1
107
108* Sun Jun 17 2012 Christoph Wickert <cwickert@fedoraproject.org> - 1.1.0-1
109- Update to 1.1.0
110
111* Sat May 05 2012 Christoph Wickert <cwickert@fedoraproject.org> - 1.0.2-2
112- Enable totem-pl-parser
113
114* Fri May 04 2012 Christoph Wickert <cwickert@fedoraproject.org> - 1.0.2-1
115- Update to 1.0.2
116- Drop upstreamed patches
117- Add README
118- Add VCS key
119
120* Thu Apr 05 2012 Kevin Fenzi <kevin@scrye.com> - 1.0.1-2
121- Rebuild for Xfce 4.10
122
123* Wed Mar 14 2012 Christoph Wickert <cwickert@fedoraproject.org> - 1.0.1-1
124- Update to 1.0.1
125
126* Thu Feb 02 2012 Christoph Wickert <cwickert@fedoraproject.org> - 1.0-1
127- Update to 1.0 Final
128- Enable Last.fm support
129
130* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-0.3.rc3
131- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
132
133* Thu Dec 15 2011 Christoph Wickert <cwickert@fedoraproject.org> - 1.0-0.2.cr3
134- Apply the cflags patch again
135
136* Wed Dec 14 2011 Christoph Wickert <cwickert@fedoraproject.org> - 1.0-0.1.rc3
137- Update to 1.0.rc3
138- Require exo-devel for playlist saving throughout sessions
139
140* Sun Dec 11 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.99.0-2
141- Rebuild for libcdio-0.83
142- Compile with '-Wno-error=deprecated-declarations' (#760960)
143
144* Wed Sep 07 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.99.0-1
145- Update to 0.99.0
146
147* Mon Aug 22 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.98.0-1
148- Update to 0.98.0
149
150* Sat Jul 30 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.97.0-2
151- Don't compile with -O3
152
153* Wed Jul 13 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.97.0-1
154- Update to 0.97.0: This version is gstreamer-based. It no longer requires
155  libmad, libmodplug, libsndfile or libvorbis but gstreamer and gstreamer-
156  plugins-base
157
158* Tue Jul 12 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.8-2
159- Build with keybinder support
160
161* Tue Jul 12 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.8-1
162- Update to 0.8.8
163
164* Thu Mar 17 2011 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.6-1
165- Update to 0.8.6
166- Drop libnotify-patch, no longer required
167
168* Thu Dec 09 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.4-1
169- Update to 0.8.4
170
171* Sun Oct 03 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.2-1
172- Update to 0.8.2
173
174* Sat Aug 21 2010 Thorsten Leemhuis <fedora [AT] leemhuis [DOT] info> - 0.8.0.2-3
175- rebuilt
176
177* Mon Aug 02 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0.2-2
178- Fix desktop file
179
180* Fri Jul 30 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0.2-1
181- Update to 0.8.0.2
182- Drop de.po patch, included upstream
183
184* Fri Jul 30 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0.1-1
185- Update to 0.8.0.1
186- Add COPYING and NEWS to docs
187
188* Thu Jul 29 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.8.0-1
189- Update to 0.8.0
190
191* Fri Jun 25 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.7.1-1
192- Update to 0.7.7.1
193
194* Fri Jun 25 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.7-1
195- Update to 0.7.7
196
197* Sat Jun 19 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.6-1
198- Update to 0.7.6
199- Remove upstreamed use-software-mixer.patch
200
201* Fri Apr 22 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.4-1
202- Update to 0.7.4
203
204* Mon Mar 22 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.3-2
205- Use software mixer by default to cope with pulseaudio
206- Remove executable bits from docs
207
208* Tue Mar 16 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.3-1
209- Update to 0.7.3
210
211* Sat Feb 20 2010 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.2-1
212- Update to 0.7.2
213
214* Wed Oct 28 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.1-1
215- Upadte to 0.7.1
216
217* Sat Oct 03 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.7.0-1
218- Upadte to 0.7.0
219
220* Sun Aug 09 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.3-1
221- Upadte to 0.6.3
222
223* Mon Jul 20 2009 Christoph Wickert <cwickert@fedoraproject.org> - 0.6.2.2-1
224- Initial Fedora package
Note: See TracBrowser for help on using the repository browser.