source: projects/specs/trunk/p/postgresql-ruby/postgresql-ruby-vl.spec @ 521

Revision 521, 2.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define oname   ruby-postgres
2%define over    0.7.1
3
4Summary: PostgreSQL extension module for programming language Ruby
5Name: postgresql-ruby
6Version: %{over}
7Release: 1%{?_dist_release}
8License: distributable
9Group: Development/Languages
10Source: http://www.postgresql.jp/interfaces/ruby/%{oname}-%{over}.tar.gz
11URL: http://www.jp.postgresql.org/interfaces/ruby/
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildPreReq: postgresql-devel, ruby, ruby-devel >= 1.8.1-0vl12
14Summary(ja): Ruby用のPostgreSQL拡張モジュール
15
16%description
17This is the extension library to access a PostgreSQL database from Ruby.
18
19%description -l ja
20本ライブラリは、RubyからPostgreSQLへアクセスするための拡張ライブラリです。
21
22%prep
23
24%setup -q -c
25
26%build
27cd %{oname}-%{over}
28ruby extconf.rb --with-pgsql-include-dir=%{_includedir}/pgsql
29make
30cd ..
31
32%install
33rm -rf ${RPM_BUILD_ROOT}
34mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
35
36# installing binaries ...
37cd %{oname}-%{over}
38make install DESTDIR=${RPM_BUILD_ROOT} sitedir=${RPM_BUILD_ROOT}%{_libdir}/ruby
39cd ..
40
41(find \
42  $RPM_BUILD_ROOT%{_libdir} \
43      -type f -o -type l) |
44 sort | sed -e "s,^$RPM_BUILD_ROOT,," > postgresql-ruby.files
45
46%clean
47rm -rf ${RPM_BUILD_ROOT}
48
49%pre
50
51%post
52
53%files -f postgresql-ruby.files
54%defattr(-, root, root)
55%doc %{oname}-%{over}/ChangeLog
56%doc %{oname}-%{over}/README
57%doc %{oname}-%{over}/README.ja
58%doc %{oname}-%{over}/doc/*.html
59%doc %{oname}-%{over}/sample
60
61%changelog
62* Thu Sep 25 2008 Shu KONNO <owa@bg.wakwak.com> 0.7.1-1vl5
63- applied new versioning policy, spec in utf-8
64
65* Wed Dec 19 2007 Shu KONNO <owa@bg.wakwak.com> 0.7.1-0vl3
66- s/Copyright/License/
67
68* Tue Oct 05 2004 Satoshi MACHINO <machino@vinelinux.org> 0.7.1-0vl2
69- fixed postgres.so's path
70
71* Tue Oct 05 2004 Satoshi MACHINO <machino@vinelinux.org> 0.7.1-0vl1
72- new upstream version (ruby-postgres-0.7.1)
73- fixed search path for postgres.so in spec
74- changed file name to README.ja
75 
76* Wed Jan 09 2002 Satoshi MACHINO <machino@vinelinux.org> 0.6.5-0vl1
77- update ruby-postgres-0.6.5
78- changed BuildPreReq from BuildRequire, and updated ruby version
79
80* Thu Jul 26 2001 akira yamada <akira@vinelinux.org>
81- rebuild with ruby-devel-1.6.4-0vl3.
82
83* Mon Apr 23 2001 akira yamada <akira@vinelinux.org>
84- new upstream version, 0.6.3.
85
86* Mon Apr 23 2001 akira yamada <akira@vinelinux.org>
87- Initial packaging.
Note: See TracBrowser for help on using the repository browser.