source: projects/specs/trunk/p/postfix/postfix-vl.spec @ 521

Revision 521, 31.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1#%define build_mysql %{?_with_mysql:1}%{!?_with_mysql:0}
2#%define build_pgsql %{?_with_pgsql:1}%{!?_with_pgsql:0}
3
4%define build_mysql 1
5%define build_pgsql 1
6
7%define _sysconfdir   /etc
8%define _data_dir     %{_var}/lib/postfix
9
10%define origversion 2.6.5
11
12# japanese documant for 2.5.x is not ready.
13# %define jconfversion 2.2.0
14# %define jmanversion 2.2.9
15# %define jhtmlversion 2.2.9
16# %define jreadmeversion 2.2.9
17
18Summary:   Postfix Mail Transport Agent
19Summary(ja):   Postfix メールトランスポートエージェント
20Name:      postfix
21Version:   %{origversion}
22Release:   2%{?_dist_release}
23URL:       http://www.postfix.org/
24License:   Distributable - IBM PUBLIC LICENSE VERSION 1.0 - SECURE MAILER
25Group:     System Environment/Daemons
26
27Source0:   ftp://postfix.cloud9.net/official/%{name}-%{version}.tar.gz
28Source1:   postfix.aliases
29Source2:   postfix.cron
30Source3:   postfix.init
31
32# japanese documents for 2.5.x is not ready.
33# Source10:  http://www.kobitosan.net/postfix/archives/postfix_jconf-%{jconfversion}.tar.gz
34# Source20:  http://www.kobitosan.net/postfix/archives/postfix_jman-%{jmanversion}.tar.gz
35# Source30:  http://www.kobitosan.net/postfix/archives/postfix_jhtml-%{jhtmlversion}.tar.gz
36# Source40:  http://www.kobitosan.net/postfix/archives/postfix_jreadme-%{jreadmeversion}.tar.gz
37
38Patch0:    postfix-2.1.5-vine.patch
39Patch1:    postfix-2.2.10-main.cf-lib64.patch
40
41# patches 100-199 are imported from debian package.
42# patches 100/101 for postfix 2.5.x are from suse. 
43Patch100: postfix-2.6.1-dynamicmaps.patch
44
45# patches 200-299 are imported from rh/fedora
46Patch200: postfix-2.5.7-large-fs.patch     
47Patch210: postfix-2.5.5-open_define-vine.patch
48
49Provides:  smtpdaemon
50Conflicts: sendmail
51Requires(pre):    chkconfig
52BuildRequires: db4-devel >= 4.6.21, pam-devel, gdbm-devel
53BuildRequires: cyrus-sasl-devel >= 2
54BuildRequires: openldap-devel, openssl-devel
55BuildRequires: pcre-devel
56%if %build_mysql
57BuildRequires: MySQL-devel
58%endif
59%if %build_pgsql
60BuildRequires: postgresql-devel
61%endif
62
63Requires:    cyrus-sasl >= 2, cyrus-sasl-md5, cyrus-sasl-plain
64Requires:    gdbm, pam, openssl
65Requires(pre):      db4 >= 4.6.21
66Obsoletes: postfix-beta
67BuildRoot: %{_tmppath}/%{name}-%{version}-root
68
69Vendor: Project Vine
70Distribution: Vine Linux
71Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
72
73
74%description
75Postfix aims to be an alternative to the widely-used sendmail
76program.  Sendmail is responsible for 70 percent of all e-mail delivered
77on the Internet.  With an estimated 100 million users, that's an
78estimated 10 billion (10^10) messages daily. A stunning number.
79
80Although IBM supported the Postfix development, it abstains from
81control over its evolution. The goal is to have Postfix installed
82on as many systems as possible. To this end, the software is given
83away with no strings attached to it, so that it can evolve with
84input from and under control by its users.
85
86#'
87%description -l ja
88Postfix は現在広く使われている sendmail を置き換える目的で
89開発されています。sendmail は約 70% の E-mail サーバで使用
90されています。また、その使用者は 100万人にもおよび、およそ
91一日 1 千万通ものメールを処理しています。
92
93Postfix の開発は IBM によってサポートされており、全世界の
94全てのシステムを postfix にすることを目標としています。
95
96%if %build_pgsql
97%package pgsql
98Summary: PGSQL map support for Postfix
99Group:     System Environment/Daemons
100Requires(pre): postfix = %{version}-%{release}
101Requires: postgresql-libs, postgresql
102%description pgsql
103This package contains shared lib module which support
104PostgreSQL map on Postfix.
105%description -l ja pgsql
106このパッケージには、Postfix で PostgreSQL を使うのに必要な
107ライブラリが納められています。
108%endif
109
110%if %build_mysql
111%package mysql
112Summary: MySQL map support for Postfix
113Group:     System Environment/Daemons
114Requires(pre): postfix = %{version}-%{release}
115%description mysql
116This package contains shared lib module which support
117MySQL map on Postfix.
118%description -l ja mysql
119このパッケージには、Postfix で MySQL を使うのに必要な
120ライブラリが納められています。
121%endif
122
123%package ldap
124Summary: LDAP map support for Postfix
125Group:     System Environment/Daemons
126Requires(pre): postfix = %{version}-%{release}
127Requires: openldap
128%description ldap
129This package contains shared lib module which support
130OpenLDAP map on Postfix.
131%description -l ja ldap
132このパッケージには、Postfix で OpenLDAP を使うのに必要な
133ライブラリが納められています。
134
135%package pcre
136Summary: PCRE map support for Postfix
137Group:     System Environment/Daemons
138Requires(pre): postfix = %{version}-%{release}
139Requires: pcre
140%description pcre
141This package contains shared lib module which support
142PCRE map on Postfix.
143%description -l ja pcre
144このパッケージには、Postfix で PCRE マップを使うのに必要な
145ライブラリが納められています。
146
147%prep
148# japanese documant for 2.4.x is not ready.
149# %setup -q -a 10 -a 20 -a 30 -a 40
150%setup -q
151
152%patch0 -p1 -b .vine
153
154%ifarch x86_64
155%patch1 -p1 -b .lib64
156%endif
157
158%patch100 -p1 -b .dynamicmaps
159perl -pi -e 's,/usr/lib/,/usr/lib64/,' conf/postfix-files
160perl -pi -e 's,-lmysqlclient,-lmysqlclient -L%{_libdir}/mysql,' src/global/Makefile.in
161
162%patch200 -p1 -b .large-fs
163%patch210 -p1 -b .open_define
164
165
166# patching src/global/Makefile to remove dependency
167pushd src/global
168%if %build_mysql
169:
170%else
171sed -ie "s/ dict_mysql.so/ /" Makefile.in
172%endif
173%if %build_pgsql
174:
175%else
176sed -ie "s/ dict_pgsql.so/ /" Makefile.in
177%endif
178popd
179
180%build
181make makefiles \
182        CCARGS="-DMAX_DYNAMIC_MAPS \
183                -DUSE_SASL_AUTH -I/usr/include/sasl \
184                -DUSE_CYRUS_SASL \
185                -DHAS_LDAP \
186                -DHAS_SSL -I/usr/include/openssl \
187                -DHAS_PCRE -I/usr/include/pcre \
188%if %build_mysql
189                -DHAS_MYSQL -I/usr/include/mysql  \
190%endif
191%if %build_pgsql
192                -DHAS_PGSQL -I/usr/include/pgsql \
193%endif
194                -DUSE_TLS" \
195        AUXLIBS="-lsasl2 -lssl -lcrypto" \
196        OPT="$RPM_OPT_FLAGS" DEBUG=""
197for libs in master global util dns tls xsasl milter
198do
199  ln -sf lib${libs}.a lib/libpostfix-${libs}.so.1
200done
201
202# make %{?_smp_mflags} DEBUG="" OPT="$RPM_OPT_FLAGS" \
203#      LD_LIBRARY_PATH=$(pwd)/lib:${LD_LIBRARY_PATH}
204
205# using _smp_mflags makes build error. why? (2008.10.11)
206make DEBUG="" OPT="$RPM_OPT_FLAGS" \
207     LD_LIBRARY_PATH=$(pwd)/lib:${LD_LIBRARY_PATH} CDBSO=""
208
209%install
210rm -rf $RPM_BUILD_ROOT
211rm -f html/Makefile.in
212rm -f README_FILES/*.*
213
214install -d $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
215install -d $RPM_BUILD_ROOT%{_sysconfdir}/postfix
216install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
217install -d $RPM_BUILD_ROOT%{_bindir}
218install -d $RPM_BUILD_ROOT%{_libdir}/postfix
219install -d $RPM_BUILD_ROOT%{_mandir}/man{1,5,8}
220install -d $RPM_BUILD_ROOT%{_mandir}/ja/man{1,5,8}
221install -d $RPM_BUILD_ROOT%{_sbindir}
222install -d $RPM_BUILD_ROOT%{_var}/spool/postfix
223install -d $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,incoming,pid,public}
224install -d $RPM_BUILD_ROOT%{_var}/spool/postfix/{bounce,defer,flush,maildrop,private,saved}
225
226install -m755 bin/* $RPM_BUILD_ROOT%{_sbindir}
227install -m755 libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
228install -m755 lib/dict_* $RPM_BUILD_ROOT%{_libdir}/postfix
229install -m755 lib/lib*.so.1 $RPM_BUILD_ROOT%{_libdir}
230
231touch conf/dynamicmaps.cf
232for i in main.cf master.cf access aliases canonical header_checks \
233         main.cf.default post-install postfix-files postfix-script \
234         relocated transport virtual dynamicmaps.cf
235do
236  install -m644 conf/$i $RPM_BUILD_ROOT%{_sysconfdir}/postfix
237done
238for i in post-install postfix-script
239do
240  install -m755 conf/$i $RPM_BUILD_ROOT%{_sysconfdir}/postfix
241done
242
243install -m644 man/man1/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
244install -m644 man/man5/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
245install -m644 man/man8/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
246
247# japanese documant for 2.4.x is not ready.
248# install jman
249# for i in 1 5 8
250# do
251#   install -m644 man-%{jmanversion}/ja/man$i/*.$i $RPM_BUILD_ROOT%{_mandir}/ja/man$i
252# done
253
254# jconf, jhtml, jreadme
255# cp -a conf-%{jconfversion} sample.ja
256# cp -a jhtml-%{jhtmlversion} html.ja
257# cp -a readme-%{jreadmeversion} README_FILES.ja
258
259install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/postfix/aliases
260install -m755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/postfix
261install -m755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/postfix
262
263ln -sf postfix/aliases $RPM_BUILD_ROOT%{_sysconfdir}/aliases
264ln -sf postfix/aliases.db $RPM_BUILD_ROOT%{_sysconfdir}/aliases.db
265
266( cd $RPM_BUILD_ROOT%{_bindir}
267  ln -sf ../sbin/sendmail mailq
268  ln -sf ../sbin/sendmail newaliases
269)
270( cd $RPM_BUILD_ROOT%{_libdir}
271  ln -sf ../sbin/sendmail sendmail
272)
273
274for I in etc/postfix/{aliases,access,canonical,header_check,relocated,transport,virtual}
275do
276   touch $RPM_BUILD_ROOT/$I{,.db}
277done
278
279# data dir
280install -d $RPM_BUILD_ROOT%{_data_dir}
281
282%pre
283if [ `grep postfix %{_sysconfdir}/passwd | wc -l` = 0 ]; then
284   %{_sbindir}/useradd -M -r -d %{_var}/spool/postfix -s "" \
285                     -c "postfix" postfix || :
286fi
287if [ `grep postfix %{_sysconfdir}/group | wc -l` = 0 ]; then
288  %{_sbindir}/groupadd -r postfix
289fi
290if [ `grep postdrop %{_sysconfdir}/group | wc -l` = 0 ]; then
291  %{_sbindir}/groupadd -r postdrop
292fi
293#if [ -f %{_var}/lock/subsys/postfix ]; then
294#   %{_sysconfdir}/rc.d/init.d/postfix stop
295#fi
296
297
298%post
299/sbin/ldconfig
300if ! grep -q "^tcp[[:space:]]" /etc/postfix/dynamicmaps.cf; then
301  echo "Adding tcp map entry to /etc/postfix/dynamicmaps.cf"
302  echo "tcp     %{_libdir}/postfix/dict_tcp.so          dict_tcp_open" >> /etc/postfix/dynamicmaps.cf
303fi
304/sbin/chkconfig --add postfix
305if [ ! -f %{_sysconfdir}/postfix/aliases.db ]; then
306  touch %{_sysconfdir}/postfix/aliases.db
307fi
308%{_sbindir}/postalias %{_sysconfdir}/postfix/aliases ||:
309if [ ! -e %{_libdir}/sendmail ]; then
310        ln -sf %{_sbindir}/sendmail %{_libdir}/sendmail
311fi
312/sbin/chkconfig --del sendmail &> /dev/null ||:
313%{_sbindir}/postfix check >/dev/null 2>&1 ||:
314if [ -f %{_var}/lock/subsys/postfix ]; then
315   %{_sysconfdir}/rc.d/init.d/postfix restart
316fi
317
318
319%preun
320if [ $1 = 0 ]; then
321   if [ -f %{_var}/lock/subsys/postfix -a -f %{_sysconfdir}/rc.d/init.d/postfix ]; then
322      %{_sysconfdir}/rc.d/init.d/postfix stop
323   fi
324   /sbin/chkconfig --del postfix
325fi
326
327
328%postun
329/sbin/ldconfig
330if [ $1 = 0 ]; then
331   if [ `grep postfix %{_sysconfdir}/passwd | wc -l` = 1 ]; then
332      %{_sbindir}/userdel postfix
333   fi
334   if [ `grep postfix %{_sysconfdir}/group | wc -l` = 1 ]; then
335      %{_sbindir}/groupdel postfix
336   fi
337   if [ `grep postdrop %{_sysconfdir}/group | wc -l` = 1 ]; then
338      %{_sbindir}/groupdel postdrop
339   fi
340   if ! [ -f %{_var}/lock/subsys/postfix ]; then
341        rm -rf %{_var}/lock/subsys/postfix
342   fi
343fi
344
345%if %build_pgsql
346%post pgsql
347if ! grep -q "^pgsql[[:space:]]" /etc/postfix/dynamicmaps.cf; then
348  echo "Adding pgsql map entry to /etc/postfix/dynamicmaps.cf"
349  echo "pgsql   %{_libdir}/postfix/dict_pgsql.so                dict_pgsql_open" >> /etc/postfix/dynamicmaps.cf
350fi
351
352%preun pgsql
353if [ $1 = 0 ]; then
354  if grep -q "^pgsql[[:space:]]" /etc/postfix/dynamicmaps.cf; then
355    cp -f /etc/postfix/dynamicmaps.cf /etc/postfix/dynamicmaps.cf.rpmsave
356    grep -v "^pgsql[[:space:]]" /etc/postfix/dynamicmaps.cf.rpmsave > /etc/postfix/dynamicmaps.cf
357  fi
358fi
359%endif
360
361%if %build_mysql
362%post mysql
363if ! grep -q "^mysql[[:space:]]" /etc/postfix/dynamicmaps.cf; then
364  echo "Adding mysql map entry to /etc/postfix/dynamicmaps.cf"
365  echo "mysql   %{_libdir}/postfix/dict_mysql.so                dict_mysql_open" >> /etc/postfix/dynamicmaps.cf
366fi
367
368%preun mysql
369if [ $1 = 0 ]; then
370  if grep -q "^mysql[[:space:]]" /etc/postfix/dynamicmaps.cf; then
371    cp -f /etc/postfix/dynamicmaps.cf /etc/postfix/dynamicmaps.cf.rpmsave
372    grep -v "^mysql[[:space:]]" /etc/postfix/dynamicmaps.cf.rpmsave > /etc/postfix/dynamicmaps.cf
373  fi
374fi
375%endif
376
377%post ldap
378if ! grep -q "^ldap[[:space:]]" /etc/postfix/dynamicmaps.cf; then
379  echo "Adding ldap map entry to /etc/postfix/dynamicmaps.cf"
380  echo "ldap    %{_libdir}/postfix/dict_ldap.so         dict_ldap_open" >> /etc/postfix/dynamicmaps.cf
381fi
382
383%preun ldap
384if [ $1 = 0 ]; then
385  if grep -q "^ldap[[:space:]]" /etc/postfix/dynamicmaps.cf; then
386    cp -f /etc/postfix/dynamicmaps.cf /etc/postfix/dynamicmaps.cf.rpmsave
387    grep -v "^ldap[[:space:]]" /etc/postfix/dynamicmaps.cf.rpmsave > /etc/postfix/dynamicmaps.cf
388  fi
389fi
390
391%post pcre
392if ! grep -q "^pcre[[:space:]]" /etc/postfix/dynamicmaps.cf; then
393  echo "Adding pcre map entry to /etc/postfix/dynamicmaps.cf"
394  echo "pcre    %{_libdir}/postfix/dict_pcre.so         dict_pcre_open" >> /etc/postfix/dynamicmaps.cf
395fi
396
397%preun pcre
398if [ $1 = 0 ]; then
399  if grep -q "^pcre[[:space:]]" /etc/postfix/dynamicmaps.cf; then
400    cp -f /etc/postfix/dynamicmaps.cf /etc/postfix/dynamicmaps.cf.rpmsave
401    grep -v "^pcre[[:space:]]" /etc/postfix/dynamicmaps.cf.rpmsave > /etc/postfix/dynamicmaps.cf
402  fi
403fi
404
405
406%clean
407rm -rf $RPM_BUILD_ROOT
408
409
410%files
411%defattr(-,root,root)
412%doc COMPATIBILITY COPYRIGHT HISTORY LICENSE INSTALL PORTING RELEASE_NOTES
413# japanese documant for 2.4.x is not ready.
414# %doc conf.ja
415# %doc html html.ja
416# %doc README_FILES README_FILES.ja
417%doc README_FILES
418# %doc man-%{jmanversion}/readme_ja.txt
419%{_sysconfdir}/aliases
420%{_sysconfdir}/aliases.db
421%config %{_sysconfdir}/cron.daily/postfix
422%dir %{_sysconfdir}/postfix
423%config %{_sysconfdir}/postfix/main.cf.default
424%config %{_sysconfdir}/postfix/master.cf
425%config(noreplace) %{_sysconfdir}/postfix/aliases
426%config(noreplace) %{_sysconfdir}/postfix/access
427%config(noreplace) %{_sysconfdir}/postfix/canonical
428%config(noreplace) %{_sysconfdir}/postfix/header_check
429%config(noreplace) %{_sysconfdir}/postfix/header_checks
430%config(noreplace) %{_sysconfdir}/postfix/main.cf
431%config(noreplace) %{_sysconfdir}/postfix/relocated
432%config(noreplace) %{_sysconfdir}/postfix/transport
433%config(noreplace) %{_sysconfdir}/postfix/virtual
434%config(noreplace) %{_sysconfdir}/postfix/dynamicmaps.cf
435%config %{_sysconfdir}/postfix/postfix-files
436%config %{_sysconfdir}/postfix/post-install
437%config %{_sysconfdir}/postfix/postfix-script
438%config %{_sysconfdir}/rc.d/init.d/postfix
439%{_bindir}/*
440%dir %{_libdir}/postfix
441%{_libdir}/postfix/*
442
443%if %{build_pgsql}
444%exclude %{_libdir}/postfix/dict_pgsql.so
445%endif
446%if %{build_mysql}
447%exclude %{_libdir}/postfix/dict_mysql.so
448%endif
449
450%exclude %{_libdir}/postfix/dict_ldap.so
451%exclude %{_libdir}/postfix/dict_pcre.so
452%{_libdir}/lib*.so.1
453%{_sbindir}/postalias
454%{_sbindir}/postcat
455%{_sbindir}/postconf
456%attr(2755,root,postdrop) %{_sbindir}/postdrop
457%{_sbindir}/postfix
458%{_sbindir}/postkick
459%{_sbindir}/postlock
460%{_sbindir}/postlog
461%{_sbindir}/postmap
462%{_sbindir}/postmulti
463%attr(2755,root,postdrop) %{_sbindir}/postqueue
464%{_sbindir}/postsuper
465%{_sbindir}/qmqp-sink
466%{_sbindir}/qmqp-source
467%{_sbindir}/sendmail
468%{_sbindir}/smtp-sink
469%{_sbindir}/smtp-source
470%attr(-,root,man) %{_mandir}/man*/*
471# %attr(-,root,man) %{_mandir}/ja/man*/*
472%dir %{_var}/spool/postfix
473%attr(0750,postfix,root) %dir %{_data_dir}
474%attr(1733,postfix,postdrop) %dir %{_var}/spool/postfix/maildrop
475%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/active
476%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/corrupt
477%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/deferred
478%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/incoming
479%attr(0755,root,root) %dir %{_var}/spool/postfix/pid
480%attr(0710,postfix,postdrop) %dir %{_var}/spool/postfix/public
481%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/bounce
482%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/defer
483%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/flush
484%attr(0710,postfix,postfix) %dir %{_var}/spool/postfix/private
485%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/saved
486%{_libdir}/sendmail
487
488%if %build_pgsql
489%files pgsql
490%defattr(-,root,root)
491%{_libdir}/postfix/dict_pgsql.so
492%endif
493
494%if %build_mysql
495%files mysql
496%defattr(-,root,root)
497%{_libdir}/postfix/dict_mysql.so
498%endif
499
500%files ldap
501%defattr(-,root,root)
502%{_libdir}/postfix/dict_ldap.so
503
504%files pcre
505%defattr(-,root,root)
506%{_libdir}/postfix/dict_pcre.so
507
508%changelog
509* Sat Feb 20 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.5-2
510- removed MySQL-shared from "Requires:" and "BuildRequires:".
511- replaced "Prereq:" with "Requires(pre):".
512- replaced "BuildPrereq:" with "BuildRequires:".
513
514* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-1
515- new upstream release
516- rebuild with db4-4.8.0
517
518* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-2
519- change /var/spool/postfix/pid owner and permission
520  (0700,postfix,postfix -> 0755,root,root)
521
522* Mon Aug  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-1
523- new upstream release
524
525* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.2-1
526- new upstream release.
527
528* Sat May 30 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.1-2
529- added a missing file.
530
531* Sat May 30 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.1-1
532- new upstream release.
533- updated dynamicmaps patch.
534
535* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.7-2
536- made to build -mysql and -pgsql as default.
537- rebuilt with MySQL-5.1.34.
538
539* Wed May 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.7-1
540- new upstream release
541- update Patch200 from fc10
542
543* Sun Mar 01 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.5.6-2
544- rebuilt with openldap-2.4.11
545
546* Mon Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.6-1
547- new upstream release
548
549* Sun Oct 12 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-4
550- add patch200/patch210 from fedora
551
552* Sun Oct 12 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-3
553- add Requires cyrus-sasl-md5, cyrus-sasl-plain for smtp auth
554- add Japanese description into sub packages
555
556* Sat Oct 11 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-2
557- update patch100/101 to fix libxsasl build issue
558- remove smp flag in build section to solve build error
559- add _data_dir
560
561* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-1
562- new upstream release
563- update patch100/101 to fit 2.5.5 (from suse)
564- add %exclude dict_{my,pg}sql.so to %%files to avoid unneeded dependancy
565  when option "--with XXsql" is specified. (from Vine 4.x update package)
566- remove HAS_DLOPEN macro.
567
568* Sat Sep 06 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.9-1
569- new upstream release with security fix
570
571* Sat Aug 30 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.8-2
572- add %%if %%build_mysql and %%if %%mysql from BuildRequires section again
573- remove unnessary dependency
574
575* Thu Aug 28 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.8-1
576- new upstream release with security fix
577
578* Mon Aug 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-4
579- spec in UTF-8
580
581* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.7-3
582- rebuilt against db4-4.6.21
583
584* Tue Apr 15 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.7-2
585- add HAS_DLOPEN macro.
586- add USE_CYRUS_SASL macro.
587- modify dynamicmaps.cf (/usr/lib -> %%{_libdir}).
588
589* Thu Mar 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.7-1
590- new upstream release
591- update patch100 (it is based from mdk 2008.0)
592- add smp_mflags in make section
593- build under new versioning policy
594
595* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-0vl10
596- rebuilt with postgresql-devel 8.2.5
597- updated Source20, 30 and 40
598
599* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl9
600- rebuild with new openssl
601
602* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.10-0vl8
603- rebuilt with new toolchain and db4-4.3.x
604
605* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 2.2.10-0vl7
606- <BTS:493> fix typo in %%if statement for %%files mysql section.
607- remove %%if %%build_mysql and %%if %%mysql from BuildRequires section,
608  (Patch100 always builds dict_mysql.o and dict_pgsql.o)
609
610* Fri Oct 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl6
611- disable MySQL, PostgreSQL support by default.
612  use "--with {mysql|pgsql}" to build them.
613
614* Mon Sep 18 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.10-0vl5
615- add lib64 patch to correct daemon_directory on x86_64 architecture
616
617* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl4
618- remove duplicated entry from aliases. (<BTS:170>)
619
620* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl3
621- add some pseudo accounts to aliases. (<BTS:170>)
622- add BuildPreReq: MySQL-shared
623
624* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.10-0vl2
625- rebuilt with openldap-2.3.27-0vl1
626
627* Sun Apr 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl1
628- new upstream release
629
630* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
631- new upstream release
632
633* Fri Sep 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.5-0vl1
634- new upstream release
635  - update to 2.2.5
636- update dynamicmaps from debian package
637- update Japaese manpages and jconf
638- add jhtml and jreadme
639- enable TLS/SSL
640
641* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
642- new upstream release
643- update all patches
644- link sasl2 instead of sasl1
645
646* Mon Jan 24 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.20-0vl6
647- enable cyrus-sasl.
648- add TLS/IPv6 patch.
649- modify main.cf to disable IPv6 as default.
650
651* Wed Oct 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.20-0vl5
652- add PreReq: db4 >= 4.2.52
653  (to avoid errors when upgrading from db40-linked version)
654
655* Mon Oct 11 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.20-0vl4
656- rebuilt with db4-4.2.52
657
658* Tue Jun  8 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.20-0vl3
659- fix first installation time bugs...
660  - remove aliases.db from %%files again
661  - add 'touch aliases.db' in %%post script
662- update default main.cf to use /etc/postfix/aliases as default alias_database
663
664* Mon Jun  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.20-0vl2
665- add /etc/postfix/aliases.db to %%files
666
667* Sat May  8 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.20-0vl1
668- new upstream release
669
670* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.19-0vl1
671- new upstream release
672- build with new postgresql
673
674* Fri Sep 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.16-0vl1
675- new upstream release
676- update jconf/jman/jhtml
677
678* Fri Jul  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.13-0vl1
679- new upstream release
680- update jman/jhtml/jreadme
681
682* Mon Jun 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.12-0vl1
683- new upstream release
684- update jconf/jman/jhtml/jreadme
685
686* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.10-0vl1
687- new upstream release
688
689* Fri May 23 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.9-0vl5
690- rebuild by new cyrus-sasl(2.1.13-3vl1)
691
692* Sat Apr 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl4
693- add more BuildPreReq, Requires
694- fix some typo
695- add missing files to %%files.
696
697* Sat Apr 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl3
698- rebuild
699
700* Sat Apr 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl2
701- add debian's dynamic map patch.
702  some additional feature is divided to sub package.
703  - postfix-ldap, postfix-mysql, postfix-pgsql, postfix-pcre
704- split common postfix libraries as shared libs.
705  - libpostfix-{master,global,util,dns}.so.1
706- use cyrus-sasl for SMTP-AUTH
707
708* Wed Apr 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl1
709- new upstream release 2.0.9
710- update jman/jhtml/jconf to 2.0.8
711
712* Wed Apr  9 2003 IWAI Masaharu <iwai@alib.jp> 2.0.7-0vl1
713- new upstream version
714- update documents
715    - jman (source4)
716    - jconf (Source5)
717    - faq.html (Source6)
718    - INSTALL.jp (Source7)
719    - jhtml (Source12)
720
721* Sun Jan 19 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.12-0vl3
722- rebuilt against db4
723
724* Wed Dec 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.12-0vl2
725- rebuild to remove unnecessary dependancy.
726
727* Sat Nov 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.12-0vl1
728- new upstream version
729- modified /etc/init.d/postfix
730
731* Sun Oct 06 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.11-0vl3
732- fixed brainless mistakes...
733  update main.cf again.
734
735* Thu Oct 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.11-0vl2
736- update main.cf patch
737  - do not use procmail for local mailer.
738  - do not show version and OS name for smtpd greeting banner.
739
740* Thu Jun 04 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.11-0vl1
741- new upstream release
742- update jman, jconf, jhtml
743
744* Tue May 28 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.10-0vl2
745- updated main.cf patch ( Patch0 )
746    undefine myhostname
747
748* Fri May 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.10-0vl1
749- changed %%{_var}/spool/postfix/private directory permission (0700 -> 0710)
750    Thanks Mr. Daisuke SUZUKI ([VineSeed:06454])
751
752* Thu May 23 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.10-0vl0
753- upstream release
754- updated japanese documents Source4-9
755    ( and the unofficial Japanese Web Site moved. )
756- added japanese documents  Source10-12
757- updated main.cf patch ( Patch0 )
758- added postdrop group
759- added some directories in %%{_var}/spool/postfix/
760    active, corrupt, deferred, incoming, pid, public, bounce,
761    defer,flush,private and saved directories
762
763* Mon Feb 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.0.20010228pl08-0vl3
764- not stop in %%pre
765- not start but restart in %%post
766
767* Mon Dec 31 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.0.20010228pl08-0vl2
768- added BuildPreReq: db3-devel
769
770* Sat Nov 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl08-0vl1
771- updated to 20010228-pl08
772
773* Fri Nov  9 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl06-0vl1
774- updated to 20010228-pl06
775
776* Sun Sep 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl05-0vl1
777- updated to 20010228-pl05
778
779* Wed Aug  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl04-0vl1
780- updated to 20010228-pl04
781
782* Wed Jun 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl03-0vl2
783- update Japanese documents and manpages
784
785* Sun May 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl03-0vl1
786- updated to 20010228-pl03
787
788* Mon May 21 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
789- 0.0.20010228pl02-0vl3
790- modified %%preun script again
791  (to check whether %%{_sysconfidir}/rc.d/init.d/postfix already exists)
792
793* Wed May 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
794- 0.0.20010228pl02-0vl2
795- fixed incorrect %%preun script :-P
796
797* Tue May  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl02-0vl1
798- updated to 20010228-pl02
799
800* Wed Apr 11 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl01-0vl4
801- add {pcre,regexp}_table to %files
802- don't replace config files
803- start postfix after install/upgrade
804
805* Mon Apr 09 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl01-0vl2
806- updated jman pages and translations.
807- added japanese sample config files.
808
809* Sat Mar 31 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl01-0vl1
810- updated to 20010228-pl01
811
812* Thu Mar  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228-0vl2
813- fixed file location
814
815* Thu Mar  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228-0vl1
816- updated to 20010228
817
818* Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 0.0.199912310pl13-0vl2
819- fixed about mandir
820
821* Thu Nov 23 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.199912310pl13-0vl1
822- updated to 19991231-pl13
823- use rpm macros in spec
824
825* Thu Nov 23 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.199912310pl11-0vl1
826- updated to 19991231-pl11
827
828* Thu Nov  9 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.199912310pl10-0vl1
829- updated to 19991231-pl10
830
831* Thu Oct 12 2000 Yoshihiro Kajiki <kajiki@ylug.org>
832- fix newaliases problem by adding slink
833
834* Sat Oct  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
835- add japanese man pages
836
837* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
838- updates to 19991231-pl09-0vl2
839- fixed Group
840
841* Sat Sep 22 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
842- updates to 19991231-pl09
843
844* Wed Aug 09 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
845- %build, removed bzip2 -9 and strip
846- fixed %files section to handle compressed man page
847
848* Wed Jun 21 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
849- Version name changes to 0.0.version
850- updates to 19991231-pl08
851  + Major changes with postfix-19991231-pl08:
852    Specify "body_checks = regexp:%{_sysconfdir}/postfix/body_checks" for a quick
853    and dirty emergency content filter that looks at non-header lines
854    one line at a time (including MIME headers inside the message body).
855    Details in conf/sample-filter.cf.
856  + Incompatible changes with postfix-19991231-pl07:
857    As required by RFC 822, Postfix now inserts a generic destination
858    message header when no destination header is present.  The text is
859    specified via the undisclosed_recipients_header configuration
860    parameter (default:  "To: undisclosed-recipients:;").
861
862* Thu Apr  6 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
863- updates to 19991231-pl06
864- added percent hack to main.cf
865
866* Sun Feb 20 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
867- adopted to Vine Linux
868
869* Mon Jan  3 2000 Jean-Michel Dault <jmdault@netrevolution.com>
870- updated to 19991231
871- added postfix group
872- corrected aliases.db bug
873
874* Mon Dec 27 1999 Jerome Dumonteil <jd@mandrakesoft.com>
875- Add postfix check in post to create sub dirs in spool
876
877* Mon Dec 20 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
878- Add -a $DOMAIN -d $LOGNAME to procmail (philippe).
879- New banner.
880
881* Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
882- fix if conflicts with sendmail.
883
884* Sat Jun  5 1999 Axalon Bloodstone <axalon@linux-mandrake.com>
885- install bins from libexec/
886
887* Sat Jun  5 1999 Bernhard Rosenkr舅zer <bero@mandrakesoft.com>
888- 19990601
889- .spec cleanup for easier updates
890
891* Wed May 26 1999 Axalon Bloodstone <axalon@linux-mandrake.com>
892- created link from %{_sbindir}/sendmail to %{_libdir}/sendmail
893  so it doesn't bug out when i rpm -e sendmail
894- Now removes %{_var}/lock/subsys/postfix like a good little prog
895  upon rpm -e
896
897* Fri Apr 23 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
898
899- Mandrake adptations.
900
901* Tue Apr 13 1999 Arne Coucheron <arneco@online.no>
902  [19990317-pl04-1]
903
904* Tue Mar 30 1999 Arne Coucheron <arneco@online.no>
905  [19990317-pl03-2]
906- Castro, Castro, pay attention my friend. You're making it very hard
907  maintaining the package if you don't follow the flow of the releases
908
909* Thu Mar 25 1999 Arne Coucheron <arneco@online.no>
910  [19990317-pl02-1]
911
912* Tue Mar 23 1999 Arne Coucheron <arneco@online.no>
913  [19990317-3]
914- added bugfix patch01
915
916* Sat Mar 20 1999 Arne Coucheron <arneco@online.no>
917  [19990317-2]
918- removed the mynetworks line in main.cf, let postfix figure it out
919- striping of the files in %{_sbindir}
920- alias database moved to %{_sysconfdir}/postfix and made a symlink to it in %{_sysconfdir}
921- enabled procmail support in main.cf and added it to Requires:
922- check status on master instead of postfix in the init script
923- obsoletes postfix-beta
924- had to move some of my latest changelog entries up here since Edgard Castro
925  didn't follow my releases
926
927* Thu Mar 18 1999 Edgard Castro <castro@usmatrix.net>
928  [19990317]
929
930* Tue Mar 16 1999 Edgard Castro <castro@usmatrix.net>
931  [alpha-19990315]
932
933* Tue Mar  9 1999 Edgard Castro <castro@usmatrix.net>
934  [19990122-pl01-2]
935- shell and gecho information changed to complie with Red Hat stardand
936- changed the name of the rpm package to postfix, instead of postfix-beta
937
938* Tue Feb 16 1999 Edgard Castro <castro@usmatrix.net>
939  [19990122-pl01-1]
940
941* Sun Jan 24 1999 Arne Coucheron <arneco@online.no>
942  [19990122-1]
943- shell for postfix user changed to /bin/true to avoid logins to the account
944- files in %{_libdir}exec/postfix moved to %{_libdir}/postfix since this complies
945  more with the Red Hat standard
946
947* Wed Jan 06 1999 Arne Coucheron <arneco@online.no>
948  [19981230-2]
949- added URL for the source
950- added a cron job for daily check of errors
951- sample config files moved from /etc/postfix/sample to the docdir
952- dropped making of symlinks in %{_sbindir} and instead installing the real
953  files there
954- because of the previous they're not needed anymore in %{_libdir}exec/postfix,
955  so they are removed from that place
956
957* Fri Jan 01 1999 Arne Coucheron <arneco@online.no>
958  [19981230-1]
959
960* Tue Dec 29 1998 Arne Coucheron <arneco@online.no>
961  [19981222-1]
962- first build of rpm version
Note: See TracBrowser for help on using the repository browser.