source: projects/specs/trunk/p/postfix/postfix-vl.spec @ 3418

Revision 3418, 31.8 KB checked in by owa, 13 years ago (diff)

rebuild with postgresql-9.0.3

Line 
1#%define build_mysql %{?_with_mysql:1}%{!?_with_mysql:0}
2#%define build_pgsql %{?_with_pgsql:1}%{!?_with_pgsql:0}
3
4%define build_mysql 1
5%define build_pgsql 1
6
7%define _sysconfdir   /etc
8%define _data_dir     %{_var}/lib/postfix
9
10%define origversion 2.6.8
11
12# japanese documant for 2.5.x is not ready.
13# %define jconfversion 2.2.0
14# %define jmanversion 2.2.9
15# %define jhtmlversion 2.2.9
16# %define jreadmeversion 2.2.9
17
18Summary:   Postfix Mail Transport Agent
19Summary(ja):   Postfix メールトランスポートエージェント
20Name:      postfix
21Version:   %{origversion}
22Release:   5%{?_dist_release}
23URL:       http://www.postfix.org/
24License:   Distributable - IBM PUBLIC LICENSE VERSION 1.0 - SECURE MAILER
25Group:     System Environment/Daemons
26
27Source0:   ftp://postfix.cloud9.net/official/%{name}-%{version}.tar.gz
28Source1:   postfix.aliases
29Source2:   postfix.cron
30Source3:   postfix.init
31
32# japanese documents for 2.5.x is not ready.
33# Source10:  http://www.kobitosan.net/postfix/archives/postfix_jconf-%{jconfversion}.tar.gz
34# Source20:  http://www.kobitosan.net/postfix/archives/postfix_jman-%{jmanversion}.tar.gz
35# Source30:  http://www.kobitosan.net/postfix/archives/postfix_jhtml-%{jhtmlversion}.tar.gz
36# Source40:  http://www.kobitosan.net/postfix/archives/postfix_jreadme-%{jreadmeversion}.tar.gz
37
38Patch0:    postfix-2.1.5-vine.patch
39Patch1:    postfix-2.2.10-main.cf-lib64.patch
40
41# patches 100-199 are imported from debian package.
42# patches 100/101 for postfix 2.5.x are from suse. 
43Patch100: postfix-2.6.8-dynamicmaps.patch
44
45# patches 200-299 are imported from rh/fedora
46Patch200: postfix-2.5.7-large-fs.patch     
47Patch210: postfix-2.5.5-open_define-vine.patch
48
49Provides:  smtpdaemon
50Conflicts: sendmail
51Requires(pre):    chkconfig
52BuildRequires: db4-devel >= 4.6.21, pam-devel, gdbm-devel
53BuildRequires: cyrus-sasl-devel >= 2
54BuildRequires: openldap-devel, openssl-devel
55BuildRequires: pcre-devel
56%if %build_mysql
57BuildRequires: MySQL-devel
58%endif
59%if %build_pgsql
60BuildRequires: postgresql-devel
61%endif
62
63Requires:    cyrus-sasl >= 2, cyrus-sasl-md5, cyrus-sasl-plain
64Requires:    gdbm, pam, openssl
65Requires(pre):      db4 >= 4.6.21
66Obsoletes: postfix-beta
67BuildRoot: %{_tmppath}/%{name}-%{version}-root
68
69Vendor: Project Vine
70Distribution: Vine Linux
71Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
72
73
74%description
75Postfix aims to be an alternative to the widely-used sendmail
76program.  Sendmail is responsible for 70 percent of all e-mail delivered
77on the Internet.  With an estimated 100 million users, that's an
78estimated 10 billion (10^10) messages daily. A stunning number.
79
80Although IBM supported the Postfix development, it abstains from
81control over its evolution. The goal is to have Postfix installed
82on as many systems as possible. To this end, the software is given
83away with no strings attached to it, so that it can evolve with
84input from and under control by its users.
85
86#'
87%description -l ja
88Postfix は現在広く使われている sendmail を置き換える目的で
89開発されています。sendmail は約 70% の E-mail サーバで使用
90されています。また、その使用者は 100万人にもおよび、およそ
91一日 1 千万通ものメールを処理しています。
92
93Postfix の開発は IBM によってサポートされており、全世界の
94全てのシステムを postfix にすることを目標としています。
95
96%if %build_pgsql
97%package pgsql
98Summary: PGSQL map support for Postfix
99Group:     System Environment/Daemons
100Requires(pre): postfix = %{version}-%{release}
101Requires: postgresql-libs, postgresql
102%description pgsql
103This package contains shared lib module which support
104PostgreSQL map on Postfix.
105%description -l ja pgsql
106このパッケージには、Postfix で PostgreSQL を使うのに必要な
107ライブラリが納められています。
108%endif
109
110%if %build_mysql
111%package mysql
112Summary: MySQL map support for Postfix
113Group:     System Environment/Daemons
114Requires(pre): postfix = %{version}-%{release}
115%description mysql
116This package contains shared lib module which support
117MySQL map on Postfix.
118%description -l ja mysql
119このパッケージには、Postfix で MySQL を使うのに必要な
120ライブラリが納められています。
121%endif
122
123%package ldap
124Summary: LDAP map support for Postfix
125Group:     System Environment/Daemons
126Requires(pre): postfix = %{version}-%{release}
127Requires: openldap
128%description ldap
129This package contains shared lib module which support
130OpenLDAP map on Postfix.
131%description -l ja ldap
132このパッケージには、Postfix で OpenLDAP を使うのに必要な
133ライブラリが納められています。
134
135%package pcre
136Summary: PCRE map support for Postfix
137Group:     System Environment/Daemons
138Requires(pre): postfix = %{version}-%{release}
139Requires: pcre
140%description pcre
141This package contains shared lib module which support
142PCRE map on Postfix.
143%description -l ja pcre
144このパッケージには、Postfix で PCRE マップを使うのに必要な
145ライブラリが納められています。
146
147%prep
148# japanese documant for 2.4.x is not ready.
149# %setup -q -a 10 -a 20 -a 30 -a 40
150%setup -q
151
152%patch0 -p1 -b .vine
153
154%ifarch x86_64
155%patch1 -p1 -b .lib64
156%endif
157
158%patch100 -p1 -b .dynamicmaps
159perl -pi -e 's,/usr/lib/,/usr/lib64/,' conf/postfix-files
160perl -pi -e 's,-lmysqlclient,-lmysqlclient -L%{_libdir}/mysql,' src/global/Makefile.in
161
162%patch200 -p1 -b .large-fs
163%patch210 -p1 -b .open_define
164
165# patching src/global/Makefile to remove dependency
166pushd src/global
167%if %build_mysql
168:
169%else
170sed -ie "s/ dict_mysql.so/ /" Makefile.in
171%endif
172%if %build_pgsql
173:
174%else
175sed -ie "s/ dict_pgsql.so/ /" Makefile.in
176%endif
177popd
178
179%build
180make makefiles \
181        CCARGS="-DMAX_DYNAMIC_MAPS \
182                -DUSE_SASL_AUTH -I/usr/include/sasl \
183                -DUSE_CYRUS_SASL \
184                -DHAS_LDAP \
185                -DHAS_SSL -I/usr/include/openssl \
186                -DHAS_PCRE -I/usr/include/pcre \
187%if %build_mysql
188                -DHAS_MYSQL -I/usr/include/mysql  \
189%endif
190%if %build_pgsql
191                -DHAS_PGSQL -I/usr/include/pgsql \
192%endif
193                -DUSE_TLS" \
194        AUXLIBS="-lsasl2 -lssl -lcrypto" \
195        OPT="$RPM_OPT_FLAGS" DEBUG=""
196for libs in master global util dns tls xsasl milter
197do
198  ln -sf lib${libs}.a lib/libpostfix-${libs}.so.1
199done
200
201# make %{?_smp_mflags} DEBUG="" OPT="$RPM_OPT_FLAGS" \
202#      LD_LIBRARY_PATH=$(pwd)/lib:${LD_LIBRARY_PATH}
203
204# using _smp_mflags makes build error. why? (2008.10.11)
205make DEBUG="" OPT="$RPM_OPT_FLAGS" \
206     LD_LIBRARY_PATH=$(pwd)/lib:${LD_LIBRARY_PATH} CDBSO=""
207
208%install
209rm -rf $RPM_BUILD_ROOT
210rm -f html/Makefile.in
211rm -f README_FILES/*.*
212
213install -d $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily
214install -d $RPM_BUILD_ROOT%{_sysconfdir}/postfix
215install -d $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
216install -d $RPM_BUILD_ROOT%{_bindir}
217install -d $RPM_BUILD_ROOT%{_libdir}/postfix
218install -d $RPM_BUILD_ROOT%{_mandir}/man{1,5,8}
219install -d $RPM_BUILD_ROOT%{_mandir}/ja/man{1,5,8}
220install -d $RPM_BUILD_ROOT%{_sbindir}
221install -d $RPM_BUILD_ROOT%{_var}/spool/postfix
222install -d $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,incoming,pid,public}
223install -d $RPM_BUILD_ROOT%{_var}/spool/postfix/{bounce,defer,flush,maildrop,private,saved}
224
225install -m755 bin/* $RPM_BUILD_ROOT%{_sbindir}
226install -m755 libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
227install -m755 lib/dict_* $RPM_BUILD_ROOT%{_libdir}/postfix
228install -m755 lib/lib*.so.1 $RPM_BUILD_ROOT%{_libdir}
229
230touch conf/dynamicmaps.cf
231for i in main.cf master.cf access aliases canonical header_checks \
232         main.cf.default post-install postfix-files postfix-script \
233         relocated transport virtual dynamicmaps.cf
234do
235  install -m644 conf/$i $RPM_BUILD_ROOT%{_sysconfdir}/postfix
236done
237for i in post-install postfix-script
238do
239  install -m755 conf/$i $RPM_BUILD_ROOT%{_sysconfdir}/postfix
240done
241
242install -m644 man/man1/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
243install -m644 man/man5/*.5 $RPM_BUILD_ROOT%{_mandir}/man5
244install -m644 man/man8/*.8 $RPM_BUILD_ROOT%{_mandir}/man8
245
246# japanese documant for 2.4.x is not ready.
247# install jman
248# for i in 1 5 8
249# do
250#   install -m644 man-%{jmanversion}/ja/man$i/*.$i $RPM_BUILD_ROOT%{_mandir}/ja/man$i
251# done
252
253# jconf, jhtml, jreadme
254# cp -a conf-%{jconfversion} sample.ja
255# cp -a jhtml-%{jhtmlversion} html.ja
256# cp -a readme-%{jreadmeversion} README_FILES.ja
257
258install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/postfix/aliases
259install -m755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/cron.daily/postfix
260install -m755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/postfix
261
262ln -sf postfix/aliases $RPM_BUILD_ROOT%{_sysconfdir}/aliases
263ln -sf postfix/aliases.db $RPM_BUILD_ROOT%{_sysconfdir}/aliases.db
264
265( cd $RPM_BUILD_ROOT%{_bindir}
266  ln -sf ../sbin/sendmail mailq
267  ln -sf ../sbin/sendmail newaliases
268)
269( cd $RPM_BUILD_ROOT%{_libdir}
270  ln -sf ../sbin/sendmail sendmail
271)
272
273for I in etc/postfix/{aliases,access,canonical,header_check,relocated,transport,virtual}
274do
275   touch $RPM_BUILD_ROOT/$I{,.db}
276done
277
278# data dir
279install -d $RPM_BUILD_ROOT%{_data_dir}
280
281%pre
282if [ `grep postfix %{_sysconfdir}/passwd | wc -l` = 0 ]; then
283   %{_sbindir}/useradd -M -r -d %{_var}/spool/postfix -s "" \
284                     -c "postfix" postfix || :
285fi
286if [ `grep postfix %{_sysconfdir}/group | wc -l` = 0 ]; then
287  %{_sbindir}/groupadd -r postfix
288fi
289if [ `grep postdrop %{_sysconfdir}/group | wc -l` = 0 ]; then
290  %{_sbindir}/groupadd -r postdrop
291fi
292#if [ -f %{_var}/lock/subsys/postfix ]; then
293#   %{_sysconfdir}/rc.d/init.d/postfix stop
294#fi
295
296
297%post
298/sbin/ldconfig
299if ! grep -q "^tcp[[:space:]]" /etc/postfix/dynamicmaps.cf; then
300  echo "Adding tcp map entry to /etc/postfix/dynamicmaps.cf"
301  echo "tcp     %{_libdir}/postfix/dict_tcp.so          dict_tcp_open" >> /etc/postfix/dynamicmaps.cf
302fi
303/sbin/chkconfig --add postfix
304if [ ! -f %{_sysconfdir}/postfix/aliases.db ]; then
305  touch %{_sysconfdir}/postfix/aliases.db
306fi
307%{_sbindir}/postalias %{_sysconfdir}/postfix/aliases ||:
308if [ ! -e %{_libdir}/sendmail ]; then
309        ln -sf %{_sbindir}/sendmail %{_libdir}/sendmail
310fi
311/sbin/chkconfig --del sendmail &> /dev/null ||:
312%{_sbindir}/postfix check >/dev/null 2>&1 ||:
313if [ -f %{_var}/lock/subsys/postfix ]; then
314   %{_sysconfdir}/rc.d/init.d/postfix restart
315fi
316
317
318%preun
319if [ $1 = 0 ]; then
320   if [ -f %{_var}/lock/subsys/postfix -a -f %{_sysconfdir}/rc.d/init.d/postfix ]; then
321      %{_sysconfdir}/rc.d/init.d/postfix stop
322   fi
323   /sbin/chkconfig --del postfix
324fi
325
326
327%postun
328/sbin/ldconfig
329if [ $1 = 0 ]; then
330   if [ `grep postfix %{_sysconfdir}/passwd | wc -l` = 1 ]; then
331      %{_sbindir}/userdel postfix
332   fi
333   if [ `grep postfix %{_sysconfdir}/group | wc -l` = 1 ]; then
334      %{_sbindir}/groupdel postfix
335   fi
336   if [ `grep postdrop %{_sysconfdir}/group | wc -l` = 1 ]; then
337      %{_sbindir}/groupdel postdrop
338   fi
339   if ! [ -f %{_var}/lock/subsys/postfix ]; then
340        rm -rf %{_var}/lock/subsys/postfix
341   fi
342fi
343
344%if %build_pgsql
345%post pgsql
346if ! grep -q "^pgsql[[:space:]]" /etc/postfix/dynamicmaps.cf; then
347  echo "Adding pgsql map entry to /etc/postfix/dynamicmaps.cf"
348  echo "pgsql   %{_libdir}/postfix/dict_pgsql.so                dict_pgsql_open" >> /etc/postfix/dynamicmaps.cf
349fi
350
351%preun pgsql
352if [ $1 = 0 ]; then
353  if grep -q "^pgsql[[:space:]]" /etc/postfix/dynamicmaps.cf; then
354    cp -f /etc/postfix/dynamicmaps.cf /etc/postfix/dynamicmaps.cf.rpmsave
355    grep -v "^pgsql[[:space:]]" /etc/postfix/dynamicmaps.cf.rpmsave > /etc/postfix/dynamicmaps.cf
356  fi
357fi
358%endif
359
360%if %build_mysql
361%post mysql
362if ! grep -q "^mysql[[:space:]]" /etc/postfix/dynamicmaps.cf; then
363  echo "Adding mysql map entry to /etc/postfix/dynamicmaps.cf"
364  echo "mysql   %{_libdir}/postfix/dict_mysql.so                dict_mysql_open" >> /etc/postfix/dynamicmaps.cf
365fi
366
367%preun mysql
368if [ $1 = 0 ]; then
369  if grep -q "^mysql[[:space:]]" /etc/postfix/dynamicmaps.cf; then
370    cp -f /etc/postfix/dynamicmaps.cf /etc/postfix/dynamicmaps.cf.rpmsave
371    grep -v "^mysql[[:space:]]" /etc/postfix/dynamicmaps.cf.rpmsave > /etc/postfix/dynamicmaps.cf
372  fi
373fi
374%endif
375
376%post ldap
377if ! grep -q "^ldap[[:space:]]" /etc/postfix/dynamicmaps.cf; then
378  echo "Adding ldap map entry to /etc/postfix/dynamicmaps.cf"
379  echo "ldap    %{_libdir}/postfix/dict_ldap.so         dict_ldap_open" >> /etc/postfix/dynamicmaps.cf
380fi
381
382%preun ldap
383if [ $1 = 0 ]; then
384  if grep -q "^ldap[[:space:]]" /etc/postfix/dynamicmaps.cf; then
385    cp -f /etc/postfix/dynamicmaps.cf /etc/postfix/dynamicmaps.cf.rpmsave
386    grep -v "^ldap[[:space:]]" /etc/postfix/dynamicmaps.cf.rpmsave > /etc/postfix/dynamicmaps.cf
387  fi
388fi
389
390%post pcre
391if ! grep -q "^pcre[[:space:]]" /etc/postfix/dynamicmaps.cf; then
392  echo "Adding pcre map entry to /etc/postfix/dynamicmaps.cf"
393  echo "pcre    %{_libdir}/postfix/dict_pcre.so         dict_pcre_open" >> /etc/postfix/dynamicmaps.cf
394fi
395
396%preun pcre
397if [ $1 = 0 ]; then
398  if grep -q "^pcre[[:space:]]" /etc/postfix/dynamicmaps.cf; then
399    cp -f /etc/postfix/dynamicmaps.cf /etc/postfix/dynamicmaps.cf.rpmsave
400    grep -v "^pcre[[:space:]]" /etc/postfix/dynamicmaps.cf.rpmsave > /etc/postfix/dynamicmaps.cf
401  fi
402fi
403
404
405%clean
406rm -rf $RPM_BUILD_ROOT
407
408
409%files
410%defattr(-,root,root)
411%doc COMPATIBILITY COPYRIGHT HISTORY LICENSE INSTALL PORTING RELEASE_NOTES
412# japanese documant for 2.4.x is not ready.
413# %doc conf.ja
414# %doc html html.ja
415# %doc README_FILES README_FILES.ja
416%doc README_FILES
417# %doc man-%{jmanversion}/readme_ja.txt
418%{_sysconfdir}/aliases
419%{_sysconfdir}/aliases.db
420%config %{_sysconfdir}/cron.daily/postfix
421%dir %{_sysconfdir}/postfix
422%config %{_sysconfdir}/postfix/main.cf.default
423%config %{_sysconfdir}/postfix/master.cf
424%config(noreplace) %{_sysconfdir}/postfix/aliases
425%config(noreplace) %{_sysconfdir}/postfix/access
426%config(noreplace) %{_sysconfdir}/postfix/canonical
427%config(noreplace) %{_sysconfdir}/postfix/header_check
428%config(noreplace) %{_sysconfdir}/postfix/header_checks
429%config(noreplace) %{_sysconfdir}/postfix/main.cf
430%config(noreplace) %{_sysconfdir}/postfix/relocated
431%config(noreplace) %{_sysconfdir}/postfix/transport
432%config(noreplace) %{_sysconfdir}/postfix/virtual
433%config(noreplace) %{_sysconfdir}/postfix/dynamicmaps.cf
434%config %{_sysconfdir}/postfix/postfix-files
435%config %{_sysconfdir}/postfix/post-install
436%config %{_sysconfdir}/postfix/postfix-script
437%config %{_sysconfdir}/rc.d/init.d/postfix
438%{_bindir}/*
439%dir %{_libdir}/postfix
440%{_libdir}/postfix/*
441
442%if %{build_pgsql}
443%exclude %{_libdir}/postfix/dict_pgsql.so
444%endif
445%if %{build_mysql}
446%exclude %{_libdir}/postfix/dict_mysql.so
447%endif
448
449%exclude %{_libdir}/postfix/dict_ldap.so
450%exclude %{_libdir}/postfix/dict_pcre.so
451%{_libdir}/lib*.so.1
452%{_sbindir}/postalias
453%{_sbindir}/postcat
454%{_sbindir}/postconf
455%attr(2755,root,postdrop) %{_sbindir}/postdrop
456%{_sbindir}/postfix
457%{_sbindir}/postkick
458%{_sbindir}/postlock
459%{_sbindir}/postlog
460%{_sbindir}/postmap
461%{_sbindir}/postmulti
462%attr(2755,root,postdrop) %{_sbindir}/postqueue
463%{_sbindir}/postsuper
464%{_sbindir}/qmqp-sink
465%{_sbindir}/qmqp-source
466%{_sbindir}/sendmail
467%{_sbindir}/smtp-sink
468%{_sbindir}/smtp-source
469%attr(-,root,man) %{_mandir}/man*/*
470# %attr(-,root,man) %{_mandir}/ja/man*/*
471%dir %{_var}/spool/postfix
472%attr(0750,postfix,root) %dir %{_data_dir}
473%attr(1733,postfix,postdrop) %dir %{_var}/spool/postfix/maildrop
474%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/active
475%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/corrupt
476%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/deferred
477%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/incoming
478%attr(0755,root,root) %dir %{_var}/spool/postfix/pid
479%attr(0710,postfix,postdrop) %dir %{_var}/spool/postfix/public
480%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/bounce
481%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/defer
482%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/flush
483%attr(0710,postfix,postfix) %dir %{_var}/spool/postfix/private
484%attr(0700,postfix,postfix) %dir %{_var}/spool/postfix/saved
485%{_libdir}/sendmail
486
487%if %build_pgsql
488%files pgsql
489%defattr(-,root,root)
490%{_libdir}/postfix/dict_pgsql.so
491%endif
492
493%if %build_mysql
494%files mysql
495%defattr(-,root,root)
496%{_libdir}/postfix/dict_mysql.so
497%endif
498
499%files ldap
500%defattr(-,root,root)
501%{_libdir}/postfix/dict_ldap.so
502
503%files pcre
504%defattr(-,root,root)
505%{_libdir}/postfix/dict_pcre.so
506
507%changelog
508* Tue Apr 12 2011 Shu KONNO <owa@bg.wakwak.com> 2.6.8-5
509- rebuilt with postgresql-9.0.3
510
511* Sun Jan  9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.8-4
512- rebuilt with openssl 1.0.0c
513- fix changelog typo..
514
515* Wed Dec 01 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.8-3
516- new upstream release.
517- updated %%patch100 and %%patch210.
518
519* Sat Feb 20 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.5-2
520- removed MySQL-shared from "Requires:" and "BuildRequires:".
521- replaced "Prereq:" with "Requires(pre):".
522- replaced "BuildPrereq:" with "BuildRequires:".
523
524* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-1
525- new upstream release
526- rebuild with db4-4.8.0
527
528* Sun Aug 16 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-2
529- change /var/spool/postfix/pid owner and permission
530  (0700,postfix,postfix -> 0755,root,root)
531
532* Mon Aug  3 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.6.3-1
533- new upstream release
534
535* Sat Jun  6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.2-1
536- new upstream release.
537
538* Sat May 30 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.1-2
539- added a missing file.
540
541* Sat May 30 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.6.1-1
542- new upstream release.
543- updated dynamicmaps patch.
544
545* Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.5.7-2
546- made to build -mysql and -pgsql as default.
547- rebuilt with MySQL-5.1.34.
548
549* Wed May 13 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.7-1
550- new upstream release
551- update Patch200 from fc10
552
553* Sun Mar 01 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.5.6-2
554- rebuilt with openldap-2.4.11
555
556* Mon Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.6-1
557- new upstream release
558
559* Sun Oct 12 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-4
560- add patch200/patch210 from fedora
561
562* Sun Oct 12 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-3
563- add Requires cyrus-sasl-md5, cyrus-sasl-plain for smtp auth
564- add Japanese description into sub packages
565
566* Sat Oct 11 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-2
567- update patch100/101 to fix libxsasl build issue
568- remove smp flag in build section to solve build error
569- add _data_dir
570
571* Fri Oct 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.5.5-1
572- new upstream release
573- update patch100/101 to fit 2.5.5 (from suse)
574- add %exclude dict_{my,pg}sql.so to %%files to avoid unneeded dependancy
575  when option "--with XXsql" is specified. (from Vine 4.x update package)
576- remove HAS_DLOPEN macro.
577
578* Sat Sep 06 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.9-1
579- new upstream release with security fix
580
581* Sat Aug 30 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.8-2
582- add %%if %%build_mysql and %%if %%mysql from BuildRequires section again
583- remove unnessary dependency
584
585* Thu Aug 28 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.8-1
586- new upstream release with security fix
587
588* Mon Aug 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-4
589- spec in UTF-8
590
591* Fri Jun 20 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.7-3
592- rebuilt against db4-4.6.21
593
594* Tue Apr 15 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.4.7-2
595- add HAS_DLOPEN macro.
596- add USE_CYRUS_SASL macro.
597- modify dynamicmaps.cf (/usr/lib -> %%{_libdir}).
598
599* Thu Mar 25 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.4.7-1
600- new upstream release
601- update patch100 (it is based from mdk 2008.0)
602- add smp_mflags in make section
603- build under new versioning policy
604
605* Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.10-0vl10
606- rebuilt with postgresql-devel 8.2.5
607- updated Source20, 30 and 40
608
609* Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl9
610- rebuild with new openssl
611
612* Wed May 09 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.10-0vl8
613- rebuilt with new toolchain and db4-4.3.x
614
615* Fri Apr 13 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 2.2.10-0vl7
616- <BTS:493> fix typo in %%if statement for %%files mysql section.
617- remove %%if %%build_mysql and %%if %%mysql from BuildRequires section,
618  (Patch100 always builds dict_mysql.o and dict_pgsql.o)
619
620* Fri Oct 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl6
621- disable MySQL, PostgreSQL support by default.
622  use "--with {mysql|pgsql}" to build them.
623
624* Mon Sep 18 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.10-0vl5
625- add lib64 patch to correct daemon_directory on x86_64 architecture
626
627* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl4
628- remove duplicated entry from aliases. (<BTS:170>)
629
630* Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl3
631- add some pseudo accounts to aliases. (<BTS:170>)
632- add BuildPreReq: MySQL-shared
633
634* Sun Aug 27 2006 NAKAMURA Kenta <kenta@vinelinux.org> 2.2.10-0vl2
635- rebuilt with openldap-2.3.27-0vl1
636
637* Sun Apr 23 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.10-0vl1
638- new upstream release
639
640* Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.8-0vl1
641- new upstream release
642
643* Fri Sep 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.5-0vl1
644- new upstream release
645  - update to 2.2.5
646- update dynamicmaps from debian package
647- update Japaese manpages and jconf
648- add jhtml and jreadme
649- enable TLS/SSL
650
651* Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.5-0vl1
652- new upstream release
653- update all patches
654- link sasl2 instead of sasl1
655
656* Mon Jan 24 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 2.0.20-0vl6
657- enable cyrus-sasl.
658- add TLS/IPv6 patch.
659- modify main.cf to disable IPv6 as default.
660
661* Wed Oct 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.20-0vl5
662- add PreReq: db4 >= 4.2.52
663  (to avoid errors when upgrading from db40-linked version)
664
665* Mon Oct 11 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.20-0vl4
666- rebuilt with db4-4.2.52
667
668* Tue Jun  8 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.20-0vl3
669- fix first installation time bugs...
670  - remove aliases.db from %%files again
671  - add 'touch aliases.db' in %%post script
672- update default main.cf to use /etc/postfix/aliases as default alias_database
673
674* Mon Jun  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.20-0vl2
675- add /etc/postfix/aliases.db to %%files
676
677* Sat May  8 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.20-0vl1
678- new upstream release
679
680* Tue Apr 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.19-0vl1
681- new upstream release
682- build with new postgresql
683
684* Fri Sep 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.16-0vl1
685- new upstream release
686- update jconf/jman/jhtml
687
688* Fri Jul  4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.13-0vl1
689- new upstream release
690- update jman/jhtml/jreadme
691
692* Mon Jun 16 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.12-0vl1
693- new upstream release
694- update jconf/jman/jhtml/jreadme
695
696* Tue Jun 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.10-0vl1
697- new upstream release
698
699* Fri May 23 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.9-0vl5
700- rebuild by new cyrus-sasl(2.1.13-3vl1)
701
702* Sat Apr 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl4
703- add more BuildPreReq, Requires
704- fix some typo
705- add missing files to %%files.
706
707* Sat Apr 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl3
708- rebuild
709
710* Sat Apr 26 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl2
711- add debian's dynamic map patch.
712  some additional feature is divided to sub package.
713  - postfix-ldap, postfix-mysql, postfix-pgsql, postfix-pcre
714- split common postfix libraries as shared libs.
715  - libpostfix-{master,global,util,dns}.so.1
716- use cyrus-sasl for SMTP-AUTH
717
718* Wed Apr 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.9-0vl1
719- new upstream release 2.0.9
720- update jman/jhtml/jconf to 2.0.8
721
722* Wed Apr  9 2003 IWAI Masaharu <iwai@alib.jp> 2.0.7-0vl1
723- new upstream version
724- update documents
725    - jman (source4)
726    - jconf (Source5)
727    - faq.html (Source6)
728    - INSTALL.jp (Source7)
729    - jhtml (Source12)
730
731* Sun Jan 19 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.12-0vl3
732- rebuilt against db4
733
734* Wed Dec 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.12-0vl2
735- rebuild to remove unnecessary dependancy.
736
737* Sat Nov 23 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.12-0vl1
738- new upstream version
739- modified /etc/init.d/postfix
740
741* Sun Oct 06 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.11-0vl3
742- fixed brainless mistakes...
743  update main.cf again.
744
745* Thu Oct 03 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.11-0vl2
746- update main.cf patch
747  - do not use procmail for local mailer.
748  - do not show version and OS name for smtpd greeting banner.
749
750* Thu Jun 04 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.11-0vl1
751- new upstream release
752- update jman, jconf, jhtml
753
754* Tue May 28 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.10-0vl2
755- updated main.cf patch ( Patch0 )
756    undefine myhostname
757
758* Fri May 24 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.10-0vl1
759- changed %%{_var}/spool/postfix/private directory permission (0700 -> 0710)
760    Thanks Mr. Daisuke SUZUKI ([VineSeed:06454])
761
762* Thu May 23 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.10-0vl0
763- upstream release
764- updated japanese documents Source4-9
765    ( and the unofficial Japanese Web Site moved. )
766- added japanese documents  Source10-12
767- updated main.cf patch ( Patch0 )
768- added postdrop group
769- added some directories in %%{_var}/spool/postfix/
770    active, corrupt, deferred, incoming, pid, public, bounce,
771    defer,flush,private and saved directories
772
773* Mon Feb 18 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.0.20010228pl08-0vl3
774- not stop in %%pre
775- not start but restart in %%post
776
777* Mon Dec 31 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.0.20010228pl08-0vl2
778- added BuildPreReq: db3-devel
779
780* Sat Nov 24 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl08-0vl1
781- updated to 20010228-pl08
782
783* Fri Nov  9 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl06-0vl1
784- updated to 20010228-pl06
785
786* Sun Sep 23 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl05-0vl1
787- updated to 20010228-pl05
788
789* Wed Aug  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl04-0vl1
790- updated to 20010228-pl04
791
792* Wed Jun 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl03-0vl2
793- update Japanese documents and manpages
794
795* Sun May 27 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl03-0vl1
796- updated to 20010228-pl03
797
798* Mon May 21 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
799- 0.0.20010228pl02-0vl3
800- modified %%preun script again
801  (to check whether %%{_sysconfidir}/rc.d/init.d/postfix already exists)
802
803* Wed May 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
804- 0.0.20010228pl02-0vl2
805- fixed incorrect %%preun script :-P
806
807* Tue May  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl02-0vl1
808- updated to 20010228-pl02
809
810* Wed Apr 11 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl01-0vl4
811- add {pcre,regexp}_table to %files
812- don't replace config files
813- start postfix after install/upgrade
814
815* Mon Apr 09 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl01-0vl2
816- updated jman pages and translations.
817- added japanese sample config files.
818
819* Sat Mar 31 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228pl01-0vl1
820- updated to 20010228-pl01
821
822* Thu Mar  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228-0vl2
823- fixed file location
824
825* Thu Mar  1 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.20010228-0vl1
826- updated to 20010228
827
828* Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 0.0.199912310pl13-0vl2
829- fixed about mandir
830
831* Thu Nov 23 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.199912310pl13-0vl1
832- updated to 19991231-pl13
833- use rpm macros in spec
834
835* Thu Nov 23 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.199912310pl11-0vl1
836- updated to 19991231-pl11
837
838* Thu Nov  9 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.0.199912310pl10-0vl1
839- updated to 19991231-pl10
840
841* Thu Oct 12 2000 Yoshihiro Kajiki <kajiki@ylug.org>
842- fix newaliases problem by adding slink
843
844* Sat Oct  2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
845- add japanese man pages
846
847* Sun Oct  1 2000 Jun Nishii <jun@vinelinux.org>
848- updates to 19991231-pl09-0vl2
849- fixed Group
850
851* Sat Sep 22 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
852- updates to 19991231-pl09
853
854* Wed Aug 09 2000 MACHINO, Satoshi <mac@netfort.gr.jp>
855- %build, removed bzip2 -9 and strip
856- fixed %files section to handle compressed man page
857
858* Wed Jun 21 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
859- Version name changes to 0.0.version
860- updates to 19991231-pl08
861  + Major changes with postfix-19991231-pl08:
862    Specify "body_checks = regexp:%{_sysconfdir}/postfix/body_checks" for a quick
863    and dirty emergency content filter that looks at non-header lines
864    one line at a time (including MIME headers inside the message body).
865    Details in conf/sample-filter.cf.
866  + Incompatible changes with postfix-19991231-pl07:
867    As required by RFC 822, Postfix now inserts a generic destination
868    message header when no destination header is present.  The text is
869    specified via the undisclosed_recipients_header configuration
870    parameter (default:  "To: undisclosed-recipients:;").
871
872* Thu Apr  6 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
873- updates to 19991231-pl06
874- added percent hack to main.cf
875
876* Sun Feb 20 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
877- adopted to Vine Linux
878
879* Mon Jan  3 2000 Jean-Michel Dault <jmdault@netrevolution.com>
880- updated to 19991231
881- added postfix group
882- corrected aliases.db bug
883
884* Mon Dec 27 1999 Jerome Dumonteil <jd@mandrakesoft.com>
885- Add postfix check in post to create sub dirs in spool
886
887* Mon Dec 20 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
888- Add -a $DOMAIN -d $LOGNAME to procmail (philippe).
889- New banner.
890
891* Wed Nov 10 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
892- fix if conflicts with sendmail.
893
894* Sat Jun  5 1999 Axalon Bloodstone <axalon@linux-mandrake.com>
895- install bins from libexec/
896
897* Sat Jun  5 1999 Bernhard Rosenkr舅zer <bero@mandrakesoft.com>
898- 19990601
899- .spec cleanup for easier updates
900
901* Wed May 26 1999 Axalon Bloodstone <axalon@linux-mandrake.com>
902- created link from %{_sbindir}/sendmail to %{_libdir}/sendmail
903  so it doesn't bug out when i rpm -e sendmail
904- Now removes %{_var}/lock/subsys/postfix like a good little prog
905  upon rpm -e
906
907* Fri Apr 23 1999 Chmouel Boudjnah <chmouel@mandrakesoft.com>
908
909- Mandrake adptations.
910
911* Tue Apr 13 1999 Arne Coucheron <arneco@online.no>
912  [19990317-pl04-1]
913
914* Tue Mar 30 1999 Arne Coucheron <arneco@online.no>
915  [19990317-pl03-2]
916- Castro, Castro, pay attention my friend. You're making it very hard
917  maintaining the package if you don't follow the flow of the releases
918
919* Thu Mar 25 1999 Arne Coucheron <arneco@online.no>
920  [19990317-pl02-1]
921
922* Tue Mar 23 1999 Arne Coucheron <arneco@online.no>
923  [19990317-3]
924- added bugfix patch01
925
926* Sat Mar 20 1999 Arne Coucheron <arneco@online.no>
927  [19990317-2]
928- removed the mynetworks line in main.cf, let postfix figure it out
929- striping of the files in %{_sbindir}
930- alias database moved to %{_sysconfdir}/postfix and made a symlink to it in %{_sysconfdir}
931- enabled procmail support in main.cf and added it to Requires:
932- check status on master instead of postfix in the init script
933- obsoletes postfix-beta
934- had to move some of my latest changelog entries up here since Edgard Castro
935  didn't follow my releases
936
937* Thu Mar 18 1999 Edgard Castro <castro@usmatrix.net>
938  [19990317]
939
940* Tue Mar 16 1999 Edgard Castro <castro@usmatrix.net>
941  [alpha-19990315]
942
943* Tue Mar  9 1999 Edgard Castro <castro@usmatrix.net>
944  [19990122-pl01-2]
945- shell and gecho information changed to complie with Red Hat stardand
946- changed the name of the rpm package to postfix, instead of postfix-beta
947
948* Tue Feb 16 1999 Edgard Castro <castro@usmatrix.net>
949  [19990122-pl01-1]
950
951* Sun Jan 24 1999 Arne Coucheron <arneco@online.no>
952  [19990122-1]
953- shell for postfix user changed to /bin/true to avoid logins to the account
954- files in %{_libdir}exec/postfix moved to %{_libdir}/postfix since this complies
955  more with the Red Hat standard
956
957* Wed Jan 06 1999 Arne Coucheron <arneco@online.no>
958  [19981230-2]
959- added URL for the source
960- added a cron job for daily check of errors
961- sample config files moved from /etc/postfix/sample to the docdir
962- dropped making of symlinks in %{_sbindir} and instead installing the real
963  files there
964- because of the previous they're not needed anymore in %{_libdir}exec/postfix,
965  so they are removed from that place
966
967* Fri Jan 01 1999 Arne Coucheron <arneco@online.no>
968  [19981230-1]
969
970* Tue Dec 29 1998 Arne Coucheron <arneco@online.no>
971  [19981222-1]
972- first build of rpm version
Note: See TracBrowser for help on using the repository browser.