source: projects/specs/trunk/p/portmap/portmap-vl.spec @ 521

Revision 521, 7.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define initdir /etc/rc.d/init.d
2
3Summary: A program which manages RPC connections.
4Name: portmap
5Version: 4.0
6Release: 63%{?_dist_release}
7Group: System Environment/Daemons
8License: BSD
9Source0: ftp://coast.cs.purdue.edu/pub/tools/unix/portmap/portmap_4.tar.gz
10Source1: portmap.init
11Source2: pmap_set.8
12Source3: pmap_dump.8
13Source4: portmap.8
14Patch0: portmap-4.0-linux.patch
15Patch1: portmap-malloc.patch
16Patch2: portmap-4.0-cleanup.patch
17Patch3: portmap-4.0-rpc_user.patch
18Patch4: portmap-4.0-sigpipe.patch
19Patch5: portmap-4.0-errno.patch
20Patch6: portmap-4.0-pie.patch
21Patch7: portmap-4.0-loopback.patch
22Source101: portmap.init.vine
23#Prereq: /sbin/chkconfig /etc/init.d
24Prereq: /sbin/chkconfig
25BuildRoot: %{_tmppath}/%{name}-%{version}-root
26#Requires: initscripts >= 5.54
27BuildRequires: tcp_wrappers
28
29%description
30The portmapper program is a security tool which prevents theft of NIS
31(YP), NFS and other sensitive information via the portmapper.  A
32portmapper manages RPC connections, which are used by protocols like
33NFS and NIS.
34
35The portmap package should be installed on any machine which acts as a
36server for protocols using RPC.
37
38%prep
39%setup -q -n portmap_4
40%patch0 -p1
41%patch1 -p1
42%patch2 -p1
43%patch3 -p1 -b .rpcuser
44%patch4 -p1 -b .sigpipe
45%patch5 -p1 -b .errno
46%patch6 -p1 -b .pie
47%patch7 -p1 -b .lo
48
49%build
50make FACILITY=LOG_AUTH ZOMBIES='-DIGNORE_SIGCHLD -Dlint' LIBS="-Wl,-Bstatic -lwrap -Wl,-Bdynamic -lnsl" RPM_OPT_FLAGS="$RPM_OPT_FLAGS" AUX=""
51
52%install
53rm -rf $RPM_BUILD_ROOT
54
55mkdir -p ${RPM_BUILD_ROOT}/sbin
56install -m 755 -s portmap ${RPM_BUILD_ROOT}/sbin
57
58mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
59install -m 755 -s pmap_set ${RPM_BUILD_ROOT}%{_sbindir}
60install -m 755 -s pmap_dump ${RPM_BUILD_ROOT}%{_sbindir}
61
62mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
63install -m 644 $RPM_SOURCE_DIR/pmap_set.8 ${RPM_BUILD_ROOT}%{_mandir}/man8
64install -m 644 $RPM_SOURCE_DIR/pmap_dump.8 ${RPM_BUILD_ROOT}%{_mandir}/man8
65install -m 644 $RPM_SOURCE_DIR/portmap.8 ${RPM_BUILD_ROOT}%{_mandir}/man8
66
67mkdir -p $RPM_BUILD_ROOT%{initdir}
68#install -m 755 $RPM_SOURCE_DIR/portmap.init ${RPM_BUILD_ROOT}%{initdir}/portmap
69install -m 755 $RPM_SOURCE_DIR/portmap.init.vine ${RPM_BUILD_ROOT}%{initdir}/portmap
70
71%clean
72rm -rf $RPM_BUILD_ROOT
73
74%post
75/sbin/chkconfig --add portmap
76/usr/sbin/groupadd -g 32 rpc > /dev/null 2>&1
77/usr/sbin/useradd -c "Portmapper RPC user" -d / -g 32 -M -s /bin/false -u 32 rpc > /dev/null 2>&1
78exit 0
79
80%triggerpostun -- portmap <= portmap-4.0-22
81/sbin/chkconfig --add portmap
82
83%preun
84if [ $1 = 0 ] ; then
85  service portmap stop > /dev/null 2>&1
86  /sbin/chkconfig --del portmap
87fi
88
89%postun
90if [ "$1" -ge "1" ]; then
91  service portmap condrestart > /dev/null 2>&1
92fi
93
94%files
95%defattr(-,root,root)
96%doc README CHANGES BLURB
97/sbin/portmap
98%{_sbindir}/pmap_dump
99%{_sbindir}/pmap_set
100%{_mandir}/man8/*
101%config %{initdir}/portmap
102
103%changelog
104* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 4.0-63vl5
105- applied new versioning policy, spec in utf-8
106
107* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0-63vl2
108- rebuilt
109
110* Thu Nov 18 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0-63vl1
111- added Patches from Fedora development
112  * Thu Aug 12 2004 Steve Dickson <SteveD@RedHat.com>
113  - Added the -l argument that allows only loopback bindings.
114  * Thu Feb 12 2004 Thomas Woerner <twoerner@redhat.com> 4.0-58
115  - added PIE patch from Ulrich Drepper
116- added BuildRequires: tcp_wrappers
117
118* Fri Sep 19 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0-56vl1
119- rebuild with new toolchains
120- s/Copyright/License/
121- added Patch from Rawhide 4.0-56.1
122  * Fri Dec  13 2002 Daniel J Walsh <dwalsh@redhat.com> 4.0-51
123  - Replace extern int errno with include <errno.h>
124  * Thu Dec  12 2002 Daniel J Walsh <dwalsh@redhat.com> 4.0-50
125  - Change spec file to stop building auxilliary files
126  - Fix Makefile to build correctly on x86-64
127  - Fix strerror.c to build correctly on x86-64
128
129* Thu Aug 16 2001 <sagami@vinelinux.org>
130- 4.0-38vl1: install portmap.init w/o i18n support for Vine
131
132* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
133- Bump release + rebuild.
134
135* Sun Apr 29 2001 Bill Nottingham <notting@redhat.com>
136- fix condrestart
137
138* Fri Apr 20 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
139- Remove "¥n" from echo statement (#36721)
140
141* Wed Feb 28 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
142- clear group memberships (#23195)
143
144* Sun Feb 11 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
145- don't die on SIGPIPE (#21748)
146- Fix condrestart so it maintains portmap state
147
148* Wed Feb  7 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
149- improve i18n
150
151* Wed Jan 24 2001 Matt Wilson <msw@redhat.com>
152- new style i18n init script
153
154* Fri Jan 19 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
155- fix manpage (#13218)
156- gettextize
157- exit if /etc/sysconfig/network doesn't exist
158  and make sure it works when networking is off (#23757)
159
160* Tue Jan  2 2001 Bill Nottingham <notting@redhat.com>
161- setgid too, not just setuid (#23195)
162
163* Thu Aug 10 2000 Jeff Johnson <jbj@redhat.com>
164- add restart shell function (#15914).
165
166* Sun Aug  6 2000 Philipp Knirsch <pknirsch@redhat.com>
167- Changed the uid/gid of the rpc user to be 32/32
168
169* Fri Aug  4 2000 Philipp Knirsch <pknirsch@redhat.com>
170- Fixed a build warning for daemon.c (missing <stdlib.h> include)
171- Portmap now running under user rpc if possible (#12427)
172
173* Wed Aug  2 2000 Bill Nottingham <notting@redhat.com>
174- start a little later (after syslog)
175- do dump/reload on restart (#14612)
176
177* Thu Jul 20 2000 Bill Nottingham <notting@redhat.com>
178- move initscript back
179
180* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
181- automatic rebuild
182
183* Sat Jul  8 2000 Bill Nottingham <notting@redhat.com>
184- make trigger work on a few later versions
185
186* Tue Jun 27 2000 Than Ngo <than@redhat.de>
187- /etc/rc.d/init.d -> /etc/init.d
188- condrestart in %postun
189- fix initscript
190- add requires initscript
191- remove links from packaging
192
193* Tue Jun  6 2000 Jeff Johnson <jbj@redhat.com>
194- FHS packaging.
195
196* Wed May 10 2000 Jeff Johnson <jbj@redhat.com>
197- apply cleanup patch (H.J. Lu)
198
199* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
200- compress man pages.
201
202* Wed Dec  1 1999 Bill Nottingham <notting@redhat.com>
203- add patch to fix some malloc issues from HP
204
205* Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
206- chkconfig --del in %preun, not %postun
207
208* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
209- initscript munging
210
211* Tue Mar 23 1999 Preston Brown <pbrown@redhat.com>
212- added man pages.
213
214* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
215- auto rebuild in the new build environment (release 14)
216
217* Fri Dec 18 1998 Cristian Gafton <gafton@redhat.com>
218- build for glibc 2.1
219
220* Tue Jul  7 1998 Jeff Johnson <jbj@redhat.com>
221- start/stop portmap at levels 11/89
222
223* Mon May 04 1998 Cristian Gafton <gafton@redhat.com>
224- fixed the trigger script
225
226* Fri May 01 1998 Jeff Johnson <jbj@redhat.com>
227- added triggerpostun
228
229* Fri May 01 1998 Cristian Gafton <gafton@redhat.com>
230- added %trigger to fix a previously broken package
231
232* Thu Apr 23 1998 Michael K. Johnson <johnsonm@redhat.com>
233- enhanced initscripts
234
235* Thu Jan 08 1998 Erik Troan <ewt@redhat.com>
236- rebuilt against glibc 2.0.6
237
238* Tue Oct 28 1997 Erik Troan <ewt@redhat.com>
239- fixed service name in stop section of init script
240
241* Tue Oct 21 1997 Donnie Barnes <djb@redhat.com>
242- fixed chkconfig support
243
244* Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
245- added restart, status commands to init script
246- added chkconfig support
247- uses a buildroot and %attr tags
248
249* Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
250- built against glibc
Note: See TracBrowser for help on using the repository browser.