source: projects/specs/trunk/p/polkit-qt/polkit-qt-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name:           polkit-qt
2Version:        0.95.1
3Release:        2%{?_dist_release}
4Summary:        Qt bindings for PolicyKit
5Summary(ja):    PolicyKit の Qt バインディング
6
7Group:          System Environment/Libraries
8License:        GPLv2+
9URL:            http://api.kde.org/kdesupport-api/kdesupport-apidocs/polkit-qt/html/
10Source0:        ftp://ftp.kde.org/pub/kde/stable/polkit-qt-1/polkit-qt-1-%{version}.tar.bz2
11BuildRoot:      %{_tmppath}/%{name}-%{version}-root
12
13BuildRequires:  automoc4
14BuildRequires:  cmake
15BuildRequires:  qt4-devel
16BuildRequires:  polkit-devel
17
18%description
19Polkit-qt is a library that lets developers use the PolicyKit API through a nice
20Qt-styled API. It is mainly a wrapper around QAction and QAbstractButton that
21lets you integrate those two component easily with PolicyKit.
22
23%package devel
24Summary: Development files for %{name}
25Group: Development/Libraries
26Requires: %{name} = %{version}-%{release}
27Requires: pkgconfig
28Requires: polkit-devel
29
30%description devel
31%{summary}.
32
33#package examples
34#Summary: Example files for %{name}
35#Group: Development/Libraries
36#Requires: %{name} = %{version}-%{release}
37
38#description examples
39#%{summary}.
40
41
42%prep
43%setup -q -n polkit-qt-1-%{version}
44
45%build
46%ifarch x86_64
47PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
48%endif
49mkdir -p %{_target_platform}
50pushd %{_target_platform}
51%cmake \
52    -DCMAKE_BUILD_TYPE=release \
53    -DBUILD_EXAMPLES=0 ..
54popd
55
56make %{?_smp_mflags} -C %{_target_platform}
57
58
59%install
60rm -rf %{buildroot}
61make install/fast DESTDIR=%{buildroot} -C %{_target_platform}
62
63
64%clean
65rm -rf %{buildroot}
66
67
68%post -p /sbin/ldconfig
69
70%postun -p /sbin/ldconfig
71
72
73%files
74%defattr(-,root,root,-)
75%doc AUTHORS COPYING README
76%{_libdir}/libpolkit-qt*.so.*
77
78%files devel
79%defattr(-,root,root,-)
80%{_includedir}/polkit-qt-1/
81%{_libdir}/libpolkit-qt*.so
82%{_libdir}/pkgconfig/polkit-qt*.pc
83
84#%files examples
85#%defattr(-,root,root,-)
86#%{_sysconfdir}/dbus-1/system.d/org.qt.policykit.examples.conf
87#%{_bindir}/polkit-example-helper
88#%{_datadir}/PolicyKit/policy/org.qt.policykit.examples.policy
89#%{_datadir}/dbus-1/system-services/org.qt.policykit.examples.service
90
91
92%changelog
93* Thu Feb 11 2010 Shu KONNO <owa@bg.wakwak.com> - 0.95.1-2
94- added qmake path to PATH (if x86_64)
95
96* Thu Feb 11 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.95.1-1
97- new upstream release
98- added BR: polkit-devel instead of PolicyKit-devel
99
100* Tue Sep 01 2009 NAKAMURA Kenta <kenta@vinelinux.org> - 0.9.2-4
101- use %%cmake macro
102
103* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.9.2-3
104- Initial build for Vine Linux
105
106* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.2-2
107- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
108
109* Wed Apr 22 2009 Rex Dieter <rdieter@fedoraproject.org> 0.9.2-1
110- polkit-0.9.2
111
Note: See TracBrowser for help on using the repository browser.