source: projects/specs/trunk/p/poedit/poedit-vl.spec @ 9687

Revision 9687, 4.5 KB checked in by Takemikaduchi, 9 years ago (diff)

dbus: new upstream release
others: rebuild

Line 
1%define name    poedit
2%define version 1.5.5
3%define release 2%{?_dist_release}
4
5Summary:        Gettext catalogs editor
6Summary(ja):    Gettext カタログの翻訳用エディタ
7Name:           %{name}
8Version:        %{version}
9Release:        %{release}
10Source0:        %{name}-%{version}.tar.gz
11Patch0: del_comment_desktop.patch
12Patch1: poedit-1.5.5-wx28.patch
13
14License:        MIT
15Group:          Applications/Development
16URL:            http://www.poedit.net/
17
18BuildRequires: desktop-file-utils
19BuildRequires: wxGTK-devel >= 2.8.0
20BuildRequires: gtkspell-devel >= 2.0, libdb-cxx-devel
21BuildRequires: libboost-devel
22BuildRoot:      %{_tmppath}/%{name}-%{version}-root
23
24
25%description
26Poedit is cross-platform gettext catalogs (.po files) editor.
27It is built with wxWidgets toolkit and can run on any platform
28supported by it (although it was only tested on Unix with GTK+
29and Windows).
30It aims to provide more convenient approach to editing catalogs
31than launching vi and editing the file by hand.
32
33%description -l ja
34Poedit はクロス・プラットフォームな gettext カタログ (.po ファイル)
35用のエディタです。Toolkit に wxWidgets を使っており、この Toolkit
36がサポートする環境であればどんなプラットフォームでも動作します。
37(実際には GTK+ を使った Unix と Windows でしかテストされていませんが)
38このプログラムは、vi を使ってファイルを編集するよりも、もっと簡単に
39カタログを編集する方法を提供することを目指しています。
40
41
42%prep
43%setup -q
44%patch0 -p1
45%patch1 -p1
46
47
48%build
49%configure
50%{__make} %{?_smp_mflags}
51
52
53%install
54%{__rm} -rf ${RPM_BUILD_ROOT}
55make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
56
57# Remove a few unnecessary locations where the makefile may install
58# copies of icons and .desktop files
59rm -rf \
60    $RPM_BUILD_ROOT%{_datadir}/applnk \
61    $RPM_BUILD_ROOT%{_datadir}/mimelnk \
62    $RPM_BUILD_ROOT%{_datadir}/gnome \
63    $RPM_BUILD_ROOT%{_datadir}/mime-info
64
65# Install the desktop file
66desktop-file-install \
67    --delete-original \
68    --add-category=GTK \
69    --dir $RPM_BUILD_ROOT%{_datadir}/applications \
70    $RPM_BUILD_ROOT%{_datadir}/applications/poedit.desktop
71
72%find_lang %{name}
73
74# work around for https://bugzilla.redhat.com/show_bug.cgi?id=866058
75rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/*/mimetypes/text-x-gettext-translation.*
76
77%clean
78%{__rm} -rf ${RPM_BUILD_ROOT}
79
80%post
81update-desktop-database &> /dev/null ||:
82touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
83
84
85%postun
86update-desktop-database &> /dev/null ||:
87if [ $1 -eq 0 ] ; then
88    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
89    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
90fi
91
92
93%posttrans
94gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
95
96
97%files -f %{name}.lang
98%defattr(-,root,root)
99%doc AUTHORS COPYING NEWS README TODO
100%{_bindir}/poedit
101%{_datadir}/applications/poedit.desktop
102%{_datadir}/icons/hicolor/*/apps/
103%{_datadir}/icons/hicolor/*/mimetypes/
104%{_datadir}/pixmaps/poedit.png
105#%{_datadir}/poedit/help
106%{_datadir}/poedit/icons
107%{_mandir}/man1/poedit.1.gz
108
109%changelog
110* Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.5-2
111- add BuildRequires: libdb-cxx-devel
112- remove BuildRequires: db4-devel
113
114* Sun Feb 10 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.5.5-1
115- new upstream release
116- added Patch1 from gentoo to fix build error
117- deleted unnecessary files
118- fixed file conflict with virtaal-0.7.1
119
120* Sun Oct 14 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.5.4-1
121- new upstream release
122- added patch0 to suppress error in installing desktop file
123
124* Fri Aug 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.5.2-2
125- new upstream release
126- added BuildRequires: desktop-file-utils, libboost-devel
127- changed BuildRequires: wxGTK-devel >= 2.6.0 to 2.8.0
128- used %%{?_smp_mflags}
129- run gtk-update-icon-cache and update-desktop-database in %%post, %%postun
130
131* Sun Jul 01 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.4.6.1-2
132- changed BuildRequires: wx-gtk2-devel >= 2.6.0 to wxGTK-devel >= 2.6.0
133
134* Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.6.1-1
135- new upstream release
136
137* Wed Apr 01 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.4.2-1
138- new upstream release
139
140* Sun Aug 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.9-1
141- spec in UTF-8; new versioning policy
142
143* Tue Jan  1 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.3.9-0vl1
144- rebuild for VineSeed.
145  * Tue Jan  1 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.3.9-0vl0
146  - initial build for Vine Linux.
147
148* Tue Jan  1 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.3.9-0vl0
149- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.