source: projects/specs/trunk/p/pod-mode/pod-mode-vl.spec @ 750

Revision 750, 3.3 KB checked in by iwaim, 14 years ago (diff)

upload: pod-mode 0.5-2

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define emacsen_pkgdir /usr/lib/emacsen-common/packages
4%define origname pod-mode
5%define origver  0.5
6
7Summary:      A major mode for editing .pod-files in (X)Emacs
8Summary(ja):  (X)Emacs で POD ファイルを編集するためのメジャーモード
9Name:         %{origname}
10Version:      %{origver}
11Release:      2%{?_dist_release}
12
13Source0:      http://search.cpan.org/CPAN/authors/id/S/SC/SCHWIGON/pod-mode/pod-mode-%{version}.tgz
14Source1:      %{origname}-install.sh
15Source2:      %{origname}-remove.sh
16Source3:      vine-default-pod-mode.el
17Source4:      pod-mode-init.el
18
19License:      GPL
20Group:        Applications/Editors/Emacs
21URL:          http://search.cpan.org/author/SCHWIGON/pod-mode/
22BuildRoot:    %{_tmppath}/%{name}-%{version}-root
23BuildArch:    noarch
24
25Requires:     emacsen
26PreReq:       emacsen
27%prereq_ge    emacsen-common
28
29Distribution: Vine Linux
30Vendor:       Project Vine
31
32
33%description
34pod-mode.el - A major mode for editing .pod-files in (X)Emacs
35
36POD is the Plain Old Documentation format of Perl.
37This mode mainly defines a grammar for syntax highlighting.
38
39%description -l ja
40pod-mode.el - (X)Emacs で POD ファイルを編集するためのメジャー
41モード
42
43POD は Plain Old Documentation format of Perl という意味です。
44このモードは、構文ハイライトのための文法を定義している程度です。
45
46%prep
47
48%setup -q -n %{origname}-%{origver}
49
50%build
51
52%install
53[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
54[ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
55
56mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
57mkdir -p %{buildroot}%{emacsen_pkgdir}/install
58mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
59
60#
61# install el files
62#
63
64cp -p *.el %{SOURCE3} %{SOURCE4} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
65
66
67#
68# install script (bytecompile el and install elc , remove)
69#
70
71%_installemacsenscript %{origname} %{SOURCE1}
72
73%_removeemacsenscript  %{origname} %{SOURCE2}
74
75
76%clean
77[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
78
79%post
80#
81# bytecompile and install
82#
83if [ "$1" = 2 ]; then
84
85%_emacsenPackageRemove %{origname}
86
87fi
88
89%_addemacsenlist %{origname}
90
91%_emacsenPackageInstall %{origname}
92
93
94%preun
95if [ "$1" = 0 ]; then
96
97%_emacsenPackageRemove %{origname}
98
99%_removeemacsenlist %{origname}
100
101fi
102
103
104%files
105%defattr(-,root,root)
106%doc README ChangeLog
107%{_datadir}/emacs/site-lisp/%{origname}
108%{emacsen_pkgdir}/install/%{origname}
109%{emacsen_pkgdir}/remove/%{origname}
110
111
112%changelog
113* Tue Apr  6 2010 IWAI, Masaharu <iwai@alib.jp> 0.5-2
114- correct output message on js2-mode-install.sh (SOURCE1)
115
116* Mon Dec 21 2009 IWAI, Masaharu <iwai@alib.jp> 0.5-1
117- new upstream release
118- apply vine-default
119  - add vine-default-pod-mode.el (Source3)
120  - add pod-mode-init.el (Source4)
121  - update pod-mode-{install,remove}.sh
122
123* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 0.4-1vl5
124- applied new versioning policy, spec in utf-8
125- added macro %%emacsen_pkgdir
126
127* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4-0vl1
128- updated to 0.4
129- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
130- s/Copyright/License/
131
132* Fri Oct 22 2004 IWAI, Masaharu <iwai@alib.jp> 0.2-0vl2
133- add Japanese description
134
135* Sat May 24 2003 IWAI Masaharu <iwai@alib.jp> 0.2-0vl1
136- first release for Vine Linux
Note: See TracBrowser for help on using the repository browser.