source: projects/specs/trunk/p/po-mode/po-mode-vl.spec @ 521

Revision 521, 7.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define origname       po-mode
2
3Summary: Emacs Lisp for editing po file of gettext
4Summary(ja): gettextの po ファイルを編集するためのEmacs Lisp
5Name: po-mode
6Version: 0.17
7Release: 5%{?_dist_release}
8License: GPLv3 and LGPLv2+
9Group: Applications/Editors/Emacs
10Source: ftp://ftp.gnu.org/gnu/gettext/gettext-%{version}.tar.gz
11URL: http://www.gnu.org/software/gettext/
12Source1: po-mode-init.el
13Source3: %{origname}-install.sh
14Source4: %{origname}-remove.sh
15Source5: vine-default-%{origname}.el
16## <BTS:VineLinux:934>:
17# http://git.savannah.gnu.org/cgit/gettext.git/commit/?id=9a6599c4d3d3db699b269b53a9a458bf0728ce08
18Patch0: po-mode-fix934.patch
19Requires(post): emacsen, emacsen-common >= 0.1
20Buildroot: %{_tmppath}/%{name}-%{version}-root
21BuildArch: noarch
22
23Packager: iwaim
24Vendor: Project Vine
25Distribution: Vine Linux
26
27%description
28Emacs Lisp for editing po file of gettext
29
30%description -l ja
31gettext の po ファイルを編集するための Emacs Lisp です.
32
33%prep
34%setup -q -n gettext-%{version}
35%patch0 -p1
36
37%build
38
39%install
40[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
41[ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
42
43mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
44mkdir -p %{buildroot}%{emacsen_pkgdir}/install
45mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
46
47#
48# install el files
49#
50
51pushd gettext-tools/misc
52cp -p *.el %{SOURCE1} %{SOURCE5} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
53popd
54
55#
56# install script (bytecompile el and install elc , remove)
57#
58
59%_installemacsenscript %{origname} %{SOURCE3}
60
61%_removeemacsenscript  %{origname} %{SOURCE4}
62
63
64%clean
65[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
66
67
68%post
69if [ "$1" = 2 ]; then
70  %_emacsenPackageRemove %{origname}
71
72fi
73
74%_addemacsenlist %{origname}
75
76%_emacsenPackageInstall %{origname}
77
78
79%preun
80if [ "$1" = 0 ]; then
81  %_emacsenPackageRemove %{origname}
82
83  %_removeemacsenlist %{origname}
84
85fi
86
87
88%files
89%defattr(-,root,root,-)
90%doc AUTHORS COPYING THANKS NEWS
91%doc gettext-tools/misc/ChangeLog
92%{_datadir}/emacs/site-lisp/%{origname}
93%{emacsen_pkgdir}/install/%{origname}
94%{emacsen_pkgdir}/remove/%{origname}
95
96
97%changelog
98* Wed Feb 24 2010 IWAI, Masaharu <iwai@alib.jp> - 0.17-5
99- split from gettext package: [VineSeed:20076]
100- add Packager
101- replace Prereq to Requires(post)
102- add using forward-line patch (Patch1): <BTS:VineLinux:934>
103
104* Tue Dec 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> - 0.17-4
105- correct some output messages on po-mode-install.sh
106- use %%emacsen_pkgdir
107
108* Sun May 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.17-3
109- we better not to use BuildConflicts very often :-P
110  instead we pass --disable-java to configure here
111- add --enable-shared --disable-static --without-included-gettext to configure
112- remove .la files
113- add -devel and --libs subpackages
114
115* Wed May  6 2009 IWAI, Masaharu <iwai@alib.jp> 0.17-2
116- apply vine-default
117  - update po-mode-init.el (Source1)
118  - update po-mode-install.sh (Source3)
119  - update po-mode-remove.sh (Source4)
120  - add vine-default-po-mode.el (Source5): based 0.17-1's po-mode-init.el
121- update %%doc: gettext-runtime/libasprintf/autosprintf_all.html
122
123* Sat Aug 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-1
124- new upstream release
125
126* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-1vl5
127- applied new versioning policy, spec in utf-8
128
129* Wed Jan 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl2
130- changelog update missing
131
132* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl1
133- new upstream release
134
135* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl6
136- changed po-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
137
138* Mon Aug 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl5
139- add BuildConflicts: libgcj34-devel not to depend on libgcj34
140
141* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl4
142- add BuildConflicts: libgcj-devel not to depend on libgcj
143- add BuildRequires: emacsen (if emacsen_pkg is enabled)
144- remove unneeded files at the %%install
145
146* Mon Aug 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl3
147- rebuilt without libgcj package
148
149* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl2
150- modified emacsen-common path
151
152* Wed Jun 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl1
153- new upstream release
154- updated Source3
155- added --disable-csharp
156
157* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl2
158- remove dependency to libgcj
159
160* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl1
161- new upstream release
162
163* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 0.12.1-1vl2
164- build without libgcj package
165- create po-mode package for Emacsen
166
167* Sun Sep 21 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.1-1vl1
168- based on Redhat Rawhide 0.12.1-1
169- dropped all patches (Rawhide does so)
170- Source100(ja.po) is much older than source, dropped
171- s/Copyright/License/
172
173* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.5-0vl1
174- new upstream release
175
176* Mon Jun 10 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
177- sync with rawhide 0.11.2-2 and Mandrake 0.11.2-4mdk
178
179* Wed Jun  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
180- sync with RH6.2
181
182* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
183- minor configure tweaks for ia64
184
185* Sun Feb 27 2000 Cristian Gafton <gafton@redhat.com>
186- add --comments to msghack
187
188* Thu Feb 10 2000 Cristian Gafton <gafton@redhat.com>
189- fix bug #9240 - gettextize has the right aclocal patch
190
191* Wed Jan 12 2000 Cristian Gafton <gafton@redhat.com>
192- add the --diff and --dummy options
193
194* Wed Oct 06 1999 Cristian Gafton <gafton@redhat.com>
195- add the --missing option to msghack
196
197* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
198- updated msghack not to merge in fuzzies in the master catalogs
199
200* Sat Sep 18 1999 Norihito Ohmori <ohmori@flatout.org>
201- update ja.po
202
203* Tue Sep 14 1999 Jun Nishii <jun@flatout.org>
204- use message.c.diff-2
205
206* Thu Aug 26 1999 Cristian Gafton <gafton@redhat.com>
207- updated msghack to understand --append
208
209* Wed Aug 11 1999 Cristian Gafton <gafton@redhat.com>
210- updated msghack to correctly deal with sorting files
211
212* Tue Jun 29 1999 Norihito Ohmori <ohmori@flatout.org>
213- added multibyte patch for msgmerge
214
215* Sun Jun 27 1999 Norihito Ohmori <ohmori@flatout.org>
216- ja locale support from JaPO Project
217
218* Thu May 06 1999 Cristian Gafton <gafton@redhat.com>
219- msghack updates
220
221* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
222- auto rebuild in the new build environment (release 8)
223
224* Mon Mar 08 1999 Cristian Gafton <gafton@redhat.com>
225- added patch for misc hacks to facilitate rpm translations
226
227* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
228- patch to allow to build on ARM
229
230* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
231- add Emacs po-mode.el files.
232
233* Sun Sep 13 1998 Cristian Gafton <gafton@redhat.com>
234- include the aclocal support files
235
236* Fri Sep  3 1998 Bill Nottingham <notting@redhat.com>
237- remove devel package (functionality is in glibc)
238
239* Tue Sep  1 1998 Jeff Johnson <jbj@redhat.com>
240- update to 0.10.35.
241
242* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
243- add gettextize.
244- create devel package for libintl.a and libgettext.h.
245
246* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
247- translations modified for de, fr, tr
248
249* Sun Nov 02 1997 Cristian Gafton <gafton@redhat.com>
250- added info handling
251- added misc-patch (skip emacs-lisp modofications)
252
253* Sat Nov 01 1997 Erik Troan <ewt@redhat.com>
254- removed locale.aliases as we get it from glibc now
255- uses a buildroot
256
257* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
258- Built against glibc
Note: See TracBrowser for help on using the repository browser.