source: projects/specs/trunk/p/po-mode/po-mode-vl.spec @ 10948

Revision 10948, 7.6 KB checked in by iwaim, 7 years ago (diff)

po-mode 0.19.8.1-1

Line 
1%define origname       po-mode
2
3Summary: Emacs Lisp for editing po file of gettext
4Summary(ja): gettextの po ファイルを編集するための Emacs Lisp
5Name: po-mode
6Version: 0.19.8.1
7Release: 1%{?_dist_release}
8License: GPLv3 and LGPLv2+
9Group: Applications/Editors/Emacs
10URL: http://www.gnu.org/software/gettext/
11
12Source: ftp://ftp.gnu.org/gnu/gettext/gettext-%{version}.tar.xz
13Source1: po-mode-init.el
14Source3: %{origname}-install.sh
15Source4: %{origname}-remove.sh
16Source5: vine-default-%{origname}.el
17Requires(post): emacsen, emacsen-common >= 0.1
18Requires: emacsen
19Buildroot: %{_tmppath}/%{name}-%{version}-root
20BuildArch: noarch
21
22Packager: iwaim
23Vendor: Project Vine
24Distribution: Vine Linux
25
26%description
27Emacs Lisp for editing po file of gettext
28
29%description -l ja
30gettext の po ファイルを編集するための Emacs Lisp です.
31
32%prep
33%setup -q -n gettext-%{version}
34
35%build
36
37%install
38[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
39[ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
40
41mkdir -p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/packages
42mkdir -p %{buildroot}%{emacsen_pkgdir}/install
43mkdir -p %{buildroot}%{emacsen_pkgdir}/remove
44
45#
46# install el files
47#
48
49pushd gettext-tools/misc
50cp -p *.el %{SOURCE1} %{SOURCE5} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
51popd
52
53#
54# install script (bytecompile el and install elc , remove)
55#
56
57%_installemacsenscript %{origname} %{SOURCE3}
58
59%_removeemacsenscript  %{origname} %{SOURCE4}
60
61
62%clean
63[ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
64
65
66%post
67if [ "$1" = 2 ]; then
68  %_emacsenPackageRemove %{origname}
69
70fi
71
72%_addemacsenlist %{origname}
73
74%_emacsenPackageInstall %{origname}
75
76
77%preun
78if [ "$1" = 0 ]; then
79  %_emacsenPackageRemove %{origname}
80
81  %_removeemacsenlist %{origname}
82
83fi
84
85
86%files
87%defattr(-,root,root,-)
88%doc AUTHORS COPYING THANKS NEWS
89%doc gettext-tools/misc/ChangeLog
90%{_datadir}/emacs/site-lisp/%{origname}
91%{emacsen_pkgdir}/install/%{origname}
92%{emacsen_pkgdir}/remove/%{origname}
93
94
95%changelog
96* Fri Feb 10 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 0.19.8.1
97- update to 0.19.8.1
98
99* Fri Apr 17 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.19.4-1
100- new upstream release
101
102* Fri Apr 22 2011 IWAI, Masaharu <iwai@alib.jp> 0.18.1.1-1
103- new upstream release
104- drop using forward-line patch (Patch0): upstream fixed
105- add Requires: emacsen
106
107* Wed Feb 24 2010 IWAI, Masaharu <iwai@alib.jp> - 0.17-5
108- split from gettext package: [VineSeed:20076]
109- add Packager
110- replace Prereq to Requires(post)
111- add using forward-line patch (Patch0): <BTS:VineLinux:934>
112
113* Tue Dec 22 2009 Munehiro Yamamoto <munepi@vinelinux.org> - 0.17-4
114- correct some output messages on po-mode-install.sh
115- use %%emacsen_pkgdir
116
117* Sun May 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.17-3
118- we better not to use BuildConflicts very often :-P
119  instead we pass --disable-java to configure here
120- add --enable-shared --disable-static --without-included-gettext to configure
121- remove .la files
122- add -devel and --libs subpackages
123
124* Wed May  6 2009 IWAI, Masaharu <iwai@alib.jp> 0.17-2
125- apply vine-default
126  - update po-mode-init.el (Source1)
127  - update po-mode-install.sh (Source3)
128  - update po-mode-remove.sh (Source4)
129  - add vine-default-po-mode.el (Source5): based 0.17-1's po-mode-init.el
130- update %%doc: gettext-runtime/libasprintf/autosprintf_all.html
131
132* Sat Aug 23 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-1
133- new upstream release
134
135* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 0.16.1-1vl5
136- applied new versioning policy, spec in utf-8
137
138* Wed Jan 31 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl2
139- changelog update missing
140
141* Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.16.1-0vl1
142- new upstream release
143
144* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl6
145- changed po-mode Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
146
147* Mon Aug 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl5
148- add BuildConflicts: libgcj34-devel not to depend on libgcj34
149
150* Fri Aug 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.14.5-0vl4
151- add BuildConflicts: libgcj-devel not to depend on libgcj
152- add BuildRequires: emacsen (if emacsen_pkg is enabled)
153- remove unneeded files at the %%install
154
155* Mon Aug 07 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl3
156- rebuilt without libgcj package
157
158* Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 0.14.5-0vl2
159- modified emacsen-common path
160
161* Wed Jun 15 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.5-0vl1
162- new upstream release
163- updated Source3
164- added --disable-csharp
165
166* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl2
167- remove dependency to libgcj
168
169* Wed Apr  7 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.14.1-0vl1
170- new upstream release
171
172* Mon Sep 22 2003 IWAI, Masaharu <iwai@alib.jp> 0.12.1-1vl2
173- build without libgcj package
174- create po-mode package for Emacsen
175
176* Sun Sep 21 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.1-1vl1
177- based on Redhat Rawhide 0.12.1-1
178- dropped all patches (Rawhide does so)
179- Source100(ja.po) is much older than source, dropped
180- s/Copyright/License/
181
182* Sun Sep 29 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.5-0vl1
183- new upstream release
184
185* Mon Jun 10 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org>
186- sync with rawhide 0.11.2-2 and Mandrake 0.11.2-4mdk
187
188* Wed Jun  7 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
189- sync with RH6.2
190
191* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
192- minor configure tweaks for ia64
193
194* Sun Feb 27 2000 Cristian Gafton <gafton@redhat.com>
195- add --comments to msghack
196
197* Thu Feb 10 2000 Cristian Gafton <gafton@redhat.com>
198- fix bug #9240 - gettextize has the right aclocal patch
199
200* Wed Jan 12 2000 Cristian Gafton <gafton@redhat.com>
201- add the --diff and --dummy options
202
203* Wed Oct 06 1999 Cristian Gafton <gafton@redhat.com>
204- add the --missing option to msghack
205
206* Wed Sep 22 1999 Cristian Gafton <gafton@redhat.com>
207- updated msghack not to merge in fuzzies in the master catalogs
208
209* Sat Sep 18 1999 Norihito Ohmori <ohmori@flatout.org>
210- update ja.po
211
212* Tue Sep 14 1999 Jun Nishii <jun@flatout.org>
213- use message.c.diff-2
214
215* Thu Aug 26 1999 Cristian Gafton <gafton@redhat.com>
216- updated msghack to understand --append
217
218* Wed Aug 11 1999 Cristian Gafton <gafton@redhat.com>
219- updated msghack to correctly deal with sorting files
220
221* Tue Jun 29 1999 Norihito Ohmori <ohmori@flatout.org>
222- added multibyte patch for msgmerge
223
224* Sun Jun 27 1999 Norihito Ohmori <ohmori@flatout.org>
225- ja locale support from JaPO Project
226
227* Thu May 06 1999 Cristian Gafton <gafton@redhat.com>
228- msghack updates
229
230* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
231- auto rebuild in the new build environment (release 8)
232
233* Mon Mar 08 1999 Cristian Gafton <gafton@redhat.com>
234- added patch for misc hacks to facilitate rpm translations
235
236* Thu Dec 03 1998 Cristian Gafton <gafton@redhat.com>
237- patch to allow to build on ARM
238
239* Wed Sep 30 1998 Jeff Johnson <jbj@redhat.com>
240- add Emacs po-mode.el files.
241
242* Sun Sep 13 1998 Cristian Gafton <gafton@redhat.com>
243- include the aclocal support files
244
245* Fri Sep  3 1998 Bill Nottingham <notting@redhat.com>
246- remove devel package (functionality is in glibc)
247
248* Tue Sep  1 1998 Jeff Johnson <jbj@redhat.com>
249- update to 0.10.35.
250
251* Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
252- add gettextize.
253- create devel package for libintl.a and libgettext.h.
254
255* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
256- translations modified for de, fr, tr
257
258* Sun Nov 02 1997 Cristian Gafton <gafton@redhat.com>
259- added info handling
260- added misc-patch (skip emacs-lisp modofications)
261
262* Sat Nov 01 1997 Erik Troan <ewt@redhat.com>
263- removed locale.aliases as we get it from glibc now
264- uses a buildroot
265
266* Mon Jun 02 1997 Erik Troan <ewt@redhat.com>
267- Built against glibc
Note: See TracBrowser for help on using the repository browser.