source: projects/specs/trunk/p/pngcrush/pngcrush-vl.spec @ 10194

Revision 10194, 4.5 KB checked in by kudoh, 8 years ago (diff)

new upstream release

Line 
1Summary: Pngcrush is an optimizer for PNG files.
2Summary(ja): pngcrush - PNG ファイルの最適化ツール
3Name: pngcrush
4Version: 1.8.1
5Release: 1%{?_dist_release}
6URL: http://pmt.sourceforge.net/pngcrush/
7Source:  http://prdownloads.sourceforge.net/pmt/%{name}-%{version}.tar.xz
8#Source1: http://prdownloads.sourceforge.net/pmt/%{name}-%{version}-CHANGELOG.txt
9#Source2: http://prdownloads.sourceforge.net/pmt/%{name}-%{version}-HELP.txt
10License: distributable
11Group: Applications/Graphics
12Packager: Yasumichi Akahoshi <yasumichi@users.sourceforge.jp>
13Buildroot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: libpng-devel pkgconfig zlib-devel
15
16%description
17Pngcrush is an optimizer for PNG (Portable Network Graphics) files.
18Its main purpose is to reduce the size of the PNG IDAT datastream by trying
19various compression levels an PNG filter methods. It also can be used to
20remove unwanted ancillary chunks, or to add certain chunks including gAMA,
21tRNS, iCCP, and textual chunks.
22
23%description -l ja
24Pngcrush は、PNG (Portable Network Graphic) ファイルの最適化ツールです。
25その主な目的は、様々な圧縮レベルや、PNG フィルタ手法を試みて、PNG IDAT
26データストリームのサイズを縮小することです。
27また、見られていない補助的なチャンクを削除したり、ガンマ、tRNS、iCCP、
28テキストなど、ある種のチャンクを追加することが可能です。
29
30%prep
31%setup -q -n %{name}-%{version}
32
33#cp -p %{SOURCE1} CHANGELOG
34#cp -p %{SOURCE2} HELP
35
36%build
37#make CFLAGS="$RPM_OPT_FLAGS"
38#%ifnarch %{ix86}
39#make -f Makefile.ext-zlib ZINC=%{_includedir} ZLIB=%{_libdir} \
40#       CFLAGS=" -I. -O3 -fomit-frame-pointer -Wall"
41#%else
42#make -f Makefile.ext-zlib ZINC=%{_includedir} ZLIB=%{_libdir}
43#%endif
44rm -f z*.h crc32.h deflate.h inf*.h trees.h png*.h # force using system headers
45pngflags=$(pkg-config --cflags --libs libpng)
46gcc %{optflags} $pngflags -lz -o pngcrush pngcrush.c
47
48%install
49[ "%{buildroot}" != "/" ] && %__rm -rf %{buildroot}
50
51#mkdir -p $RPM_BUILD_ROOT%{_bindir}
52#install -m755 pngcrush-zlib $RPM_BUILD_ROOT%{_bindir}/pngcrush
53%{__install} -D -m0755 pngcrush %{buildroot}%{_bindir}/pngcrush
54
55%clean
56[ "%{buildroot}" != "/" ] && %__rm -rf %{buildroot}
57
58%files
59%defattr(-,root,root)
60#%doc CHANGELOG HELP
61%doc ChangeLog.html
62%{_bindir}/pngcrush
63
64%changelog
65* Sun Apr 24 2016 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.8.1-1
66- new upstream release
67
68* Tue Jul 01 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.76-1
69- new upstream release
70
71* Wed Jul 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.33-1
72- new upstream release
73
74* Mon Jul 09 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.31-1
75- new upstream release
76
77* Sun Jun 17 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.30-1
78- new upstream release
79
80* Mon May 28 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.28-1
81- new upstream release
82
83* Wed Apr 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.27-1
84- new upstream release
85
86* Tue Mar 06 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.25-1
87- new upstream release
88
89* Fri Jan 20 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.24-1
90- new upstream release
91- changed source archive type bzip2 to xz
92
93* Sat Dec 18 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.13-1
94- new upstream release
95- added BuildRequires: libpng-devel pkgconfig
96- updated spec
97
98* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.6.4-1vl5
99- applied new versioning policy, spec in utf-8
100
101* Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.6.4-0vl2
102- define PNG_USE_PNGGCCRD only on ix86 archs
103
104* Fri Sep 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-0vl1
105- new upstream release
106- changed Group to Applications/Graphics
107
108* Fri Dec 31 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.5.10-0vl6
109- rebuild with libpng-1.2.8
110
111* Sun Oct 17 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.5.10-0vl5
112- rebuild with libpng-1.2.7
113
114* Mon Aug 30 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.5.10-0vl4
115- rebuild with libpng-1.2.6rc3
116  - add handle-chunk-macros.patch (HANDLE_CHUNK_* -> PNG_HANDLE_CHUNK_*)
117
118* Mon Aug 30 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.5.10-0vl3
119- use system's shared libraries (patch0)
120  - add (Build)Requires: libpng(-devel), zlib(-devel)
121- modify description (ja)
122
123* Mon Jul 12 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.5.10-0vl2
124- add URL
125- remove Requires: libpng >= 1.2.4
126- use distributable as License
127- use more macros
128- extract source quietly
129
130* Thu Jun 03 2004 Yasumichi Akahoshi <yasumichi@users.sourceforge.jp>
131- pngcrush.spec was written for pngcrush-1.5.10.
Note: See TracBrowser for help on using the repository browser.