source: projects/specs/trunk/p/pm-utils/pm-utils-vl.spec @ 521

Revision 521, 17.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Power management utilities and scripts
2Summary(ja): 電源管理ユーティリティおよびスクリプト
3Name: pm-utils
4License: GPLv2
5Version: 1.2.6.1
6Release: 1%{?_dist_release}
7Group: System Environment/Base
8URL: http://pm-utils.freedesktop.org
9
10Source0: http://pm-utils.freedesktop.org/releases/pm-utils-%{version}.tar.gz
11
12Source21: pm-utils-99hd-apm-restore
13Source22: pm-utils-hd-apm-restore.conf
14Source23: pm-utils-bugreport-info.sh
15
16Source100: 00tuxonice
17Source101: tuxonice.sysconfig
18
19BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
20BuildRequires: xmlto
21# for chvt
22Requires: kbd
23#Requires: radeontool
24# for hd apm settings
25Requires: hdparm
26# for on_ac_power
27Requires: hal
28%ifarch %{ix86} x86_64
29Requires: vbetool
30%endif
31Conflicts: apmd < 3.2.2
32
33
34%description
35The pm-utils package contains utilities and scripts useful for tasks related
36to power management.
37
38%package devel
39Summary: Files for development using %{name}
40Summary(ja): Files for development using %{name}
41Group: Development/Libraries
42Requires: %{name} = %{version}-%{release}
43# for /usr/share/pkgconfig
44Requires:       pkgconfig
45
46%description devel
47This package contains the pkg-config files for development
48when building programs that use %{name}.
49
50
51%prep
52%setup -q
53
54
55%build
56%configure
57make
58
59
60%install
61rm -rf %{buildroot}
62
63make install DESTDIR=%{buildroot}
64
65install -D -m 0600 /dev/null %{buildroot}%{_localstatedir}/log/pm-suspend.log
66mkdir -p %{buildroot}%{_localstatedir}/run/pm-utils/{locks,storage}
67
68install -D -m 0755 %{SOURCE21} %{buildroot}%{_libdir}/pm-utils/sleep.d/99hd-apm-restore.hook
69install -D -m 0644 %{SOURCE22} %{buildroot}%{_sysconfdir}/pm-utils-hd-apm-restore.conf
70
71install -D -m 0755 %{SOURCE23} %{buildroot}%{_bindir}/pm-utils-bugreport-info.sh
72
73install -D -m 0755 %{SOURCE100} %{buildroot}%{_libdir}/pm-utils/sleep.d/00tuxonice
74install -D -m 0644 %{SOURCE101} %{buildroot}%{_sysconfdir}/sysconfig/tuxonice
75
76# VINE: documents handled directly with %%doc directive in the %%files section
77rm -rf %{buildroot}%{_datadir}/doc/pm-utils
78
79
80%clean
81rm -rf %{buildroot}
82
83
84%files
85%defattr(-,root,root,-)
86%doc AUTHORS COPYING ChangeLog NEWS README* TODO pm/HOWTO*
87%config(noreplace) %{_sysconfdir}/pm-utils-hd-apm-restore.conf
88%config(noreplace) %{_sysconfdir}/sysconfig/tuxonice
89%{_sysconfdir}/pm/
90%dir %{_libdir}/pm-utils/
91%{_libdir}/pm-utils/bin/
92%{_libdir}/pm-utils/defaults
93%{_libdir}/pm-utils/functions
94%{_libdir}/pm-utils/pm-functions
95%{_libdir}/pm-utils/power.d/
96%{_libdir}/pm-utils/sleep.d/
97%{_libdir}/pm-utils/module.d
98%{_bindir}/on_ac_power
99%{_bindir}/pm-is-supported
100%{_bindir}/pm-utils-bugreport-info.sh
101%{_sbindir}/pm-hibernate
102%{_sbindir}/pm-powersave
103%{_sbindir}/pm-suspend
104%{_sbindir}/pm-suspend-hybrid
105%{_mandir}/man1/*.1.gz
106%{_mandir}/man8/*.8.gz
107%{_localstatedir}/run/pm-utils/
108#%dir %{_datadir}/doc/pm-utils
109#%doc %{_datadir}/doc/pm-utils/*
110
111# no logrotate needed, because only one run of pm-utils is stored
112# in the logfile
113%ghost %verify(not md5 size mtime) %{_localstatedir}/log/pm-suspend.log
114
115
116%files devel
117%defattr(-,root,root,-)
118%{_libdir}/pkgconfig/pm-utils.pc
119
120
121%changelog
122* Sun Jan 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.6.1-1
123- new upstream release
124
125* Sat May  9 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.5-2
126- don't own /usr/share/doc/pm-utils: use %%doc directive to handle documents
127- use %%{buildroot} instead of $RPM_BUILD_ROOT
128
129* Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
130- new upstream release
131
132* Sat Apr 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-5
133- add 00tuxonice to setup image_size_limit and enable_escape
134- add /etc/sysconfig/tuxonice
135
136* Fri Apr 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-4
137- remove 00tuxonice
138
139* Thu Mar 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
140- new upstream release
141
142* Wed Oct 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2.1-3
143- add 00tuxonice to set tuxonice-userui on hibernate
144
145* Mon Oct 13 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2.1-2
146- add Requires: vbetool
147
148* Sun Oct 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2.1-1
149- initial build for Vine Linux
150
151* Thu Sep 11 2008 Richard Hughes <rhughes@redhat.com> - 1.2.0-1
152- Update to 1.2.0
153- The core hook-running machinery will now abort running hooks of one fails,
154  and the front-end scripts will return a failure error code if hook-running
155  was aborted.
156
157* Mon Jun 22 2008 Richard Hughes <rhughes@redhat.com> - 1.1.2.3-1
158- Update to 1.1.2.3
159
160* Fri Jun 20 2008 Till Maas <opensource@till.name> - 1.1.2.2-2
161- %%pre and %%post scriptlets should not be needed anymore, old
162  config files should be already moved in every supported release
163  and the selinux context for the logfile should be restored by
164  rpm
165- remove pcitulils BR, it was needed for vbetool, which is in a
166  separate package now
167- substitute %%{__rm} macros for uniform macro usage
168
169* Mon May 29 2008 Richard Hughes <rhughes@redhat.com> - 1.1.2.2-1
170- Update to 1.1.2.2
171
172* Mon May 28 2008 Richard Hughes <rhughes@redhat.com> - 1.1.2.1-2
173- Change BR from docbook-utils to xmlto
174
175* Mon May 28 2008 Richard Hughes <rhughes@redhat.com> - 1.1.2.1-1
176- Update to 1.1.2.1
177
178* Mon May 12 2008 Richard Hughes <rhughes@redhat.com> - 1.1.1-2
179- Add missing BR for docbook-utils
180
181* Mon May 12 2008 Richard Hughes <rhughes@redhat.com> - 1.1.1-1
182- Update to 1.1.1, and drop patches that no longer apply.
183
184* Wed Apr 30 2008 Richard Hughes <rhughes@redhat.com> - 1.1.0-9
185- Remove the usermode dep on the advice of Till Maas.
186
187* Wed Apr 30 2008 Richard Hughes <rhughes@redhat.com> - 1.1.0-8
188- Rip out all the consolehelper and PAM stuff - users are not meant to be
189  running these tools directly and it's a massive change from upstream.
190
191* Fri Apr 18 2008 Peter Jones <pjones@redhat.com> - 1.1.0-7
192- Default to "shutdown" for hibernate unless it's unavailable.
193
194* Tue Apr 15 2008 Jesse Keating <jkeating@redhat.com> - 1.1.0-6
195- Don't error on post restorecon call (which can fail if selinux is disabled)
196
197* Mon Apr 14 2008 Till Maas <opensource till name> - 1.1.0-5
198- remove double %%dir %%{_libdir}/pm-utils
199- update pm-utils-99hd-apm-restore to work with current pm-utils release
200  Red Hat Bugzilla: #442294
201- move config file for hd apm restore away from config.d, which is only used
202  for pm-utils internal config anymore
203- own /var/run/pm-utils/ and create storage/locks subdirs (may be
204  needed for selinux)
205- make sure an empty logfile is created after install (touch -a ...)
206- sort %%files
207- make Source0: an URL
208- remove Conflicts: bluez utils, all supported Fedora releases ship
209  already a newer version
210- remove unused BR: hal-devel, dbus-devel, pkgconfig, docbook-utils
211
212* Mon Apr  8 2008 Richard Hughes <rhughes@redhat.com> - 1.1.0-4
213- Fix build on 64 bit machines - harder.
214
215* Mon Apr  8 2008 Richard Hughes <rhughes@redhat.com> - 1.1.0-3
216- Fix build on 64 bit machines.
217
218* Mon Apr  8 2008 Richard Hughes <rhughes@redhat.com> - 1.1.0-2
219- Actually do the build.
220
221* Mon Apr  7 2008 Matthias Clasen <mclasen@redhat.com> - 1.1.0-1
222- Update to 1.1.0
223- Add devel subpackage for the pc file
224
225* Thu Apr 03 2008 Adam Jackson <ajax@redhat.com> 0.99.4-16
226- x86_64 is not a macro, don't %%ifarch on it.
227
228* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.99.4-15
229- Autorebuild for GCC 4.3
230
231* Fri Jan 11 2008 Till Maas <opensource till name> - 0.99.4-14
232- add pm-utils-bugreport-info.sh script to collect information for bugreports
233- require Hal (RH #428452)
234
235* Wed Jan 09 2008 Till Maas <opensource till name> - 0.99.4-13
236- update README to describe the current beheaviour of pm-utils
237
238* Tue Jan 08 2008 Till Maas <opensource till name> - 0.99.4-12
239- remove ExclusiveArch, because it contains all supported archs
240  (in case an arch schould be excluded, please use ExcludeArch)
241- improve readability of usermode setup
242- remove pm-restart pm-shutdown from usermode setup, because
243  there are no such binaries
244- list more files in %%files explicit to make it obvious when
245  there are changes in the distributed package
246- add .conf suffix to oldconfig files
247
248* Tue Jan 08 2008 Till Maas <opensource till name> - 0.99.4-11
249- make it possible to specify the hibernate mode (RH #375701)
250
251* Wed Jan 02 2008 Till Maas <opensource till name> - 0.99.4-10
252- enhance hd-apm-restore and add a config file
253- fix source-definition for hd-apm-restore
254- add hook suffix for hook script
255
256* Wed Jan 02 2008 Till Maas <opensource till name> - 0.99.4-9
257- restore hd apm level (RH #382061)
258- Add hdparm requires for new hook
259
260* Mon Dec 31 2007 Till Maas <opensource till name> - 0.99.4-8
261- Add documentation to %%doc
262
263* Sun Dec 30 2007 Till Maas <opensource till name> - 0.99.4-7
264- fix some bugs (RH #302401)
265
266* Tue Nov 27 2007 Dennis Gilmore <dennis@ausil.us> - 0.99.4-6
267- add sparc archs to ExclusiveArch list
268
269* Wed Oct 10 2007 Till Maas <opensource till name> - 0.99.4-5
270- Require vbetool only for x86 archs (RH #325741)
271- add missing BR for docbook-utils
272
273* Thu Sep 20 2007 Till Maas <opensource till name> - 0.99.4-4
274- fix manpage cut and paste mistake (RH #286201)
275
276* Thu Sep 20 2007 Till Maas <opensource till name> - 0.99.4-3
277- remove unused patch (vidhooks)
278- add patch to keep logfile (RH #237840 (f7), #238068 (devel)),
279  to keep selinux context
280- simplify spec
281- restore selinux context of logfile in %%post
282- use rpmmacros more often
283
284* Tue Sep 11 2007 Till Maas <opensource till name> - 0.99.4-2
285- Require vbetool not on ppc and ppc64
286
287* Mon Sep 10 2007 Peter Jones <pjones@redhat.com> - 0.99.4-1
288- Merge new upstream
289- remove pm/power.d/laptop-tools
290- add --quirk-reset-brightness (needed for the Fujitsu Lifebook S7110)
291
292* Sat Sep 08 2007 Till Maas <opensource till name> - 0.99.3-12
293- Adjust %%files to own /etc/pm/ and /usr/lib/pm-utils/ (#233906)
294- remove (C|CXX|F)FLAGS definitions, they are already in %%configure
295- remove Core in Summary tag
296- add URL for pm-utils
297- add %%{?arm} to ExclusiveArch (#245463)
298- remove vbetool and require it (it is a separate package now)
299- remove radeontool and require it (it is a separate package now)
300- Update License Tag
301- cleanup buildrequires
302- clear %%setup
303
304* Mon Aug 27 2007 Adam Jackson <ajax@redhat.com> 0.99.3-11
305- Install (not just build) vbetool and radeontool on x86_64 too
306- Explicitly list files under %%_sbindir, so they don't drop away again
307- Light spec cleanups
308
309* Thu Aug 16 2007 Phil Knirsch <pknirsch@redhat.com> - 0.99.3-10
310- License verification and update
311
312* Wed Jul 18 2007 Phil Knirsch <pknirsch@redhat.com> - 0.99.3-9
313- Fixed description to be distribution independant (#247366)
314
315* Thu Jun 07 2007 Peter Jones <pjones@redhat.com> - 0.99.3-8
316- Bump release and rebuild for newer buildsystem code
317
318* Tue Jun 05 2007 Phil Knirsch <pknirsch@redhat.com> - 0.99.3-7
319- Bump release and rebuild
320
321* Tue May 29 2007 Phil Knirsch <pknirsch@redhat.com> - 0.99.3-6
322- Fixed missing builds for vbetool and radeontool for some archs (#241469)
323- Fixed typo in functions where wrong variable was used (#241633)
324
325* Wed May 16 2007 Peter Jones <pjones@redhat.com> - 0.99.3-5
326- ... and create the directory the logfile goes in.
327
328* Wed May 16 2007 Peter Jones <pjones@redhat.com> - 0.99.3-4
329- Bump release to appease Koji.
330
331* Wed May 16 2007 Peter Jones <pjones@redhat.com> - 0.99.3-3
332- Create logfile in %%post and %%gost it.
333
334* Wed Apr 25 2007 Peter Jones <pjones@redhat.com> - 0.99.3-2
335- Get rid of bogus redirect on "vbetool post"
336- add zlib linkage for vbetool and radeontool
337
338* Mon Mar 26 2007 Peter Jones <pjones@redhat.com> - 0.99.3-1
339- update to 0.99.3
340- configure manually in the spec to avoid %%_lib as lib64
341
342* Tue Mar 13 2007 Peter Jones <pjones@redhat.com> - 0.99.2-1
343- update to 0.99.2
344
345* Fri Feb  2 2007 Peter Jones <pjones@redhat.com> - 0.99.1-1
346- Fix setsysfont hook to actually hit tty0, not the pty of the current task.
347
348* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 0.19.1-6
349- build so that hooks run properly on resume; fix syntax error in
350  functions-intel (pjones)
351
352* Fri Jan 26 2007 Phil Knirsch <pknirsch@redhat.com> - 0.19.1-5
353- Fixed problem with changes in 10NetworkManager hook (#224556)
354
355* Wed Jan 24 2007 Phil Knirsch <pknirsch@redhat.com> - 0.19.1-4
356- Start/stop correct services in 10NetworkManager hook (#215253)
357- Fixed check for /sys/power/disk and /sys/power/state (#214407)
358- Added proper error messages in case /sys/power/disk or /sys/power/state are
359  missing (#215386)
360- Removed service calls and module load/unload for bluetooth hook (#213387)
361- Added hook file to restore the sysfont after resume (#215391)
362- Added the possibility to disable hibernate and suspend completely via the
363  config file (#216459)
364- Symlinked the config file to /etc/sysconfig/power-management (#216459)
365- Fixed pm-powersave permission check bug (#222819)
366- Small specfile cleanups
367
368* Sun Oct  1 2006 Peter Jones <pjones@redhat.com> - 0.19.1-3
369- Disable bluetooth suspend/reusme hook by default; the kernel modules seem
370  to support this correctly these days.
371
372* Thu Sep 28 2006 Peter Jones <pjones@redhat.com> - 0.19.1-2
373- Ignore emacs backup files in config directories (#185979)
374
375* Tue Aug  8 2006 Peter Jones <pjones@redhat.com> - 0.19.1-1
376- Hopefully fix Centrino ThinkPad suspend+resume
377- Hopefully fix Intel Mac Mini/MacBook suspend+resume
378
379* Mon Jul 31 2006 Jeremy Katz <katzj@redhat.com> - 0.19-3
380- doing the vbestate save/restore on intel video with the modesetting
381  intel xorg driver is broken.  so don't do it.
382
383* Tue Jul 18 2006 John (J5) Palmieri <johnp@redhat.com> - 0.19-2
384- requier a newer version of D-Bus and rebuild
385
386* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 0.19-1.1
387- rebuild
388
389* Tue Jun 13 2006 Peter Jones <pjones@redhat.com> - 0.19-1
390- update from CVS
391- move pam and consolehelper stuff here.
392- move video hooks here since HAL isn't ready
393
394* Tue Apr 25 2006 Peter Jones <pjones@redhat.com> - 0.18-1
395- Make it work cross-distro
396
397* Mon Apr 17 2006 Peter Jones <pjones@redhat.com> - 0.17-1
398- add more helper functions
399- rework things that were forking an extra subshell
400- fix the suspend lock
401- work around bluetooth/usb suspend wackiness
402
403* Fri Mar 17 2006 Peter Jones <pjones@redhat.com> - 0.16-1
404- rework the difference between hibernate and suspend; get rid of PM_MODE
405- add 00clear script
406- move default_resume_kernel from "functions" to 01grub's hibernate section
407
408* Sat Mar 11 2006 Peter Jones <pjones@redhat.com> - 0.15-1
409- fix hibernate check in a way that doesn't break "sleep".
410
411* Fri Mar 10 2006 Peter Jones <pjones@redhat.com> - 0.14-1
412- fix hibernate check in /etc/pm/hooks/20video
413
414* Fri Mar 03 2006 Phil Knirsch <pknirsch@redhat.com> - 0.13-1
415- Revert last changes for ATI graphics chips as they seem to cause more
416  problems than they solved.
417
418* Wed Mar 01 2006 Phil Knirsch <pknirsch@redhat.com> - 0.12-1
419- Use vbetool post instead of vbetool dpms on for ATI cards.
420
421* Tue Feb 28 2006 Jeremy Katz <katzj@redhat.com>
422- allow building on all x86 arches (#183175)
423
424* Tue Feb 28 2006 Jeremy Katz <katzj@redhat.com> - 0.11-1
425- fix display on resume with nvidia graphics
426- add infrastructure to tell what pm-util is running; don't resume
427  video on return from hibernate as the BIOS has already re-initialized it
428
429* Fri Feb 24 2006 Phil Knirsch <pknirsch@redhat.com> - 0.10-1
430- Added missing pciutils-devel BuildRequires (#182566)
431- Fixed missing vbestata save/restore calls for video suspend/resume (#182167,
432  #169494)
433- Renamed hook scripts to allow local pre and post inserts (#179421)
434- Added support for blinking led lights on Thinkpad Laptops during suspend
435  (#179420)
436- Added pm-powersave script for powersaving via HAL (#169054)
437- Added symlinks for pm-shutdown and pm-restart (#165953)
438
439* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 0.09-1.2
440- bump again for double-long bug on ppc(64)
441
442* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 0.09-1.1
443- rebuilt for new gcc4.1 snapshot and glibc changes
444
445* Tue Jan 24 2006 Jeremy Katz <katzj@redhat.com> - 0.09-1
446- Remove button module on suspend
447- Set default kernel in grub to current one when hibernating
448  so that resume works
449
450* Thu Dec 22 2005 Peter Jones <pjones@redhat.com> - 0.08-1
451- Fix scripts for new pciutils
452
453* Fri Dec  9 2005 Dave Jones <davej@redhat.com>
454- Update to latest vbetool (0.5-1)
455  Now also built on x86-64 too.
456
457* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
458- rebuilt
459
460* Thu Dec 01 2005 John (J5) Palmieri <johnp@redhat.com> - 0.07-3
461- rebuild for the new dbus
462
463* Wed Nov 30 2005 Peter Jones <pjones@redhat.com> - 0.07-2
464- restart ntpd in the background
465- switch terminals early so we don't wake the screen back up
466
467* Fri Nov 18 2005 Bill Nottingham <notting@redhat.com> - 0.06-3
468- nix that, wait for the kernel to settle down
469
470* Wed Nov 16 2005 Bill Nottingham <notting@redhat.com> - 0.06-2
471- fix LRMI usage in vbetool
472
473* Thu Nov 10 2005 Peter Jones <pjones@redhat.com> - 0.06-1
474- kill acpi_video_cmd calls in functions-ati
475- fix lcd_on in functions-ati
476
477* Fri Sep 30 2005 Bill Nottingham <notting@redhat.com> - 0.05-1
478- check for presence of various tools/files before using them (#169560, #196562)
479
480* Fri Aug 12 2005 Jeremy Katz <katzj@redhat.com> - 0.04-1
481- add pm-hibernate
482
483* Tue Jul 05 2005 Bill Nottingham <notting@redhat.com> - 0.03-1
484- fix path to video functions in video hook
485
486* Mon Jul 04 2005 Bill Nottingham <notting@redhat.com> - 0.02-1
487- add a pm-suspend (#155613)
488
489* Wed Apr 13 2005 Bill Nottingham <notting@redhat.com> - 0.01-1
490- initial version - package up vbetool, radeontool, new on_ac_power
Note: See TracBrowser for help on using the repository browser.