source: projects/specs/trunk/p/pluma/pluma-vl.spec @ 11670

Revision 11670, 5.8 KB checked in by iwaim, 6 years ago (diff)

pluma 1.20.1-1

Line 
1%define major_ver 1.20
2%define ver %{major_ver}.1
3%define rel 1
4
5Summary:        An powerfull text editor for MATE
6Name:           pluma
7Version:        %{ver}
8Release:        %{rel}%{?_dist_release}
9Source0:        http://pub.mate-desktop.org/releases/%{major_ver}/%{name}-%{version}.tar.xz
10License:        GPLv2
11Group:          Applications/Editors
12URL:            http://mate-desktop.org/
13
14BuildRequires:  mate-common
15BuildRequires:  gtk3-devel
16BuildRequires:  gtksourceview3-devel
17BuildRequires:  mate-desktop-devel
18BuildRequires:  libpeas-devel
19BuildRequires:  caja-devel
20BuildRequires:  libsoup-devel
21BuildRequires:  enchant-devel
22BuildRequires:  libSM-devel
23BuildRequires:  iso-codes
24BuildRequires:  itstool
25BuildRequires:  gtk-doc
26BuildRequires:  autoconf
27BuildRequires:  automake
28
29Requires(posttrans,postun):     glib2
30Requires(post,postun):  desktop-file-utils
31
32Obsoletes:      mate-text-editor < 1.8.0
33Provides:       mate-text-editor = %{version}-%{release}
34
35BuildRoot:      %{_tmppath}/%{name}-%{version}-root
36
37Vendor:         Project Vine
38Distribution:   Vine Linux
39Packager:       Takemikaduchi, iwaim
40
41
42%description
43Pluma is part of MATE and uses the latest GTK+ and MATE libraries.
44Complete MATE integration is featured, with support for Drag and Drop (DnD)
45from Caja (the MATE file manager), the use of the MATE help system,
46the MATE Virtual File System and the MATE print framework.
47
48
49%package                devel
50Summary:        Development tools for %{name}
51Summary(ja):    %{name} の開発環境
52Group:          Development/Libraries
53Requires:       %{name} = %{version}-%{release}
54Requires:       pkgconfig
55Obsoletes:              mate-text-editor < 1.8.0
56Provides:               mate-text-editor = %{version}-%{release}
57
58%description    devel
59Header files and libraries for building a extension library for the
60%{name}.
61
62
63%package        docs
64Summary:        Documentation for %{name}
65Summary(ja):    %{name} 用のドキュメント
66Group:          Documentation
67Requires:       %{name} = %{version}-%{release}
68BuildArch:      noarch
69Obsoletes:              mate-file-manager-doc < 1.8.0
70Provides:               mate-file-manager-doc = %{version}-%{release}
71
72%description    docs
73This package contains documentation for %{name}.
74
75
76%prep
77%setup -q
78
79
80%build
81(if ! test -x configure; then NOCONFIGURE=1 ./autogen.sh; fi)
82%configure \
83        --libexecdir=%{_libexecdir}/mate \
84        --disable-static
85
86%{__make} %{?_smp_mflags}
87
88
89%install
90%{__rm} -rf ${RPM_BUILD_ROOT}
91
92%{__make} install DESTDIR=${RPM_BUILD_ROOT}
93
94find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
95find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
96
97%find_lang %{name}
98
99
100%clean
101%{__rm} -rf ${RPM_BUILD_ROOT}
102
103%post
104/sbin/ldconfig
105update-desktop-database %{_datadir}/applications >& /dev/null ||:
106
107%postun
108/sbin/ldconfig
109if [ $1 -eq 0 ]; then
110  update-desktop-database %{_datadir}/applications >& /dev/null ||:
111  glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
112fi
113
114%posttrans
115glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
116
117
118%files -f %{name}.lang
119%defattr(-,root,root,-)
120%doc COPYING ChangeLog NEWS README
121%{_bindir}/%{name}
122#%{_libdir}/%{name}/plugin-loaders/libcloader.so
123%{_libdir}/girepository-1.0/Pluma-1.0.typelib
124%{_libdir}/%{name}/plugins
125%{_libexecdir}/mate/%{name}/pluma-bugreport.sh
126%{_datadir}/appdata/%{name}.appdata.xml
127%{_datadir}/applications/%{name}.desktop
128%{_datadir}/glib-2.0/schemas/org.mate.pluma.gschema.xml
129%{_datadir}/glib-2.0/schemas/org.mate.pluma.plugins.spell.gschema.xml
130%{_datadir}/glib-2.0/schemas/org.mate.pluma.plugins.filebrowser.gschema.xml
131%{_datadir}/glib-2.0/schemas/org.mate.pluma.plugins.time.gschema.xml
132%{_datadir}/help/*
133%{_datadir}/%{name}
134%{_mandir}/man1/%{name}.1.gz
135
136%files devel
137%defattr(-,root,root,-)
138%{_includedir}/%{name}
139%{_libdir}/pkgconfig/%{name}.pc
140%{_datadir}/gir-1.0/Pluma-1.0.gir
141
142%files docs
143%defattr(-,root,root,-)
144%{_datadir}/gtk-doc/html/%{name}
145
146
147%changelog
148* Sun May 20 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.20.1-1
149- update to 1.20.1
150
151* Thu Jan 18 2018 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.3-1
152- update to 1.18.3
153
154* Wed May 10 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.2-1
155- update to 1.18.2
156
157* Sat Apr  8 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.18.1-1
158- update to 1.18.1
159- move to GTK3+
160- add BR: libpeas-devel and caja-devel
161- add Pluma gir/typelib file
162- drop plugin-loaders
163
164* Sun Apr  2 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.16.1-1
165- update to 1.16.1
166
167* Sun Nov 27 2016 IWAI, Masaharu <iwaim.sub@gmail.com> 1.16.0-1
168- new upstream release
169- update Packager
170
171* Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.0-1
172- new upstream release
173
174* Sat Feb 20 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-1
175- new upstream release
176
177* Tue Dec 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.1-1
178- new upstream release
179
180* Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
181- new upstream release
182
183* Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
184- new upstream release
185
186* Sat Jul 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.1-1
187- new upstream release
188
189* Sat May 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
190- new upstream release
191- add BuildRequires: mate-desktop-devel
192
193* Sun May 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.1-1
194- new upstream release
195
196* Wed Apr 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.0-1
197- new upstream release
198- rename package
199- add BuildRequires: itstool
200
201* Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-2
202- rebuild with VineSeed environment
203
204* Sun May 19 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.0-1
205- new upstream release
206
207* Thu Aug 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.0-1
208- new upstream release
209- remove Patch0 (mate-text-editor-1.2.0-configure.patch)
210
211* Sat May 12 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.0-1
212- new upstream release
213- add Patch0 (mate-text-editor-1.2.0-configure.patch)
214
215* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-2
216- change category
217
218* Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.0-1
219- initial build for Vine Linux
220
Note: See TracBrowser for help on using the repository browser.