source: projects/specs/trunk/p/pixman/pixman-vl.spec @ 521

Revision 521, 4.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2
3Name:           pixman
4Version:        0.17.4
5Release:        1%{?_dist_release}
6Summary:        Pixel manipulation library
7Summary(ja):    ピクセル操作ライブラリ
8
9Group:          System Environment/Libraries
10License:        MIT
11URL:            http://xorg.freedesktop.org/archive/individual/lib/
12Source0:        pixman-%{version}.tar.bz2
13
14# revert changes
15# http://cgit.freedesktop.org/pixman/commit/?id=7aeed3fc08b3359a3e4e6178f569dbb28ffdad08
16# This breaks notification area icon.
17#Patch1:                pixman-0.15.14-revert-fast-path-call.patch
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21Obsoletes:      libpixman <= 0.1.6
22
23%description
24Pixman is a pixel manipulation library for X and cairo.
25
26%package devel
27Summary: Pixel manipulation library development package
28Group: Development/Libraries
29Requires: %{name} = %{version}-%{release}
30Requires: pkgconfig
31Obsoletes: libpixman-devel <= 0.1.6
32
33%description devel
34Development library for pixman.
35
36# compat32
37%package -n compat32-%{name}
38Summary:        Pixel manipulation library
39Summary(ja):    ピクセル操作ライブラリ
40Group:          System Environment/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description -n compat32-%{name}
44Pixman is a pixel manipulation library for X and cairo.
45
46%package -n compat32-%{name}-devel
47Summary: Pixel manipulation library development package
48Group: Development/Libraries
49Requires: compat32-%{name} = %{version}-%{release}
50Requires: %{name}-devel = %{version}-%{release}
51
52%description -n compat32-%{name}-devel
53Development library for pixman.
54
55%prep
56%setup -q
57#%patch1 -p1
58
59%build
60%configure --disable-static
61make %{?_smp_mflags}
62
63%install
64rm -rf $RPM_BUILD_ROOT
65make install DESTDIR=$RPM_BUILD_ROOT
66rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
67
68%clean
69rm -rf $RPM_BUILD_ROOT
70
71%post -p /sbin/ldconfig
72%postun -p /sbin/ldconfig
73
74%post -n compat32-%{name} -p /sbin/ldconfig
75%postun -n compat32-%{name} -p /sbin/ldconfig
76
77%files
78%defattr(-,root,root,-)
79%{_libdir}/libpixman-1*.so.*
80
81%files devel
82%defattr(-,root,root,-)
83%dir %{_includedir}/pixman-1
84%{_includedir}/pixman-1/pixman.h
85%{_includedir}/pixman-1/pixman-version.h
86%{_libdir}/libpixman-1*.so
87%{_libdir}/pkgconfig/pixman-1.pc
88
89# compat32
90%if %{build_compat32}
91%files -n compat32-%{name}
92%defattr(-,root,root,-)
93%{_libdir}/libpixman-1*.so.*
94
95%files -n compat32-%{name}-devel
96%defattr(-,root,root,-)
97%{_libdir}/libpixman-1*.so
98%{_libdir}/pkgconfig/pixman-1.pc
99%endif
100
101%changelog
102* Wed Feb 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17.4-1
103- new upstream release
104
105* Wed Nov 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.16.2-1
106- new upstream release
107
108* Thu Jul 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.18-1
109- new upstream release
110
111* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.14-2
112- add Patch1 to fix notification icon
113
114* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.14-1
115- new upstream release
116
117* Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.15.4-2
118- added compat32 subpackage for x86_64 arch support again.
119
120* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.4-1
121- new upstream release
122
123* Sat May 02 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.15.2-2
124- added compat32 subpackage for x86_64 arch support.
125
126* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-1
127- new upstream release
128
129* Fri Mar 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.14.0-1
130- new upstream release
131
132* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.12.0-1
133- new upstream release
134
135* Sun Sep 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.10-1
136- new upstream release
137
138* Mon Aug 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.11.8-1
139- new upstream release
140
141* Fri Jul 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.11.6-1
142- new upstream release
143
144* Thu May  1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.10.0-1vl5
145- Initial build for Vine Linux
146
147* Thu Apr  3 2008 Soren Sandmann <sandmann@redhat.com> 0.10.0-1
148- Update to 0.10.0
149
150* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.9.6-4
151- Autorebuild for GCC 4.3
152
153* Wed Oct 31 2007 Behdad Esfahbod <besfahbo@redhat.com> 0.9.6-3
154- Third time's the charm.
155
156* Wed Oct 31 2007 Behdad Esfahbod <besfahbo@redhat.com> 0.9.6-2
157- Second try.
158
159* Wed Oct 31 2007 Behdad Esfahbod <besfahbo@redhat.com> 0.9.6-1
160- Update to 0.9.6 release.
161
162* Wed Sep 05 2007 Adam Jackson <ajax@redhat.com> 0.9.5-1
163- Update to 0.9.5 release.
164
165* Mon Aug 27 2007 Adam Jackson <ajax@redhat.com> 0.9.0-7.20070827
166- New snapshot
167
168* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> 0.9.0-4.20070824
169- New snapshot
170
171* Wed Jul 25 2007 Jeremy Katz <katzj@redhat.com> - 0.9.0-3.20070724
172- rebuild for toolchain bug
173
174* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 0.9.0-2.20070724
175- Re-add it, %%dir is not the same as adding a dir whole.
176
177* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 0.9.0-1.20070724
178- Remove redundant header from %%files devel.
179
180* Fri May 18 2007 Adam Jackson <ajax@redhat.com> 0.9.0-0.20070724
181- git build so I can build git X.
Note: See TracBrowser for help on using the repository browser.