source: projects/specs/trunk/p/pitivi/pitivi-vl.spec @ 6583

Revision 6583, 8.3 KB checked in by kudoh, 12 years ago (diff)
Line 
1%global major 0.15
2%global minor 2
3
4Name:           pitivi
5Version:        %{major}.%{minor}
6Release:        1%{?_dist_release}
7Summary:        Non-linear video editor
8Summary(ja):    ノンリニアビデオ編集ソフトウェア
9Group:          Applications/Multimedia
10License:        LGPLv2+
11URL:            http://www.pitivi.org/
12Source0:        http://ftp.gnome.org/pub/GNOME/sources/pitivi/%{major}/pitivi-%{version}.tar.xz
13BuildRequires: intltool
14BuildRequires: python
15BuildRequires: desktop-file-utils
16BuildRequires: gnome-doc-utils
17
18Requires:       gnonlin
19Requires:       gstreamer-plugins-good
20Requires:       gstreamer-python
21Requires:       pygtk2
22Requires:       pygoocanvas
23Requires:       python-zope-interface
24Requires:       python-setuptools
25Requires:       hicolor-icon-theme
26BuildArch:      noarch
27
28Vendor:         Project Vine
29Distribution:   Vine Linux
30Packager:       kazutaka
31
32%description
33Pitivi is an application using the GStreamer multimedia framework to
34manipulate a large set of multimedia sources.
35
36At this level of development it can be compared to a classic video editing
37program.
38
39%description -l ja
40Pitivi は GStreamer マルチメディアフレームワークを利用した、
41多くの種類のメディアファイルを操作できるアプリケーションです。
42
43まだ開発中ですが、現状でもビデオ編集に必要となる基本的な機能は
44備えています。
45
46
47%prep
48%setup -q
49
50for f in `find . -name \*.py`
51do
52        sed -e '/^#!/,1d' < $f > $f.tmp && mv $f.tmp $f
53done
54
55%build
56%configure --libdir=%{_datadir}
57
58%{__make} %{?_smp_mflags}
59
60%install
61%{__make} DESTDIR=%{buildroot} install
62desktop-file-install --delete-original \
63        --dir %{buildroot}%{_datadir}/applications \
64        --add-category AudioVideoEditing \
65        data/pitivi.desktop
66
67%find_lang %{name}
68
69%clean
70%{__rm} -rf %{buildroot}
71
72%post
73touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
74gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
75
76update-desktop-database &> /dev/null || :
77update-mime-database %{_datadir}/mime &> /dev/null || :
78
79%postun
80if [ $1 -eq 0 ] ; then
81    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
82    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
83fi
84
85update-desktop-database &> /dev/null || :
86update-mime-database %{_datadir}/mime &> /dev/null || :
87
88
89%files -f %{name}.lang
90%defattr(-,root,root,-)
91%doc AUTHORS ChangeLog COPYING NEWS
92%{_bindir}/%{name}
93%{_datadir}/%{name}
94%{_datadir}/applications/%{name}.desktop
95%{_datadir}/gnome/help/%{name}/*/
96%{_datadir}/icons/hicolor/*/apps/%{name}.*
97%{_datadir}/mime/packages/%{name}.xml
98%{_mandir}/man1/%{name}.1.gz
99
100%changelog
101* Tue Jul 17 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.15.2-1
102- new upstream release
103- changed source archive type bz2 to xz
104- added BuildRequires: gnome-doc-utils
105- run gtk-update-icon-cache in %%post, %%postun
106
107* Wed Apr 27 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.13.5-1
108- initial build for Vine Linux based on fedora development
109
110* Wed Sep 22 2010 Chen Lei <supercyper@163.com> - 0.13.5-1
111- Update to 0.13.5
112
113* Wed Aug 11 2010 David Malcolm <dmalcolm@redhat.com> - 0.13.4-3
114- recompiling .py files against Python 2.7 (rhbz#623347)
115
116* Mon Mar 15 2010 Benjamin Otte <otte@redhat.com> - 0.13.4-2
117- Make sure Pitivi has an icon in the menu.
118
119* Wed Mar 10 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.4-1.1
120- Upload new tarball :)
121
122* Wed Mar 10 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.4-1
123- Update to 0.13.4
124
125* Tue Mar  9 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.3.2-0.1
126- Update to 0.13.3.2
127
128* Fri Dec 11 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.3-3.3.837f0d73
129- Make sure we have the correct source uploaded.
130
131* Thu Dec 10 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.3-3.2.837f0d73
132- Update to git master to see if this fixes anyone's problems
133- Call update-desktop-database/update-mime-database in post/postun
134
135* Thu Dec  3 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.3-3
136- Add Req on python-setuptools for BZ#540192
137
138* Wed Sep 23 2009 Orcan Ogetbil <oget[DOT]fedora[AT]gmail[DOT]com> - 0.13.3-2
139- Update desktop file according to F-12 FedoraStudio feature
140
141* Mon Sep 14 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.3-1
142- 0.13.3 Release : ... we shall never (sur)render
143-
144- The PiTiVi team is proud to announce the second release in the
145- unstable 0.13 PiTiVi series.
146-
147- Due to its dependency on GStreamer, The PiTiVi team strongly
148- recommends users have all official latest gstreamer libraries and
149- plugins installed for the best user experience.
150-
151- Title is from a quote by Winston Churchill “We shall defend our
152- island, whatever the cost may be, we shall fight on the beaches, we
153- shall fight on the landing grounds, we shall fight in the fields and
154- in the streets, we shall fight in the hills; we shall never
155- surrender.”
156-
157- Features of this release
158-
159-    * Fix rendering failures
160-    * UI beautifications
161-    * Switch to themeable ruler
162-    * Speed optimisations
163-    * Show the project name in the window title
164
165* Sat Aug 29 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.2.2-0.1
166- Update to prerelease for 0.13.3
167- Streamline BuildRequires
168
169* Fri Aug 14 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.2-2
170- Bump required version of gstreamer-python
171
172* Thu Aug 13 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.2-1
173- Update to 0.13.2 "Jailbreak (out of Deadlock City)"
174-
175- The PiTiVi team is proud to announce the second release in the
176- unstable 0.13 PiTiVi series.
177-
178- Due to its dependency on GStreamer, The PiTiVi team strongly
179- recommends users have all official latest gstreamer libraries and
180- plugins installed for the best user experience.
181-
182- Features of this release
183-
184-    * Undo/Redo support
185-    * Audio mixing
186-    * Ripple/Roll edit
187-    * misc fixes everywhere
188
189* Wed Aug 12 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.1.3-1
190- Update to latest prerelease.
191
192* Mon Jul 27 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.1.2-1
193- Update to prerelease
194
195* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13.1-2.1
196- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
197
198* Thu May 28 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.1-1
199- 0.13.1 Release "L'Aquila Immota Manet : The eagle remains unmoved"
200- ------------------------------------------------------------------
201-
202- The PiTiVi team is proud to announce the first release in the unstable 0.13
203- PiTiVi series.
204-
205- This release is in memory of those who have lost their lives, friends,
206- houses in the April 6th 2009 earthquake in l'Aquila, Italy.
207-
208- Due to its dependency on GStreamer, The PiTiVi team strongly
209- recommends users have all official latest gstreamer libraries and
210- plugins installed for the best user experience.
211-
212-
213- * Features of this release
214-
215-  * core rewrite
216-  * multi-layered timeline
217-  * trimming features
218-  * audio waveforms and video thumbnails in timeline
219-  * picture support
220-  * New project file format support
221
222* Thu May 21 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.13.0.2-1
223- Upgrade to 0.13.1 prerelease
224
225* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11.3-3
226- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
227
228* Sat Jan 17 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.3-2
229- Add patch from Denis Leroy to fix running with Python 2.6
230
231* Mon Dec 15 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.3-1
232- Update to 0.11.3
233
234* Thu Dec  4 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.2.2-2
235- Upload the sources
236
237* Thu Dec  4 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.2.2-1
238- Update to 0.11.2.2
239
240* Sat Nov 29 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.2-2
241- Rebuild for Python 2.6
242
243* Wed Oct 15 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.2-1
244- Update to 0.11.2
245
246* Mon Oct 13 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.1.4-1
247- Update to 0.11.1.4
248
249* Mon Jan 14 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.1-2
250- Add requirement for python-setuptools. (BZ#426855)
251
252* Sat Dec  8 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.1-1
253- Update to 0.11.1
254
255* Sun Nov 11 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.0-2
256- Add missing BR
257
258* Wed Oct 16 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.11.0-1
259- Update to 0.11.0
260
261* Wed Jun 27 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.3-2
262- Add versioned requires for gnonlin. (BZ#245981)
263
264* Fri Jun 22 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.3-1
265- Update to 0.10.3
266
267* Mon May 28 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.2.2-3
268- BR gettext
269
270* Mon May 28 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 0.10.2.2-2
271- BR perl(XML::Parser)
Note: See TracBrowser for help on using the repository browser.