source: projects/specs/trunk/p/pipewire/pipewire-vl.spec @ 12435

Revision 12435, 8.6 KB checked in by tomop, 4 years ago (diff)

updated 5 packages

flatpak-1.8.1-1

libportal-0.3-5

pipewire-0.2.7-1

xdg-desktop-portal-gtk-1.6.0-1

xdg-desktop-portal-1.6.0-1

Line 
1%bcond_with systemd
2%bcond_with rtkit
3%bcond_with man
4
5%global apiversion   0.2
6%global spaversion   0.1
7
8#global snap       20141103
9#global gitrel     327
10#global gitcommit  aec811798cd883a454b9b5cd82c77831906bbd2d
11#global shortcommit %(c=%{gitcommit}; echo ${c:0:5})
12
13# https://bugzilla.redhat.com/983606
14%global _hardened_build 1
15
16# where/how to apply multilib hacks
17%global multilib_archs x86_64 %{ix86} ppc64 ppc s390x s390 sparc64 sparcv9 ppc64le
18
19Name:           pipewire
20Summary:        Media Sharing Server
21Version:        0.2.7
22Release:        1%{?snap:.%{snap}git%{shortcommit}}%{?_dist_release}%{?with_systemd:.systemd}
23Vendor:         Project Vine
24Distribution:   Vine Linux
25
26License:        LGPLv2+
27URL:            https://pipewire.org/
28%if 0%{?gitrel}
29# git clone git://anongit.freedesktop.org/gstreamer/pipewire
30# cd pipewire; git reset --hard %{gitcommit}; ./autogen.sh; make; make distcheck
31Source0:        pipewire-%{version}-%{gitrel}-g%{shortcommit}.tar.gz
32%else
33Source0:        https://github.com/PipeWire/pipewire/archive/%{version}.tar.gz
34%endif
35
36## upstream patches
37Patch1:         0001-build-and-link-a2dp-codecs.c-as-well.patch
38Patch2:         0001-bluez5-declare-factory-as-extern.patch
39
40## upstreamable patches
41
42BuildRequires:  meson >= 0.35.0
43BuildRequires:  gcc
44BuildRequires:  pkgconfig
45BuildRequires:  pkgconfig(dbus-1)
46BuildRequires:  pkgconfig(glib-2.0) >= 2.32
47BuildRequires:  pkgconfig(gio-unix-2.0) >= 2.32
48BuildRequires:  pkgconfig(gstreamer-1.0) >= 1.10.0
49BuildRequires:  pkgconfig(gstreamer-base-1.0) >= 1.10.0
50BuildRequires:  pkgconfig(gstreamer-plugins-base-1.0) >= 1.10.0
51BuildRequires:  pkgconfig(gstreamer-net-1.0) >= 1.10.0
52BuildRequires:  pkgconfig(gstreamer-allocators-1.0) >= 1.10.0
53%if %{with systemd}
54BuildRequires:  systemd-devel >= 184
55%else
56BuildRequires:  pkgconfig(libudev)
57%endif
58BuildRequires:  alsa-lib-devel
59BuildRequires:  libv4l-devel
60BuildRequires:  doxygen
61%if %{with man}
62BuildRequires:  xmltoman
63%endif
64BuildRequires:  graphviz
65BuildRequires:  sbc-devel
66
67Requires(pre):  shadow-utils
68Requires:       %{name}-libs%{?_isa} = %{version}-%{release}
69%if %{with systemd}
70Requires:       systemd >= 184
71%endif
72%if %{with rtkit}
73Requires:       rtkit
74%endif
75
76# https://bugzilla.redhat.com/983606
77%global _hardened_build 1
78
79%if %{with systemd}
80## enable systemd activation
81%global systemd 1
82%endif
83
84%description
85PipeWire is a multimedia server for Linux and other Unix like operating
86systems.
87
88
89%package libs
90Summary:        Libraries for PipeWire clients
91License:        LGPLv2+
92Recommends:     %{name}%{?_isa} = %{version}-%{release}
93
94%description libs
95This package contains the runtime libraries for any application that wishes
96to interface with a PipeWire media server.
97
98
99%package devel
100Summary:        Headers and libraries for PipeWire client development
101License:        LGPLv2+
102Requires:       %{name}-libs%{?_isa} = %{version}-%{release}
103
104%description devel
105Headers and libraries for developing applications that can communicate with
106a PipeWire media server.
107
108
109%package doc
110Summary:        PipeWire media server documentation
111License:        LGPLv2+
112
113%description doc
114This package contains documentation for the PipeWire media server.
115
116
117%package utils
118Summary:        PipeWire media server utilities
119License:        LGPLv2+
120Requires:       %{name}%{?_isa} = %{version}-%{release}
121Requires:       %{name}-libs%{?_isa} = %{version}-%{release}
122
123%description utils
124This package contains command line utilities for the PipeWire media server.
125
126
127%prep
128%setup -q -T -b0 -n %{name}-%{version}%{?gitrel:-%{gitrel}-g%{shortcommit}}
129
130%patch1 -p1 -b .0001
131%patch2 -p1 -b .0002
132
133
134%build
135%meson \
136        -D docs=true \
137        -D man=true \
138        -D gstreamer=enabled \
139%if %{with systemd}
140        -D systemd=true
141%else
142        -D systemd=false
143%endif
144%meson_build
145
146
147%install
148%meson_install
149
150
151%check
152%meson_test
153
154
155%pre
156getent group pipewire >/dev/null || groupadd -r pipewire
157getent passwd pipewire >/dev/null || \
158    useradd -r -g pipewire -d %{_localstatedir}/run/pipewire -s /sbin/nologin -c "PipeWire System Daemon" pipewire
159exit 0
160
161%if %{with systemd}
162%post
163%systemd_user_post pipewire.service
164%systemd_user_post pipewire.socket
165%endif
166
167%post libs -p /sbin/ldconfig
168%postun libs -p /sbin/ldconfig
169
170
171%files
172%license LICENSE GPL LGPL
173%doc README
174%if 0%{?systemd}
175%{_userunitdir}/pipewire.*
176%endif
177%{_bindir}/pipewire
178%dir %{_sysconfdir}/pipewire/
179%{_sysconfdir}/pipewire/pipewire.conf
180%if %{with man}
181%{_mandir}/man1/pipewire.1*
182%{_mandir}/man5/pipewire.conf.5*
183%endif
184
185%files libs
186%license LICENSE GPL LGPL
187%doc README
188%{_libdir}/libpipewire-%{apiversion}.so.*
189%{_libdir}/pipewire-%{apiversion}/
190%{_libdir}/spa/
191%{_libdir}/gstreamer-1.0/libgstpipewire.*
192
193%files devel
194%{_libdir}/libpipewire-%{apiversion}.so
195%{_includedir}/pipewire/
196%{_includedir}/spa/
197%{_libdir}/pkgconfig/libpipewire-%{apiversion}.pc
198%{_libdir}/pkgconfig/libspa-%{spaversion}.pc
199
200%files doc
201%{_datadir}/doc/pipewire/html
202
203%files utils
204%{_bindir}/pipewire-monitor
205%{_bindir}/pipewire-cli
206%if %{with man}
207%{_mandir}/man1/pipewire-monitor.1*
208%{_mandir}/man1/pipewire-cli.1*
209%endif
210%{_bindir}/spa-monitor
211%{_bindir}/spa-inspect
212
213
214%changelog
215* Wed Jul 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.2.7-1
216- new upstream release.
217
218* Mon Sep 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.2.6-6
219- initial build for Vine Linux.
220
221* Mon Sep 16 2019 Kalev Lember <klember@redhat.com> - 0.2.6-5
222- Don't require the daemon package for -devel subpackage
223- Move pipewire.conf man page to the daemon package
224
225* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.6-4
226- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
227
228* Wed Jun 19 2019 Wim Taymans <wtaymans@redhat.com> - 0.2.6-3
229- Add patch to reuse fd in pipewiresrc
230- Add patch for device provider
231- Add patch to disable extra security checks until portal is fixed.
232
233* Tue Jun 04 2019 Kalev Lember <klember@redhat.com> - 0.2.6-2
234- Split libpipewire and the gstreamer plugin out to -libs subpackage
235
236* Wed May 22 2019 Wim Taymans <wtaymans@redhat.com> - 0.2.6-1
237- Update to 0.2.6
238- Add patch for alsa-lib 1.1.9 include path
239
240* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.2.5-3
241- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
242
243* Fri Jan 04 2019 Wim Taymans <wtaymans@redhat.com> - 0.2.5-2
244- Add patch to avoid invalid conversion error with C++ compilers
245
246* Thu Nov 22 2018 Wim Taymans <wtaymans@redhat.com> - 0.2.5-1
247- Update to 0.2.5
248
249* Thu Nov 22 2018 Wim Taymans <wtaymans@redhat.com> - 0.2.4-1
250- Update to 0.2.4
251
252* Thu Oct 18 2018 Wim Taymans <wtaymans@redhat.com> - 0.2.3-2
253- Add systemd socket activation
254
255* Thu Aug 30 2018 Wim Taymans <wtaymans@redhat.com> - 0.2.3-1
256- Update to 0.2.3
257
258* Tue Jul 31 2018 Wim Taymans <wtaymans@redhat.com> - 0.2.2-1
259- Update to 0.2.2
260
261* Fri Jul 20 2018 Wim Taymans <wtaymans@redhat.com> - 0.2.1-1
262- Update to 0.2.1
263
264* Tue Jul 17 2018 Wim Taymans <wtaymans@redhat.com> - 0.2.0-1
265- Update to 0.2.0
266
267* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.9-2
268- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
269
270* Tue Feb 27 2018 Wim Taymans <wtaymans@redhat.com> - 0.1.9-1
271- Update to 0.1.9
272
273* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.8-3
274- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
275
276* Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.1.8-2
277- Switch to %%ldconfig_scriptlets
278
279* Tue Jan 23 2018 Wim Taymans <wtaymans@redhat.com> - 0.1.8-1
280- Update to 0.1.8
281
282* Fri Nov 24 2017 Wim Taymans <wtaymans@redhat.com> - 0.1.7-1
283- Update to 0.1.7
284- Add to build when memfd_create is already defined
285
286* Fri Nov 03 2017 Wim Taymans <wtaymans@redhat.com> - 0.1.6-1
287- Update to 0.1.6
288
289* Tue Sep 19 2017 Wim Taymans <wtaymans@redhat.com> - 0.1.5-2
290- Add patch to avoid segfault when probing
291
292* Tue Sep 19 2017 Wim Taymans <wtaymans@redhat.com> - 0.1.5-1
293- Update to 0.1.5
294
295* Thu Sep 14 2017 Kalev Lember <klember@redhat.com> - 0.1.4-3
296- Rebuilt for GNOME 3.26.0 megaupdate
297
298* Fri Sep 08 2017 Wim Taymans <wtaymans@redhat.com> - 0.1.4-2
299- Install SPA hooks
300
301* Wed Aug 23 2017 Wim Taymans <wtaymans@redhat.com> - 0.1.4-1
302- Update to 0.1.4
303
304* Wed Aug 09 2017 Wim Taymans <wtaymans@redhat.com> - 0.1.3-1
305- Update to 0.1.3
306
307* Tue Jul 04 2017 Wim Taymans <wtaymans@redhat.com> - 0.1.2-1
308- Update to 0.1.2
309- Added more build requirements
310- Make separate doc package
311
312* Mon Jun 26 2017 Wim Taymans <wtaymans@redhat.com> - 0.1.1-1
313- Update to 0.1.1
314- Add dbus-1 to BuildRequires
315- change libs-devel to -devel
316
317* Wed Sep 9 2015 Wim Taymans <wtaymans@redhat.com> - 0.1.0-2
318- Fix BuildRequires to use pkgconfig, add all dependencies found in configure.ac
319- Add user and groups  if needed
320- Add license to %%licence
321
322* Tue Sep 1 2015 Wim Taymans <wtaymans@redhat.com> - 0.1.0-1
323- First version
Note: See TracBrowser for help on using the repository browser.