source: projects/specs/trunk/p/pinentry/pinentry-vl.spec @ 12523

Revision 12523, 13.1 KB checked in by tomop, 3 years ago (diff)

updated 2 packages

jasper-2.0.24-1

pinentry-1.1.1-1

Line 
1
2Name:    pinentry
3Version: 1.1.1
4Release: 1%{?_dist_release}
5Summary: Collection of simple PIN or passphrase entry dialogs
6Group: accessories
7Vendor: Project Vine
8Distribution: Vine Linux
9
10# qt & qt4 subpackage have different license, see subpackage definitions
11License: GPLv2+
12URL:     http://www.gnupg.org/aegypten/
13Source0: https://gnupg.org/ftp/gcrypt/pinentry/pinentry-%{version}.tar.bz2
14Source1: https://gnupg.org/ftp/gcrypt/pinentry/pinentry-%{version}.tar.bz2.sig
15
16# borrowed from opensuse
17Source10: pinentry-wrapper
18
19BuildRequires: gcr-devel
20BuildRequires: gtk2-devel
21BuildRequires: libcap-devel
22BuildRequires: ncurses-devel
23BuildRequires: libgpg-error-devel
24BuildRequires: libassuan-devel
25BuildRequires: libsecret-devel
26BuildRequires: pkgconfig(Qt5Core) pkgconfig(Qt5Gui) pkgconfig(Qt5Widgets)
27
28Requires(pre): %{_sbindir}/update-alternatives
29Requires(post): /sbin/install-info
30Requires(preun): /sbin/install-info
31
32Provides: %{name}-curses = %{version}-%{release}
33
34%description
35Pinentry is a collection of simple PIN or passphrase entry dialogs which
36utilize the Assuan protocol as described by the aegypten project; see
37http://www.gnupg.org/aegypten/ for details.
38This package contains the curses (text) based version of the PIN entry dialog.
39
40
41%package gnome3
42Summary: Passphrase/PIN entry dialog for GNOME 3
43Group: accessories
44Requires: %{name} = %{version}-%{release}
45Provides: %{name}-gui = %{version}-%{release}
46
47%description gnome3
48Pinentry is a collection of simple PIN or passphrase entry dialogs which
49utilize the Assuan protocol as described by the aegypten project; see
50http://www.gnupg.org/aegypten/ for details.
51This package contains the GNOME 3 version of the PIN entry dialog.
52
53
54%package gtk
55Summary: Passphrase/PIN entry dialog based on GTK+
56Group: accessories
57Requires: %{name} = %{version}-%{release}
58Provides: %{name}-gui = %{version}-%{release}
59Provides: pinentry-gtk2 = %{version}-%{release}
60
61%description gtk
62Pinentry is a collection of simple PIN or passphrase entry dialogs which
63utilize the Assuan protocol as described by the aegypten project; see
64http://www.gnupg.org/aegypten/ for details.
65This package contains the GTK GUI based version of the PIN entry dialog.
66
67
68%package qt
69Summary: Passphrase/PIN entry dialog based on Qt5
70Group: accessories
71Requires: %{name} = %{version}-%{release}
72Provides: %{name}-gui = %{version}-%{release}
73Obsoletes: pinentry-qt4 < 0.8.0-2
74Provides:  pinentry-qt5 = %{version}-%{release}
75
76%description qt
77Pinentry is a collection of simple PIN or passphrase entry dialogs which
78utilize the Assuan protocol as described by the aegypten project; see
79http://www.gnupg.org/aegypten/ for details.
80This package contains the Qt5 GUI based version of the PIN entry dialog.
81
82
83%package emacs
84Summary: Passphrase/PIN entry dialog based on emacs
85Group: accessories
86Requires: %{name} = %{version}-%{release}
87
88%description emacs
89Pinentry is a collection of simple PIN or passphrase entry dialogs which
90utilize the Assuan protocol as described by the aegypten project; see
91http://www.gnupg.org/aegypten/ for details.
92This package contains the emacs based version of the PIN entry dialog.
93
94
95%debug_package
96
97
98%prep
99%setup -q
100
101
102%build
103%if 0%{?fedora} > 22
104# FTBFS on f23/gcc5 without this
105CXXFLAGS="%{optflags} -std=c++11"
106%endif
107
108%configure \
109  --disable-rpath \
110  --disable-dependency-tracking \
111  --without-libcap \
112  --enable-pinentry-gnome3 \
113  --enable-pinentry-gtk2 \
114  --enable-pinentry-qt5 \
115  --enable-pinentry-emacs \
116  --enable-libsecret
117
118make %{?_smp_mflags}
119
120
121%install
122make install DESTDIR=$RPM_BUILD_ROOT
123
124# Symlink for Backward compatibility
125ln -s pinentry-gtk-2 $RPM_BUILD_ROOT%{_bindir}/pinentry-gtk
126ln -s pinentry-qt $RPM_BUILD_ROOT%{_bindir}/pinentry-qt4
127
128install -p -m755 -D %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/pinentry
129
130# unpackaged files
131rm -fv $RPM_BUILD_ROOT%{_infodir}/dir
132
133
134%post
135if [ -f %{_infodir}/pinentry.info* ]; then
136/sbin/install-info %{_infodir}/pinentry.info %{_infodir}/dir ||:
137fi
138
139%preun
140if [ $1 -eq 0 -a -f %{_infodir}/pinentry.info* ] ; then
141  /sbin/install-info --delete %{_infodir}/pinentry.info %{_infodir}/dir ||:
142fi
143
144
145%files
146%{!?_licensedir:%global license %%doc}
147%license COPYING
148%doc AUTHORS ChangeLog NEWS README THANKS TODO
149%{_bindir}/pinentry-curses
150%{_bindir}/pinentry
151%{_infodir}/pinentry.info*
152
153%files gnome3
154%{_bindir}/pinentry-gnome3
155
156%files gtk
157%{_bindir}/pinentry-gtk
158%{_bindir}/pinentry-gtk-2
159
160%files qt
161%{_bindir}/pinentry-qt
162# symlink for backward compatibility
163%{_bindir}/pinentry-qt4
164
165%files emacs
166%{_bindir}/pinentry-emacs
167
168
169%changelog
170* Thu Feb 04 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.1-1
171- new upstream release.
172
173* Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.0-2
174- updated Source10.
175
176* Thu Mar 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.0-1
177- new upstream release.
178
179* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> - 0.9.7-4
180- rebuild with gcc-5.4.0
181
182* Sun May 22 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.9.7-3
183- initial build for Vine Linux.
184
185* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.7-2
186- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
187
188* Mon Dec 07 2015 Boris Ranto <branto@redhat.com> - 0.9.7-1
189- Rebase to latest upstream version
190
191* Tue Oct 27 2015 Stef Walter <stefw@redhat.com> - 0.9.6-4
192- Enable libsecret, which enables password caching in pinentry-gnome3
193- Resolves rhbz#1275567
194
195* Thu Oct 15 2015 Kalev Lember <klember@redhat.com> - 0.9.6-3
196- Add pinentry-gnome3 support to pinentry wrapper
197
198* Mon Sep 21 2015 Kalev Lember <klember@redhat.com> - 0.9.6-2
199- Build pinentry-gnome3
200
201* Fri Sep 11 2015 Boris Ranto <branto@redhat.com> - 0.9.6-1
202- Rebase to latest upstream version
203- Modify backwards compatible symlink for qt(4)
204- Enable pinentry-emacs since it was enabled by default in 0.9.5
205
206* Thu Jul 02 2015 Boris Ranto <branto@redhat.com> - 0.9.5-1
207- Rebase to latest upstream version
208- Removing qt4 pinentry patch -- got merged upstream
209- New package pinentry-emacs that hosts pinentry-emacs
210- New dependencies on libassuan and libgpg-error (de-bundling)
211
212* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.2-2
213- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
214
215* Thu May 14 2015 Boris Ranto <branto@redhat.com> - 0.9.2-1
216- Rebase to latest upstream version
217
218* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 0.9.1-2
219- Rebuilt for GCC 5 C++11 ABI change
220
221* Wed Mar 25 2015 Boris Ranto <branto@redhat.com> - 0.9.1-1
222- Rebase to latest upstream version
223- There are no longer any moc files so there is no need to patch them
224
225* Fri Mar 13 2015 Rex Dieter <rdieter@fedoraproject.org> - 0.9.0-3
226- fix FTBFS on f23/gcc5
227- drop deprecated configure flags
228
229* Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.9.0-2
230- Rebuilt for Fedora 23 Change
231  https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
232
233* Wed Nov 12 2014 Boris Ranto <branto@redhat.com> - 0.9.0-1
234- Rebase to latest upstream version
235
236* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-7
237- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
238
239* Tue Aug 12 2014 Boris Ranto <branto@redhat.com> - 0.8.3-6
240- fix bogus dates
241- upgrade pinentry-wrapper to handle corner cases better
242
243* Wed Jul 30 2014 Tom Callaway <spot@fedoraproject.org> - 0.8.3-5
244- fix license handling
245
246* Sat Jul 19 2014 Rex Dieter <rdieter@fedoraproject.org> 0.8.3-4
247- /usr/bin/pinentry should not check if stderr is opened (#787775)
248
249* Sat Jul 19 2014 Rex Dieter <rdieter@fedoraproject.org> - 0.8.3-3
250- .spec cleanup (drop support for old releases)
251- -gtk: Provides: pinentry-gtk2
252
253* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-2
254- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
255
256* Thu Jan 30 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.3-1
257- Update to latest upstream version (0.8.3)
258
259* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-11
260- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
261
262* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-10
263- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
264
265* Wed Nov 14 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-9
266- Fix macros expansions so that conditionals work
267
268* Mon Nov 12 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-8
269- Fix up licenses for qt and qt4 subpackages (#875875)
270
271* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-7
272- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
273
274* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-6
275- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
276
277* Mon Nov 14 2011 Adam Jackson <ajax@redhat.com> 0.8.1-5
278- Rebuild for new libpng
279
280* Tue Jul 26 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-4
281- Improve wrapper to fallback to curses even with DISPLAY set (#622077)
282
283* Fri Feb 18 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-3
284- Fix pinentry-curses running as root by disabling capabilities (#677670)
285
286* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-2
287- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
288
289* Tue Feb  1 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-1
290- Updated to latest upstream version (0.8.1)
291
292* Fri May  7 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.0-3
293- Fix X11 even race with gtk (#589998)
294- Fix qt4 problems with creating window in the background (#589532)
295
296* Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.8.0-2
297- -qt: build as qt4 version, and drop qt3 support (f13+ only)
298
299* Tue Apr 27 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.0-1
300- pinentry-0.8.0
301- pinentry-gtk keyboard grab fail results in SIGABRT (#585422)
302
303* Sun Apr 18 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-5
304- pinentry-gtk -g segfaults on focus change (#520236)
305
306* Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-4
307- Errors installing with --excludedocs (#515925)
308
309* Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-3
310- drop alternatives, use app-wrapper instead (borrowed from opensuse)
311- -qt4 experimental subpkg, -qt includes qt3 version again  (#523488)
312
313* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.6-2
314- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
315
316* Mon Jun 22 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-1
317- pinentry-0.7.6
318- -qt switched qt4 version, where applicable (f9+, rhel6+)
319- fixup scriptlets
320
321* Sat Apr 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.5-1
322- pinentry-0.7.5
323
324* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-6
325- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
326
327* Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.7.4-5
328- pinentry failed massrebuild attempt for GCC 4.3 (#434400)
329
330* Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.7.4-4
331- s/qt-devel/qt3-devel/ (f9+)
332
333* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.7.4-3
334- Autorebuild for GCC 4.3
335
336* Sun Feb 17 2008 Adam Tkac <atkac redhat com> - 0.7.4-2
337- rebuild against new libcap
338
339* Sun Dec 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.4-1
340- pinentry-0.7.4
341- BR: libcap-devel
342
343* Sat Aug 25 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.3-2
344- respin (BuildID)
345
346* Sat Aug 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.3-1
347- pinentry-0.7.3
348- License: GPLv2+
349
350* Thu May 10 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.2-15
351- respin (for ppc64)
352
353* Mon Dec 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-14
354- -14 respin (to help retire ATrpms pinentry pkg)
355
356* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-3
357- fc6 respin
358
359* Wed Aug 09 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-2
360- fc6 respin
361
362* Wed Mar 01 2006 Rex Dieter <rexdieter[AT]users.sf.net>
363- fc5: gcc/glibc respin
364
365* Tue Oct 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.7.2-1
366- 0.7.2, docs patch applied upstream.
367- Switch to GTK2 in -gtk.
368- Fine tune dependencies.
369- Build with dependency tracking disabled.
370- Clean up obsolete pre-FC2 support.
371
372* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.7.1-4
373- rebuilt
374
375* Wed Jun 30 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.3
376- BuildRequires qt-devel >= 3.2.
377
378* Sat May 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.2
379- Spec cleanups.
380
381* Sat Apr 24 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.1
382- Update to 0.7.1.
383
384* Fri Dec 26 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.0-0.fdr.1
385- Update to 0.7.0.
386- Split GTK+ and QT dialogs into subpackages.
387
388* Thu Jul 10 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.9-0.fdr.1
389- Update to 0.6.9.
390- Smoother experience with --excludedocs.
391- Don't change alternative priorities on upgrade.
392
393* Sat Mar 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.fdr.1
394- Update to current Fedora guidelines.
395
396* Wed Feb 12 2003 Warren Togami <warren@togami.com> 0.6.8-1.fedora.3
397- info/dir temporary workaround
398
399* Sat Feb  8 2003 Ville Skyttä <ville.skytta at iki.fi> - 0.6.8-1.fedora.1
400- First Fedora release.
Note: See TracBrowser for help on using the repository browser.