source: projects/specs/trunk/p/pinentry/pinentry-vl.spec @ 11564

Revision 11564, 12.8 KB checked in by tomop, 6 years ago (diff)

pinentry-1.1.0-1

Line 
1
2Name:    pinentry
3Version: 1.1.0
4Release: 1%{?_dist_release}
5Summary: Collection of simple PIN or passphrase entry dialogs
6
7Vendor: Project Vine
8Distribution: Vine Linux
9
10# qt & qt4 subpackage have different license, see subpackage definitions
11License: GPLv2+
12URL:     http://www.gnupg.org/aegypten/
13Source0: ftp://ftp.gnupg.org/gcrypt/pinentry/%{name}-%{version}.tar.bz2
14Source1: ftp://ftp.gnupg.org/gcrypt/pinentry/%{name}-%{version}.tar.bz2.sig
15
16# borrowed from opensuse
17Source10: pinentry-wrapper
18
19BuildRequires: gcr-devel
20BuildRequires: gtk2-devel
21BuildRequires: libcap-devel
22BuildRequires: ncurses-devel
23BuildRequires: libgpg-error-devel
24BuildRequires: libassuan-devel
25BuildRequires: libsecret-devel
26BuildRequires: pkgconfig(Qt5Core) pkgconfig(Qt5Gui) pkgconfig(Qt5Widgets)
27
28Requires(pre): %{_sbindir}/update-alternatives
29Requires(post): /sbin/install-info
30Requires(preun): /sbin/install-info
31
32Provides: %{name}-curses = %{version}-%{release}
33
34%description
35Pinentry is a collection of simple PIN or passphrase entry dialogs which
36utilize the Assuan protocol as described by the aegypten project; see
37http://www.gnupg.org/aegypten/ for details.
38This package contains the curses (text) based version of the PIN entry dialog.
39
40%package gnome3
41Summary: Passphrase/PIN entry dialog for GNOME 3
42Requires: %{name} = %{version}-%{release}
43Provides: %{name}-gui = %{version}-%{release}
44%description gnome3
45Pinentry is a collection of simple PIN or passphrase entry dialogs which
46utilize the Assuan protocol as described by the aegypten project; see
47http://www.gnupg.org/aegypten/ for details.
48This package contains the GNOME 3 version of the PIN entry dialog.
49
50%package gtk
51Summary: Passphrase/PIN entry dialog based on GTK+
52Requires: %{name} = %{version}-%{release}
53Provides: %{name}-gui = %{version}-%{release}
54Provides: pinentry-gtk2 = %{version}-%{release}
55%description gtk
56Pinentry is a collection of simple PIN or passphrase entry dialogs which
57utilize the Assuan protocol as described by the aegypten project; see
58http://www.gnupg.org/aegypten/ for details.
59This package contains the GTK GUI based version of the PIN entry dialog.
60
61%package qt
62Summary: Passphrase/PIN entry dialog based on Qt5
63Requires: %{name} = %{version}-%{release}
64Provides: %{name}-gui = %{version}-%{release}
65Obsoletes: pinentry-qt4 < 0.8.0-2
66Provides:  pinentry-qt5 = %{version}-%{release}
67%description qt
68Pinentry is a collection of simple PIN or passphrase entry dialogs which
69utilize the Assuan protocol as described by the aegypten project; see
70http://www.gnupg.org/aegypten/ for details.
71This package contains the Qt5 GUI based version of the PIN entry dialog.
72
73%package emacs
74Summary: Passphrase/PIN entry dialog based on emacs
75Requires: %{name} = %{version}-%{release}
76%description emacs
77Pinentry is a collection of simple PIN or passphrase entry dialogs which
78utilize the Assuan protocol as described by the aegypten project; see
79http://www.gnupg.org/aegypten/ for details.
80This package contains the emacs based version of the PIN entry dialog.
81
82%prep
83%setup -q
84
85%build
86
87%if 0%{?fedora} > 22
88# FTBFS on f23/gcc5 without this
89CXXFLAGS="%{optflags} -std=c++11"
90%endif
91
92%configure \
93  --disable-rpath \
94  --disable-dependency-tracking \
95  --without-libcap \
96  --enable-pinentry-gnome3 \
97  --enable-pinentry-gtk2 \
98  --enable-pinentry-qt \
99  --enable-pinentry-emacs \
100  --enable-libsecret
101
102make %{?_smp_mflags}
103
104
105%install
106make install DESTDIR=$RPM_BUILD_ROOT
107
108# Symlink for Backward compatibility
109ln -s pinentry-gtk-2 $RPM_BUILD_ROOT%{_bindir}/pinentry-gtk
110ln -s pinentry-qt $RPM_BUILD_ROOT%{_bindir}/pinentry-qt4
111
112install -p -m755 -D %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/pinentry
113
114# unpackaged files
115rm -fv $RPM_BUILD_ROOT%{_infodir}/dir
116
117
118%post
119if [ -f %{_infodir}/pinentry.info* ]; then
120/sbin/install-info %{_infodir}/pinentry.info %{_infodir}/dir ||:
121fi
122
123%preun
124if [ $1 -eq 0 -a -f %{_infodir}/pinentry.info* ] ; then
125  /sbin/install-info --delete %{_infodir}/pinentry.info %{_infodir}/dir ||:
126fi
127
128%files
129%{!?_licensedir:%global license %%doc}
130%license COPYING
131%doc AUTHORS ChangeLog NEWS README THANKS TODO
132%{_bindir}/pinentry-curses
133%{_bindir}/pinentry
134%{_infodir}/pinentry.info*
135
136%files gnome3
137%{_bindir}/pinentry-gnome3
138
139%files gtk
140%{_bindir}/pinentry-gtk
141%{_bindir}/pinentry-gtk-2
142
143%files qt
144%{_bindir}/pinentry-qt
145# symlink for backward compatibility
146%{_bindir}/pinentry-qt4
147
148%files emacs
149%{_bindir}/pinentry-emacs
150
151%changelog
152* Thu Mar 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.1.0-1
153- new upstream release.
154
155* Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> - 0.9.7-4
156- rebuild with gcc-5.4.0
157
158* Sun May 22 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.9.7-3
159- initial build for Vine Linux.
160
161* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.7-2
162- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
163
164* Mon Dec 07 2015 Boris Ranto <branto@redhat.com> - 0.9.7-1
165- Rebase to latest upstream version
166
167* Tue Oct 27 2015 Stef Walter <stefw@redhat.com> - 0.9.6-4
168- Enable libsecret, which enables password caching in pinentry-gnome3
169- Resolves rhbz#1275567
170
171* Thu Oct 15 2015 Kalev Lember <klember@redhat.com> - 0.9.6-3
172- Add pinentry-gnome3 support to pinentry wrapper
173
174* Mon Sep 21 2015 Kalev Lember <klember@redhat.com> - 0.9.6-2
175- Build pinentry-gnome3
176
177* Fri Sep 11 2015 Boris Ranto <branto@redhat.com> - 0.9.6-1
178- Rebase to latest upstream version
179- Modify backwards compatible symlink for qt(4)
180- Enable pinentry-emacs since it was enabled by default in 0.9.5
181
182* Thu Jul 02 2015 Boris Ranto <branto@redhat.com> - 0.9.5-1
183- Rebase to latest upstream version
184- Removing qt4 pinentry patch -- got merged upstream
185- New package pinentry-emacs that hosts pinentry-emacs
186- New dependencies on libassuan and libgpg-error (de-bundling)
187
188* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.2-2
189- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
190
191* Thu May 14 2015 Boris Ranto <branto@redhat.com> - 0.9.2-1
192- Rebase to latest upstream version
193
194* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 0.9.1-2
195- Rebuilt for GCC 5 C++11 ABI change
196
197* Wed Mar 25 2015 Boris Ranto <branto@redhat.com> - 0.9.1-1
198- Rebase to latest upstream version
199- There are no longer any moc files so there is no need to patch them
200
201* Fri Mar 13 2015 Rex Dieter <rdieter@fedoraproject.org> - 0.9.0-3
202- fix FTBFS on f23/gcc5
203- drop deprecated configure flags
204
205* Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.9.0-2
206- Rebuilt for Fedora 23 Change
207  https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
208
209* Wed Nov 12 2014 Boris Ranto <branto@redhat.com> - 0.9.0-1
210- Rebase to latest upstream version
211
212* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-7
213- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
214
215* Tue Aug 12 2014 Boris Ranto <branto@redhat.com> - 0.8.3-6
216- fix bogus dates
217- upgrade pinentry-wrapper to handle corner cases better
218
219* Wed Jul 30 2014 Tom Callaway <spot@fedoraproject.org> - 0.8.3-5
220- fix license handling
221
222* Sat Jul 19 2014 Rex Dieter <rdieter@fedoraproject.org> 0.8.3-4
223- /usr/bin/pinentry should not check if stderr is opened (#787775)
224
225* Sat Jul 19 2014 Rex Dieter <rdieter@fedoraproject.org> - 0.8.3-3
226- .spec cleanup (drop support for old releases)
227- -gtk: Provides: pinentry-gtk2
228
229* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-2
230- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
231
232* Thu Jan 30 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.3-1
233- Update to latest upstream version (0.8.3)
234
235* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-11
236- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
237
238* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-10
239- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
240
241* Wed Nov 14 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-9
242- Fix macros expansions so that conditionals work
243
244* Mon Nov 12 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-8
245- Fix up licenses for qt and qt4 subpackages (#875875)
246
247* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-7
248- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
249
250* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-6
251- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
252
253* Mon Nov 14 2011 Adam Jackson <ajax@redhat.com> 0.8.1-5
254- Rebuild for new libpng
255
256* Tue Jul 26 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-4
257- Improve wrapper to fallback to curses even with DISPLAY set (#622077)
258
259* Fri Feb 18 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-3
260- Fix pinentry-curses running as root by disabling capabilities (#677670)
261
262* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-2
263- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
264
265* Tue Feb  1 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-1
266- Updated to latest upstream version (0.8.1)
267
268* Fri May  7 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.0-3
269- Fix X11 even race with gtk (#589998)
270- Fix qt4 problems with creating window in the background (#589532)
271
272* Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.8.0-2
273- -qt: build as qt4 version, and drop qt3 support (f13+ only)
274
275* Tue Apr 27 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.0-1
276- pinentry-0.8.0
277- pinentry-gtk keyboard grab fail results in SIGABRT (#585422)
278
279* Sun Apr 18 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-5
280- pinentry-gtk -g segfaults on focus change (#520236)
281
282* Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-4
283- Errors installing with --excludedocs (#515925)
284
285* Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-3
286- drop alternatives, use app-wrapper instead (borrowed from opensuse)
287- -qt4 experimental subpkg, -qt includes qt3 version again  (#523488)
288
289* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.6-2
290- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
291
292* Mon Jun 22 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-1
293- pinentry-0.7.6
294- -qt switched qt4 version, where applicable (f9+, rhel6+)
295- fixup scriptlets
296
297* Sat Apr 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.5-1
298- pinentry-0.7.5
299
300* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-6
301- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
302
303* Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.7.4-5
304- pinentry failed massrebuild attempt for GCC 4.3 (#434400)
305
306* Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.7.4-4
307- s/qt-devel/qt3-devel/ (f9+)
308
309* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.7.4-3
310- Autorebuild for GCC 4.3
311
312* Sun Feb 17 2008 Adam Tkac <atkac redhat com> - 0.7.4-2
313- rebuild against new libcap
314
315* Sun Dec 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.4-1
316- pinentry-0.7.4
317- BR: libcap-devel
318
319* Sat Aug 25 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.3-2
320- respin (BuildID)
321
322* Sat Aug 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.3-1
323- pinentry-0.7.3
324- License: GPLv2+
325
326* Thu May 10 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.2-15
327- respin (for ppc64)
328
329* Mon Dec 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-14
330- -14 respin (to help retire ATrpms pinentry pkg)
331
332* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-3
333- fc6 respin
334
335* Wed Aug 09 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-2
336- fc6 respin
337
338* Wed Mar 01 2006 Rex Dieter <rexdieter[AT]users.sf.net>
339- fc5: gcc/glibc respin
340
341* Tue Oct 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.7.2-1
342- 0.7.2, docs patch applied upstream.
343- Switch to GTK2 in -gtk.
344- Fine tune dependencies.
345- Build with dependency tracking disabled.
346- Clean up obsolete pre-FC2 support.
347
348* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.7.1-4
349- rebuilt
350
351* Wed Jun 30 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.3
352- BuildRequires qt-devel >= 3.2.
353
354* Sat May 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.2
355- Spec cleanups.
356
357* Sat Apr 24 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.1
358- Update to 0.7.1.
359
360* Fri Dec 26 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.0-0.fdr.1
361- Update to 0.7.0.
362- Split GTK+ and QT dialogs into subpackages.
363
364* Thu Jul 10 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.9-0.fdr.1
365- Update to 0.6.9.
366- Smoother experience with --excludedocs.
367- Don't change alternative priorities on upgrade.
368
369* Sat Mar 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.fdr.1
370- Update to current Fedora guidelines.
371
372* Wed Feb 12 2003 Warren Togami <warren@togami.com> 0.6.8-1.fedora.3
373- info/dir temporary workaround
374
375* Sat Feb  8 2003 Ville Skyttä <ville.skytta at iki.fi> - 0.6.8-1.fedora.1
376- First Fedora release.
Note: See TracBrowser for help on using the repository browser.