source: projects/specs/trunk/p/pinentry/pinentry-vl.spec @ 10309

Revision 10309, 12.7 KB checked in by tomop, 8 years ago (diff)

pinentry-0.9.7-3

Line 
1
2Name:    pinentry
3Version: 0.9.7
4Release: 3%{?_dist_release}
5Summary: Collection of simple PIN or passphrase entry dialogs
6
7Vendor: Project Vine
8Distribution: Vine Linux
9
10# qt & qt4 subpackage have different license, see subpackage definitions
11License: GPLv2+
12URL:     http://www.gnupg.org/aegypten/
13Source0: ftp://ftp.gnupg.org/gcrypt/pinentry/%{name}-%{version}.tar.bz2
14Source1: ftp://ftp.gnupg.org/gcrypt/pinentry/%{name}-%{version}.tar.bz2.sig
15
16# borrowed from opensuse
17Source10: pinentry-wrapper
18
19BuildRequires: gcr-devel
20BuildRequires: gtk2-devel
21BuildRequires: libcap-devel
22BuildRequires: ncurses-devel
23BuildRequires: qt4-devel
24BuildRequires: libgpg-error-devel
25BuildRequires: libassuan-devel
26BuildRequires: libsecret-devel
27
28Requires(pre): %{_sbindir}/update-alternatives
29Requires(post): /sbin/install-info
30Requires(preun): /sbin/install-info
31
32Provides: %{name}-curses = %{version}-%{release}
33
34%description
35Pinentry is a collection of simple PIN or passphrase entry dialogs which
36utilize the Assuan protocol as described by the aegypten project; see
37http://www.gnupg.org/aegypten/ for details.
38This package contains the curses (text) based version of the PIN entry dialog.
39
40%package gnome3
41Summary: Passphrase/PIN entry dialog for GNOME 3
42Requires: %{name} = %{version}-%{release}
43Provides: %{name}-gui = %{version}-%{release}
44%description gnome3
45Pinentry is a collection of simple PIN or passphrase entry dialogs which
46utilize the Assuan protocol as described by the aegypten project; see
47http://www.gnupg.org/aegypten/ for details.
48This package contains the GNOME 3 version of the PIN entry dialog.
49
50%package gtk
51Summary: Passphrase/PIN entry dialog based on GTK+
52Requires: %{name} = %{version}-%{release}
53Provides: %{name}-gui = %{version}-%{release}
54Provides: pinentry-gtk2 = %{version}-%{release}
55%description gtk
56Pinentry is a collection of simple PIN or passphrase entry dialogs which
57utilize the Assuan protocol as described by the aegypten project; see
58http://www.gnupg.org/aegypten/ for details.
59This package contains the GTK GUI based version of the PIN entry dialog.
60
61%package qt
62Summary: Passphrase/PIN entry dialog based on Qt4
63# original code for secstring.cpp doesn't allow GPL versions higher than 3 to be
64# used
65License: GPLv2 or GPLv3
66Requires: %{name} = %{version}-%{release}
67Provides: %{name}-gui = %{version}-%{release}
68Obsoletes: pinentry-qt4 < 0.8.0-2
69Provides:  pinentry-qt4 = %{version}-%{release}
70%description qt
71Pinentry is a collection of simple PIN or passphrase entry dialogs which
72utilize the Assuan protocol as described by the aegypten project; see
73http://www.gnupg.org/aegypten/ for details.
74This package contains the Qt4 GUI based version of the PIN entry dialog.
75
76%package emacs
77Summary: Passphrase/PIN entry dialog based on emacs
78Requires: %{name} = %{version}-%{release}
79%description emacs
80Pinentry is a collection of simple PIN or passphrase entry dialogs which
81utilize the Assuan protocol as described by the aegypten project; see
82http://www.gnupg.org/aegypten/ for details.
83This package contains the emacs based version of the PIN entry dialog.
84
85%prep
86%setup -q
87
88%build
89
90%if 0%{?fedora} > 22
91# FTBFS on f23/gcc5 without this
92CXXFLAGS="%{optflags} -std=c++11"
93%endif
94
95%configure \
96  --disable-rpath \
97  --disable-dependency-tracking \
98  --without-libcap \
99  --enable-pinentry-gnome3 \
100  --enable-pinentry-gtk2 \
101  --enable-pinentry-qt \
102  --enable-pinentry-emacs \
103  --enable-libsecret
104
105make %{?_smp_mflags}
106
107
108%install
109make install DESTDIR=$RPM_BUILD_ROOT
110
111# Backwards compatibility
112ln -s pinentry-gtk-2 $RPM_BUILD_ROOT%{_bindir}/pinentry-gtk
113# This changed in 0.9.6
114ln -s pinentry-qt $RPM_BUILD_ROOT%{_bindir}/pinentry-qt4
115
116install -p -m755 -D %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/pinentry
117
118# unpackaged files
119rm -fv $RPM_BUILD_ROOT%{_infodir}/dir
120
121
122%post
123if [ -f %{_infodir}/pinentry.info* ]; then
124/sbin/install-info %{_infodir}/pinentry.info %{_infodir}/dir ||:
125fi
126
127%preun
128if [ $1 -eq 0 -a -f %{_infodir}/pinentry.info* ] ; then
129  /sbin/install-info --delete %{_infodir}/pinentry.info %{_infodir}/dir ||:
130fi
131
132%files
133%{!?_licensedir:%global license %%doc}
134%license COPYING
135%doc AUTHORS ChangeLog NEWS README THANKS TODO
136%{_bindir}/pinentry-curses
137%{_bindir}/pinentry
138%{_infodir}/pinentry.info*
139
140%files gnome3
141%{_bindir}/pinentry-gnome3
142
143%files gtk
144%{_bindir}/pinentry-gtk
145%{_bindir}/pinentry-gtk-2
146
147%files qt
148%{_bindir}/pinentry-qt
149%{_bindir}/pinentry-qt4
150
151%files emacs
152%{_bindir}/pinentry-emacs
153
154%changelog
155* Sun May 22 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.9.7-3
156- initial build for Vine Linux.
157
158* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.7-2
159- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
160
161* Mon Dec 07 2015 Boris Ranto <branto@redhat.com> - 0.9.7-1
162- Rebase to latest upstream version
163
164* Tue Oct 27 2015 Stef Walter <stefw@redhat.com> - 0.9.6-4
165- Enable libsecret, which enables password caching in pinentry-gnome3
166- Resolves rhbz#1275567
167
168* Thu Oct 15 2015 Kalev Lember <klember@redhat.com> - 0.9.6-3
169- Add pinentry-gnome3 support to pinentry wrapper
170
171* Mon Sep 21 2015 Kalev Lember <klember@redhat.com> - 0.9.6-2
172- Build pinentry-gnome3
173
174* Fri Sep 11 2015 Boris Ranto <branto@redhat.com> - 0.9.6-1
175- Rebase to latest upstream version
176- Modify backwards compatible symlink for qt(4)
177- Enable pinentry-emacs since it was enabled by default in 0.9.5
178
179* Thu Jul 02 2015 Boris Ranto <branto@redhat.com> - 0.9.5-1
180- Rebase to latest upstream version
181- Removing qt4 pinentry patch -- got merged upstream
182- New package pinentry-emacs that hosts pinentry-emacs
183- New dependencies on libassuan and libgpg-error (de-bundling)
184
185* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9.2-2
186- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
187
188* Thu May 14 2015 Boris Ranto <branto@redhat.com> - 0.9.2-1
189- Rebase to latest upstream version
190
191* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 0.9.1-2
192- Rebuilt for GCC 5 C++11 ABI change
193
194* Wed Mar 25 2015 Boris Ranto <branto@redhat.com> - 0.9.1-1
195- Rebase to latest upstream version
196- There are no longer any moc files so there is no need to patch them
197
198* Fri Mar 13 2015 Rex Dieter <rdieter@fedoraproject.org> - 0.9.0-3
199- fix FTBFS on f23/gcc5
200- drop deprecated configure flags
201
202* Sat Feb 21 2015 Till Maas <opensource@till.name> - 0.9.0-2
203- Rebuilt for Fedora 23 Change
204  https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
205
206* Wed Nov 12 2014 Boris Ranto <branto@redhat.com> - 0.9.0-1
207- Rebase to latest upstream version
208
209* Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-7
210- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
211
212* Tue Aug 12 2014 Boris Ranto <branto@redhat.com> - 0.8.3-6
213- fix bogus dates
214- upgrade pinentry-wrapper to handle corner cases better
215
216* Wed Jul 30 2014 Tom Callaway <spot@fedoraproject.org> - 0.8.3-5
217- fix license handling
218
219* Sat Jul 19 2014 Rex Dieter <rdieter@fedoraproject.org> 0.8.3-4
220- /usr/bin/pinentry should not check if stderr is opened (#787775)
221
222* Sat Jul 19 2014 Rex Dieter <rdieter@fedoraproject.org> - 0.8.3-3
223- .spec cleanup (drop support for old releases)
224- -gtk: Provides: pinentry-gtk2
225
226* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.3-2
227- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
228
229* Thu Jan 30 2014 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.3-1
230- Update to latest upstream version (0.8.3)
231
232* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-11
233- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
234
235* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-10
236- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
237
238* Wed Nov 14 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-9
239- Fix macros expansions so that conditionals work
240
241* Mon Nov 12 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-8
242- Fix up licenses for qt and qt4 subpackages (#875875)
243
244* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-7
245- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
246
247* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-6
248- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
249
250* Mon Nov 14 2011 Adam Jackson <ajax@redhat.com> 0.8.1-5
251- Rebuild for new libpng
252
253* Tue Jul 26 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-4
254- Improve wrapper to fallback to curses even with DISPLAY set (#622077)
255
256* Fri Feb 18 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-3
257- Fix pinentry-curses running as root by disabling capabilities (#677670)
258
259* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8.1-2
260- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
261
262* Tue Feb  1 2011 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.1-1
263- Updated to latest upstream version (0.8.1)
264
265* Fri May  7 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.0-3
266- Fix X11 even race with gtk (#589998)
267- Fix qt4 problems with creating window in the background (#589532)
268
269* Thu Apr 29 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.8.0-2
270- -qt: build as qt4 version, and drop qt3 support (f13+ only)
271
272* Tue Apr 27 2010 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.8.0-1
273- pinentry-0.8.0
274- pinentry-gtk keyboard grab fail results in SIGABRT (#585422)
275
276* Sun Apr 18 2010 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-5
277- pinentry-gtk -g segfaults on focus change (#520236)
278
279* Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-4
280- Errors installing with --excludedocs (#515925)
281
282* Sun Sep 13 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-3
283- drop alternatives, use app-wrapper instead (borrowed from opensuse)
284- -qt4 experimental subpkg, -qt includes qt3 version again  (#523488)
285
286* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.6-2
287- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
288
289* Mon Jun 22 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.6-1
290- pinentry-0.7.6
291- -qt switched qt4 version, where applicable (f9+, rhel6+)
292- fixup scriptlets
293
294* Sat Apr 25 2009 Rex Dieter <rdieter@fedoraproject.org> - 0.7.5-1
295- pinentry-0.7.5
296
297* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.4-6
298- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
299
300* Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.7.4-5
301- pinentry failed massrebuild attempt for GCC 4.3 (#434400)
302
303* Tue Mar 25 2008 Rex Dieter <rdieter@fedoraproject.org> - 0.7.4-4
304- s/qt-devel/qt3-devel/ (f9+)
305
306* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.7.4-3
307- Autorebuild for GCC 4.3
308
309* Sun Feb 17 2008 Adam Tkac <atkac redhat com> - 0.7.4-2
310- rebuild against new libcap
311
312* Sun Dec 09 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.4-1
313- pinentry-0.7.4
314- BR: libcap-devel
315
316* Sat Aug 25 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.3-2
317- respin (BuildID)
318
319* Sat Aug 11 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.3-1
320- pinentry-0.7.3
321- License: GPLv2+
322
323* Thu May 10 2007 Rex Dieter <rdieter[AT]fedoraproject.org> - 0.7.2-15
324- respin (for ppc64)
325
326* Mon Dec 04 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-14
327- -14 respin (to help retire ATrpms pinentry pkg)
328
329* Mon Aug 28 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-3
330- fc6 respin
331
332* Wed Aug 09 2006 Rex Dieter <rexdieter[AT]users.sf.net> - 0.7.2-2
333- fc6 respin
334
335* Wed Mar 01 2006 Rex Dieter <rexdieter[AT]users.sf.net>
336- fc5: gcc/glibc respin
337
338* Tue Oct 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.7.2-1
339- 0.7.2, docs patch applied upstream.
340- Switch to GTK2 in -gtk.
341- Fine tune dependencies.
342- Build with dependency tracking disabled.
343- Clean up obsolete pre-FC2 support.
344
345* Thu Apr  7 2005 Michael Schwendt <mschwendt[AT]users.sf.net> - 0.7.1-4
346- rebuilt
347
348* Wed Jun 30 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.3
349- BuildRequires qt-devel >= 3.2.
350
351* Sat May 22 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.2
352- Spec cleanups.
353
354* Sat Apr 24 2004 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.1-0.fdr.1
355- Update to 0.7.1.
356
357* Fri Dec 26 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.7.0-0.fdr.1
358- Update to 0.7.0.
359- Split GTK+ and QT dialogs into subpackages.
360
361* Thu Jul 10 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.9-0.fdr.1
362- Update to 0.6.9.
363- Smoother experience with --excludedocs.
364- Don't change alternative priorities on upgrade.
365
366* Sat Mar 22 2003 Ville Skyttä <ville.skytta at iki.fi> - 0:0.6.8-0.fdr.1
367- Update to current Fedora guidelines.
368
369* Wed Feb 12 2003 Warren Togami <warren@togami.com> 0.6.8-1.fedora.3
370- info/dir temporary workaround
371
372* Sat Feb  8 2003 Ville Skyttä <ville.skytta at iki.fi> - 0.6.8-1.fedora.1
373- First Fedora release.
Note: See TracBrowser for help on using the repository browser.