source: projects/specs/trunk/p/pilot-link/pilot-link-vl.spec @ 521

Revision 521, 8.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define ver     0.12.4
2%define srcver  %{ver}
3%define rel     1%{?_dist_release}
4%define support_perl 0
5
6Summary:        File transfer utilities between Linux and PalmPilots.
7Summary(ja):    Linux と Palm handheld device を接続する為のユーティリティ
8Name:           pilot-link
9Version:        %{ver}
10Release:        %{rel}
11Epoch:          1
12Source:         http://downloads.pilot-link.org/pilot-link-%{srcver}.tar.bz2
13Source1:        connect-palm-ppp.tar.bz2
14Source2:        60-libpisock.rules.vine
15# (fc) 0.10.99 fix python/perl installation
16Patch1:         pilot-link-0.11.0-perlmd5.patch
17Patch2:         pilot-link-0.11.0-perlpollute.patch
18Patch3:         pilot-link-0.11.2-malsync.patch
19Patch4:         pilot-link-0.11.5-broken.patch
20#Patch7:        pilot-link-0.11.3-destdir.patch.bz2
21#Patch9:        pilot-link-0.11.8-configure.patch
22License:        GPL/LGPL
23Group:          Applications/Other
24
25BuildRoot:      %{_tmppath}/%{name}-%{version}-root
26BuildRequires:  bison >= 1.35
27BuildRequires:  libusb-devel >= 0.1
28BuildRequires:  readline-devel
29BuildRequires:  bluez-libs-devel
30BuildRequires:  popt-devel
31%if %{support_perl}
32BuildRequires:  perl
33%endif
34Requires:       libusb >= 0.1
35
36Vendor:         Project Vine
37Distribution:   Vine Linux
38
39
40%description
41This suite of tools allows you to upload and download programs and
42data files between a Linux/UNIX machine and the PalmPilot.  It has a
43few extra utils that will allow for things like syncing the
44PalmPilot's calendar app with Ical.  Note that you might still need to
45consult the sources for pilot-link if you would like the Python, Tcl,
46or Perl bindings.
47
48Install pilot-link if you want to synchronize your Palm with your Vine
49Linux system.
50
51%description -l ja
52このツールを使うと、Linux/Unix マシンと Palm handheld device の間で
53プログラムやファイルを転送することができます。このツールには、Palm
54handheld device の予定表と Ical との間で同期を可能にするようないくつ
55かのユーティリティが付属しています。もし Python や Tcl、あるいは
56Perl bindingsを使用する場合は、pilot-link の source を調べる必要が
57あることに注意してください。
58
59Palm handheld device を Vine Linux システムで同期させたい場合は
60pilot-link をインストールします。
61
62%package devel
63Summary:        PalmPilot development header files.
64Summary(ja):    Palm handheld プログラム開発用のヘッダ ファイル
65Group:          Development/Libraries
66Requires:       %{name} = %{epoch}:%{version}
67Requires:       pkgconfig
68
69%description devel
70This package contains the development headers that are used to build
71the pilot-link package.  It also includes the static libraries
72necessary to build static pilot apps.
73
74If you want to develop PalmPilot synchronizing applications, you'll
75need to install pilot-link-devel.
76
77%description devel -l ja
78このパッケージには、pilot-link パッケージを構築する為に必要な開発用の
79ヘッダ ファイルが含まれます。また、スタティックな Palm 用アプリケーション
80の構築に必要なスタティック ライブラリも含まれます。
81
82Palm handheld deviceと同期するアプリケーションを開発したい場合は、
83pilot-link-devel パッケージをインストールする必要があります。
84
85%prep
86%setup -q -a 1
87%if %{support_perl}
88%patch1 -p1 -b .perlmd5
89%patch2 -p1 -b .perlpollute
90%patch3 -p1 -b .malsync
91%endif
92
93#%patch7 -p1 -b .destdir
94#patch9 -p1 -b .mathlib
95
96#needed by patch 7 & 8
97#aclocal
98#automake
99
100#update libtool (needed for linking libpisock++ correctly)
101#libtoolize --force
102
103%build
104%configure\
105  --disable-static \
106  --enable-conduits \
107  --enable-libusb \
108  --with-libpng \
109  --with-bluez \
110  --without-python \
111  --without-tcl \
112  --without-java \
113%if %{support_perl}
114  --with-perl
115%else
116  --without-perl
117%endif
118
119make
120
121%install
122[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
123
124%if %{support_perl}
125if test -f bindings/Perl/Makefile.PL ; then
126   cd bindings/Perl
127   perl -pi -e 's|^\$libdir =.*|\$libdir = "%{buildroot}%{_libdir}";|g' Makefile.PL
128   CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL PREFIX=$RPM_BUILD_ROOT/usr INSTALLDIRS=vendor
129   make
130   cd ../..
131fi
132%endif
133
134%__make install DESTDIR=$RPM_BUILD_ROOT
135#%makeinstall -C doc/man
136
137%if %{support_perl}
138make install -C bindings/Perl
139rm -f %{buildroot}%{_libdir}/perl5/vendor_perl/%{perl_version}/*/auto/PDA/Pilot/Pilot.bs \
140      %{buildroot}%{_libdir}/perl5/site_perl/*/*/*/PDA/Pilot/.packlist
141%endif
142
143# install modified udev rules.
144mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
145install -m644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d/60-libpisock.rules
146
147# remove files we don't want to include
148rm -f $RPM_BUILD_ROOT/%{_libdir}/*.la
149
150%post -p /sbin/ldconfig
151
152%postun -p /sbin/ldconfig
153
154
155%clean
156[ -n "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != / ] && rm -rf $RPM_BUILD_ROOT
157
158%files
159%defattr(-,root,root)
160%doc COPYING COPYING.LIB ChangeLog README NEWS AUTHORS doc/README.*
161%{_sysconfdir}/udev/rules.d/60-libpisock.rules
162%{_libdir}/*.so.*
163%{_datadir}/pilot-link
164%if %{support_perl}
165%{_libdir}/perl5/vendor_perl/*/*/*/PDA
166%{_libdir}/perl5/vendor_perl/*/*/PDA
167%endif
168%{_bindir}/*
169%{_mandir}/man*/*
170
171%files devel
172%defattr(-, root, root)
173#{_libdir}/*.a
174%{_libdir}/*.so
175#%{_libdir}/*.la
176%{_libdir}/pkgconfig/pilot-link.pc
177%{_includedir}/*
178%{_datadir}/aclocal/*.m4
179
180
181%changelog
182* Wed Aug 26 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.12.4-1
183- new upstream release
184- removed static libraries from devel package
185- added --with-bluez to %%configure (added also BR: bluez-libs-devel)
186
187* Mon Sep 08 2008 Shu KONNO <owa@bg.wakwak.com> 0.12.0-1vl5
188- applied new versioning policy, spec in utf-8
189
190* Sat Sep 30 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12.0-0vl2
191- add modified udev rules (Source2). <BTS:VineLinux:222>
192
193* Sat Sep 02 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.12.0-0vl1
194- source update.
195- change Group to Applications/Other
196- use %%configure macro instead of ./configure
197- delete unused configure options for itcl and tk.
198- use '%%__make install' to use DESTDIR variable.
199- comment out '%%makeinstall -C doc/man'(not required to install man).
200- add 60-libpisock.rules for udev in %%files.
201- add pilot-link.pc in %%files for -devel.
202- add Requires libusb and BuildRequires libusb-devel >= 0.1.
203
204* Fri Jan  6 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.11.8-0vl3
205- rebuild for VineSeed
206- add "%%{epoch}:" to Requires in pilot-link-devel
207
208* Sun Nov 07 2004 Kazutaka Harada <kazutaka@dc4.so-net.ne.jp> 0.11.8-0vl2
209- convert spec from SJIS to EUC.
210
211* Wed Nov 03 2004 Kazutaka Harada <kazutaka@dc4.so-net.ne.jp> 0.11.8-0vl1
212- source update
213- add japanese translation(summary & description).
214- use License tag instead of Copyright.
215- change BuildRequires XFree86-devel to XOrg-devel.
216- add BuildRequires readline-devel.
217- add new Patch9.(avoid make error "undefined reference to `pow'")
218
219* Fri May 23 2003 Tomoya TAKA <taka@vinelinux.org> 0.11.7-0vl2
220- disuse %%configure macro to avoid unsuitable prefixed filename
221
222* Mon Mar 24 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 0.11.7-0vl1
223- source update
224
225* Fri Jan 04 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.5-0vl2
226- unfortunately added Epoch 1
227  (the previous version was 0.9.5.pre5-0vl2. Sigh...)
228
229* Sat Oct 13 2001 <uh@u.dhis.portside.net>
230- 0.9.5-0vl1
231- upgrade to 0.9.5
232- add COPYING.LIB to %doc
233
234* Mon Mar 26 2001 Akira TAGOH <tagoh@gnome.gr.jp> 0.9.5-pre5-0vl1
235- New upstream release.
236- Fixed defattr stuff for devel package.
237- Use rpmmacros.
238
239* Wed Oct 20 1999 Preston Brown <pbrown@redhat.com>
240- upgrade to pilot-link 0.9.3, rewrite spec.
241
242* Tue Apr 06 1999 Preston Brown <pbrown@redhat.com>
243- strip binaries
244
245* Tue Mar 30 1999 Preston Brown <pbrown@redhat.com>
246- added missing files from devel subpackage
247
248* Fri Mar 26 1999 Preston Brown <pbrown@redhat.com>
249- move /usr/lib/pix to /usr/lib/pilot-link (dumb, BAD name)
250
251* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
252- auto rebuild in the new build environment (release 5)
253
254* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
255- Injected new description and group.
256
257* Thu Jan 21 1999 Bill Nottingham <notting@redhat.com>
258- arm fix
259
260* Fri Sep 24 1998 Michael Maher <mike@redhat.com>
261- cleaned up spec file, updated package
262
263* Tue May 19 1998 Michael Maher <mike@redhat.com>
264- updated rpm
265
266* Thu Jan 29 1998 Otto Hammersmith <otto@redhat.com>
267- added changelog
268- updated to 0.8.9
269- removed explicit requires for /usr/bin/perl
270
Note: See TracBrowser for help on using the repository browser.