source: projects/specs/trunk/p/pidgin/pidgin-vl.spec @ 521

Revision 521, 25.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# SSL library (1: gnutls, 0: nss)
2%define ssl_lib 1
3
4# required version of libraries
5%define _pango_ver              1.4.0
6%define _glib_ver               2.2.2
7%define _gtk_ver                2.6.0
8%define _libstartupnotify_ver   0.5
9%define _libsqlite_ver          3.3.0
10%define _libxml_ver             2.6.0
11%define _gst_ver                0.10.0
12%define _dbus_ver               0.35
13
14#%%define extraver beta7
15
16Summary:        A GTK+ based multi-protocol instant messaging client
17Summary(ja):    マルチプロトコル対応のインスタントメッセンジャー
18Name:           pidgin
19Version:        2.6.5
20Release:        1%{?_dist_release}
21License:        GPL
22Group:          Applications/Internet
23URL:            http://pidgin.im/
24Source0:        http://jaist.dl.sourceforge.net/sourceforge/pidgin/%{name}-%{version}%{?extraver:%{extraver}}.tar.bz2
25# Source1:      http://mikeforce.homelinux.org/gnome/po/pidgin-ja.po
26Source1:        pidgin-2.6.2-ja.po
27Patch0:         http://www.honeyplanet.jp/%{name}-2.6.5_jp.diff.gz
28Patch1:         %{name}-2.0.0beta7_jp-enable-shortcut.patch
29BuildRoot:      %{_tmppath}/%{name}-%{version}-root
30BuildRequires:  gtk2-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
31BuildRequires:  pango-devel >= %{_pango_ver}
32BuildRequires:  startup-notification-devel >= %{_libstartupnotify_ver}
33BuildRequires:  dbus-devel >= %{_dbus_ver}
34BuildRequires:  libxml2-devel >= %{_libxml_ver}
35BuildRequires:  sqlite3-devel >= %{_libsqlite_ver}
36BuildRequires:  audiofile-devel, libao-devel
37BuildRequires:  ncurses-devel
38BuildRequires:  avahi-glib-devel
39BuildRequires:  pkgconfig
40BuildRequires:  doxygen
41BuildRequires:  intltool
42
43# SSL library (1: gnutls, 0: nss)
44%if %{ssl_lib}
45BuildRequires:  gnutls-devel
46%else
47BuildRequires:  nss-devel
48%endif
49
50# for Vine4/5
51%if %{?_dist_release} != "vl4"
52BuildRequires:  NetworkManager-devel
53# BuildRequires:  libidn-devel
54BuildRequires:  gstreamer-devel >= %{_gst_ver}
55BuildRequires:  libXScrnSaver-devel
56BuildRequires:  NetworkManager-devel
57BuildRequires:  dbus-glib-devel >= %{_dbus_ver}
58%endif
59
60Requires:       libpurple = %{version}-%{release}
61Requires:       gtk2 >= %{_gtk_ver}
62Requires:       pango >= %{_pango_ver}
63Requires:       startup-notification >= %{_libstartupnotify_ver}
64Requires:       sqlite3 >= %{_libsqlite_ver}
65Requires:       audiofile, libao, gstreamer >= %{_gst_ver}
66
67Requires(post,pre,preun): GConf2
68Requires(post,postun): gtk2 >= %{_gtk_ver}
69
70# Pidgin (Gtk+-based client) obsoletes Gaim
71Provides:       gaim
72Obsoletes:      gaim
73
74Vendor: Project Vine
75Distribution: Vine Linux
76
77%description
78Pidgin is a multi-protocol instant messaging client. It is compatible
79with AIM (Oscar and TOC protocols), ICQ, MSN Messenger, Yahoo, IRC,
80Jabber, Gadu-Gadu, and Zephyr networks.
81
82%description -l ja
83Pidgin は複数のプロトコルに対応したインスタントメッセンジャーです。
84AIM (Oscar, TOC プロトコル)、ICQ、MSN Messenger、Yahoo Messenger、
85IRC、Jabber、Gadu-Gadu、Zephyr に対応しています。
86
87%package devel
88Summary:        Development headers, documentation, and libraries for Pidgin
89Summary(ja):    Pidgin の開発用ヘッダーファイル、ライブラリ及びドキュメント
90Group:          Development/Libraries
91Requires:       %{name} = %{version}-%{release}
92Requires:       libpurple-devel = %{version}-%{release}
93Obsoletes:      gaim-devel
94Provides:       gaim-devel
95
96%description devel
97The pidgin-devel package contains the header files, developer
98documentation, and libraries required for development of Pidgin scripts
99and plugins.
100
101%description -l ja devel
102このパッケージには、Pidgin のスクリプトやプラグインを開発するために必要な
103ヘッダーファイル、ライブラリ及びドキュメントが含まれています。
104
105%package -n libpurple
106Summary:        libpurple library for IM clients like Pidgin and Finch
107Summary(ja):    Pidgin や Finch のような IM クライアントのためのライブラリ
108Group:          System Environment/Libraries
109Requires:       glib2 >= %{_glib_ver}
110Requires:       libxml2 >= %{_libxml_ver}
111Requires:       dbus-glib >= %{_dbus_ver}, dbus-glib >= %{_dbus_ver}
112Requires:       avahi-glib
113%if %{ssl_lib}
114Requires:       gnutls
115%else
116Requires:       nss
117%endif
118Requires(post):   ldconfig
119Requires(postun): ldconfig
120
121%description -n libpurple
122The libpurple package contains core library for instant messaging clients
123sudh as Pidgin and Finch.
124
125%description -l ja -n libpurple
126このパッケージには、Pidgin や Finch といったインスタントメッセンジャーの
127コアライブラリが含まれています。
128
129%package -n libpurple-devel
130Summary:        Development headers, documentation, and libraries for libpurple
131Summary(ja):    libpurple の開発用ヘッダーファイル、ライブラリ及びドキュメント
132Group:          Development/Libraries
133Requires:       libpurple = %{version}-%{release}
134Requires:       glib2-devel
135Requires:       pkgconfig
136
137%description -n libpurple-devel
138The libpurple-devel package contains the header files, developer
139documentation, and libraries required for development of libpurple based
140instant messaging clients or plugins for any libpurple based clients.
141
142%description -l ja -n libpurple-devel
143このパッケージには、libpurple を使ったインスタントメッセンジャーや、
144libpurple を使ったインスタントメッセンジャー用のプラグインを開発する
145ために必要なヘッダーファイル、ライブラリ及びドキュメントが含まれてい
146ます。
147
148%package -n finch
149Summary:        A text based multi-protocol instant messaging client
150Summary(ja):    テキストベースのインスタントメッセンジャー
151Group:          Applications/Internet
152Requires:       libpurple = %{version}-%{release}
153Requires:       ncurses
154Requires(post):   ldconfig
155Requires(postun): ldconfig
156
157%description -n finch
158Finch is a text based multi-protocol instant messaging client. This can
159be run from a standard text console or from a terminal within X Window
160System.
161It is compatible with AIM (Oscar and TOC protocols), ICQ, MSN Messenger,
162Yahoo, IRC, Jabber, Gadu-Gadu, and Zephyr networks.
163
164%description -l ja -n finch
165Finch は複数のプロトコルに対応したテキストベースのインスタントメッセン
166ジャーです。スタンダードなテキストコンソールや、X Windows System 上の
167ターミナルから起動することができます。
168AIM (Oscar, TOC プロトコル)、ICQ、MSN Messenger、Yahoo Messenger、
169IRC、Jabber、Gadu-Gadu、Zephyr に対応しています。
170
171%package -n finch-devel
172Summary:        Development headers, documentation, and libraries for Finch
173Summary(ja):    Finch の開発用ヘッダーファイル、ライブラリ及びドキュメント
174Group:          Development/Libraries
175Requires:       finch = %{version}-%{release}
176Requires:       libpurple-devel = %{version}-%{release}
177Requires:       ncurses-devel
178
179%description -n finch-devel
180The finch-devel package contains the header files, developer
181documentation, and libraries required for development of Finch scripts
182and plugins.
183
184%description -l ja -n finch-devel
185このパッケージには、Finch のスクリプトやプラグインを開発するために必要な
186ヘッダーファイル、ライブラリ及びドキュメントが含まれています。
187
188%prep
189%setup -q -n %{name}-%{version}%{?extraver:%{extraver}}
190
191%patch0 -p1 -b .japanese
192%patch1 -p1 -b .shortcut
193
194# update ja.po
195%__cp -f %{SOURCE1} po/ja.po
196
197%build
198%configure \
199        --disable-mono --disable-perl --disable-tcl \
200        --disable-gtkspell --disable-meanwhile \
201%if %{ssl_lib}
202        --enable-gnutls=yes --enable-nss=no \
203%else
204        --enable-gnutls=no --enable-nss=yes \
205%endif
206%if %{?_dist_release} == "vl4"
207        --disable-nm \
208        --disable-gstreamer \
209%else
210        --enable-nm \
211        --enable-gstreamer \
212%endif
213        --enable-dbus \
214        --disable-gstreamer-interfaces \
215        --disable-idn \
216        --disable-gevolution \
217        --disable-schemas-install \
218        --disable-debug \
219        --disable-vv
220
221%__make %{?_smp_mflags}
222
223%install
224%__rm -rf %{buildroot}
225%makeinstall DBUS_SERVICES_DIR=%{buildroot}%{_datadir}/dbus-1/services
226
227%find_lang %{name}
228
229# remove unneeded files
230%{_bindir}/find %{buildroot}%{_libdir} -name "*.la" -exec %__rm -f "{}" \;
231%{_bindir}/find %{buildroot}%{_libdir} -name "*.a" -exec %__rm -f "{}" \;
232
233%post
234# install gconf rule
235export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
236for schema in purple ; do
237        %{_bindir}/gconftool-2 --makefile-install-rule \
238                %{_sysconfdir}/gconf/schemas/${schema}.schemas > /dev/null ||:
239done
240
241touch --no-create %{_datadir}/icons/hicolor
242if [ -x /usr/bin/gtk-update-icon-cache ]; then
243  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
244fi
245
246%pre
247if [ "$1" -gt 1 ]; then
248  export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
249  for schema in purple ; do
250        %{_bindir}/gconftool-2 --makefile-uninstall-rule \
251                %{_sysconfdir}/gconf/schemas/${schema}.schemas > /dev/null ||:
252  done
253fi
254
255%preun
256if [ "$1" -eq 0 ]; then
257  export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
258  for schema in purple ; do
259        %{_bindir}/gconftool-2 --makefile-uninstall-rule \
260                %{_sysconfdir}/gconf/schemas/${schema}.schemas > /dev/null ||:
261  done
262fi
263
264%postun
265touch --no-create %{_datadir}/icons/hicolor
266if [ -x /usr/bin/gtk-update-icon-cache ]; then
267  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
268fi
269
270%post -n libpurple
271%{_syssbindir}/ldconfig
272
273%postun -n libpurple
274%{_syssbindir}/ldconfig
275
276%post -n finch
277%{_syssbindir}/ldconfig
278
279%postun -n finch
280%{_syssbindir}/ldconfig
281
282%clean
283%__rm -rf %{buildroot}
284
285%files
286%defattr(-,root,root)
287%{_sysconfdir}/gconf/schemas/purple.schemas
288%{_bindir}/pidgin
289%{_libdir}/pidgin/
290%{_mandir}/man*/pidgin.*
291%{_datadir}/applications/pidgin.desktop
292%{_datadir}/pixmaps/pidgin/
293%{_datadir}/icons/*/*/*/pidgin.*
294#%{_datadir}/dbus-1/services/gaim.service
295
296%files devel
297%defattr(-,root,root)
298%{_includedir}/pidgin
299%{_libdir}/pkgconfig/pidgin.pc
300
301%files -n libpurple -f %{name}.lang
302%defattr(-,root,root)
303%doc NEWS COPYING AUTHORS README ChangeLog doc/*.txt
304%{_bindir}/purple-*
305%{_libdir}/libpurple.so.*
306%{_libdir}/libpurple-*.so.*
307%{_libdir}/purple-*
308%dir %{_datadir}/purple
309%{_datadir}/purple/ca-certs/
310%{_datadir}/sounds/purple
311
312%files -n libpurple-devel
313%defattr(-,root,root)
314%doc ChangeLog.API HACKING PLUGIN_HOWTO
315%{_includedir}/libpurple
316%{_libdir}/libpurple.so
317%{_libdir}/libpurple-*.so
318%{_libdir}/pkgconfig/purple.pc
319%{_datadir}/aclocal/purple.m4
320
321%files -n finch
322%defattr(-,root,root)
323%{_bindir}/finch
324%{_libdir}/finch
325%{_libdir}/libgnt.so.*
326%{_libdir}/gnt
327%{_mandir}/man*/finch.*
328
329%files -n finch-devel
330%defattr(-,root,root)
331%{_includedir}/finch
332%{_includedir}/gnt
333%{_libdir}/libgnt.so
334%{_libdir}/pkgconfig/finch.pc
335%{_libdir}/pkgconfig/gnt.pc
336
337%changelog
338* Mon Jan 18 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.6.5-1
339- new upstream release with security fixes (CVE-2010-0013)
340
341* Sat Oct 31 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.6.3-1
342- new upstream release with security fixes (CVE-2009-3615)
343
344* Wed Oct  7 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.6.2-4
345- update ja.po (Thanks to Harada-san)
346
347* Sat Sep 26 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.6.2-3
348- fix dependency
349
350* Fri Sep 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.6.2-2
351- fix if branch section for vine4 build
352
353* Fri Sep 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.6.2-1
354- new upstream release with security fixes (CVE-2009-2703,3026,3083,3085)
355- add configure option --disable-vv
356- add configure option --disable-gstreamer,--disable-gstreamer-interfaces
357- add BR: libidn-devel for Vine5 and later
358- add %if branch for vine4 build
359
360* Sun Aug 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.5.9-1
361- new upstream release with security fix (CVE-2009-2694)
362
363* Mon Jun 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.5.8-1
364- new upstream release
365- update Patch0
366
367* Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.5.7-1
368- new upstream release
369- add BR: intltool
370- update Patch0
371
372* Mon May 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.5.6-1
373- new upstream release with security fix (CVE-2009-1373,4,5,6)
374- update Patch0
375
376* Mon May 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 2.5.5-1
377- new upstream release
378- update Patch0
379- add BuildRequires: NetworkManager-devel
380
381* Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.5.1-3
382- rebuild with gnutls-2.6.3
383
384* Fri Sep 05 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.5.1-2
385- add BuildRequires: libXScrnSaver-devel
386
387* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
388- new upstream release
389- update Patch0
390- diable meawhile integration
391
392* Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-2
393- updated Patch0
394
395* Sun Apr 13 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.1-1vl5
396- new upstream release
397- updated Patch0
398
399* Sat Dec 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.3.1-0vl2
400- update ja.po (source1)
401
402* Sat Dec 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.3.1-0vl1
403- new upstream release
404- update jp.diff (patch0)
405- update ja.po (source1)
406
407* Mon Oct 08 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.2.1-0vl1
408- [SECURITY] new upstream release
409  - MSN Remote "Nudge" DoS (CVE-2007-4996)
410- update jp.diff (patch0)
411- update ja.po (source1)
412- update %%files section
413- add BuildRequires: avahi-glib-devel, doxygen
414
415* Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.0.2-0vl1
416- new upstream release
417- update jp.diff (patch0)
418- update ja.po (source1)
419
420* Sun May 20 2007 KAZUKI SHIMURA <ksh753@gmail.com> 2.0.0-0vl3
421- move pidgin.mo to libpurple package
422
423* Sun May 20 2007 KAZUKI SHIMURA <ksh753@gmail.com> 2.0.0-0vl2
424- use more macros
425- separate {libpurple,finch}-{,devel} packages
426- add BuildRequires: dbus-glib-devel
427- s/mozilla-nss/nss/
428
429* Sat May 19 2007 KAZUKI SHIMURA <ksh753@gmail.com> 2.0.0-0vl1
430- new upstream release
431- update jp.diff (patch0)
432- run gtk-update-icon-cache with '--force'
433
434* Sat May 05 2007 KAZUKI SHIMURA <ksh753@gmail.com> 2.0.0-0vl0.0beta7.1
435- fix scripts
436- add PreReq: gtk2 >= 2.6.0
437
438* Sat May 05 2007 KAZUKI SHIMURA <ksh753@gmail.com> 2.0.0-0vl0.0beta7
439- new upstream release (2.0.0beta7)
440- update and modify jp.diff (patch0)
441- update enable-shortcut.patch (patch1)
442- gaim -> pidgin
443  - add Obsoletes: gaim
444  - update %%files
445
446* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0-0vl0.0beta6.1
447- rebuild with dbus-1.0
448
449* Mon Jan 29 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.0.0-0vl0.0beta6
450- upstream release (2.0.0beta6)
451- update jp.diff (patch0)
452- drop jp-oscar.patch (patch2)
453
454* Sat Dec 09 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.0.0-0vl0.0beta5
455- upstream release (2.0.0beta5)
456- update jp.diff (patch0; based on 2.0.0beta4_jp.diff)
457- update enable-shortcut.patch (patch1)
458- add jp-oscar.patch (patch2)
459  - cf. http://garakuta.homelinux.org/~nosuke/diary/diary.html?y=2006&m=11&d=12&n=1#12-1
460- add BuildRequires: {libxml2,sqlite3,gstreamer,ncurses}-devel
461- add '--disable-mono --disable-schemas-install' options to %%configure
462- update %%files
463- run gconftool-2 at %%post,preun
464
465* Tue Oct 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.0.0-0vl0.0beta3.5
466- rebuild with gnutls-1.4.1
467
468* Fri Sep 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.0.0-0vl0.0beta3.4
469- add --disable-gevolution option to %%configure
470  not to depend on evolution-data-server
471
472* Thu Aug 31 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.0.0-0vl0.0beta3.3
473- rebuilt without evolution-data-server-devel
474
475* Sun Aug 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.0.0-0vl0.0beta3.2
476- upstream release (2.0.0beta3.1)
477
478* Sat Apr 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.0.0-0vl0.0beta3.1
479- add Requires: %%{name} = %%{version} to -devel package
480
481* Mon Apr 03 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.0.0-0vl0.0beta3
482- upstream release (2.0.0beta3)
483- update jp.diff
484- use original ja.po
485- use DBUS_SERVICES_DIR instead of DBUS_SESSION_DIR
486
487* Sat Mar 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.0.0-0vl0.0beta2.2
488- update ja.po
489
490* Sun Mar 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.0-0vl0.0beta2.1
491- rebuild with dbus-0.61
492
493* Mon Feb 06 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.0.0-0vl0.0beta2
494- upstream release (2.0.0beta2)
495- update jp.diff
496- use original ja.po
497- add %%{_datadir}/pixmaps/gaim.svg
498
499* Wed Dec 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.0.0-0vl0.0beta1.1
500- update ja.po
501
502* Tue Dec 27 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.0.0-0vl0.0beta1
503- upstream release (2.0.0beta1)
504- use gnutls instead of mozilla-nss
505- update jp.diff, ja.po
506- add BuildRequires: dbus-devel, Requires: dbus
507- add enable-shortcut.patch to enable shortcut keys
508
509* Sun Aug 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.5.0-0vl1
510- [SECURITY FIX] upstream release
511  - AIM/ICQ non-UTF-8 filename crash (CAN-2005-2102)
512  - AIM/ICQ away message buffer overflow (CAN-2005-2103)
513  - Gadu-Gadu memory alignment bug (CAN-2005-2370)
514- update jp.patch, ja.po
515
516* Sat Jul 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
517- upstream release
518- update jp.patch (to 1.3.1-1), ja.po
519
520* Fri Jun 10 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
521- [SECURITY FIX] upstream release
522  - Remote Yahoo! crash (CAN-2005-1269)
523  - MSN Remote DoS (CAN-2005-1934)
524- update ja.po
525- use gaim.desktop in source archive
526  - drop gaim.desktop (source10)
527
528* Thu May 12 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.0-0vl1
529- [SECURITY FIX] upstream release
530  - Remote crash on some protocols (CAN-2005-1261)
531  - MSN Remote DoS (CAN-2005-1262)
532- update ja.po
533
534* Sat Apr 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
535- update jp.patch, ja.po
536
537* Sat Apr 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
538- [SECURITY FIX] upstream release
539  - Remote DoS on receiving malformed HTML (CAN-2005-0965)
540  - Remote DoS on receiving certain messages over IRC (CAN-2005-0966)
541  - Jabber remote crash (CAN-2005-0967)
542- update jp.patch, ja.po
543- add Requires: glib2-devel for devel package
544- remove %%{_libdir}/gaim/*.la from devel package
545
546* Mon Mar 28 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
547- add ssl_lib macro to switch SSL library (gnutls/mozilla-nss)
548
549* Fri Mar 18 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
550- upstream release
551- update jp.patch, ja.po
552
553* Fri Mar 18 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.4-0vl2
554- rebuild with rpm-4.0.5-1vl10 to strip shared libraries
555
556* Sat Feb 26 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.4-0vl1
557- [SECURITY FIX] upstream release
558- update ja.po
559- change devel's group to Development/Libraries
560
561* Sat Feb 19 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.3-0vl1
562- [SECURITY FIX] upstream release
563- update jp.patch, ja.po, gaim.desktop
564- add PreReq: ldconfig
565
566* Sun Jan 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
567- upstream release
568- update jp.patch, ja.po
569
570* Wed Jan 05 2005 KAUZKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
571- upstream release
572- update jp.patch, ja.po
573
574* Sun Dec 05 2004 KAUZKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
575- upstream release
576- update jp.patch, ja.po
577
578* Tue Nov 16 2004 KAUZKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
579- upstream release
580- update jp.patch, ja.po
581
582* Fri Oct 22 2004 KAUZKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
583- upstream release
584- update ja.po
585
586* Sun Oct 10 2004 KAUZKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-0vl1
587- upstream release
588- update jp patch, ja.po
589
590* Tue Sep 21 2004 KAUZKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.0-0vl1
591- upstream release
592- update jp patch, ja.po
593
594* Sun Aug 28 2004 KAUZKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.82.1-0vl1
595- upstream release
596- update jp patch, ja.po
597
598* Sun Aug 08 2004 KAUZKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.81-0vl1
599- upstream release
600- update jp patch
601- modify ja.po
602
603* Fri Jul 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80-0vl2
604- add translated desktop file (%%{SOURCE10})
605
606* Thu Jul 22 2004 KAUZKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.80-0vl1
607- upstream release
608- drop ja.po
609- disable tcl scripting support
610- move *.la to devel package
611- add pkgconfig/gaim.pc to devel package
612
613* Sun Jun 27 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.79-0vl2
614- add ja.po (translated by AIHANA-san)
615
616* Sat Jun 26 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.79-0vl1
617- upstream release
618- update jp patch
619
620* Wed Jun 02 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.78-0vl1
621- upstream release
622- update jp patch
623
624* Tue Apr 27 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.77-0vl1
625- upstream release
626- updated jp patch
627- added (Build)Requires: pango(-devel), startup-notification(-devel)
628
629* Mon Apr 05 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.76-0vl2
630- separate devel package
631- modify summary and description
632
633* Mon Apr 05 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.76-0vl1
634- upstream release
635- updated jp patch
636
637* Wed Dec 03 2003 KAZUKI SHIMURA <rito@pos.to> 0.74-0vl1
638- upstream release
639- updated jp patch
640
641* Tue Nov 11 2003 KAZUKI SHIMURA <rito@pos.to> 0.72-0vl2
642- updated jp patch
643
644* Tue Nov 04 2003 KAZUKI SHIMURA <rito@pos.to> 0.72-0vl1
645- upstream release
646- modified jp patch
647
648* Tue Oct 14 2003 KAZUKI SHIMURA <rito@pos.to> 0.71-0vl1
649- upstream release
650- updated jp patch
651- added (Build)Requires: mozilla-nss(-devel), mozilla-nspr(-devel)
652- added (Build)Requires: audio-file(-devel), libao(-devel)
653
654* Tue Sep 30 2003 KAZUKI SHIMURA <rito@pos.to> 0.70-0vl1
655- upstream release
656- updated jp patch
657
658* Sun Sep 28 2003 KAZUKI SHIMURA <rito@pos.to> 0.69-0vl2
659- updated jp patch
660
661* Fri Sep 26 2003 KAZUKI SHIMURA <rito@pos.to> 0.69-0vl1
662- upstream release
663- updated Japanese patch
664
665* Thu Sep 04 2003 KAZUKI SHIMURA <rito@pos.to> 0.68-0vl1
666- upstream release
667- updated Japanese patch
668
669* Sun Jul 27 2003 KAZUKI SHIMURA <rito@pos.to> 0.66-0vl1
670- upstream release
671- updated Japanese patch
672
673* Wed Jul 16 2003 KAZUKI SHIMURA <rito@pos.to> 0.64-0vl2
674- added Japanese patch
675- fixed
676  - Spec was in Shift_JIS.
677  - Summary in Japanese was not on Summary(ja) but on Summary.
678
679* Tue Jun 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.64-0vl1
680- new upstream release
681- gtk2 version.
682
683* Fri May 30 2003 KAZUKI SHIMURA <rito@pos.to> 0.59.9-0vl1
684- updated to 0.59.9
685- modified Japanese patch (Patch 0)
686
687* Sun Feb 16 2003 KAZUKI SHIMURA <rito@pos.to> 0.59.8-0vl2
688- updated Japanese patch
689
690* Mon Jan 20 2003 KAZUKI SHIMURA <rito@pos.to> 0.59.8-0vl1
691- updated Japanese patch
692
693* Sat Jan 18 2003 KAZUKI SHIMURA <rito@pos.to>
694- upstream release
695- modified Japanese patch
696
697* Sat Dec 07 2002 KAZUKI SHIMURA <rito@pos.to> 0.59.6-0vl1
698- upstream release
699- eliminate old Japanese patch, add new Japanese patch
700
701* Sat Sep 21 2002 KAZUKI SHIMURA <rito@pos.to> 0.59.3-0vl1
702- upstream release
703
704* Sat Sep 21 2002 KAZUKI SHIMURA <rito@pos.to> 0.59.2-1vl2
705- added japanese patch
706
707* Wed Sep 11 2002 IWAI Masaharu <iwai@alib.jp> 0.59.2-1vl1
708- upstream release
709- dropped japanese patch
710- dropped STATUS in %%doc
711
712* Wed Feb 27 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.52-1vl1
713- upstream release
714- updated japanese patch
715- obsoleted automake patch
716
717* Mon Feb  4 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.51-1vl1
718- upstream release
719- updated japanese patch
720- added automake patch (exec automake --gnu, patched japanese patch)
721
722* Mon Jan 14 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 0.49-1vl1
723- first build for Vine Linux ( based Rawhide 0.43-1 )
724- added japanese patch ( Patch0 )
725- added HACKING and STATUS in %%doc
726- added --disable-gnome option in configure options
727- added gtk+-devel >= 1.2.3 and glib-devel >= 1.2.3 in BuildRequires
728- eliminated gnome-core-devel and gnome-libs-devel from BuildRequires tag
729- eliminated aspell from Requires tag
730- eliminated gnome-core from Prereq tag
731- eliminated Epoch tag
732- used %%makeinstall macro in %%install stage
733
734* Fri Sep 14 2001 Matt Wilson <msw@redhat.com>
735- update to 0.43
736
737* Fri Aug 03 2001 Christopher Blizzard <blizzard@redhat.com>
738- Add BuildRequires for gnome-libs-devel (bug #44739)
739
740* Mon Jul 02 2001 Christopher Blizzard <blizzard@redhat.com>
741- Add BuildRequires for gnome-core-devel (bug #44739)
742
743* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
744- Bump release + rebuild.
745
746* Thu Feb 15 2001 Trond Eivind Glomsr藷?<teg@redhat.com>
747- make it compile
748
749* Sun Feb 11 2001 Tim Powers <timp@redhat.com>
750- updated to 0.11.0pre4 (bug fixes)
751- applied Bero's konqueror patch to fix kfm->konq
752
753* Tue Dec  5 2000 Tim Powers <timp@redhat.com>
754- updated to 0.11.0pre2
755- enable gnome support
756- updated ispell to aspell patch
757- cleaned up file list
758
759* Thu Nov 16 2000 Tim Powers <timp@redhat.com>
760- updated to 0.10.3
761
762* Fri Nov 10 2000 Tim Powers <timp@redhat.com>
763- update to 0.10.2
764
765* Mon Sep 11 2000 Tim Powers <timp@redhat.com>
766- some ideas taken from the package available at the gaim website, mainly to install the applet stuff too.
767
768* Wed Aug 9 2000 Tim Powers <timp@redhat.com>
769- added Serial so that we can upgrade from Helix packages from 6.2
770
771* Mon Jul 24 2000 Prospector <prospector@redhat.com>
772- rebuilt
773
774* Tue Jul 18 2000 Tim Powers <timp@redhat.com>
775- changed default spell checker to aspell from ispell, patched.
776- requires aspell
777
778* Mon Jul 10 2000 Tim Powers <timp@redhat.com>
779- rebuilt
780
781* Thu Jun 22 2000 Tim Powers <timp@redhat.com>
782- fixed problems with ldconfig PreReq, shouls have been /sbin/ldconfig
783
784* Mon Jun 12 2000 Preston Brown <pbrown@redhat.com>
785- 0.9.19
786- fix ldconfig stuff
787
788* Thu Jun 1 2000 Tim Powers <timp@redhat.com>
789- cleaned up spec for use with RPM 4.0 (al la _sysconfdir _datadir etc)
790- update to 0.9.17
791- yay! a man page!
792
793* Thu May 25 2000 Tim Powers <timp@redhat.com>
794- we left a bunch of stuff out, pixmaps, plugins. Fixed
795- added applnk entry
796
797* Wed May 10 2000 Tim Powers <timp@redhat.com>
798- updated to 0.9.15
799
800* Mon Apr 24 2000 Matt Wilson <msw@redhat.com>
801- updated to 0.9.14
802
803* Mon Apr 24 2000 Matt Wilson <msw@redhat.com>
804- updated to 0.9.13
805
806* Thu Feb 10 2000 Matt Wilson <msw@redhat.com>
807- added patch to prevent floating point errors in lag-o-meter update
808  code
809
810* Wed Nov 10 1999 Tim Powers <timp@redhat.com>
811- updated to 0.9.10
812
813* Tue Jul 13 1999 Tim Powers <timp@redhat.com>
814- rebuilt and put into Powertools 6.1
815
816* Mon Jul 12 1999 Dale Lovelace <dale@redhat.com>
817- First RPM Build
Note: See TracBrowser for help on using the repository browser.