source: projects/specs/trunk/p/pidentd/pidentd-vl.spec @ 521

Revision 521, 5.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _noVersionedDependencies 1
2%define initdir /etc/rc.d/init.d
3
4Summary: An implementation of the RFC1413 identification server.
5Name: pidentd
6Version: 3.0.19
7Release: 1%{?_dist_release}
8License: Public domain
9Group: System Environment/Daemons
10Source: ftp://ftp.lysator.liu.se/pub/unix/ident/servers/pidentd-%{version}.tar.gz
11Patch0: pidentd-3.0.10-dummy.patch
12Patch1: pidentd-3.0.12-nospace.patch
13Source1: identd.conf
14Source2: identd.init
15Source3: sysconfig.identd
16Provides: identd = %{version}
17PreReq: chkconfig, fileutils, sed, initscripts >= 5.54, util-linux >= 2.11a-4
18BuildRequires: openssl-devel glibc-devel
19BuildRoot: %{_tmppath}/%{name}-root
20Distribution: Vine Linux
21Vendor: Project Vine
22
23%description
24The pidentd package contains identd, which implements the RFC1413
25identification server.  Identd looks up specific TCP/IP connections
26and returns either the user name or other information about the
27process that owns the connection.
28
29Install pidentd if you need to look up information about specific
30TCP/IP connections.
31
32%prep
33%setup -q
34#%patch0 -p1 -b .dummy
35%patch1 -p1 -b .nospace
36
37%build
38%configure --with-threads=yes --with-des=yes
39make
40make -C src # itest idecrypt ikeygen
41
42%install
43rm -rf $RPM_BUILD_ROOT
44mkdir -p ${RPM_BUILD_ROOT}%{_sbindir}
45mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man8
46
47%makeinstall
48
49pushd $RPM_BUILD_ROOT
50
51ln -s identd .%{_sbindir}/in.identd    # XXX /etc/inetd.conf may need this
52ln -s identd.8 .%{_mandir}/man8/in.identd.8
53
54mkdir -p ./%{_sysconfdir} ./%{initdir}
55install -m 0644 %SOURCE1 .%{_sysconfdir}/identd.conf
56install -m 0755 %SOURCE2 .%{initdir}/identd
57
58popd
59
60mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig
61install -m 644 %SOURCE3 $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/identd
62touch $RPM_BUILD_ROOT/%{_sysconfdir}/identd.key
63
64# remove unpackaged files from the buildroot
65rm -f $RPM_BUILD_ROOT%{_sbindir}/ibench
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%pre
71groupadd -g 98 ident >/dev/null 2>&1 || :
72useradd -M -n -g ident -o -r -d / -s /sbin/nologin \
73        -c "pident user" -u 98 ident >/dev/null 2>&1 || :
74
75%post
76/sbin/chkconfig --add identd
77
78# XXX forcibly remove pidentd from inetd's control
79cd /etc &&
80  [ -f inetd.conf ] &&
81  sed -e 's/^[  ]*auth[         ]/#&/' < inetd.conf > inetd.conf.xxx &&
82  cat inetd.conf.xxx > inetd.conf
83rm -f /etc/inetd.conf.xxx
84
85%preun
86if [ $1 = 0 ]; then
87    /sbin/service identd stop > /dev/null 2>&1
88    /sbin/chkconfig --del identd
89fi
90
91%postun
92if [ "$1" -ge "1" ]; then
93    /sbin/service identd condrestart > /dev/null 2>&1
94fi
95
96%files
97%defattr(-,root,root)
98%doc BUGS ChangeLog FAQ INSTALL README Y2K doc/rfc1413.txt KNOWNBUGS
99%{_sbindir}/idecrypt
100%{_sbindir}/ikeygen
101%{_sbindir}/identd
102%{_sbindir}/in.identd
103%attr(0644,root,root)   %config %{_sysconfdir}/identd.conf
104%attr(0644,root,root)   %config(noreplace) %{_sysconfdir}/sysconfig/identd
105%config(missingok,noreplace) %ghost  %attr(0600,root,root) %{_sysconfdir}/identd.key
106%attr(0755,root,root)   %config %{initdir}/identd
107%{_mandir}/man8/*
108
109%changelog
110* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.19-1vl5
111- new upstream release
112- dropt pidentd-3.0.10-dummy.patch
113- applied new versioning policy
114
115* Mon Mar 29 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.16-0vl2
116- resync fedora 3.0.16-2
117
118* Thu Mar  4 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.16-0vl1
119- add PreReq: chkconfig, sed
120- new upstream release
121
122* Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.10-5vl6
123- rebuild to remove rpmlib dependancy
124
125* Tue May 29 2001 <sagami@vinelinux.org>
126- 3.0.10-5vl5: use better macros due to building difficulty
127
128* Thu Nov 09 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
129- 3.0.10-5vl4
130- added _noVersionedDependencies flag
131
132* Mon Nov 6 2000 Kazuhisa TAKEI <takei@vinelinux.org> 3.0.10-5vl2
133- rebuild on rpm 3.0.6
134
135* Wed Jul 12 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
136- 3.0.10-5vl1
137- added --without-des argument for %configure line
138
139* Tue Feb 22 2000 Jeff Johnson <jbj@redhat.com>
140- forcibly remove pidentd from inetd's control in %post.
141
142* Mon Feb 21 2000 Bill Nottingham <notting@redhat.com>
143- add patch to drop privs correctly
144
145* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
146- compress man pages.
147
148* Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
149- rebuild to fix depenencies
150
151* Wed Jan 19 2000 Jeff Johnson <jbj@redhat.com>
152- update to 3.0.10.
153
154* Wed Jan 12 2000 Jeff Johnson <jbj@redhat.com>
155- update to 3.0.8.
156- reduce no. of kernel threads to 2 in default configuration.
157
158* Tue Jan  4 2000 Bill Nottingham <notting@redhat.com>
159- return of the init script
160
161* Wed Sep 29 1999 Bill Nottingham <notting@redhat.com>
162- fix unaligned traps on Alpha
163- oops, take init script out
164
165* Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
166- strip binaries
167
168* Sat Sep  4 1999 Jeff Johnson <jbj@redhat.com>
169- start identd through inetd.conf.
170
171* Tue Aug 24 1999 Bill Nottingham <notting@redhat.com>
172- start after NFS mounts (for NFS /usr)
173
174* Thu Aug 19 1999 Jeff Johnson <jbj@redhat.com>
175- start identd with same options as were used when started by inetd.
176
177* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
178- update to 3.0.7.
179
180* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
181- initscript munging
182
183* Fri Aug  6 1999 Jeff Johnson <jbj@redhat.com>
184- update to 3.0.5.
185
186* Tue Feb  2 1999 Jeff Johnson <jbj@redhat.com>
187- update to 3.0.2.
188- use %configure
189
190* Thu Nov 12 1998 Jeff Johnson <jbj@redhat.com>
191- update to 2.8.4.
192
193* Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
194- build root
195
196* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
197- translations modified for de, fr, tr
198
199* Thu Oct 21 1997 Cristian Gafton <gafton@redhat.com>
200- updated to 2.7
201
202* Fri Jul 18 1997 Erik Troan <ewt@redhat.com>
203- built against glibc
Note: See TracBrowser for help on using the repository browser.