source: projects/specs/trunk/p/physfs/physfs-vl.spec @ 8952

Revision 8952, 4.8 KB checked in by Takemikaduchi, 10 years ago (diff)

physfs: update to 2.0.3
others: rebuild

Line 
1%define name physfs
2%define version 2.0.3
3%define release 1%{?_dist_release}
4
5Summary: Library to provide abstract access to various archives
6Name: %{name}
7Version: %{version}
8Release: %{release}
9Source0: http://icculus.org/physfs/downloads/%{name}-%{version}.tar.bz2
10
11
12License: BSD
13Group: System Environment/Libraries
14URL: http://icculus.org/physfs/
15
16BuildRequires: zlib-devel, readline-devel, doxygen
17BuildRequires: cmake
18BuildRequires: wxGTK-devel
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21%description
22 PhysicsFS is a library to provide abstract access to various archives.
23It is intended for use in video games, and the design was somewhat
24inspired by Quake 3's file subsystem.
25The programmer defines a "write directory" on the physical filesystem.
26No file writing done through the PhysicsFS API can leave that write directory,
27for security.
28For example, an embedded scripting language cannot write outside
29of this path if it uses PhysFS for all of its I/O, which means
30that untrusted scripts can run more safely.
31Symbolic links can be disabled as well, for added safety.
32For file reading, the programmer lists directories and archives
33that form a "search path".
34Once the search path is defined, it becomes a single,
35transparent hierarchical filesystem.
36This makes for easy access to ZIP files in the same way
37as you access a file directly on the disk,
38and it makes it easy to ship a new archive
39that will override a previous archive on a per-file basis.
40Finally, PhysicsFS gives you platform-abstracted means to determine
41if CD-ROMs are available, the user's home directory,
42where in the real filesystem your program is running, etc.
43
44%package devel
45Summary: Development libraries and headers for physfs
46Group: Development/Libraries
47Requires: %{name} = %{version}-%{release}
48
49%description devel
50This package contains the libraries and headers necessary for developing
51packages with physfs functionality.
52
53
54%prep
55%setup -q
56
57%build
58%ifarch x86_64
59mv CMakeLists.txt CMakeLists.txt.orig
60cat CMakeLists.txt.orig \
61        | sed "s/LIBRARY DESTINATION lib/LIBRARY DESTINATION %{_lib}/" \
62        | sed "s/ARCHIVE DESTINATION lib/ARCHIVE DESTINATION %{_lib}/" \
63        > CMakeLists.txt
64%endif
65cmake -D CMAKE_INSTALL_PREFIX=%{_prefix} .
66make %{?_smp_mflags}
67doxygen
68
69%install
70%{__rm} -rf ${RPM_BUILD_ROOT}
71make DESTDIR=${RPM_BUILD_ROOT} install
72%{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}/*.la
73%{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}/*.a
74mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
75install -m0644 docs/man/man3/* $RPM_BUILD_ROOT%{_mandir}/man3
76
77# Handle man page conflicts (bz #183705) from Fedora
78mv $RPM_BUILD_ROOT%{_mandir}/man3/author.3 \
79    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-author.3
80mv $RPM_BUILD_ROOT%{_mandir}/man3/description.3 \
81    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-description.3
82mv $RPM_BUILD_ROOT%{_mandir}/man3/extension.3 \
83    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-extension.3
84mv $RPM_BUILD_ROOT%{_mandir}/man3/major.3 \
85    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-major.3
86mv $RPM_BUILD_ROOT%{_mandir}/man3/minor.3 \
87    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-minor.3
88mv $RPM_BUILD_ROOT%{_mandir}/man3/patch.3 \
89    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-patch.3
90mv $RPM_BUILD_ROOT%{_mandir}/man3/url.3 \
91    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-url.3
92
93%clean
94%{__rm} -rf ${RPM_BUILD_ROOT}
95
96%post -p /sbin/ldconfig
97
98%postun -p /sbin/ldconfig
99
100%files
101%defattr(-,root,root,-)
102%doc CHANGELOG.txt CREDITS.txt LICENSE.txt TODO.txt
103%{_libdir}/*.so.*
104%{_bindir}/test_physfs
105
106%files devel
107%defattr(-,root,root,-)
108%doc docs/html/ docs/latex/
109%{_includedir}/physfs.h
110%{_libdir}/*.so
111%{_mandir}/man3/*
112
113%changelog
114* Mon Sep 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.3-1
115- update to 2.0.3
116- remove Patch0,1
117
118* Wed Jul 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.0.2-1
119- new upstream release
120- added Patch0,1 from Debian sid
121- added BuildRequires: wxGTK-devel
122
123* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1vl5
124- applied new versioning policy
125
126* Thu Jan 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-0vl3
127- updated CMakeLists.txt for lib64
128
129* Fri Sep 07 2007 Atsushi SHICHI <ats777@gmail.com> 1.1.1-0vl2
130- remove "-D PHYSFS_BUILD_TEST:BOOL=OFF" from cmake option.
131- add test_physfs to %%files.
132
133* Thu Sep 06 2007 Atsushi SHICHI <ats777@gmail.com> 1.1.1-0vl1
134- new upstream release.
135- add "BuildRequires: cmake".
136- to use cmake instead of %%configure.
137- update %%files.
138- temporarily remove test_physfs from %%files.
139- remove libphysfs.la from %%files devel.
140
141* Mon Sep 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.1.0-0vl1
142- initial build for Vine Linux 4.1
143
144* Mon Oct 17 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.1.0-0vlmp2
145- change Group: System Environment/Libraries
146
147* Fri Jun 24 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0.0-0vlmp1
148- initial build for Vine Linux 3.2
149
150# end of file
Note: See TracBrowser for help on using the repository browser.