source: projects/specs/trunk/p/physfs/physfs-vl.spec @ 6550

Revision 6550, 4.8 KB checked in by kudoh, 12 years ago (diff)
Line 
1%define name physfs
2%define version 2.0.2
3%define release 1%{?_dist_release}
4
5Summary: Library to provide abstract access to various archives
6Name: %{name}
7Version: %{version}
8Release: %{release}
9Source0: http://icculus.org/physfs/downloads/%{name}-%{version}.tar.gz
10Patch0: do_not_link_against_curses.diff
11Patch1: remove_unused_variable.diff
12
13
14License: BSD
15Group: System Environment/Libraries
16URL: http://icculus.org/physfs/
17
18BuildRequires: zlib-devel, readline-devel, doxygen
19BuildRequires: cmake
20BuildRequires: wxGTK-devel
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22
23%description
24 PhysicsFS is a library to provide abstract access to various archives.
25It is intended for use in video games, and the design was somewhat
26inspired by Quake 3's file subsystem.
27The programmer defines a "write directory" on the physical filesystem.
28No file writing done through the PhysicsFS API can leave that write directory,
29for security.
30For example, an embedded scripting language cannot write outside
31of this path if it uses PhysFS for all of its I/O, which means
32that untrusted scripts can run more safely.
33Symbolic links can be disabled as well, for added safety.
34For file reading, the programmer lists directories and archives
35that form a "search path".
36Once the search path is defined, it becomes a single,
37transparent hierarchical filesystem.
38This makes for easy access to ZIP files in the same way
39as you access a file directly on the disk,
40and it makes it easy to ship a new archive
41that will override a previous archive on a per-file basis.
42Finally, PhysicsFS gives you platform-abstracted means to determine
43if CD-ROMs are available, the user's home directory,
44where in the real filesystem your program is running, etc.
45
46%package devel
47Summary: Development libraries and headers for physfs
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50
51%description devel
52This package contains the libraries and headers necessary for developing
53packages with physfs functionality.
54
55
56%prep
57%setup -q
58%patch0 -p1
59%patch1 -p1
60
61%build
62%ifarch x86_64
63mv CMakeLists.txt CMakeLists.txt.orig
64cat CMakeLists.txt.orig \
65        | sed "s/LIBRARY DESTINATION lib/LIBRARY DESTINATION %{_lib}/" \
66        | sed "s/ARCHIVE DESTINATION lib/ARCHIVE DESTINATION %{_lib}/" \
67        > CMakeLists.txt
68%endif
69cmake -D CMAKE_INSTALL_PREFIX=%{_prefix} .
70make %{?_smp_mflags}
71doxygen
72
73%install
74%{__rm} -rf ${RPM_BUILD_ROOT}
75make DESTDIR=${RPM_BUILD_ROOT} install
76#%{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}/*.la
77mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
78install -m0644 docs/man/man3/* $RPM_BUILD_ROOT%{_mandir}/man3
79
80# Handle man page conflicts (bz #183705) from Fedora
81mv $RPM_BUILD_ROOT%{_mandir}/man3/author.3 \
82    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-author.3
83mv $RPM_BUILD_ROOT%{_mandir}/man3/description.3 \
84    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-description.3
85mv $RPM_BUILD_ROOT%{_mandir}/man3/extension.3 \
86    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-extension.3
87mv $RPM_BUILD_ROOT%{_mandir}/man3/major.3 \
88    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-major.3
89mv $RPM_BUILD_ROOT%{_mandir}/man3/minor.3 \
90    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-minor.3
91mv $RPM_BUILD_ROOT%{_mandir}/man3/patch.3 \
92    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-patch.3
93mv $RPM_BUILD_ROOT%{_mandir}/man3/url.3 \
94    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-url.3
95
96%clean
97%{__rm} -rf ${RPM_BUILD_ROOT}
98
99%post -p /sbin/ldconfig
100
101%postun -p /sbin/ldconfig
102
103%files
104%defattr(-,root,root,-)
105%doc CHANGELOG.txt CREDITS.txt LICENSE.txt TODO.txt
106%{_libdir}/*.so.*
107%{_bindir}/test_physfs
108%{_bindir}/wxtest_physfs
109
110%files devel
111%defattr(-,root,root,-)
112%doc docs/html/ docs/latex/
113%{_includedir}/physfs.h
114%{_libdir}/*.a
115#%{_libdir}/*.la
116%{_libdir}/*.so
117%{_mandir}/man3/*
118
119%changelog
120* Wed Jul 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.0.2-1
121- new upstream release
122- added Patch0,1 from Debian sid
123- added BuildRequires: wxGTK-devel
124
125* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1vl5
126- applied new versioning policy
127
128* Wed Jan 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-0vl3
129- updated CMakeLists.txt for lib64
130
131* Fri Sep 07 2007 Atsushi SHICHI <ats777@gmail.com> 1.1.1-0vl2
132- remove "-D PHYSFS_BUILD_TEST:BOOL=OFF" from cmake option.
133- add test_physfs to %%files.
134
135* Wed Sep 06 2007 Atsushi SHICHI <ats777@gmail.com> 1.1.1-0vl1
136- new upstream release.
137- add "BuildRequires: cmake".
138- to use cmake instead of %%configure.
139- update %%files.
140- temporarily remove test_physfs from %%files.
141- remove libphysfs.la from %%files devel.
142
143* Mon Sep 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.1.0-0vl1
144- initial build for Vine Linux 4.1
145
146* Mon Oct 17 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.1.0-0vlmp2
147- change Group: System Environment/Libraries
148
149* Fri Jun 24 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0.0-0vlmp1
150- initial build for Vine Linux 3.2
151
152# end of file
Note: See TracBrowser for help on using the repository browser.