source: projects/specs/trunk/p/physfs/physfs-vl.spec @ 9463

Revision 9463, 5.0 KB checked in by inagaki, 9 years ago (diff)

2015-03-22 Ryoichi INAGAKI <ryo1@…>

  • device-mapper-multipath, lvm2, libqalculate, ntp, perl-Term-ReadLine?-Gnu, physfs, postgresql: rebuilt


Line 
1Summary: Library to provide abstract access to various archives
2Summary(ja): 様々なアーカイブへの抽象的アクセスを提供するライブラリ
3Name: physfs
4Version: 2.0.3
5Release: 2%{?_dist_release}
6Source0: http://icculus.org/physfs/downloads/%{name}-%{version}.tar.bz2
7
8License: zlib
9Group: System Environment/Libraries
10URL: http://icculus.org/physfs/
11
12BuildRequires: zlib-devel, readline-devel, doxygen
13BuildRequires: cmake
14BuildRequires: wxGTK-devel
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17%description
18PhysicsFS is a library to provide abstract access to various archives. It is
19intended for use in video games, and the design was somewhat inspired by Quake
203's file subsystem. The programmer defines a "write directory" on the physical
21filesystem. No file writing done through the PhysicsFS API can leave that
22write directory, for security. For example, an embedded scripting language
23cannot write outside of this path if it uses PhysFS for all of its I/O, which
24means that untrusted scripts can run more safely. Symbolic links can be
25disabled as well, for added safety. For file reading, the programmer lists
26directories and archives that form a "search path". Once the search path is
27defined, it becomes a single, transparent hierarchical filesystem. This makes
28for easy access to ZIP files in the same way as you access a file directly on
29the disk, and it makes it easy to ship a new archive that will override a
30previous archive on a per-file basis. Finally, PhysicsFS gives you
31platform-abstracted means to determine if CD-ROMs are available, the user's
32home directory, where in the real filesystem your program is running, etc.
33
34%package devel
35Summary: Development libraries and headers for physfs
36Summary(ja): Physfs の開発用ライブラリ並びにヘッダファイル
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39
40%description devel
41This package contains the libraries and headers necessary for developing
42packages with physfs functionality.
43
44
45%prep
46%setup -q
47
48%build
49%ifarch x86_64
50mv CMakeLists.txt CMakeLists.txt.orig
51cat CMakeLists.txt.orig \
52        | sed "s/LIBRARY DESTINATION lib/LIBRARY DESTINATION %{_lib}/" \
53        | sed "s/ARCHIVE DESTINATION lib/ARCHIVE DESTINATION %{_lib}/" \
54        > CMakeLists.txt
55%endif
56cmake -D CMAKE_INSTALL_PREFIX=%{_prefix} .
57make %{?_smp_mflags}
58doxygen
59
60%install
61%{__rm} -rf ${RPM_BUILD_ROOT}
62make DESTDIR=${RPM_BUILD_ROOT} install
63%{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}/*.la
64%{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}/*.a
65mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
66install -m0644 docs/man/man3/* $RPM_BUILD_ROOT%{_mandir}/man3
67
68# Handle man page conflicts (bz #183705) from Fedora
69mv $RPM_BUILD_ROOT%{_mandir}/man3/author.3 \
70    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-author.3
71mv $RPM_BUILD_ROOT%{_mandir}/man3/description.3 \
72    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-description.3
73mv $RPM_BUILD_ROOT%{_mandir}/man3/extension.3 \
74    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-extension.3
75mv $RPM_BUILD_ROOT%{_mandir}/man3/major.3 \
76    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-major.3
77mv $RPM_BUILD_ROOT%{_mandir}/man3/minor.3 \
78    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-minor.3
79mv $RPM_BUILD_ROOT%{_mandir}/man3/patch.3 \
80    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-patch.3
81mv $RPM_BUILD_ROOT%{_mandir}/man3/url.3 \
82    $RPM_BUILD_ROOT%{_mandir}/man3/physfs-url.3
83
84%clean
85%{__rm} -rf ${RPM_BUILD_ROOT}
86
87%post -p /sbin/ldconfig
88
89%postun -p /sbin/ldconfig
90
91%files
92%defattr(-,root,root,-)
93%doc CHANGELOG.txt CREDITS.txt LICENSE.txt TODO.txt
94%{_libdir}/*.so.*
95%{_bindir}/test_physfs
96
97%files devel
98%defattr(-,root,root,-)
99%doc docs/html/ docs/latex/
100%{_includedir}/physfs.h
101%{_libdir}/*.so
102%{_mandir}/man3/*
103
104%changelog
105* Sun Mar 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 2.0.3-2
106- rebuilt with readline 6.3
107- fixed License to zlib
108- added Japanese summary
109
110* Mon Sep 15 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 2.0.3-1
111- update to 2.0.3
112- remove Patch0,1
113
114* Wed Jul 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 2.0.2-1
115- new upstream release
116- added Patch0,1 from Debian sid
117- added BuildRequires: wxGTK-devel
118
119* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-1vl5
120- applied new versioning policy
121
122* Thu Jan 03 2008 Shu KONNO <owa@bg.wakwak.com> 1.1.1-0vl3
123- updated CMakeLists.txt for lib64
124
125* Fri Sep 07 2007 Atsushi SHICHI <ats777@gmail.com> 1.1.1-0vl2
126- remove "-D PHYSFS_BUILD_TEST:BOOL=OFF" from cmake option.
127- add test_physfs to %%files.
128
129* Thu Sep 06 2007 Atsushi SHICHI <ats777@gmail.com> 1.1.1-0vl1
130- new upstream release.
131- add "BuildRequires: cmake".
132- to use cmake instead of %%configure.
133- update %%files.
134- temporarily remove test_physfs from %%files.
135- remove libphysfs.la from %%files devel.
136
137* Mon Sep 3 2007 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.1.0-0vl1
138- initial build for Vine Linux 4.1
139
140* Mon Oct 17 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.1.0-0vlmp2
141- change Group: System Environment/Libraries
142
143* Fri Jun 24 2005 Munehiro Yamamoto <myamamoto@g.math.s.chiba-u.ac.jp> 1.0.0-0vlmp1
144- initial build for Vine Linux 3.2
145
146# end of file
Note: See TracBrowser for help on using the repository browser.