source: projects/specs/trunk/p/php-pear-Net-SMTP/php-pear-Net-SMTP-vl.spec @ 5913

Revision 5913, 6.3 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1%{!?__pear: %{expand: %%global __pear %{_bindir}/pear5}}
2%global pear_name Net_SMTP
3
4Name:           php-pear-Net-SMTP
5Version:        1.6.1
6Release:        3%{?_dist_release}
7Summary:        Provides an implementation of the SMTP protocol
8
9Group:          Development/Libraries
10License:        PHP
11URL:            http://pear.php.net/package/Net_SMTP
12Source0:        http://pear.php.net/get/%{pear_name}-%{version}.tgz
13Source2:        xml2changelog
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16BuildArch:      noarch
17BuildRequires:  php-pear(PEAR) >= 1.9.1
18
19Requires(post): %{__pear}
20Requires(postun): %{__pear}
21Provides:       php-pear(%{pear_name}) = %{version}
22Requires:       php-pear(PEAR) >= 1.4.9
23Requires:       php-pear(Net_Socket) >= 1.0.7
24Requires:       php-pear(Auth_SASL)
25
26
27%description
28Provides an implementation of the SMTP protocol using PEAR's Net_Socket class.
29
30php-pear-Net-SMTP can optionally use package "php-pear-Auth-SASL".
31
32
33%prep
34%setup -q -c
35%{_bindir}/php -n %{SOURCE2} package.xml | tee CHANGELOG | head -n 2
36
37cd %{pear_name}-%{version}
38# package.xml is V2
39mv ../package.xml %{name}.xml
40
41
42%build
43cd %{pear_name}-%{version}
44# Empty build section, most likely nothing required.
45
46
47%install
48rm -rf %{buildroot}
49cd %{pear_name}-%{version}
50
51%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
52
53# Clean up unnecessary files
54rm -rf %{buildroot}%{pear_phpdir}/.??*
55
56# Install XML package description
57%{__mkdir_p} %{buildroot}%{pear_xmldir}
58%{__install} -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
59
60
61%check
62# Sanity check
63lst=$(find %{buildroot}%{pear_phpdir} -exec grep -q %{buildroot} {} \; -print)
64[ ! -z "$lst" ] && echo "Reference to BUILDROOT in $lst" && exit 1;
65
66# For documentation purpose only
67# After install, as root :
68# cd /usr/share/pear/test/Net_SMTP/tests
69# cp config.php.dist config.php
70# vi config.php # you should use a working mail account
71# pear run-tests -p Net_SMTP
72# Should return
73# 3 PASSED TESTS
74# 0 SKIPPED TESTS
75
76
77%clean
78rm -rf %{buildroot}
79
80
81%post
82%{__pear} install --nodeps --soft --force --register-only \
83    %{pear_xmldir}/%{name}.xml >/dev/null || :
84
85
86%postun
87if [ $1 -eq 0 ] ; then
88    %{__pear} uninstall --nodeps --ignore-errors --register-only \
89        %{pear_name} >/dev/null || :
90fi
91
92
93%files
94%defattr(-,root,root,-)
95%doc CHANGELOG
96%doc %{pear_docdir}/%{pear_name}
97%{pear_phpdir}/Net/*
98%{pear_testdir}/%{pear_name}
99%{pear_xmldir}/%{name}.xml
100
101%changelog
102* Tue Mar 13 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.1-3
103- initial build for Vine Linux
104
105* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.1-2
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
107
108* Tue Aug 16 2011 Remi Collet <Fedora@FamilleCollet.com> 1.6.1-1
109- Version 1.6.1 (stable) - API 1.2.0 (stable)
110
111* Fri Jun 10 2011 Remi Collet <Fedora@FamilleCollet.com> 1.6.0-1
112- Version 1.6.0 (stable) - API 1.2.0 (stable)
113
114* Sat Apr 17 2011 Remi Collet <Fedora@FamilleCollet.com> 1.5.2-1
115- Version 1.5.2 (stable) - API 1.1.3 (stable)
116
117* Fri Mar 11 2011 Remi Collet <Fedora@FamilleCollet.com> 1.5.1-1
118- Version 1.5.1 (stable) - API 1.1.3 (stable)
119- keep doc in pear_docdir
120
121* Sun Feb 13 2011 Remi Collet <Fedora@FamilleCollet.com> 1.5.0-1
122- Version 1.5.0 (stable) - API 1.1.3 (stable)
123
124* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.4-2
125- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
126
127* Mon Oct 11 2010 Remi Collet <Fedora@FamilleCollet.com> 1.4.4-1
128- Version 1.4.4 (stable) - API 1.1.3 (stable)
129
130* Mon Oct 11 2010 Remi Collet <Fedora@FamilleCollet.com> 1.4.3-1
131- Version 1.4.3 (stable) - API 1.1.3 (stable)
132- set timezone during build
133
134* Tue Mar 09 2010 Remi Collet <Fedora@FamilleCollet.com> 1.4.2-1
135- update to 1.4.2
136
137* Mon Jan 25 2010 Remi Collet <Fedora@FamilleCollet.com> 1.4.1-1
138- update to 1.4.1
139
140* Sun Jan 24 2010 Remi Collet <Fedora@FamilleCollet.com> 1.4.0-1
141- update to 1.4.0
142- add examples to %%doc
143
144* Sun Nov 29 2009 Remi Collet <Fedora@FamilleCollet.com> 1.3.4-1
145- update to 1.3.4
146
147* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.3-2
148- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
149
150* Tue Jul 14 2009 Remi Collet <Fedora@FamilleCollet.com> 1.3.3-1
151- update to 1.3.3
152- rename Net_SMTP.xml to php-pear-Net-SMTP.xml
153
154* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.2-2
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
156
157* Sun Dec 21 2008 Remi Collet <Fedora@FamilleCollet.com> 1.3.2-1
158- update to 1.3.2
159
160* Tue Jun 10 2008 Remi Collet <Fedora@FamilleCollet.com> 1.3.1-1
161- update to 1.3.1
162- add Comment on howto to run test suite
163
164* Sun Apr 27 2008 Remi Collet <Fedora@FamilleCollet.com> 1.3.0-1
165- update to 1.3.0
166
167* Fri Feb 15 2008 Remi Collet <Fedora@FamilleCollet.com> 1.2.11-1
168- update to 1.2.11
169- fix License
170
171* Sat Mar 31 2007 Remi Collet <Fedora@FamilleCollet.com> 1.2.10-1
172- remove PEAR from sumnary
173- update to 1.2.10
174- requires Net_Socket >= 1.0.7
175- spec cleanup
176- add generated CHANGELOG
177- don't own /usr/share/pear/Net (already own by Net_Socket)
178
179* Fri Sep 08 2006 Remi Collet <Fedora@FamilleCollet.com> 1.2.8-5
180- last template.spec
181
182* Sun Sep 03 2006 Remi Collet <Fedora@FamilleCollet.com> 1.2.8-4
183- new and simpler %%prep and %%install
184
185* Sat Sep 02 2006 Remi Collet <Fedora@FamilleCollet.com> 1.2.8-3
186- install Licence in prep
187- use new macros from /etc/rpm/macros.pear
188- own /usr/share/pear/Net
189- require php >= 4.0.5
190
191* Sat May 20 2006 Remi Collet <Fedora@FamilleCollet.com> 1.2.8-2
192- Require pear >= 1.4.9
193- bundle the v3.01 PHP LICENSE file
194- use --packagingroot (instead of -R)
195- check from install to check (as in php-pear)
196- Remove Auth_SASL from Requires (optional)
197
198* Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.2.8-1
199- spec for extras
200- workaround for buggy pear 1.4.6 installer
201- use %%{_datadir}/pear/.pkgxml for XML (Bug #190252)
202
203* Thu Apr 06 2006 Remi Collet <rpms@FamilleCollet.com> 1.2.8-3.fc{3,4,5}.remi
204- change /var/lib/pear to %%{_libdir}/php/pear for XML (as in extras for FC5)
205- spec cleanning
206
207* Sat Mar 04 2006 Remi Collet <RPMS@FamilleCollet.com> 1.2.8-2.fc{3,4}.remi
208- add Requires: php-pear(Auth_SASL)
209
210* Sat Feb 25 2006 Remi Collet <RPMS@FamilleCollet.com> 1.2.8-1.fc{3,4}.remi
211- update to 1.2.8
212
213* Sat Jan  7 2006 Remi Collet <remi.collet@univ-reims.fr> 1.2.7-1.fc{3,4}.remi
214- initial RPM
Note: See TracBrowser for help on using the repository browser.