source: projects/specs/trunk/p/php-pear-Mail/php-pear-Mail-vl.spec @ 5913

Revision 5913, 4.8 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1%{!?__pear: %{expand: %%global __pear %{_bindir}/pear5}}
2%global pear_name Mail
3
4Name:           php-pear-Mail
5Version:        1.2.0
6Release:        4%{?_dist_release}
7Summary:        Class that provides multiple interfaces for sending emails
8
9Group:          Development/Libraries
10License:        BSD
11URL:            http://pear.php.net/package/Mail
12Source0:        http://pear.php.net/get/%{pear_name}-%{version}.tgz
13Source2:        xml2changelog
14
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16
17BuildArch:      noarch
18BuildRequires:  php-pear(PEAR) >= 1.5.6
19Requires:       php-pear(PEAR) >= 1.5.6
20Requires:       php-pear(Net_SMTP) >= 1.4.1
21Requires(post): %{__pear}
22Requires(postun): %{__pear}
23Provides:       php-pear(%{pear_name}) = %{version}
24
25
26%description
27PEAR's Mail package defines an interface for implementing mailers under the
28PEAR hierarchy.  It also provides supporting functions useful to multiple
29mailer backends.  Currently supported backends include: PHP's native
30mail() function, sendmail, and SMTP.  This package also provides a RFC822
31email address list validation utility class.
32
33
34%prep
35%setup -q -c
36
37# Package is V2
38%{_bindir}/php -n %{SOURCE2} package.xml >CHANGELOG
39mv package.xml %{pear_name}-%{version}/%{name}.xml
40
41
42%build
43cd %{pear_name}-%{version}
44# Empty build section, most likely nothing required.
45
46
47%install
48rm -rf %{buildroot}
49cd %{pear_name}-%{version}
50%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
51
52# Clean up unnecessary files
53rm -rf %{buildroot}%{pear_phpdir}/.??*
54
55# Install XML package description
56mkdir -p %{buildroot}%{pear_xmldir}
57install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
58
59
60%clean
61rm -rf %{buildroot}
62
63
64%post
65%{__pear} install --nodeps --soft --force --register-only \
66    %{pear_xmldir}/%{name}.xml >/dev/null || :
67
68%postun
69if [ $1 -eq 0 ] ; then
70    %{__pear} uninstall --nodeps --ignore-errors --register-only \
71        %{pear_name} >/dev/null || :
72fi
73
74
75%files
76%defattr(-,root,root,-)
77%doc CHANGELOG
78%{pear_phpdir}/Mail.php
79%{pear_phpdir}/Mail
80%{pear_testdir}/Mail
81%{pear_xmldir}/%{name}.xml
82
83
84%changelog
85* Tue Mar 13 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.0-4
86- initial build for Vine Linux
87
88* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-3
89- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
90
91* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
92- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
93
94* Mon Mar  1 2010 Remi Collet <Fedora@FamilleCollet.com> 1.2.0-1
95- update to 1.2.0
96- license is now BSD
97
98* Fri Nov 27 2009 Remi Collet <Fedora@FamilleCollet.com> 1.1.14-5
99- Fix CVE-2009-4023 (#540842)
100- rename Mail.xml to php-pear-Mail.xml
101
102* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.14-4
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
104
105* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.14-3
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
107
108* Fri Aug 24 2007 Remi Collet <Fedora@FamilleCollet.com> 1.1.14-2
109- Fix License
110
111* Thu Oct 12 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.14-1
112- update to 1.1.14
113
114* Sat Sep 16 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.13-1
115- regenerate SPEC with pear make-rpm-spec
116- remove PEAR from sumnary
117- update to 1.1.13
118- add generated CHANGELOG %%doc
119
120* Fri Sep 08 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-8
121- last template.spec
122
123* Mon Sep 04 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-7
124- new and simpler %%prep and %%install
125
126* Mon Aug 28 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-6
127- FE6 rebuild
128
129* Sat Jul 22 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-5
130- remove "rm pearrc"
131- secure scriplet with || :
132- install Licence in prep
133- use new macros from /etc/rpm/macros.pear
134
135* Mon May 15 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-4
136- Require pear >= 1:1.4.9
137- Requires(hint): php-pear(Net_SMTP) >= 1.1.0 (only comment actually)
138- bundle the v3.01 PHP LICENSE file
139- use --packagingroot (instead of -R)
140- check from install to check (as in php-pear)
141
142* Sun May 14 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-3
143- License : PHP -> PHP License
144
145* Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-2
146- new spec for extras
147- use %%{_datadir}/pear/.pkgxml for XML (Bug #190252)
148
149* Thu Apr 27 2006 Remi Collet <Fedora@FamilleCollet.com> 1.1.10-1
150- spec for extras
151
152* Wed Apr 26 2006 Remi Collet <rpms@FamilleCollet.com> 1.1.10-1.fc{3,4,5}.remi
153- update to 1.1.10
154
155* Thu Apr 06 2006 Remi Collet <rpms@FamilleCollet.com> 1.1.9-2.fc{3,4,5}.remi
156- change /var/lib/pear to %%{_libdir}/php/pear for XML (as in extras for FC5)
157- spec cleanning
158
159* Sat Jan  7 2006 Remi Collet <remi.collet@univ-reims.fr> 1.1.9-1.fc{3,4}.remi
160- initial RPM
Note: See TracBrowser for help on using the repository browser.