source: projects/specs/trunk/p/php-pear-Log/php-pear-Log-vl.spec @ 5913

Revision 5913, 7.9 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1%{!?__pear: %{expand: %%global __pear /usr/bin/pear5}}
2%global pear_name Log
3
4Summary:        Abstracted logging facility for PHP
5Name:           php-pear-Log
6Version:        1.12.7
7Release:        1%{?_dist_release}
8License:        MIT
9Group:          Development/Libraries
10Source          http://pear.php.net/get/Log-%{version}.tgz
11Source2:        xml2changelog
12
13BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14URL:            http://pear.php.net/package/Log
15
16BuildArch:      noarch
17## Vine's php5-pear is a subpackage from php5 (internal version 1.9.4)
18BuildRequires:  php-pear(PEAR) >= 1.4.9
19Requires:       php-pear(PEAR) >= 1.4.9
20Requires:       php-pear
21Requires:       php-pear(DB) >= 1.3
22Requires:       php-pear(MDB2) >= 2.0.0
23Requires:       php-pear(Mail)
24Requires(post): %{__pear}
25Requires(postun): %{__pear}
26Provides:       php-pear(Log) = %{version}
27
28
29%description
30The Log framework provides an abstracted logging system.
31It supports logging to console, file, syslog, SQL, Sqlite, mail, and mcal
32targets.  It also provides a subject - observer mechanism.
33
34php-pear-Log can optionally use package "php-pear-DB" (version >= 1.3)
35and "php-pear-MDB2" (version >= 2.0.0RC1).
36
37
38%prep
39%setup -c -q
40%{_bindir}/php -n %{SOURCE2} package.xml | tee CHANGELOG | head -n 10
41
42cd %{pear_name}-%{version}
43# package.xml is V2
44mv ../package.xml %{name}.xml
45
46
47%build
48# Empty build section
49
50
51%install
52rm -rf %{buildroot}
53
54pushd Log-%{version}
55%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
56
57# Clean up unnecessary files
58rm -rf %{buildroot}%{pear_phpdir}/.??*
59
60# Install XML package description
61install -D -p -m 644 %{name}.xml %{buildroot}%{pear_xmldir}/%{name}.xml
62
63popd
64
65
66%clean
67rm -rf %{buildroot}
68
69
70%check
71lst=$(find %{buildroot}%{pear_phpdir} -exec grep -q %{buildroot} {} \; -print)
72[ ! -z "$lst" ] && echo "Reference to BUILDROOT in $lst" && exit 1;
73
74cd %{pear_name}-%{version}
75%{__pear} \
76   run-tests \
77   -i "-d include_path=%{buildroot}%{pear_phpdir}:%{pear_phpdir}" \
78   tests | tee ../tests.log
79grep "FAILED TESTS" ../tests.log && exit 1
80
81
82%post
83%{__pear} install --nodeps --soft --force --register-only %{pear_xmldir}/%{name}.xml >/dev/null || :
84
85
86%postun
87if [ "$1" -eq "0" ]; then
88    %{__pear} uninstall --nodeps --ignore-errors --register-only %{pear_name} >/dev/null || :
89fi
90
91
92%files
93%defattr(-,root,root,-)
94%doc CHANGELOG
95%doc %{pear_docdir}/%{pear_name}
96%{pear_phpdir}/Log
97%{pear_phpdir}/Log.php
98%{pear_testdir}/Log
99%{pear_datadir}/Log
100%{pear_xmldir}/%{name}.xml
101
102
103%changelog
104* Tue Mar 13 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.12.7-1
105- initial build for Vine Linux
106
107* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12.7-2
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
109
110* Thu Sep 22 2011 Remi Collet <Fedora@FamilleCollet.com> 1.12.7-1
111- Version 1.12.7 (stable) - API 1.0.0 (stable)
112- minor spec cleanups
113
114* Fri May 27 2011 Remi Collet <Fedora@FamilleCollet.com> 1.12.6-1
115- Version 1.12.6 (stable) - API 1.0.0 (stable)
116
117* Sun Apr 17 2011 Remi Collet <Fedora@FamilleCollet.com> 1.12.5-4
118- remove temporary link in doc
119
120* Wed Mar 16 2011 Remi Collet <Fedora@FamilleCollet.com> 1.12.5-3
121- doc in %%{pear_docdir}
122
123* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.12.5-2
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
125
126* Fri Dec 23 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.5-1
127- Version 1.12.5 (stable) - API 1.0.0 (stable)
128
129* Mon Dec  6 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.4-1.1
130- levels.phpt fails, see http://pear.php.net/bugs/18099
131
132* Mon Dec  6 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.4-1
133- Version 1.12.4 (stable) - API 1.0.0 (stable)
134
135* Tue Sep 28 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.3-1
136- Version 1.12.3 (stable) - API 1.0.0 (stable)
137- run tests during %%check
138
139* Sun Aug 29 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.2-1
140- Version 1.12.2 (stable) - API 1.0.0 (stable)
141
142* Sat May 29 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.1-1
143- bump release (missing sources)
144
145* Sat May 29 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.1-1
146- update to Version 1.12.1 (stable) - API 1.0.0 (stable)
147- type in french description
148
149* Mon Jan 25 2010 Remi Collet <Fedora@FamilleCollet.com> 1.12.0-1
150- update to 1.12.0
151
152* Sat Dec 26 2009 Remi Collet <Fedora@FamilleCollet.com> 1.11.6-1
153- update to 1.11.6
154
155* Sat Aug 08 2009 Remi Collet <Fedora@FamilleCollet.com> 1.11.5-1
156- update to 1.11.5
157- rename Log.xml to php-pear-Log.xml
158
159* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.11.4-2
160- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
161
162* Mon Mar 30 2009 Remi Collet <Fedora@FamilleCollet.com> 1.11.4-1
163- update to 1.11.4
164
165* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.11.3-2
166- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
167
168* Sat Nov 22 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.3-1
169- update to 1.11.3
170
171* Fri Sep 05 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.2-1
172- update to 1.11.2
173
174* Wed Aug 06 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.1-1
175- update to 1.11.1
176
177* Sat Jun 28 2008 Remi Collet <Fedora@FamilleCollet.com> 1.11.0-1
178- update to 1.11.0 : switch from PHP to MIT license
179
180* Thu May 08 2008 Remi Collet <Fedora@FamilleCollet.com> 1.10.1-1
181- update to 1.10.1
182
183* Sat Jan 26 2008 Remi Collet <Fedora@FamilleCollet.com> 1.10.0-1
184- update to 1.10.0
185- add Requires php-pear(Mail) (new handler)
186- remove levels.patch (merged upstream)
187
188* Sat Jan 26 2008 Remi Collet <Fedora@FamilleCollet.com> 1.9.16-1
189- update to 1.9.16
190- add examples in documentation
191- add levels.patch http://pear.php.net/bugs/bug.php?id=12933
192
193* Wed Jan 02 2008 Remi Collet <Fedora@FamilleCollet.com> 1.9.14-1
194- update to 1.9.14
195
196* Thu Dec 13 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.13-1
197- update to 1.9.13
198- add documentation in %%check (post install only)
199
200* Wed Dec 12 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.12-1
201- update to 1.9.12
202
203* Fri Aug 24 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.11-2
204- Fix License
205
206* Sat May 02 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.11-1
207- update to 1.9.11
208
209* Mon Feb 12 2007 Remi Collet <Fedora@FamilleCollet.com> 1.9.10-1
210- update to 1.9.10
211- All tests succeed with php-5.2.x : http://pear.php.net/bugs/bug.php?id=9023
212
213* Sat Oct 28 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.9-1
214- update to 1.9.9
215
216* Sat Sep 16 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-6
217- add CHANGELOG to %%doc
218
219* Fri Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-5.fc5.1
220- rebuild for FC5
221
222* Thu Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-5
223- BR php-pear >= 1:1.4.9-1.2
224
225* Thu Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-4
226- last template.spec
227
228* Mon Sep 04 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-3
229- new and simpler %%prep and %%install
230
231* Sat Sep 02 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-2
232- failsafe scriplet
233
234* Tue Aug 01 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.8-1
235- update to 1.9.8
236
237* Tue Jul 11 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.7-1
238- update to 1.9.7
239- use new macros from /etc/rpm/macros.pear
240
241* Tue May 30 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.6-1
242- install Licence in prep
243- update to 1.9.6
244
245* Mon May 15 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-3
246- Require pear >= 1.4.9
247- Requires(hint): (only comment actually) + description
248- bundle the v3.01 PHP LICENSE file (as in php-pear)
249- use --packagingroot (instead of -R)
250- check from install to check (as in php-pear)
251
252* Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-2
253- cleanning (description-line-too-long)
254
255* Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.5-1
256- use %%{_datadir}/pear/.pkgxml for XML (Bug #190252)
257- update to 1.9.5
258- workaround for buggy pear 1.4.6 installer
259
260* Thu Apr 27 2006 Remi Collet <Fedora@FamilleCollet.com> 1.9.4-1
261- spec for extras
262- add french summary & description
263
264* Wed Apr 26 2006 Remi Collet <rpms@FamilleCollet.com> 1.9.4-1.fc{3,4,5}.remi
265- update to 1.9.4
266
267* Thu Apr 06 2006 Remi Collet <rpms@FamilleCollet.com> 1.9.3-1.fc{3,4,5}.remi
268- initial RPM
Note: See TracBrowser for help on using the repository browser.