source: projects/specs/trunk/p/php-pear-Auth-SASL/php-pear-Auth-SASL-vl.spec @ 5913

Revision 5913, 4.1 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1# default values when new /etc/rpm/macros.pear not present
2%{!?__pear:       %global __pear       %{_bindir}/pear5}
3
4%global pear_name Auth_SASL
5
6Summary:     Abstraction of various SASL mechanism responses
7Name:        php-pear-Auth-SASL
8Version:     1.0.6
9Release:     3%{?_dist_release}
10License:     BSD
11Group:       Development/Libraries
12URL:         http://pear.php.net/package/Auth_SASL
13Source:      http://pear.php.net/get/%{pear_name}-%{version}.tgz
14
15BuildRoot:        %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
16BuildArch:        noarch
17BuildRequires:    php-pear(PEAR) >= 1.4.9
18
19Requires:         php-pear(PEAR) >= 1.4.9
20Requires(post):   %{__pear}
21Requires(postun): %{__pear}
22Provides:         php-pear(%{pear_name}) = %{version}
23
24%description
25Provides code to generate responses to common SASL mechanisms, including:
26o Digest-MD5
27o CramMD5
28o Plain
29o Anonymous
30o Login (Pseudo mechanism)
31
32
33%prep
34%setup -c -q
35mv package.xml %{pear_name}-%{version}/%{name}.xml
36
37
38%build
39# Empty build section
40
41
42%install
43rm -rf %{buildroot}
44
45cd %{pear_name}-%{version}
46%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
47
48# Clean up unnecessary files
49rm -rf %{buildroot}%{pear_phpdir}/.??*
50
51# Install XML package description
52mkdir -p %{buildroot}%{pear_xmldir}
53install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
54
55
56%check
57# Sanity check
58lst=$(find %{buildroot}%{pear_phpdir} -exec grep -q %{buildroot} {} \; -print)
59[ ! -z "$lst" ] && echo "Reference to BUILDROOT in $lst" && exit 1;
60
61
62%clean
63rm -rf %{buildroot}
64
65
66%post
67%{__pear} install --nodeps --soft --force --register-only %{pear_xmldir}/%{name}.xml >/dev/null || :
68
69
70%postun
71# if refcount = 0 then package has been removed (not upgraded)
72if [ "$1" -eq "0" ]; then
73    %{__pear} uninstall --nodeps --ignore-errors --register-only  %{pear_name} >/dev/null || :
74fi
75
76
77%files
78%defattr(-,root,root,-)
79%{pear_phpdir}/Auth
80%{pear_xmldir}/%{name}.xml
81
82
83%changelog
84* Tue Mar 13 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.6-3
85- initial build for Vine Linux
86
87* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.6-2
88- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
89
90* Sat Oct 01 2011 Remi Collet  <remi@fedoraproject.org> 1.0.6-1
91- update to 1.0.6 (API 1.0.3) - QA release
92
93* Wed Sep 14 2011 Remi Collet <Fedora@FamilleCollet.com> 1.0.5-1
94- update to 1.0.5 - QA release
95
96* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.4-2
97- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
98
99* Mon Feb 08 2010 Remi Collet <Fedora@FamilleCollet.com> 1.0.4-1
100- update to 1.0.4
101
102* Sat Aug 08 2009 Remi Collet <Fedora@FamilleCollet.com> 1.0.3-1
103- update to 1.0.3
104
105* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-7
106- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
107
108* Sat Apr 25 2009 Remi Collet <Fedora@FamilleCollet.com> 1.0.2-6
109- remove PEAR from sumnary
110- remove php (httpd) dependency
111- spec clean up
112
113* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-5
114- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
115
116* Thu Sep 07 2006 Remi Collet <Fedora@FamilleCollet.com> 1.0.2-4
117- last template.spec
118
119* Sun Sep 03 2006 Remi Collet <Fedora@FamilleCollet.com> 1.0.2-3
120- new and simpler %%prep and %%install
121
122* Sun Jul 23 2006 Remi Collet <Fedora@FamilleCollet.com> 1.0.2-2
123- use new macros from /etc/rpm/macros.pear
124- own /usr/share/pear/Auth
125
126* Sun May 21 2006 Remi Collet <Fedora@FamilleCollet.com> 1.0.2-1
127- update to new 1.0.2
128
129* Sat May 20 2006 Remi Collet <Fedora@FamilleCollet.com> 1.0.1-2
130- Require pear >= 1.4.9
131- use --packagingroot (instead of -R)
132- check from install to check (as in php-pear)
133
134* Sat May 06 2006 Remi Collet <Fedora@FamilleCollet.com> 1.0.1-1
135- spec for extras
136- use %%{_datadir}/pear/.pkgxml for XML (Bug #190252)
137
138* Thu Apr 06 2006 Remi Collet <rpms@FamilleCollet.com> 1.0.1-2.fc{3,4,5}.remi
139- change /var/lib/pear to %%{_libdir}/php/pear for XML (as in extras for FC5)
140- spec cleanning
141
142* Sat Mar 04 2006 Remi Collet <RPMS@FamilleCollet.com> 1.0.1-1.fc{3,4}.remi
143- initial RPM of 1.0.1
Note: See TracBrowser for help on using the repository browser.