source: projects/specs/trunk/p/php-ext-memcached/php-ext-memcached-vl.spec @ 12516

Revision 12516, 3.9 KB checked in by tomop, 3 years ago (diff)

updated 4 packages

php-ext-clearsilver-0.4-16

php-ext-mailparse-3.1.1-1

php-ext-memcached-3.1.5.git20201219-1

php-ext-phpredis-5.3.2-1

  • Property svn:executable set to *
Line 
1# needs launching memcached
2%bcond_with test
3
4%define build_targets 74 80
5%define extname memcached
6
7%global gitdate 20201219
8%global githash bfb0a66809d43080219ab5381235f848c91eff7e
9
10%define srcdir php-%{extname}-%{?githash:%{githash}}%{!?githash:%{version}}
11
12Summary: memcached extension for PHP
13Summary(ja): PHP用memcached拡張
14Name: php-ext-memcached
15Version: 3.1.5%{?gitdate:.git%{gitdate}}
16Release: 1%{_dist_release}
17Group: programming
18Vendor: Project Vine
19Distribution: Vine Linux
20Packager: tomop
21
22License: The PHP License
23%if %{?githash:1}%{!?githash:0}
24Source: https://github.com/php-memcached-dev/php-memcached/archive/%{githash}.tar.gz
25%else
26Source: https://github.com/php-memcached-dev/php-memcached/archive/v3.1.5.tar.gz#/php-%{extname}-%{version}.tar.gz
27%endif
28Patch0: sess_prefix.patch
29BuildRequires: libmemcached-devel
30BuildRequires: zlib-devel
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32
33%description
34This module enable to access memcached in PHP scripts.
35
36%description -l ja
37このモジュールは、PHPスクリプト中でmemcachedにアクセスできるようにします。
38
39
40%package -n php74-ext-%{extname}
41Summary: memcached extension for PHP-7.4
42Summary(ja): PHP-7.4用memcached拡張
43Group: programming
44BuildRequires: php74-devel
45%if "%{?req_php74_api}" != ""
46Requires: %{req_php74_api}
47%endif
48
49%description -n php74-ext-%{extname}
50This module enable to access memcached in PHP scripts.
51
52%description -n php74-ext-%{extname} -l ja
53このモジュールは、PHPスクリプト中でmemcachedにアクセスできるようにします。
54
55
56%package -n php80-ext-%{extname}
57Summary: memcached extension for PHP-8.0
58Summary(ja): PHP-8.0用memcached拡張
59Group: programming
60BuildRequires: php80-devel
61%if "%{?req_php80_api}" != ""
62Requires: %{req_php80_api}
63%endif
64
65%description -n php80-ext-%{extname}
66This module enable to access memcached in PHP scripts.
67
68%description -n php80-ext-%{extname} -l ja
69このモジュールは、PHPスクリプト中でmemcachedにアクセスできるようにします。
70
71
72%debug_package
73
74
75%prep
76%setup -T -c -a 0 -n %{srcdir}
77pushd %{srcdir}
78
79mkdir -p ../docs
80cp -f CREDITS LICENSE README* ChangeLog ../docs/
81popd
82
83for v in %{build_targets}; do
84cp -a %{srcdir} php${v}
85done
86
87
88%build
89for v in %{build_targets}; do
90pushd php${v}
91phpize${v}
92%configure --with-php-config=php-config${v}
93%__make %{?_smp_mflags}
94popd
95done
96
97
98%install
99rm -rf %{buildroot}
100
101cat > memcached.ini <<EOF
102; Enable memcached extension module
103extension=memcached.so
104
105EOF
106
107cat %{srcdir}/memcached.ini >> memcached.ini
108
109for v in %{build_targets}; do
110pushd php${v}
111
112mkdir -p %{buildroot}%{_libdir}/php${v}/
113mkdir -p %{buildroot}%{_sysconfdir}/php${v}/php.d
114%makeinstall INSTALL_ROOT=%{buildroot}
115
116install -m644 ../memcached.ini %{buildroot}%{_sysconfdir}/php${v}/php.d/memcached.ini
117
118cat > ../files.php${v} <<EOF
119%%defattr(-,root,root)
120%%doc docs/*
121%{_libdir}/php${v}/*
122%%config(noreplace) %{_sysconfdir}/php${v}/php.d/*
123EOF
124
125popd
126done
127
128
129%check
130%if %{with test}
131for v in %{build_targets}; do
132pushd php${v}
133NO_INTERACTION=yes TEST_PHPDBG_EXECUTABLE=/usr/bin/phpdbg${v} make test
134popd
135done
136%endif
137
138
139%clean
140rm -rf %{buildroot}
141
142%files -n php74-ext-%{extname} -f files.php74
143%files -n php80-ext-%{extname} -f files.php80
144
145
146%changelog
147* Sat Dec 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net>
148- added php80 support.
149- dropped php73 support.
150
151* Thu Dec 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.5-1
152- new upstream release.
153- added php74 support.
154
155* Fri Dec 21 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.1-1
156- new upstream release.
157- dropped Patch1: fixed in upstream.
158- drooped php72 support.
159
160* Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.5-1
161- added php73 support.
162
163* Wed Dec 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.4-1
164- new upstream release.
165
166* Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.3-1
167- initial build for Vine Linux.
Note: See TracBrowser for help on using the repository browser.