source: projects/specs/trunk/p/php-ext-mailparse/php-ext-mailparse-vl.spec @ 12516

Revision 12516, 4.4 KB checked in by tomop, 3 years ago (diff)

updated 4 packages

php-ext-clearsilver-0.4-16

php-ext-mailparse-3.1.1-1

php-ext-memcached-3.1.5.git20201219-1

php-ext-phpredis-5.3.2-1

  • Property svn:executable set to *
Line 
1%bcond_without php80
2%bcond_without php74
3
4%define extname mailparse
5
6Summary: Email message manipulation for PHP
7Summary(ja): PHP用e-mailメッセージ操作拡張
8Name: php-ext-%{extname}
9Version: 3.1.1
10Release: 1%{_dist_release}
11Group: programming
12Vendor: Project Vine
13Distribution: Vine Linux
14Packager: tomop
15
16License: The PHP License
17URL: https://pecl.php.net/package/mailparse
18Source: https://pecl.php.net/get/%{extname}-%{version}.tgz
19BuildRoot: %{_tmppath}/%{name}-%{version}-root
20
21%description
22 Mailparse is an extension for parsing and working with email messages.
23It can deal with rfc822 and rfc2045 (MIME) compliant messages.
24
25%description -l ja
26 Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
27rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
28
29
30%if %{with php74}
31%package -n php74-ext-mailparse
32Summary: Email message manipulation for PHP-7.4
33Summary(ja): PHP-7.4用e-mailメッセージ操作拡張
34Group: programming
35BuildRequires: php74-devel
36%if "%{?req_php74_api}" != ""
37Requires: %{req_php74_api}
38%endif
39
40%description -n php74-ext-mailparse
41 Mailparse is an extension for parsing and working with email messages.
42It can deal with rfc822 and rfc2045 (MIME) compliant messages.
43
44%description -n php74-ext-mailparse -l ja
45 Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
46rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
47%endif
48
49%if %{with php80}
50%package -n php80-ext-mailparse
51Summary: Email message manipulation for PHP-8.0
52Summary(ja): PHP-8.0用e-mailメッセージ操作拡張
53Group: programming
54BuildRequires: php80-devel
55%if "%{?req_php80_api}" != ""
56Requires: %{req_php80_api}
57%endif
58
59%description -n php80-ext-mailparse
60 Mailparse is an extension for parsing and working with email messages.
61It can deal with rfc822 and rfc2045 (MIME) compliant messages.
62
63%description -n php80-ext-mailparse -l ja
64 Mailparseモジュールは、e-mailメッセージの解析・操作を行うPHP拡張です。
65rfc822やrfc2045 (MIME)に準拠したメッセージを取り扱うことが可能です。
66%endif
67
68
69%debug_package
70
71
72%prep
73%setup -q -c -n %{extname}-%{version}
74cp %{extname}-%{version}/{LICENSE,README.md,CREDITS} ./
75
76%if %{with php74}
77cp -a %{extname}-%{version} php74
78pushd php74
79phpize74
80popd
81%endif
82
83%if %{with php80}
84cp -a %{extname}-%{version} php80
85pushd php80
86phpize80
87popd
88%endif
89
90
91%build
92%if %{with php74}
93pushd php74
94%configure --with-php-config=%{_bindir}/php-config74
95%__make %{?_smp_mflags}
96popd
97%endif
98
99%if %{with php80}
100pushd php80
101%configure --with-php-config=%{_bindir}/php-config80
102%__make %{?_smp_mflags}
103popd
104%endif
105
106
107%install
108rm -rf %{buildroot}
109%if %{with php74}
110mkdir -p %{buildroot}%{_libdir}/php74/
111mkdir -p %{buildroot}%{_sysconfdir}/php74/php.d
112pushd php74
113%makeinstall INSTALL_ROOT=%{buildroot}
114popd
115
116cat > %{buildroot}%{_sysconfdir}/php74/php.d/%{extname}.ini <<EOF
117; Enable %{extname} extension module
118extension=%{extname}.so
119
120EOF
121%endif
122
123%if %{with php80}
124mkdir -p %{buildroot}%{_libdir}/php80/
125mkdir -p %{buildroot}%{_sysconfdir}/php80/php.d
126pushd php80
127%makeinstall INSTALL_ROOT=%{buildroot}
128popd
129
130cat > %{buildroot}%{_sysconfdir}/php80/php.d/%{extname}.ini <<EOF
131; Enable %{extname} extension module
132extension=%{extname}.so
133
134EOF
135%endif
136
137
138%clean
139rm -rf %{buildroot}
140
141%if %{with php74}
142%files -n php74-ext-mailparse
143%defattr(-,root,root)
144%license LICENSE
145%doc README CREDITS
146%{_libdir}/php74/*
147%config(noreplace) %{_sysconfdir}/php74/php.d/*
148%endif
149
150%if %{with php80}
151%files -n php80-ext-mailparse
152%defattr(-,root,root)
153%license LICENSE
154%doc README CREDITS
155%{_libdir}/php80/*
156%config(noreplace) %{_sysconfdir}/php80/php.d/*
157%endif
158
159
160%changelog
161* Sat Dec 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.1-1
162- new upstream release.
163- added php80 support.
164- dropped php73 support.
165
166* Thu Dec 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.3-1
167- dropped Patch0: fixed in upstream.
168- added php74 support.
169- dropped php72 support.
170
171* Sat Dec 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.2-2
172- added php73 support.
173
174* Wed Dec 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.0.2-1
175- new upstream release.
176- built with php72.
177
178* Fri Apr 10 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-2
179- rebuilt with php5-5.6.7.
180
181* Fri Dec 13 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.6-1
182- initial build.
183
Note: See TracBrowser for help on using the repository browser.