source: projects/specs/trunk/p/php-ext-apc/php-ext-apc-vl.spec @ 6099

Revision 6099, 1.5 KB checked in by tomop, 12 years ago (diff)

added PHP extensions.

  • Property svn:executable set to *
Line 
1Summary: Alternative PHP Cache
2Name: php-ext-apc
3Version: 3.1.10
4Release: 1%{_dist_release}
5Source: APC-%{version}.tgz
6License: The PHP License
7Group: Development/Languages
8BuildRequires: php5-devel
9BuildRoot: %{_tmppath}/%{name}-%{version}-root
10Requires: %{req_php_api}
11
12%description
13APC is the Alternative PHP Cache. It was conceived of to provide a free,
14open, and robust framework for caching and optimizing PHP intermediate code.
15
16apc.php is placed into %{_docdir}/%{name}-%{version}.
17
18%package devel
19Summary: A header file to serialize with APC
20Group: Development/Libraries
21Requires: php5-devel
22Requires: %{name} = %{version}
23
24%description devel
25This package contains definitions of apc.serializer hooks.
26
27%prep
28%setup -q -n APC-%{version}
29mv ../package.xml ./
30phpize
31
32%build
33%configure --with-apc=shared --enable-mmap --enable-sem
34%__make %{?_smp_mflags}
35
36%install
37rm -rf %{buildroot}
38mkdir -p %{buildroot}%{_libdir}/php5/
39mkdir -p %{buildroot}%{_sysconfdir}/php5/php.d
40%makeinstall INSTALL_ROOT=%{buildroot}
41
42
43cat > %{buildroot}%{_sysconfdir}/php5/php.d/apc.ini <<EOF
44; Enable APC extension module
45extension="apc.so"
46
47EOF
48
49
50%clean
51rm -rf %{buildroot}
52
53%files
54%defattr(-,root,root)
55%doc CHANGELOG INSTALL LICENSE NOTICE TODO TECHNOTES.txt apc.php
56%{_libdir}/php5/*
57%config(noreplace) %{_sysconfdir}/php5/php.d/*
58
59%files devel
60%{_includedir}/php5/ext/apc
61
62%changelog
63* Sat Apr 28 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.1.10-1
64- new upstream release.
65
66* Wed Mar 11 2009 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.19-1
67- initial build.
68
Note: See TracBrowser for help on using the repository browser.