source: projects/specs/trunk/p/phonon/phonon-vl.spec @ 5037

Revision 5037, 5.9 KB checked in by inagaki, 13 years ago (diff)

update: akonadi, phonon

Line 
1%define qt4_ver 4.7.2
2# Qt4 version auto-detection
3%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
4%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
5%define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/include)
6
7%global pulseaudio_version %(pkg-config --modversion libpulse 2>/dev/null || echo 0.9.15)
8
9Name: phonon
10Summary: Multimedia framework api
11Summary(ja): マルチメディアフレームワーク API
12Version: 4.5.0
13Release: 2%{?_dist_release}
14
15Group: System Environment/Libraries
16License: LGPLv2+
17URL: http://phonon.kde.org/
18
19Source0: ftp://ftp.kde.org/pub/kde/stable/phonon/4.4.4/phonon-%{version}.tar.bz2
20
21Patch1: phonon-4.4.4-no_rpath.patch
22## Mandriva/upstreamable patches
23Patch53: phonon-4.3.50-phonon-allow-stop-empty-source.patch
24
25## Upstream patches
26Patch100: phonon-4.5.0-pulseaudio-1.0-qpow.patch
27
28## Vine patches
29Patch200: phonon-4.5.0-pulseaudio-1.0.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32BuildRequires: automoc4 >= 0.9.86
33BuildRequires: cmake >= 2.6.2
34BuildRequires: glib2-devel
35BuildRequires: libqzeitgeist-devel
36BuildRequires: libxcb-devel
37BuildRequires: libxml2-devel
38BuildRequires: qt4-devel >= 4.6.0
39BuildRequires: pulseaudio-libs-devel >= 0.9.15
40
41# TODO: enable the following Requires in next release
42Requires: phonon-backend >= 4.4
43Requires: pulseaudio-libs >= %{pulseaudio_version}
44Requires: qt4 >= %{_qt4_version}
45
46%description
47Phonon is a cross-platform portable Multimedia Support Abstraction,
48which allows you to play multiple audio or video formats with the same
49quality on all platforms, no matter which underlying architecture is
50used.
51
52%package devel
53Summary: Development files for phonon
54Summary(ja): phonon の開発用ファイル
55Group: Development/Libraries
56Requires: %{name} = %{version}-%{release}
57Requires: qt4-devel = %{_qt4_version}
58
59%description devel
60Header files for developing applications using phonon
61
62%prep
63%setup -q
64
65%patch1 -p1 -b .no_rpath
66%patch53 -p1 -b .phonon-allow-stop-empty-source
67
68%patch100 -p1 -b .qpow
69
70%patch200 -p0 -b .pulseaudio-1.0
71
72%build
73%ifarch x86_64
74PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
75%endif
76
77mkdir -p %{_target_platform}
78pushd %{_target_platform}
79unset QTDIR || : ; . /etc/profile.d/qt4.sh
80%cmake \
81    ..
82popd
83
84make %{?_smp_mflags} -C %{_target_platform}
85
86%install
87rm -rf $RPM_BUILD_ROOT
88
89make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
90
91# symlink for qt/phonon compatibility
92ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
93
94# own these dirs
95mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_backend/
96mkdir -p $RPM_BUILD_ROOT%{_datadir}/kde4/services/phononbackends/
97
98mkdir -p $RPM_BUILD_ROOT%{_qt4_headerdir}
99pushd $RPM_BUILD_ROOT%{_qt4_headerdir}
100ln -sf %{_includedir}/phonon phonon
101popd
102
103%clean
104rm -rf $RPM_BUILD_ROOT
105
106%post -p /sbin/ldconfig
107
108%postun -p /sbin/ldconfig
109
110%files
111%defattr(-,root,root)
112%doc COPYING.LIB
113%{_libdir}/*.so.*
114%{_qt4_plugindir}/designer/*.so
115%{_datadir}/dbus-1/interfaces/*
116# kde4-specific dirs
117%dir %{_libdir}/kde4/plugins/phonon_backend
118%dir %{_datadir}/kde4/services/phononbackends
119
120%files devel
121%defattr(-,root,root)
122%dir %{_includedir}/KDE
123%{_includedir}/KDE/Phonon/
124%{_includedir}/phonon/
125%{_qt4_headerdir}/phonon
126%{_qt4_prefix}/mkspecs/modules/qt_phonon.pri
127%{_libdir}/*.so
128%{_libdir}/pkgconfig/*.pc
129%{_datadir}/phonon-buildsystem/
130
131%changelog
132* Sat Oct 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
133- added Patch100 and 200 to build with pulseaudio-1.0
134
135* Sun Jun  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
136- new upstream release
137- added BR: libqzeitgeist-devel
138
139* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-2
140- rebuilt with qt4-4.7.2
141
142* Sat Jan 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-1
143- new upstream release
144- rebuilt with qt4-4.7.1 on VineSeed
145
146* Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.3-1
147- new upstream release
148
149* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
150- added sybolic link in %%{_qt4_headerdir}
151
152* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
153- new upstream release
154- dropt Patch51 and 57
155- rebuilt with rpm-4.8.1
156
157* Sat Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
158- new upstream release
159- dropt Patch1, 50, 54 and 100
160- added Patch57
161  * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
162  - F11: patch/modularize pa device-manager bits
163
164* Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
165- added qmake path to PATH (if x86_64)
166
167* Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
168- new upstream release
169- built with new toolchain
170
171* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
172- added Patch102 and 103 from FC
173  * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
174  - fix for '#' in filenames
175  * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
176  - restore patches to the xine backend
177
178* Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
179- added Patch100 and 101 from FC
180  * Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
181  - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
182- added backend sub-pakcages
183
184* Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
185- new upstream release
186- add BuildPrereq: cmake
187
188* Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
189- new upstream release
190
191* Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
192- new upstream release
193- update %%files
194- add BuildPrereq: xine-lib-devel libxcb-devel
195
196* Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
197- new upstream release
198
199* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
200- added script to append qmake path
201- added option -DLIB_INSTALL_DIR at cmake
202
203* Tue Oct  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
204- initial release for VineSeed
Note: See TracBrowser for help on using the repository browser.