source: projects/specs/trunk/p/phonon/phonon-vl.spec @ 2091

Revision 2091, 7.7 KB checked in by inagaki, 14 years ago (diff)

update: amarok, phonon
NEW: qtscriptgenerator

Line 
1%define qt4_ver 4.6.3
2# Qt4 version auto-detection
3%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
4%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt-%{qt4_ver})
5%define _qt4_headerdir %(pkg-config --variable headerdir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix}/include)
6
7%define tar_ver 4.4
8
9Name: phonon
10Summary: Multimedia framework api
11Summary(ja): マルチメディアフレームワーク API
12Version: 4.4.2
13Release: 2%{?_dist_release}
14
15Group: System Environment/Libraries
16License: LGPLv2+
17URL: http://phonon.kde.org/
18
19Source0: ftp://ftp.kde.org/pub/kde/stable/phonon/4.4.2/phonon-%{version}.tar.bz2
20
21Source10: http://gstreamer.freedesktop.org/data/images/artwork/gstreamer-logo.svg
22Source11: hi16-phonon-gstreamer.png
23Source12: hi22-phonon-gstreamer.png
24Source13: hi32-phonon-gstreamer.png
25Source14: hi48-phonon-gstreamer.png
26Source15: hi64-phonon-gstreamer.png
27Source16: hi128-phonon-gstreamer.png
28
29## Mandriva/upstreamable patches
30Patch51: phonon-4.3.50-fix-decodebin-usage.patch
31Patch52: phonon-4.3.50-gstreamer-fix-seekable-query-failed.patch
32Patch53: phonon-4.3.50-phonon-allow-stop-empty-source.patch
33Patch57: phonon-4.3.80-pulse-devicemove-rejig.patch
34
35## Upstream patches
36
37BuildRoot: %{_tmppath}/%{name}-%{version}-root
38BuildRequires: automoc4 >= 0.9.86
39BuildRequires: cmake >= 2.6.2
40BuildRequires: glib2-devel
41BuildRequires: gstreamer-devel
42BuildRequires: gstreamer-plugins-base-devel
43BuildRequires: libxcb-devel
44BuildRequires: libxml2-devel
45BuildRequires: qt4-devel >= 4.4.0
46BuildRequires: xine-lib-devel
47BuildRequires: pulseaudio-libs-devel
48
49Requires: phonon-backend >= %{version}
50Requires: qt4 >= 4.4.0
51
52%description
53Phonon is a cross-platform portable Multimedia Support Abstraction,
54which allows you to play multiple audio or video formats with the same
55quality on all platforms, no matter which underlying architecture is
56used.
57
58%package backend-gstreamer
59Summary: Gstreamer phonon backend
60Group: System Environment/Libraries
61Requires: %{name} = %{version}-%{release}
62Requires: gstreamer-plugins-good
63Obsoletes: %{name}-backend-gst < 4.2.0-4
64Provides:  %{name}-backend-gst = %{version}-%{release}
65Provides: phonon-backend = %{version}-%{release}
66
67%description backend-gstreamer
68%{summary}.
69
70%package backend-xine
71Summary: xine phonon backend
72Group: System Environment/Libraries
73Requires: %{name} = %{version}-%{release}
74Provides: phonon-backend = %{version}-%{release}
75
76%description backend-xine
77%{summary}.
78
79%package devel
80Summary: Development files for phonon
81Group: Development/Libraries
82Requires: %{name} = %{version}-%{release}
83Requires: qt4-devel = %{_qt4_version}
84
85%description devel
86Header files for developing applications using phonon
87
88%prep
89%setup -q
90
91#patch51 -p0 -b .fix-decodebin-usage
92%patch52 -p1 -b .gstreamer-fix-seekable-query-failed
93%patch53 -p1 -b .phonon-allow-stop-empty-source
94#patch57 -p1 -b .pulse-devicemove-rejig
95
96
97%build
98%ifarch x86_64
99PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
100%endif
101
102mkdir -p %{_target_platform}
103pushd %{_target_platform}
104unset QTDIR || : ; . /etc/profile.d/qt4.sh
105%cmake \
106    -DUSE_INSTALL_PLUGIN=TRUE \
107    ..
108popd
109
110make %{?_smp_mflags} -C %{_target_platform}
111
112%install
113rm -rf $RPM_BUILD_ROOT
114make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
115
116# symlink for qt/phonon compatibility
117ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
118
119# move the oxygen-only phonon-xine icons to hicolor
120test -d $RPM_BUILD_ROOT%{_datadir}/icons/hicolor && exit 0
121mv $RPM_BUILD_ROOT%{_datadir}/icons/oxygen \
122   $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
123
124# gstreamer icons
125install -D -m 0644 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/phonon-gstreamer.svg
126install -D -m 0644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/phonon-gstreamer.png
127install -D -m 0644 %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/phonon-gstreamer.png
128install -D -m 0644 %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/phonon-gstreamer.png
129install -D -m 0644 %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/phonon-gstreamer.png
130install -D -m 0644 %{SOURCE15} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/64x64/apps/phonon-gstreamer.png
131install -D -m 0644 %{SOURCE16} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps/phonon-gstreamer.png
132
133
134mkdir -p $RPM_BUILD_ROOT%{_qt4_headerdir}
135pushd $RPM_BUILD_ROOT%{_qt4_headerdir}
136ln -sf %{_includedir}/phonon phonon
137popd
138
139%clean
140rm -rf $RPM_BUILD_ROOT
141
142%post -p /sbin/ldconfig
143
144%postun -p /sbin/ldconfig
145
146%posttrans backend-gstreamer
147gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
148
149%posttrans backend-xine
150gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
151
152%postun backend-gstreamer
153if [ $1 -eq 0 ] ; then
154  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
155fi
156
157%postun backend-xine
158if [ $1 -eq 0 ] ; then
159  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
160fi
161
162%files
163%defattr(-,root,root)
164%doc COPYING.LIB
165%{_libdir}/*.so.*
166%{_datadir}/dbus-1/interfaces/*
167# kde4-specific dirs
168%dir %{_libdir}/kde4/plugins/phonon_backend
169%dir %{_datadir}/kde4/services/phononbackends
170
171%files backend-gstreamer
172%defattr(-,root,root,-)
173%{_libdir}/kde4/plugins/phonon_backend/phonon_gstreamer.so
174%{_datadir}/kde4/services/phononbackends/gstreamer.desktop
175%{_datadir}/icons/hicolor/*/apps/phonon-gstreamer.*
176
177%files backend-xine
178%defattr(-,root,root,-)
179%{_libdir}/kde4/plugins/phonon_backend/phonon_xine.so
180%{_datadir}/kde4/services/phononbackends/xine.desktop
181%{_datadir}/icons/hicolor/*/apps/phonon-xine.*
182
183%files devel
184%defattr(-,root,root)
185%dir %{_includedir}/KDE
186%{_includedir}/KDE/Phonon/
187%{_includedir}/phonon/
188%{_qt4_headerdir}/phonon
189%{_libdir}/*.so
190%{_libdir}/pkgconfig/*.pc
191
192%changelog
193* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
194- added sybolic link in %%{_qt4_headerdir}
195
196* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
197- new upstream release
198- dropt Patch51 and 57
199- rebuilt with rpm-4.8.1
200
201* Sat Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
202- new upstream release
203- dropt Patch1, 50, 54 and 100
204- added Patch57
205  * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
206  - F11: patch/modularize pa device-manager bits
207
208* Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
209- added qmake path to PATH (if x86_64)
210
211* Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
212- new upstream release
213- built with new toolchain
214
215* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
216- added Patch102 and 103 from FC
217  * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
218  - fix for '#' in filenames
219  * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
220  - restore patches to the xine backend
221
222* Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
223- added Patch100 and 101 from FC
224  * Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
225  - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
226- added backend sub-pakcages
227
228* Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
229- new upstream release
230- add BuildPrereq: cmake
231
232* Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
233- new upstream release
234
235* Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
236- new upstream release
237- update %%files
238- add BuildPrereq: xine-lib-devel libxcb-devel
239
240* Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
241- new upstream release
242
243* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
244- added script to append qmake path
245- added option -DLIB_INSTALL_DIR at cmake
246
247* Tue Oct  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
248- initial release for VineSeed
Note: See TracBrowser for help on using the repository browser.