source: projects/specs/trunk/p/phonon/phonon-vl.spec @ 1850

Revision 1850, 7.0 KB checked in by inagaki, 14 years ago (diff)

rebuilt with rpm-4.8.1

Line 
1%define tar_ver 4.4
2
3Name: phonon
4Summary: Multimedia framework api
5Summary(ja): マルチメディアフレームワーク API
6Version: 4.4.2
7Release: 1%{?_dist_release}
8
9Group: System Environment/Libraries
10License: LGPLv2+
11URL: http://phonon.kde.org/
12
13Source0: ftp://ftp.kde.org/pub/kde/stable/phonon/4.4.2/phonon-%{version}.tar.bz2
14
15Source10: http://gstreamer.freedesktop.org/data/images/artwork/gstreamer-logo.svg
16Source11: hi16-phonon-gstreamer.png
17Source12: hi22-phonon-gstreamer.png
18Source13: hi32-phonon-gstreamer.png
19Source14: hi48-phonon-gstreamer.png
20Source15: hi64-phonon-gstreamer.png
21Source16: hi128-phonon-gstreamer.png
22
23## Mandriva/upstreamable patches
24Patch51: phonon-4.3.50-fix-decodebin-usage.patch
25Patch52: phonon-4.3.50-gstreamer-fix-seekable-query-failed.patch
26Patch53: phonon-4.3.50-phonon-allow-stop-empty-source.patch
27Patch57: phonon-4.3.80-pulse-devicemove-rejig.patch
28
29## Upstream patches
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-root
32BuildRequires: automoc4 >= 0.9.86
33BuildRequires: cmake >= 2.6.2
34BuildRequires: glib2-devel
35BuildRequires: gstreamer-devel
36BuildRequires: gstreamer-plugins-base-devel
37BuildRequires: libxcb-devel
38BuildRequires: libxml2-devel
39BuildRequires: qt4-devel >= 4.4.0
40BuildRequires: xine-lib-devel
41BuildRequires: pulseaudio-libs-devel
42
43Requires: phonon-backend >= %{version}
44Requires: qt4 >= 4.4.0
45
46%description
47Phonon is a cross-platform portable Multimedia Support Abstraction,
48which allows you to play multiple audio or video formats with the same
49quality on all platforms, no matter which underlying architecture is
50used.
51
52%package backend-gstreamer
53Summary: Gstreamer phonon backend
54Group: System Environment/Libraries
55Requires: %{name} = %{version}-%{release}
56Requires: gstreamer-plugins-good
57Obsoletes: %{name}-backend-gst < 4.2.0-4
58Provides:  %{name}-backend-gst = %{version}-%{release}
59Provides: phonon-backend = %{version}-%{release}
60
61%description backend-gstreamer
62%{summary}.
63
64%package backend-xine
65Summary: xine phonon backend
66Group: System Environment/Libraries
67Requires: %{name} = %{version}-%{release}
68Provides: phonon-backend = %{version}-%{release}
69
70%description backend-xine
71%{summary}.
72
73%package devel
74Summary: Development files for phonon
75Group: Development/Libraries
76Requires: %{name} = %{version}-%{release}
77Requires: qt4-devel >= 4.4.0
78
79%description devel
80Header files for developing applications using phonon
81
82%prep
83%setup -q
84
85#patch51 -p0 -b .fix-decodebin-usage
86%patch52 -p1 -b .gstreamer-fix-seekable-query-failed
87%patch53 -p1 -b .phonon-allow-stop-empty-source
88#patch57 -p1 -b .pulse-devicemove-rejig
89
90
91%build
92%ifarch x86_64
93PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
94%endif
95
96mkdir -p %{_target_platform}
97pushd %{_target_platform}
98unset QTDIR || : ; . /etc/profile.d/qt4.sh
99%cmake \
100    -DUSE_INSTALL_PLUGIN=TRUE \
101    ..
102popd
103
104make %{?_smp_mflags} -C %{_target_platform}
105
106%install
107rm -rf $RPM_BUILD_ROOT
108make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
109
110# symlink for qt/phonon compatibility
111ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
112
113# move the oxygen-only phonon-xine icons to hicolor
114test -d $RPM_BUILD_ROOT%{_datadir}/icons/hicolor && exit 0
115mv $RPM_BUILD_ROOT%{_datadir}/icons/oxygen \
116   $RPM_BUILD_ROOT%{_datadir}/icons/hicolor
117
118# gstreamer icons
119install -D -m 0644 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/scalable/apps/phonon-gstreamer.svg
120install -D -m 0644 %{SOURCE11} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/16x16/apps/phonon-gstreamer.png
121install -D -m 0644 %{SOURCE12} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/22x22/apps/phonon-gstreamer.png
122install -D -m 0644 %{SOURCE13} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/32x32/apps/phonon-gstreamer.png
123install -D -m 0644 %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps/phonon-gstreamer.png
124install -D -m 0644 %{SOURCE15} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/64x64/apps/phonon-gstreamer.png
125install -D -m 0644 %{SOURCE16} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps/phonon-gstreamer.png
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post -p /sbin/ldconfig
131
132%postun -p /sbin/ldconfig
133
134%posttrans backend-gstreamer
135gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
136
137%posttrans backend-xine
138gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
139
140%postun backend-gstreamer
141if [ $1 -eq 0 ] ; then
142  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
143fi
144
145%postun backend-xine
146if [ $1 -eq 0 ] ; then
147  gtk-update-icon-cache %{_datadir}/icons/hicolor &> /dev/null ||:
148fi
149
150%files
151%defattr(-,root,root)
152%doc COPYING.LIB
153%{_libdir}/*.so.*
154%{_datadir}/dbus-1/interfaces/*
155# kde4-specific dirs
156%dir %{_libdir}/kde4/plugins/phonon_backend
157%dir %{_datadir}/kde4/services/phononbackends
158
159%files backend-gstreamer
160%defattr(-,root,root,-)
161%{_libdir}/kde4/plugins/phonon_backend/phonon_gstreamer.so
162%{_datadir}/kde4/services/phononbackends/gstreamer.desktop
163%{_datadir}/icons/hicolor/*/apps/phonon-gstreamer.*
164
165%files backend-xine
166%defattr(-,root,root,-)
167%{_libdir}/kde4/plugins/phonon_backend/phonon_xine.so
168%{_datadir}/kde4/services/phononbackends/xine.desktop
169%{_datadir}/icons/hicolor/*/apps/phonon-xine.*
170
171%files devel
172%defattr(-,root,root)
173%dir %{_includedir}/KDE
174%{_includedir}/KDE/Phonon/
175%{_includedir}/phonon/
176%{_libdir}/*.so
177%{_libdir}/pkgconfig/*.pc
178
179%changelog
180* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
181- new upstream release
182- dropt Patch51 and 57
183- rebuilt with rpm-4.8.1
184
185* Sat Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
186- new upstream release
187- dropt Patch1, 50, 54 and 100
188- added Patch57
189  * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
190  - F11: patch/modularize pa device-manager bits
191
192* Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
193- added qmake path to PATH (if x86_64)
194
195* Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
196- new upstream release
197- built with new toolchain
198
199* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
200- added Patch102 and 103 from FC
201  * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
202  - fix for '#' in filenames
203  * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
204  - restore patches to the xine backend
205
206* Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
207- added Patch100 and 101 from FC
208  * Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
209  - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
210- added backend sub-pakcages
211
212* Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
213- new upstream release
214- add BuildPrereq: cmake
215
216* Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
217- new upstream release
218
219* Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
220- new upstream release
221- update %%files
222- add BuildPrereq: xine-lib-devel libxcb-devel
223
224* Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
225- new upstream release
226
227* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
228- added script to append qmake path
229- added option -DLIB_INSTALL_DIR at cmake
230
231* Tue Oct  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
232- initial release for VineSeed
Note: See TracBrowser for help on using the repository browser.