source: projects/specs/trunk/p/phonon/phonon-vl.spec @ 9067

Revision 9067, 5.9 KB checked in by inagaki, 9 years ago (diff)

2014-11-08 Ryoichi INAGAKI <ryo1@…>

  • gtk-xfce-engine: changed Group
  • numactl, phonon, phonon-backend-gstreamer: updated


RevLine 
[9067]1%define qt4_ver 4.8.6
[2091]2# Qt4 version auto-detection
3%define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo %{qt4_ver})
[9067]4%define _qt4_prefix %(pkg-config --variable prefix --silence-errors Qt 2>/dev/null || echo %{_libdir}/qt4)
[5383]5%define _qt4_datadir %(pkg-config --variable datadir --silence-errors Qt 2>/dev/null || echo %{_qt4_prefix})
[2091]6
[2611]7%global pulseaudio_version %(pkg-config --modversion libpulse 2>/dev/null || echo 0.9.15)
[574]8
[1850]9Name: phonon
[521]10Summary: Multimedia framework api
11Summary(ja): マルチメディアフレームワーク API
[9067]12Version: 4.8.2
[5199]13Release: 1%{?_dist_release}
[1850]14
[521]15Group: System Environment/Libraries
16License: LGPLv2+
17URL: http://phonon.kde.org/
18
[8056]19Source0: ftp://ftp.kde.org/pub/kde/stable/phonon/4.7.1/src/phonon-%{version}.tar.xz
[1850]20
[8056]21Patch1: phonon-4.7.1-no_rpath.patch
[521]22
23## Upstream patches
24
[5037]25## Vine patches
26
[521]27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28BuildRequires: automoc4 >= 0.9.86
[574]29BuildRequires: cmake >= 2.6.2
[521]30BuildRequires: glib2-devel
[4048]31BuildRequires: libqzeitgeist-devel
[521]32BuildRequires: libxcb-devel
33BuildRequires: libxml2-devel
[2611]34BuildRequires: qt4-devel >= 4.6.0
[5383]35BuildRequires: openssl-devel
[2611]36BuildRequires: pulseaudio-libs-devel >= 0.9.15
[521]37
[2611]38# TODO: enable the following Requires in next release
[4048]39Requires: phonon-backend >= 4.4
[2611]40Requires: pulseaudio-libs >= %{pulseaudio_version}
41Requires: qt4 >= %{_qt4_version}
[521]42
43%description
44Phonon is a cross-platform portable Multimedia Support Abstraction,
45which allows you to play multiple audio or video formats with the same
46quality on all platforms, no matter which underlying architecture is
47used.
48
49%package devel
50Summary: Development files for phonon
[2611]51Summary(ja): phonon の開発用ファイル
[521]52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
[5383]54Requires: qt4-devel >= %{_qt4_version}
[521]55
56%description devel
57Header files for developing applications using phonon
58
59%prep
[1850]60%setup -q
[2611]61%patch1 -p1 -b .no_rpath
[521]62
63%build
64%ifarch x86_64
65PATH="$PATH:`/usr/bin/pkg-config --variable=bindir Qt`"
66%endif
67
68mkdir -p %{_target_platform}
69pushd %{_target_platform}
70%cmake \
[5383]71    -DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT:BOOL=ON \
[521]72    ..
73popd
74
75make %{?_smp_mflags} -C %{_target_platform}
76
77%install
78rm -rf $RPM_BUILD_ROOT
[2611]79
[521]80make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
81
82# symlink for qt/phonon compatibility
83ln -s ../KDE/Phonon $RPM_BUILD_ROOT%{_includedir}/phonon/Phonon
84
[2611]85# own these dirs
86mkdir -p $RPM_BUILD_ROOT%{_libdir}/kde4/plugins/phonon_backend/
87mkdir -p $RPM_BUILD_ROOT%{_datadir}/kde4/services/phononbackends/
[521]88
89%clean
90rm -rf $RPM_BUILD_ROOT
91
92%post -p /sbin/ldconfig
93
94%postun -p /sbin/ldconfig
95
96%files
97%defattr(-,root,root)
98%doc COPYING.LIB
99%{_libdir}/*.so.*
[4048]100%{_qt4_plugindir}/designer/*.so
[521]101%{_datadir}/dbus-1/interfaces/*
102# kde4-specific dirs
103%dir %{_libdir}/kde4/plugins/phonon_backend
104%dir %{_datadir}/kde4/services/phononbackends
105
106%files devel
107%defattr(-,root,root)
108%dir %{_includedir}/KDE
109%{_includedir}/KDE/Phonon/
110%{_includedir}/phonon/
111%{_libdir}/*.so
[5383]112%dir %{_libdir}/cmake/
113%{_libdir}/cmake/phonon/
[521]114%{_libdir}/pkgconfig/*.pc
[5383]115%{_datadir}/phonon/buildsystem/
116%{_qt4_datadir}/mkspecs/modules/qt_phonon.pri
[521]117
118%changelog
[9067]119* Fri Nov  7 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 4.8.2-1
120- new upstream release
121
[8056]122* Tue Dec 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.7.1-1
123- new upstream release
124- update Patch1
125- remove Patch50 (phonon-4.5.57-plugindir.patch)
126
[5383]127* Sat Jan  7 2012 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.6.0-1
128- new upstream release
129
[5199]130* Sat Nov 26 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.1-1
131- new upstream release
132
[5037]133* Sat Oct 22 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-2
134- added Patch100 and 200 to build with pulseaudio-1.0
135
[4048]136* Sun Jun  5 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
137- new upstream release
138- added BR: libqzeitgeist-devel
139
[2981]140* Tue Mar  8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-2
141- rebuilt with qt4-4.7.2
142
[2611]143* Sat Jan 29 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.4-1
144- new upstream release
145- rebuilt with qt4-4.7.1 on VineSeed
146
[2342]147* Mon Dec 13 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.4.3-1
148- new upstream release
149
[2091]150* Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-2
151- added sybolic link in %%{_qt4_headerdir}
152
[1850]153* Mon Sep 20 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
154- new upstream release
155- dropt Patch51 and 57
156- rebuilt with rpm-4.8.1
157
[8056]158* Sun Mar 14 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.0-1
[574]159- new upstream release
160- dropt Patch1, 50, 54 and 100
161- added Patch57
162  * Fri Jan 22 2010 Rex Dieter <rdieter@fedoraproject.org> - 4.3.80-5.2
163  - F11: patch/modularize pa device-manager bits
164
[521]165* Sun Feb 14 2010 Shu KONNO <owa@bg.wakwak.com> 4.3.80-2
166- added qmake path to PATH (if x86_64)
167
168* Sat Feb 13 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.80-1
169- new upstream release
170- built with new toolchain
171
172* Sat Aug 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-3
173- added Patch102 and 103 from FC
174  * Thu Jun 18 2009 Rex Dieter <rdieter@fedoraproject.org> - 4.3.1-11
175  - fix for '#' in filenames
176  * Fri Jun 05 2009 Kevin Kofler <Kevin@tigcc.ticalc.org> - 4.3.1-8
177  - restore patches to the xine backend
178
179* Fri Aug 14 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-2
180- added Patch100 and 101 from FC
181  * Tue Mar  3 2009 Lukáš Tinkl <ltinkl@redhat.com> - 4.3.1-2
182  - backport GStreamer backend bugfixes (UTF-8 file handling, volume fader)
183- added backend sub-pakcages
184
185* Thu Mar 26 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.1-1
186- new upstream release
187- add BuildPrereq: cmake
188
189* Sat Jan 24 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.3.0-1
190- new upstream release
191
192* Wed Jan 14 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.96-1
193- new upstream release
194- update %%files
195- add BuildPrereq: xine-lib-devel libxcb-devel
196
197* Wed Nov 26 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.80-1
198- new upstream release
199
200* Thu Oct 09 2008 Shu KONNO <owa@bg.wakwak.com> 4.2.0-2
201- added script to append qmake path
202- added option -DLIB_INSTALL_DIR at cmake
203
204* Tue Oct  7 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.2.0-1
205- initial release for VineSeed
Note: See TracBrowser for help on using the repository browser.