source: projects/specs/trunk/p/perl-namespace-clean/perl-namespace-clean-vl.spec @ 12120

Revision 12120, 11.8 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# Run optional test
2%bcond_with perl_namespace_clean_enables_optional_test
3
4Name:           perl-namespace-clean
5Summary:        Keep your namespace tidy
6Version:        0.27
7Release:        11%{?_dist_release}
8License:        GPL+ or Artistic
9URL:            https://metacpan.org/release/namespace-clean
10Source0:        https://cpan.metacpan.org/authors/id/R/RI/RIBASUSHI/namespace-clean-%{version}.tar.gz
11
12Vendor:        Project Vine
13Distribution:  Vine Linux
14
15BuildArch:      noarch
16# Module Build
17BuildRequires:  coreutils
18BuildRequires:  findutils
19BuildRequires:  make
20BuildRequires:  perl >= 2:5.26.2
21BuildRequires:  perl(ExtUtils::MakeMaker)
22BuildRequires:  perl(File::Spec)
23BuildRequires:  perl(File::Temp)
24# Module Runtime
25BuildRequires:  perl(B::Hooks::EndOfScope)
26BuildRequires:  perl(base)
27BuildRequires:  perl(constant)
28BuildRequires:  perl(Exporter)
29BuildRequires:  perl(Package::Stash)
30BuildRequires:  perl(strict)
31BuildRequires:  perl(vars)
32BuildRequires:  perl(warnings)
33# Test Suite
34BuildRequires:  perl(Config)
35BuildRequires:  perl(DB)
36BuildRequires:  perl(File::Glob)
37BuildRequires:  perl(FindBin)
38BuildRequires:  perl(IPC::Open2)
39BuildRequires:  perl(lib)
40BuildRequires:  perl(sort)
41BuildRequires:  perl(Test::More)
42%if %{with perl_namespace_clean_enables_optional_test}
43# Optional Tests
44BuildRequires:  perl(Variable::Magic)
45%endif
46# Runtime
47Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
48Requires:       perl(B::Hooks::EndOfScope)
49Requires:       perl(Package::Stash)
50
51# Avoid unwanted requires/provides that come with the test suite
52%{?perl_default_filter}
53# namespace::clean::_Util is a private package
54%global __requires_exclude %{?__requires_exclude:__requires_exclude|}^perl\\(namespace::clean::_Util\\)
55
56%description
57When you define a function, or import one, into a Perl package, it will
58naturally also be available as a method. This does not per se cause
59problems, but it can complicate subclassing and, for example, plugin
60classes that are included via multiple inheritance by loading them as
61base classes.
62
63The 'namespace::clean' pragma will remove all previously declared or
64imported symbols at the end of the current package's compile cycle.
65Functions called in the package itself will still be bound by their
66name, but they won't show up as methods on your class or instances.
67
68%prep
69%setup -q -n namespace-clean-%{version}
70
71%build
72perl Makefile.PL INSTALLDIRS=vendor
73make %{?_smp_mflags}
74
75%install
76make pure_install DESTDIR=%{buildroot}
77find %{buildroot} -type f -name .packlist -delete
78%{_fixperms} -c %{buildroot}
79
80%check
81make test
82
83%files
84%doc Changes t/
85%{perl_vendorlib}/namespace/
86%{_mandir}/man3/namespace::clean.3*
87
88%changelog
89* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.27-11
90- initial build for Vine Linux.
91
92* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.27-10
93- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
94
95* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.27-9
96- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
97
98* Fri Jun 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.27-8
99- Perl 5.28 rebuild
100
101* Fri Feb  9 2018 Paul Howarth <paul@city-fan.org> - 0.27-7
102- BR: perl-generators unconditionally
103
104* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 0.27-6
105- Escape macros in %%changelog
106
107* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.27-5
108- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
109
110* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.27-4
111- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
112
113* Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.27-3
114- Perl 5.26 rebuild
115
116* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.27-2
117- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
118
119* Thu May 19 2016 Paul Howarth <paul@city-fan.org> - 0.27-1
120- Update to 0.27
121  - Allow packages to be cleaned multiple times
122  - Ensure the debugger workarounds are applied only when DB::sub is actively
123    used (they are superfluous otherwise)
124  - Work around P5#72210, resulting in fails on 5.8.8 -Duselongdouble
125  - Fix incorrect name in META (CPAN RT#107813)
126- BR: perl-generators where available
127- Simplify find command using -delete
128
129* Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.26-3
130- Perl 5.24 rebuild
131
132* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.26-2
133- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
134
135* Wed Oct  7 2015 Paul Howarth <paul@city-fan.org> - 0.26-1
136- Update to 0.26
137  - Exclusively use Package::Stash::PP on perls < 5.8.7 until a fixed
138    Package::Stash::XS ships - breakage keeps getting re-introduced
139    (CPAN RT#74151, CPAN RT#107343)
140  - Explicitly document the late runtime binding of 'sort SUBNAME ...'
141    (CPAN RT#101247)
142  - No longer rely on Sub::Identify - either use Sub::Util or B (CPAN RT#96945)
143- Classify buildreqs by usage
144- Filter dependency on private package namespace::clean::_Util
145- Drop EL-6 support since build requirements can't be met there
146
147* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25-5
148- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
149
150* Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.25-4
151- Perl 5.22 rebuild
152
153* Fri Aug 29 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.25-3
154- Perl 5.20 rebuild
155
156* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.25-2
157- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
158
159* Wed Mar  5 2014 Paul Howarth <paul@city-fan.org> - 0.25-1
160- Update to 0.25
161  - Fix incorrect ExtUtils::CBuilder detection routine leading to Makefile.PL
162    crashes when EU::CB is not available
163- Drop obsoletes/provides for old tests sub-package
164- Drop EL-5 support since build requirements can't be met there
165
166* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24-4
167- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
168
169* Mon Jul 29 2013 Petr Pisar <ppisar@redhat.com> - 0.24-3
170- Perl 5.18 rebuild
171
172* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.24-2
173- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
174
175* Wed Dec  5 2012 Paul Howarth <paul@city-fan.org> - 0.24-1
176- Update to 0.24
177  - Properly skip debugger test when optional deps not available
178  - Make sure pure-perl tests pass correctly on space-containing paths
179    (CPAN RT#77528)
180  - Remove all the pure-perl fallback code and depend on PP-capable
181    B::H::EOS 0.12
182- Module no longer attempts to use Hash::Util::FieldHash, so drop filters
183- BR: perl(Sub::Identify) and perl(Sub::Name) unconditionally
184- BR: perl(base), perl(ExtUtils::CBuilder) and perl(lib)
185- Drop BR: perl(FindBin), not dual-lived upstream
186- Update patch for building with old Test::More versions
187
188* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.23-3
189- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
190
191* Tue Jun 19 2012 Petr Pisar <ppisar@redhat.com> - 0.23-2
192- Perl 5.16 rebuild
193
194* Sun Mar 11 2012 Paul Howarth <paul@city-fan.org> - 0.23-1
195- Update to 0.23
196  - Rely on B::Hooks::EndOfScope version 0.10 to fix issues with new
197    Module::Runtime versions (≥ 0.012) on perl 5.10 due to incorrect hook
198    firing due to %%^H localisation
199  - Fix failures on 5.13.6 due to incorrect version number threshold
200    (CPAN RT#74683)
201- Don't need to remove empty directories from buildroot
202- Drop %%defattr, redundant since rpm 4.4
203
204* Fri Jan 27 2012 Paul Howarth <paul@city-fan.org> - 0.22-1
205- Update to 0.22
206  - Limit the debugger workarounds to perls between 5.8.8 and 5.14, extend
207    debugger support to all perl versions (CPAN RT#69862)
208  - If possible, automatically install (but not load) the debugger workaround
209    libraries on perls between 5.8.8 and 5.14 (CPAN RT#72368)
210  - Add back dropped NAME section (CPAN RT#70259)
211  - Simplify the ≥ 5.10 PP variant even more - move the hook from DESTROY
212    into DELETE
213  - Force explicit callback invocation order on 5.8 PP
214  - Replace the %%^H tie approach with fieldhashes, which fixes all known
215    corner cases and caveats on supported perls ≥ 5.8.1 (CPAN RT#73402)
216  - Compile away the debugger fixup on perls ≥ 5.15.5
217- Only BR:/R: Sub::Identify and Sub::Name for perl versions where they're
218  actually needed
219- Reinstate compatibility with old distributions like EL-5
220  - Patch test suite to work with Test::More < 0.88 if necessary
221  - Filter dependency on Hash::Util::FieldHash on perl 5.8.x
222  - Add back buildroot definition, %%clean section, %%defattr etc.
223- Only include tests if we have %%{perl_default_filter} to avoid the unwanted
224  requires/provides that come with them
225- Drop redundant buildreq perl(CPAN)
226- Make %%files list more explicit
227- Use tabs
228
229* Sun Jan 22 2012 Iain Arnell <iarnell@gmail.com> - 0.21-3
230- Drop tests subpackage; move tests to main package documentation
231
232* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.21-2
233- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
234
235* Sun Oct 02 2011 Iain Arnell <iarnell@gmail.com> - 0.21-1
236- Update to latest upstream version
237- Clean up spec for modern rpmbuild
238
239* Wed Jul 20 2011 Petr Sabata <contyk@redhat.com> - 0.20-3
240- Perl mass rebuild
241
242* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.20-2
243- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
244
245* Sat Jan 08 2011 Iain Arnell <iarnell@gmail.com> - 0.20-1
246- Update to latest upstream version
247- Update BR perl(Package::Stash) >= 0.22
248
249* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.18-2
250- Rebuild to fix problems with vendorarch/lib (#661697)
251
252* Sun Aug 01 2010 Iain Arnell <iarnell@gmail.com> - 0.18-1
253- Update by Fedora::App::MaintainerTools 0.006
254- Updating to latest GA CPAN version (0.18)
255- Added a new br on perl(Exporter) (version 0)
256- Altered br on perl(ExtUtils::MakeMaker) (6.42 => 6.31)
257- Added a new br on perl(Package::Stash) (version 0.03)
258- Added a new br on perl(constant) (version 0)
259- Added a new br on perl(vars) (version 0)
260- Dropped old BR on perl(Symbol)
261- Dropped old requires on perl(Symbol)
262- Manually drop unnecessary requires
263
264* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.14-1
265- Mass rebuild with perl-5.12.0 & update
266
267* Tue Feb 23 2010 Chris Weyl <cweyl@alumni.drew.edu> - 0.13-2
268- Update by Fedora::App::MaintainerTools 0.003
269- PERL_INSTALL_ROOT => DESTDIR
270
271* Fri Feb 05 2010 Chris Weyl <cweyl@alumni.drew.edu> - 0.13-1
272- Update filtering perl_default_filter
273- Auto-update to 0.13 (by cpan-spec-update 0.01)
274- Altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
275- Added a new br on perl(Sub::Identify) (version 0.04)
276- Added a new br on perl(Sub::Name) (version 0.04)
277- Altered br on perl(Test::More) (0.62 => 0.88)
278- Added a new br on CPAN (inc::Module::AutoInstall found)
279- Added a new req on perl(B::Hooks::EndOfScope) (version 0.07)
280- Added a new req on perl(Sub::Identify) (version 0.04)
281- Added a new req on perl(Sub::Name) (version 0.04)
282- Added a new req on perl(Symbol) (version 0)
283
284* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.11-3
285- Rebuild against perl 5.10.1
286
287* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-2
288- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
289
290* Thu Apr 02 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.11-1
291- Update to 0.11
292
293* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.09-2
294- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
295
296* Tue Dec 02 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.09-1
297- Update to 0.09
298- Note BR change from Scope::Guard to B::Hooks::EndOfScope
299
300* Mon Sep 08 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.08-2
301- Bump
302
303* Sat Sep 06 2008 Chris Weyl <cweyl@alumni.drew.edu> - 0.08-1
304- Initial Fedora packaging
305- Generated with cpan2dist (CPANPLUS::Dist::Fedora version 0.0.1)
Note: See TracBrowser for help on using the repository browser.