source: projects/specs/trunk/p/perl-namespace-autoclean/perl-namespace-autoclean-vl.spec @ 12120

Revision 12120, 10.6 KB checked in by tomop, 5 years ago (diff)

perl-5.26 and friends

Line 
1# Run optional test
2%bcond_with perl_namespace_autoclean_enables_optional_test
3%global perl_bootstrap 1
4
5Name:           perl-namespace-autoclean
6Version:        0.28
7Release:        15%{?_dist_release}
8License:        GPL+ or Artistic
9Summary:        Keep imports out of your namespace
10Source0:        https://cpan.metacpan.org/authors/id/E/ET/ETHER/namespace-autoclean-%{version}.tar.gz
11URL:            https://metacpan.org/release/namespace-autoclean
12
13Vendor:        Project Vine
14Distribution:  Vine Linux
15
16BuildArch:      noarch
17# Module Build
18BuildRequires:  coreutils
19BuildRequires:  findutils
20BuildRequires:  make
21BuildRequires:  perl >= 2:5.26.2
22BuildRequires:  perl(ExtUtils::MakeMaker)
23# Module
24BuildRequires:  perl(B::Hooks::EndOfScope)
25BuildRequires:  perl(List::Util)
26BuildRequires:  perl(namespace::clean)
27BuildRequires:  perl(strict)
28BuildRequires:  perl(Sub::Identify)
29BuildRequires:  perl(warnings)
30# Test Suite
31BuildRequires:  perl(base)
32BuildRequires:  perl(Carp)
33BuildRequires:  perl(constant)
34BuildRequires:  perl(File::Basename)
35BuildRequires:  perl(File::Spec)
36BuildRequires:  perl(FindBin)
37BuildRequires:  perl(overload)
38BuildRequires:  perl(Scalar::Util)
39BuildRequires:  perl(Test::More)
40BuildRequires:  perl(Test::Requires)
41%if %{with perl_namespace_autoclean_enables_optional_test}
42# Optional Tests
43BuildRequires:  perl(CPAN::Meta)
44%if 0
45BuildRequires:  perl(Moo)
46%endif
47%if ! %{defined perl_bootstrap}
48# Break build-cycle: perl-namespace-autoclean → perl-Moose
49# → perl-Package-DeprecationManager → perl-namespace-autoclean
50# Break build-cycle: perl-namespace-autoclean → perl-Mouse → perl-Moose
51# → perl-Package-DeprecationManager → perl-namespace-autoclean
52BuildRequires:  perl(Moose)
53BuildRequires:  perl(Moose::Role)
54BuildRequires:  perl(MooseX::Role::WithOverloading) >= 0.09
55BuildRequires:  perl(Mouse)
56%endif
57BuildRequires:  perl(Sub::Install)
58BuildRequires:  perl(Sub::Name)
59%endif
60# Runtime
61Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
62Requires:       perl(Sub::Identify)
63
64%description
65When you import a function into a Perl package, it will naturally also be
66available as a method. The 'namespace::autoclean' pragma will remove all
67imported symbols at the end of the current package's compile cycle. Functions
68called in the package itself will still be bound by their name, but they won't
69show up as methods on your class or instances. This module is very similar to
70namespace::clean, except it will clean all imported functions, no matter if you
71imported them before or after you 'use'd the pragma. It will also not touch
72anything that looks like a method.
73
74%prep
75%setup -q -n namespace-autoclean-%{version}
76
77%build
78perl Makefile.PL INSTALLDIRS=vendor
79make %{?_smp_mflags}
80
81%install
82make pure_install DESTDIR=%{buildroot}
83find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
84%{_fixperms} %{buildroot}
85
86%check
87make test
88
89%files
90%license LICENCE
91%doc Changes CONTRIBUTING README
92%{perl_vendorlib}/namespace/
93%{_mandir}/man3/namespace::autoclean.3*
94
95%changelog
96* Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.28-15
97- initial build for Vine Linux.
98
99* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-14
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
101
102* Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-13
103- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
104
105* Sun Jul 01 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-12
106- Perl 5.28 re-rebuild of bootstrapped packages
107
108* Fri Jun 29 2018 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-11
109- Perl 5.28 rebuild
110
111* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-10
112- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
113
114* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-9
115- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
116
117* Wed Jun 07 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-8
118- Perl 5.26 re-rebuild of bootstrapped packages
119
120* Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-7
121- Perl 5.26 rebuild
122
123* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-6
124- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
125
126* Wed May 18 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-5
127- Perl 5.24 re-rebuild of bootstrapped packages
128
129* Mon May 16 2016 Jitka Plesnikova <jplesnik@redhat.com> - 0.28-4
130- Perl 5.24 rebuild
131
132* Tue Mar 29 2016 Petr Pisar <ppisar@redhat.com> - 0.28-3
133- Break build-cycle: perl-namespace-autoclean → perl-Moose
134 → perl-Package-DeprecationManager → perl-namespace-autoclean
135- Break build-cycle: perl-namespace-autoclean → perl-Mouse → perl-Moose
136 → perl-Package-DeprecationManager → perl-namespace-autoclean
137- Remove unused direct test dependency on Class::MOP
138
139* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.28-2
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
141
142* Tue Oct 13 2015 Paul Howarth <paul@city-fan.org> - 0.28-1
143- Update to 0.28
144  - Skip failing tests with old Moo or when Sub::Util is broken
145    (CPAN RT#107643)
146
147* Wed Sep  9 2015 Paul Howarth <paul@city-fan.org> - 0.27-1
148- Update to 0.27
149  - Package with only ExtUtils::MakeMaker to ease installation on perl 5.6
150
151* Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.26-4
152- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
153
154* Wed Jun 10 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.26-3
155- Perl 5.22 re-rebuild of bootstrapped packages
156
157* Mon Jun 08 2015 Jitka Plesnikova <jplesnik@redhat.com> - 0.26-2
158- Perl 5.22 rebuild
159
160* Sun Jun  7 2015 Paul Howarth <paul@city-fan.org> - 0.26-1
161- Update to 0.26
162  - Mark all Mouse tests as TODO below perl 5.010, to enable installation
163    despite apparent instability issues (see CPAN RT#101825)
164
165* Sat Jun  6 2015 Paul Howarth <paul@city-fan.org> - 0.25-1
166- Update to 0.25
167  - Load Moo::Role earlier in a test, to make a potential misconfiguration more
168    visible
169
170* Mon Jan  5 2015 Paul Howarth <paul@city-fan.org> - 0.24-1
171- Update to 0.24
172  - Be more lenient in optional Mouse tests to handle edge cases in older and
173    pure perl versions
174- Drop redundant %%{?perl_default_filter}
175
176* Tue Nov  4 2014 Paul Howarth <paul@city-fan.org> - 0.22-1
177- Update to 0.22
178  - Drop testing of MooseX::MarkAsMethods, now that Moose 2.1400 has better
179    overload handling
180
181* Tue Sep 23 2014 Paul Howarth <paul@city-fan.org> - 0.20-1
182- Update to 0.20
183  - Moose earlier than 2.0300 had a broken ->does method, which called methods
184    on a class's meta when it might not be initialized (CPAN RT#98424)
185
186* Sun Sep 07 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.19-4
187- Perl 5.20 re-rebuild of bootstrapped packages
188
189* Mon Sep 01 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.19-3
190- Perl 5.20 rebuild
191
192* Fri Aug 15 2014 Jitka Plesnikova <jplesnik@redhat.com> - 0.19-2
193- Disable BRs MooseX::MarkAsMethods and MooseX::Role::WithOverloading to
194  avoid circular deps when bootstrapping
195
196* Thu Aug 14 2014 Paul Howarth <paul@city-fan.org> - 0.19-1
197- Update to 0.19
198  - Bump dependency on B::Hooks::EndOfScope, to get the separation of pure-perl
199    and XS components (CPAN RT#89245)
200  - Repository migrated to the github moose organization
201  - Update configure_requires checking in Makefile.PL, add CONTRIBUTING file
202  - Changed the code to no longer _require_ Class::MOP; if your class is not a
203    Moose class then we don't load Class::MOP, which was particularly
204    problematic for Moo classes, as using namespace::autoclean with a Moo class
205    "upgraded" it to be a Moose class
206  - Using this module just broke overloading in a class (CPAN RT#50938)
207  - Add -except to import options; this allows you to explicitly not clean a
208    sub.
209  - Better method detection for Mouse (GH#4)
210  - More comprehensive testing with Moo/Mouse/Moose
211  - Fixed cleaning of constants
212- This release by ETHER -> update source URL
213- Switch to Module::Build::Tiny flow
214- Update %%description to remove reference to Class::MOP
215- Make %%files list more explicit
216
217* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-7
218- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
219
220* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-6
221- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
222
223* Fri Aug 02 2013 Petr Pisar <ppisar@redhat.com> - 0.13-5
224- Perl 5.18 rebuild
225
226* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-4
227- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
228
229* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.13-3
230- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
231
232* Fri Jun 22 2012 Petr Pisar <ppisar@redhat.com> - 0.13-2
233- Perl 5.16 rebuild
234
235* Sat Jan 14 2012 Iain Arnell <iarnell@gmail.com> 0.13-1
236- update to latest upstream version
237
238* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.12-4
239- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
240
241* Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 0.12-3
242- Perl mass rebuild
243
244* Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.12-2
245- Perl mass rebuild
246
247* Sun Mar 13 2011 Iain Arnell <iarnell@gmail.com> 0.12-1
248- update to latest upstream version
249- clean up spec for modern rpmbuild
250
251* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.11-3
252- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
253
254* Tue Dec 21 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.11-2
255- 661697 rebuild for fixing problems with vendorach/lib
256
257* Tue May 04 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.09-4
258- Mass rebuild with perl-5.12.0
259
260* Mon Dec  7 2009 Stepan Kasal <skasal@redhat.com> - 0.09-3
261- rebuild against perl 5.10.1
262
263* Thu Sep 17 2009 Stepan Kasal <skasal@redhat.com> 0.09-2
264- fix the previous changelog entry
265
266* Wed Sep 16 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.09-1
267- add %%perl_default_filter'ing
268- auto-update to 0.09 (by cpan-spec-update 0.01)
269- added a new req on perl(B::Hooks::EndOfScope) (version 0.07)
270- added a new req on perl(Class::MOP) (version 0.80)
271- added a new req on perl(List::Util) (version 0)
272- added a new req on perl(namespace::clean) (version 0.11)
273
274* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.08-2
275- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
276
277* Wed Jul 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.08-1
278- submission
279
280* Wed Jul 01 2009 Chris Weyl <cweyl@alumni.drew.edu> 0.08-0
281- initial RPM packaging
282- generated with cpan2dist (CPANPLUS::Dist::RPM version 0.0.8)
Note: See TracBrowser for help on using the repository browser.