source: projects/specs/trunk/p/perl-load/perl-load-vl.spec @ 5875

Revision 5875, 1.9 KB checked in by shaolin, 12 years ago (diff)
  • new packages
Line 
1%define real_name load
2
3Summary: Control when subroutines will be loaded
4Name:           perl-%{real_name}
5Version:        0.20
6Release:        1%{?_dist_release}
7License:        Artistic or GPL+
8Group:          Development/Libraries
9URL:            http://search.cpan.org/dist/load/
10Source:         http://www.cpan.org/authors/id/E/EL/ELIZABETH/load-%{version}.tar.gz
11BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
12
13BuildArch:      noarch
14BuildRequires:  perl
15BuildRequires:  perl(ExtUtils::MakeMaker)
16Requires:       perl(:MODULE_COMPAT_%(eval "`perl -V:version`"; echo $version))
17
18%description
19The "load" pragma allows a module developer to give the application
20developer more options with regards to optimize for memory or CPU
21usage. The "load" pragma gives more control on the moment when
22subroutines are loaded and start taking up memory. This allows the
23application developer to optimize for CPU usage (by loading all of a
24module at compile time and thus reducing the amount of CPU used during
25the execution of an application). Or allow the application developer
26to optimize for memory usage, by loading subroutines only when they
27are actually needed, thereby however increasing the amount of CPU
28needed during execution.
29
30%prep
31%setup -n %{real_name}-%{version}
32
33%build
34%{expand: %%define optflags %{optflags} -fPIC}
35perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
36make %{?_smp_mflags}
37
38%install
39rm -rf %{buildroot}
40make pure_install DESTDIR=%{buildroot}
41find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
42find %{buildroot} -depth -type d -exec rmdir {} ';' 2>/dev/null
43%{_fixperms} %{buildroot}
44
45%check
46make test
47
48%clean
49%{__rm} -rf %{buildroot}
50
51%files
52%defattr(-, root, root, -)
53%doc MANIFEST README CHANGELOG TODO
54%doc %{_mandir}/man3/load.3pm*
55%{perl_vendorlib}/load.pm
56
57%changelog
58* Sat Mar 10 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.20-1
59- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.