source: projects/specs/trunk/p/perl-libxml-perl/perl-libxml-perl-vl.spec @ 12121

Revision 12121, 4.0 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define perl_vendorlib    %(eval "`perl -V:installvendorlib`"; echo $installvendorlib)
2%define _use_internal_dependency_generator 0
3
4%define module  libxml-perl
5Summary: A collection of Perl modules for working with XML.
6Name: perl-%{module}
7Version: 0.08
8Release: 4%{?_dist_release}
9License: distributable
10Group: Development/Libraries
11Source0: http://search.cpan.org/CPAN/authors/id/K/KM/KMACLEOD/%{module}-%{version}.tar.gz
12URL: http://search.cpan.org/dist/libxml-perl/
13
14Vendor:         Project Vine
15Distribution:   Vine Linux
16
17BuildArch: noarch
18BuildRoot: %{_tmppath}/%{name}-%{version}-root
19BuildRequires: perl(ExtUtils::MakeMaker)
20BuildRequires: perl(XML::Parser)
21Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
22Requires: perl(XML::Parser)
23
24
25%description
26libxml-perl is a collection of smaller Perl modules, scripts, and
27documents for working with XML in Perl.  libxml-perl software works in
28combination with XML::Parser, PerlSAX, XML::DOM, XML::Grove and
29others.
30
31
32%prep
33%setup -q -n %{module}-%{version}
34
35%build
36CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
37make
38
39%install
40rm -rf $RPM_BUILD_ROOT
41mkdir -p $RPM_BUILD_ROOT%{_prefix}
42make DESTDIR=$RPM_BUILD_ROOT install
43
44[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
45
46find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
47
48find $RPM_BUILD_ROOT/usr -type f -print |
49        sed "s@^$RPM_BUILD_ROOT@@g" |
50        grep -v perllocal.pod |
51        grep -v "\.packlist" > perl-libxml-perl-%{version}-filelist
52if [ "$(cat perl-libxml-perl-%{version}-filelist)X" = "X" ] ; then
53    echo "ERROR: EMPTY FILE LIST"
54    exit -1
55fi
56
57%check
58make test || /bin/true
59
60%clean
61rm -rf $RPM_BUILD_ROOT
62
63%files -f perl-libxml-perl-%{version}-filelist
64%defattr(-,root,root)
65%doc README ChangeLog Changes doc examples
66%dir %{perl_vendorlib}/Data
67%dir %{perl_vendorlib}/Data/Grove
68%dir %{perl_vendorlib}/XML
69%dir %{perl_vendorlib}/XML/Handler
70%dir %{perl_vendorlib}/XML/Parser
71%dir %{perl_vendorlib}/XML/PatAct
72
73%changelog
74* Mon May 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.08-4
75- rebuilt with perl-5.26.
76
77* Wed Nov  5 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.08-3
78- rebuilt with perl 5.16.3
79
80* Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 0.08-2vl6
81- build with perl 5.12.3
82- add Vendor and Distribution tags
83- update URL value
84
85* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.0.8-1
86- applied new versioning policy
87- rebuilt with perl-5.10.0-2
88- changed Group to Development/Libraries
89
90* Wed Jul 19 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.0.8-0vl2
91- rebuilt with perl-5.8.6
92- changed Group to Development/Languages
93
94* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 0.0.8-0vl1
95- new upstream release
96
97* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 0.0.7-28vl4
98- rebuilt on perl-5.8.2
99
100* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 0.0.7-28vl3
101- rebuilt on perl-5.8.1
102
103* Wed Apr 30 2003 IWAI Masaharu <iwai@alib.jp> 0.07-28vl2
104- build with perl-5.8.0
105- add some documents
106- add some directories
107- add perl-XML-Parser's version in {Build,}Requires
108
109* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 0.07-28vl1
110- build for VineLinux
111
112* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
113- automated release bump and build
114
115* Wed Mar 27 2002 Chip Turner <cturner@redhat.com>
116- move to vendor_perl
117
118* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
119- automated rebuild
120
121* Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 0.07-5
122- imported from mandrake. tweaked man path.
123
124* Sun Jun 17 2001 Geoffrey Lee <snailtalk@mandrakesoft.com> 0.07-4mdk
125- Rebuild for the latest perl.
126- Remove Distribution and Vendor tag.
127- Don't run make test for now.
128
129* Tue Mar 13 2001 Jeff Garzik <jgarzik@mandrakesoft.com> 0.07-3mdk
130- BuildArch: noarch
131- add docs
132- rename spec file
133- clean up spec a bit
134- run automated tests
135
136* Sat Sep 16 2000 Stefan van der Eijk <s.vandereijk@chello.nl> 0.07-2mdk
137- Call spec-helper before creating filelist
138
139* Wed Aug 09 2000 Jean-Michel Dault <jmdault@mandrakesoft.com> 0.07-1mdk
140- Macroize package
Note: See TracBrowser for help on using the repository browser.