source: projects/specs/trunk/p/perl-libxml-enno/perl-libxml-enno-vl.spec @ 521

Revision 521, 2.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _use_internal_dependency_generator 0
2
3Summary: A collection of Perl modules for XML parsing and validation.
4Name: perl-libxml-enno
5Version: 1.02
6Release: 30%{?_dist_release}
7License: distributable
8Group: Development/Libraries
9Source0: libxml-enno-%{version}.tar.gz
10Url: http://www.cpan.org
11BuildRoot: %{_tmppath}/%{name}-%{version}-root/
12BuildRequires: perl >= 5.8.2
13Requires: perl >= 5.8.2
14Provides: perl(XML::Handler::DOM)
15BuildRequires: perl-Parse-Yapp
16BuildRequires: perl-libwww-perl
17BuildRequires: perl-DateManip
18BuildArch: noarch
19
20%description
21libxml-enno contains the modules XML::DOM, XML::XQL, XML::Checker and
22several other packages used for parsing XML from Perl.
23
24# Provide perl-specific find-{provides,requires}.
25%define __find_provides /usr/lib/rpm/find-provides.perl
26%define __find_requires /usr/lib/rpm/find-requires.perl
27
28%prep
29%setup -q -n libxml-enno-%{version}
30
31%build
32CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor
33make
34
35%install
36rm -rf $RPM_BUILD_ROOT
37make DESTDIR=$RPM_BUILD_ROOT install
38
39[ -x /usr/lib/rpm/brp-compress ] && /usr/lib/rpm/brp-compress
40
41find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
42
43find $RPM_BUILD_ROOT/usr -type f -print |
44        sed "s@^$RPM_BUILD_ROOT@@g" |
45        grep -v perllocal.pod |
46        grep -v "\.packlist" > libxml-enno-%{version}-filelist
47if [ "$(cat libxml-enno-%{version}-filelist)X" = "X" ] ; then
48    echo "ERROR: EMPTY FILE LIST"
49    exit -1
50fi
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55#check
56#make test || /bin/true
57
58%files -f libxml-enno-%{version}-filelist
59%defattr(-,root,root)
60
61%changelog
62* Sat May 31 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.02-30
63- applied new versioning policy
64- rebuilt with perl-5.10.0-2
65
66* Sun Sep  3 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.02-29vl6
67- changed Group to Development/Libraries
68- installed files to vendor_perl dir
69
70* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 1.02-29vl5
71- build on perl-5.8.6-0vl1
72
73* Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 1.02-29vl4
74- built on perl-5.8.2
75
76* Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.02-29vl3
77- built on perl-5.8.1
78
79* Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 1.02-29vl2
80- build on perl-5.8.0
81
82* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 1.02-29vl1
83- build for VineLinux
84
85* Tue Aug  6 2002 Chip Turner <cturner@redhat.com>
86- automated release bump and build
87
88* Mon Aug  5 2002 Chip Turner <cturner@redhat.com>
89- updated description
90
91* Tue Jun  4 2002 Chip Turner <cturner@redhat.com>
92- properly claim directories owned by package so they are removed when package is removed
93
94* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
95- automated rebuild
96
97* Fri Dec 7 2001 root <root@redhat.com>
98- Spec file was autogenerated.
Note: See TracBrowser for help on using the repository browser.