source: projects/specs/trunk/p/perl-libwww-perl/perl-libwww-perl-vl.spec @ 521

Revision 521, 3.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define rel 1
2
3Summary: A Perl interface to the World-Wide Web
4Name: perl-libwww-perl
5Version: 5.833
6Release: %{rel}%{?_dist_release}
7License: GPL or Artistic
8Group: Development/Libraries
9Source0: ftp://ftp.cpan.org/pub/CPAN/modules/by-module/LWP/libwww-perl-%{version}.tar.gz
10Source10: filter-depends.sh
11URL: http://search.cpan.org/dist/libwww-perl/
12BuildRoot: %{_tmppath}/%{name}-%{version}-root
13BuildArch: noarch
14BuildRequires: perl >= 5.8.0, perl-URI, perl-HTML-Parser perl-Compress-Zlib
15Requires: perl >= 5.8.0, perl-URI, perl-HTML-Parser perl-Compress-Zlib
16
17%define __find_requires %{SOURCE10}
18#define __perl_requires %{SOURCE10}
19
20%description
21The libwww-perl collection is a set of Perl modules which provides a
22simple and consistent application programming interface to the
23World-Wide Web.  The main focus of the library is to provide classes
24and functions that allow you to write WWW clients. The library also
25contain modules that are of more general use and even classes that
26help you implement simple HTTP servers.
27
28%prep
29%setup -q -n libwww-perl-%{version}
30
31%build
32CFLAGS="$RPM_OPT_FLAGS" perl Makefile.PL INSTALLDIRS=vendor << EOO
33y
34y
35y
36y
37y
38n
39n
40n
41EOO
42make
43
44%install
45rm -rf $RPM_BUILD_ROOT
46mkdir -p $RPM_BUILD_ROOT%{_prefix}
47make DESTDIR=$RPM_BUILD_ROOT install
48
49find $RPM_BUILD_ROOT \( -name perllocal.pod -o -name .packlist \) -exec rm -v {} \;
50
51find $RPM_BUILD_ROOT%{_prefix} -type f -print |
52        sed "s@^$RPM_BUILD_ROOT@@g" |
53        grep -v ^%{_mandir} |
54        grep -v perllocal.pod |
55        grep -v "\.packlist" > %{name}.files
56if [ "$(cat %{name}.files)X" = "X" ] ; then
57    echo "ERROR: EMPTY FILE LIST"
58    exit -1
59fi
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%check
65make test
66
67%files -f %{name}.files
68%defattr(-,root,root)
69%doc README Changes
70%dir %{perl_vendorlib}/Bundle
71%dir %{perl_vendorlib}/File
72%dir %{perl_vendorlib}/HTML
73%dir %{perl_vendorlib}/HTTP
74%dir %{perl_vendorlib}/HTTP/Cookies
75%dir %{perl_vendorlib}/HTTP/Headers
76%dir %{perl_vendorlib}/HTTP/Request
77%dir %{perl_vendorlib}/LWP
78%dir %{perl_vendorlib}/LWP/Authen
79%dir %{perl_vendorlib}/LWP/Protocol
80%dir %{perl_vendorlib}/Net
81%dir %{perl_vendorlib}/Net/HTTP
82%dir %{perl_vendorlib}/WWW
83%dir %{perl_vendorlib}/WWW/RobotRules
84%{_mandir}/man?/*
85
86%changelog
87* Thu Nov 05 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 5.833-1
88- new upstream release
89- delete perllocal.pod and .packlist at %%install section
90
91* Fri Apr 25 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 5.812-2
92- new upstream release
93
94* Sun Jul 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.806-0vl1
95- new upstream release
96- s/Copyright/License/
97- changed Group to Development/Libraries
98- installed modules to vendor_perl directory
99- added SOURCE10 (removed dependancy for Win32)
100
101* Sat Dec  4 2004 IWAI, Masaharu <iwai@alib.jp> 5.802-0vl1
102- new upstream release
103- add perl-Compress-Zlib in {Build,}Requires
104
105* Thu Apr 24 2003 IWAI Masaharu <iwai@alib.jp> 5.69-0vl2
106- add many direcotries in %%files
107
108* Wed Apr 16 2003 Satoshi MACHINO <machino@vinelinux.org> 5.69-0vl1
109- New upstream version
110        -- libwww-perl-5.69
111- build on perl-5.8.0
112- removed perl-MIME-Base64 and perl-libnet from BuildRequires and Requires
113        -- perl-5.8.0 included them
114
115* Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 5.65-0vl1
116- New upstream version
117
118* Sat Feb  9 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 5.63-0vl1
119- first build for Vine Linux
120
Note: See TracBrowser for help on using the repository browser.