source: projects/specs/trunk/p/perl-gettext/perl-gettext-vl.spec @ 521

Revision 521, 3.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define PackageName gettext
2
3Name: perl-%{PackageName}
4Version: 1.05
5Release: 9%{?_dist_release}
6Summary: Interface to gettext family of functions
7
8Group: Development/Libraries
9License: GPL or Artistic
10Source: http://search.cpan.org/CPAN/authors/id/P/PV/PVANDRY/gettext-%{version}.tar.gz
11URL:    http://search.cpan.org/~pvandry/gettext/
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildRequires: gettext
15Requires:       gettext
16Requires:       perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
17
18Obsoletes: perl-Locale-gettext <= 1.05
19
20%description
21Perl module gettext - This module give acces to the C library functions
22for internatialization gettext.
23
24
25%prep
26%setup -q -n %{PackageName}-%{version}
27
28%build
29%{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
30make %{?_smp_mflags}
31
32%install
33rm -rf %{buildroot}
34make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
35find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
36find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
37find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
38chmod -R u+w $RPM_BUILD_ROOT/*
39
40%check
41unset LC_MESSAGES
42case "$LANG" in
43''|'C'|'POSIX' )
44  export LANG=en_US.UTF-8;;
45esac
46make test
47
48%clean
49rm -rf %{buildroot}
50
51
52%files
53%defattr(-,root,root,-)
54%doc README
55%{perl_vendorarch}/auto/Locale
56%{perl_vendorarch}/Locale
57%{_mandir}/man3/*.3*
58
59
60%changelog
61* Mon Jul 07 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.05-9
62- rebuild with perl-5.10
63- new versioning policy
64
65* Sat Sep  2 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.05-8vl1
66- new upstream release
67
68* Sun Jan  2 2005 IWAI, Masaharu <iwai@alib.jp> 1.03-0vl2
69- build on perl-5.8.6-0vl1
70- update URL
71
72* Sun Sep 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.03-0vl1
73- new upstream release
74- changed Group: and URL:
75- added Prereq: gettext
76- moved perllocal.pod to docdir
77- rebuild with perl 5.8.2
78
79* Tue Oct  7 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.01-14vl2
80- rebuild to remove dependancy at i386
81- rebuild with perl 5.8.1
82
83* Tue Nov 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.01-14vl1
84- build for Vine Linux
85
86* Sun Nov 11 2001 Magic Bumper <dist@conectiva.com.br>
87+ perl-%{PackageName}-1.01-14cl
88- rebuilt against current perl version
89
90* Fri Mar 02 2001 Rodrigo Barbosa <rodrigob@conectiva.com>
91+ perl-gettext-1.01-13cl
92- Removing macros from changelog
93
94* Thu Dec 07 2000 Rodrigo Barbosa <rodrigob@conectiva.com>
95- Added AutoProv: no
96
97* Mon Oct 31 2000 Raul Dias <rsd@conectiva.com>
98- Changed perl from "Requires:" to "Prereq:".
99
100* Sat Oct 28 2000 Raul Dias <rsd@conectiva.com>
101- Updated spec file
102- eliminate sed use
103
104* Fri Sep 29 2000 Raul Dias <rsd@conectiva.com>
105- Updated spec file
106
107* Tue Jun 06 2000 Raul Dias <rsd@conectiva.com>
108- Fixed instalation without %%doc
109
110* Mon May 22 2000 Raul Dias <rsd@conectiva.com.br>
111- New spec allow compiling with perl version 5.00503 and >= 5.6.0
112
113* Fri May 05 2000 Raul Dias <rsd@conectiva.com>
114- New spec format
115
116* Fri Mar 10 2000 Raul Dias <rsd@conectiva.com.br>
117- first build
118
Note: See TracBrowser for help on using the repository browser.